概要

トップページ 次へ

Atelier Web Remote Commander を使用すると、ローカル コンピュータからサーバやワークステーションを管理または監査したり、リモート ヘルプデスク サポートを提供したりすることが可能になります。
いくつかの高パフォーマンス リモート接続ツールが既に市場に出回っているので、一見何も目新しいものはないような印象を受けるかもしれません。

しかし、AWRC をインストールして実際使い始めると、まったく異なる種類のツールであることに気付くでしょう。

· AWRC では、リモート マシンにソフトウェアを何も準備 (インストール) することなく実行することができるので非常に便利です。マシンを指定し、接続するだけです。
· 他の製品と比べても、AWRC はリモート管理および監査のための強力なツールを豊富に備えています。これらのツールを使用すると、リモート システムのほぼすべての操作をあたかもその前に座っているかのように行うことができます。
· AWRC は安全面でも優れています。管理者権限のないリモート ユーザがリモート システム上で行える操作は制限されます。


主な機能

前へ トップページ 次へ

Atelier Web Remote Commander (AWRC) の主な機能を以下に紹介します。

· リモート コンピュータのデスクトップにアクセスして、マウスやキーボードでソフトウェアを起動することができます。
· リモート キーボード上のすべてのキーストロークをシュミレートすることができます。
· マウスクリックやキーストロークでスクリーンセーバから回復することができます。パスワード保護されたスクリーンセーバにも対応しています。
· リモート コンピュータ上で Ctrl+Alt+Del をシュミレートして、ログオンすることができます。デフォルトではホットキーは Ctr+Alt+D に設定されています。
· ディスク、パーティション、フォルダ、ファイルにアクセスすることができます。共有を開始する場合、パーティションやフォルダは不要です。
· リモート システムからリモート ファイルまたはディレクトリ ツリーをダウンロードすることができます。
· リモート システムにローカル ファイルまたはディレクトリ ツリーをアップロードすることができます。
· 代替資格を使用して、リモート コンピュータ上のプログラムを起動することができます。
· ファイルをリモートで Zip/Unzip することができます。
· 新しいディレクトリを作成したり、ファイルやディレクトリの名前を変更したりすることができます。
· リモート コンピュータ上のファイルやディレクトリを削除、コピー、または移動することができます。
· クリップボードの内容 (テキスト、画像などの Windows 標準クリップボードのフォーマット) を送信または受信することができます。
· パーティション情報　(ファイル システム、タイプ、シリアル番号、ボリューム ラベル、容量、空容量) を確認することができます。
· 共有部を表示することができます。
· ユーザ リスト、アカウントの詳細、ローカル グループ、グローバル グループを確認することができます。
· 組織全体の堅固なパスワード ポリシーの監査のために、パスワード ハッシュの即時読み込みが可能です。
· サービスを管理することができます。サービスは起動、停止、一時停止、復帰、アンロードすることができます。
· プロセスを確認して、必要に応じて停止することができます。
· リモートでシャットダウン、電源オフ、再起動が可能です。
· システム情報 (オペレーティング システム、プロセッサ、BIOS、メモリ、ディスプレイ アダプタ、論理プリンタ) を確認することができます。
· 各ハードウェア デバイスの詳細を確認することができます。
· 物理メモリ ビューアが備わっています。
· ポート検出機能 (アプリケーションとポートのマッピング) が備わっています。
· リモート コンピュータ上のネットワークに関連したさまざまな情報 (接続中およびリスニング ポート、TCP 統計情報、UDP 統計情報、ICMP 統計情報、ルーティング テーブル、DNS サーバ、強靭なルート、IP 統計情報/設定、インストール済みプロトコル/プロトコル詳細、アドレス情報テーブル、ネットワークとメディア テーブル、インタフェース統計情報/設定) を確認することができます。
· リモート インターラクティブ ユーザとの会話のためのチャット機能が備わっています。
· リモート デスクトップをローカル コンピュータ上で快適に見るために、アンチエイリアス スケーリング (拡大/縮小) 機能が備わっています。
· Windows の認証機能を使用して、管理者権限を持つユーザにのみリモート システムへの接続を許可することができます (強力なパスワードが推奨されます)。
· 強力な暗号化技術により情報の外部漏洩を防止することができます。
· 処理を開始する前にリモートからの承認を受けるための承認要求機能が備わっています。
· 正確なパスワードが入力されるまでプログラムを起動することはできません。
· リモート インターラクティブ ユーザによって進行中の作業を妨げられないように、接続中はリモート キーボードとマウスを無効にすることができます。
· ファイアウォールにも透過的です。
· 企業内の Microsoft Networks LAN およびインターネットを経由して動作します。
· ポートを開くことはありませんので、Microsoft Networks の動作がファイアウォールでブロックされない限り、どのようなファイアウォールにも完全に透過的です。


システム要件

AWRC を使用するためには、以下の要件を満たしている必要があります。

· ローカル システムおよびリモート システムが Pentium II/III 600 またはそれ以上と互換性がある必要があります。Pentium/AMD 1000 以上が推奨されています。
· ローカル マシンおよびリモート マシンの RAM は 64MB 以上必要です (128MB またはそれ以上が強く推奨されています)。
· ローカル システムには、Windows® NT 4.0 SP4 またはそれ以降、Windows® 2000、Windows® XP、Windows® XP Pro x64 64-Bit、Windows® Server 2003、または Windows® Server 2003 x64 64-Bit が搭載されている必要があります。また、リモート システムには、Windows® NT 4.0 SP4 またはそれ以降、Windows® 2000、Windows® XP Pro、Windows® XP Pro x64 64-Bit、Windows® Server 2003、または Windows® Server 2003 x64 64-Bit が搭載されている必要があります。
· リモート コンピュータのプラットフォームが Windows® XP Pro の場合は、ローカル アカウントの共有とセキュリティ モデルが "クラシック" に設定されている場合にのみアクセス可能です。
· この設定は、コントロール パネルから [管理ツール]、[ローカル セキュリティ ポリシー] の順にクリックし、[ネットワーク アクセス: ローカル アカウントの共有とセキュリティ モデル] で [クラシック - ローカル ユーザーがローカル ユーザーとして認証する] を選択することで有効にできます。また、Windows エクスプローラで [ツール]、[フォルダ オプション]、[表示] の順にクリックし、[簡易ファイルの共有を使用する] チェック ボックスをオフにしても、有効にすることができます。
· ログイン資格として、リモート マシンでの管理者権限が必要になります。または、リモート マシンの管理者グループのユーザ名とパスワードを入力する必要があります。
· Microsoft Networks、つまり Client for Microsoft Networks がローカル マシンおよびリモート マシンの両方にインストールされている必要があります。また、少なくともリモート マシン上でファイルとプリンタの共有が可能でなければなりません。


接続の開始

リモート マシンの名前または IP アドレスを [リモート ホスト] ボックスに入力します。
必要であれば、[ユーザ名] ボックスと [パスワード] ボックスにユーザ名とパスワードを入力してください。

リモート コンピュータのキーボードを有効にする場合は、[リモート キーボードのアクティブ/非アクティブ] オプションをオンにします。

[接続] ボタンをクリックします。

リモート コンピュータでの操作を開始する前に承認を要求する場合は、[接続] ボタンをクリックする前に、[承認要求] チェック ボックスをオンにしておく必要があります。

接続が正常に行われなかったり、ソフトウェアが予測外の動作をした場合は、以下の手順に従ってください。

1. 「システム要件」を注意深く読み直し、ローカル システムおよびリモート システムがこの要件を満たしているかどうか確認してください。
2. 「よくある質問 (FAQ)」を確認してください。該当する対応策が見つからない場合は、さらに弊社 Web サイトの最新の FAQ ページ (英語) を確認してください。
3. それでも解決しない場合は、http://www.atelierweb.com/support.htm のフォームからお問い合わせください。なお、日本語版の問題については、contact@nextEDGEtech までお問い合わせください。1 および 2 の手順を踏む前のご連絡はできる限りご遠慮ください。サポート スタッフはこころよく対応いたしますが、たいていの場合、回答は既に「システム要件」または「よくある質問 (FAQ)」の中に言及されています。


保存、クリップボードへのコピー、印刷

グリッド上で右クリックして [保存] または [名前を付けて保存] ([ファイル システム] タブでは [グリッドの保存] または [名前を付けてグリッドを保存]) をクリックすると、それぞれ対応する情報をファイルに保存することができます。デフォルトのファイル名は、[オプション] ダイアログ ボックスで設定することができます。
メモ:情報は未フォーマットの ASCII ファイルとして保存されます。すべて列は必要なスペース (タブではない) の数で揃えられます。

また、[デスクトップ] タブの [リモート画面の保存] ボタンをクリックすると、リモート デスクトップを .BMP 形式で保存することができます。

グリッド上で右クリックして ［クリップボードにコピー］をクリックすると、それぞれ対応する情報をテキスト形式でクリップボードにコピーすることができます。

グリッド上で右クリックして [印刷] をクリックすると、それぞれ対応する情報を印刷することができます。
メモ:通常 Courier New のような固定ピッチのフォントはテキストの配置を保つことができるため、これらのフォントのみがプレビューの [フォント設定] に用意されています。


表示領域の調整

表示領域を拡大または縮小するには、上部の情報パネルと下部の接続パネルの間にある薄緑の分割線を上下にドラッグします。

接続中に フルスクリーン モード ボタンをクリックすると、フルスクリーン モードに切り替わります。
フルスクリーン モードでは、リモート デスクトップのイメージがローカル コンピュータの画面全体に表示されます。フルスクリーン モードから通常モードに戻すには、キーボードの Ctrl+Alt+Z キー (デフォルト) を押します。このホットキーは、[オプション] ダイアログ ボックスで変更することができます。

リモート スクリーンの解像度縦横比がローカル スクリーンの解像度縦横比と異なる場合、リモート スクリーンのローカル イメージに歪曲が生じることがあります。しかし、イメージの歪曲は、[オプション] ダイアログ ボックスで [フルスクリーン表示レートをメンテナンス] チェック ボックスをオンにすることで防ぐことができます。このチェック ボックスをオンにすることで、リモート スクリーンの縦横比は同率で伸縮されるようになり、ローカル スクリーンとリモート スクリーンの縦横比が異なる場合は、補正のためスクリーンの左または下の領域が黒い帯として残されます。


フォント サイズの調整

グリッド上で右クリックして [フォント拡大] または [フォント縮小] をクリックすると、グリッドのフォント サイズを調整することができます。
なお、変更したフォント サイズはセッションを変更した場合でも維持されます。


イメージ スケール

リモート デスクトップのスクリーンのサイズは元のサイズの 25% から 200% の範囲で変更可能です。
サイズの変更時には、アンチエイリアス フィルタが適用されるため、元の状態を細かい部分までほとんど維持できます。
なお、デフォルトのスケールは、[オプション] ダイアログ ボックスで指定することができます。
フルスクリーン モードでは、サイズの変更は自動的に行われますが、最大限に見た目を快適に保つために同様のアンチエイリアス フィルタが適用されます。


クリップボードの内容の転送

クリップボードの内容は、ローカル コンピュータとリモート コンピュータの間で相互に転送することができます。
これには、[デスクトップ] タブの [クリップボード内容をリモートに送信]/[クリップボードの内容をリモートから取得] の 2 つのボタンを使用します。
AWRC では、画像や音声を含め、標準的なクリップボードのフォーマットであればシステム間で送信したり取得したりすることはできますが、独自のフォーマットや OLE のようなフォーマットには対応していません。


暗号化

AWRC での接続時には、暗号化を有効にすることも、無効にすることもできます。
保持するデータの機密性が高くない LAN 環境では、通常は暗号化接続を利用しなくても十分でしょう。

しかし、インターネットのように悪質な攻撃を受ける可能性のあるネットワークとの接続には、AWRC の提供する強力な暗号化技術を利用することをお勧めします。これにより、現行の暗号解読技術からも、ハードウェアに対する物量攻撃からも機密情報を堅牢に保護することが可能になります。

暗号化処理は 2 段階に分けて行われます。

最初の段階では、AWRC は楕円曲線非対称鍵 (1024 ビット RSA 強度に相当) を使用して、352 ビット セッション鍵をリモート コンピュータに送信します。
まず、AWRC は公開鍵 (パブリック キー) をリモート コンピュータに送信します。リモート コンピュータは複雑な乱数アルゴリズムを使用して (推測不可能な) 別の鍵のペアを生成し、自身の公開鍵をクライアントの公開鍵で暗号化してからクライアントに送信します。クライアントはリモート公開鍵を解読してから、セッション鍵をそのリモート公開鍵で暗号化して送信します。

その後で、すべてのデータのやりとりが 352 ビットの長さのセッション鍵によって Blowfish CBC 暗号化されるので、ほぼ解読は不可能といっても過言ではありません。
AWRC の暗号化と暗号解読の処理速度は非常に速いため、パフォーマンスを深刻に低下させることなく常に強力な暗号化環境を維持できます。

AWRC の暗号化技術は、Microsoft Networks の通信とプロトコル自体には対応していません。同様に、共有とサービスの情報も暗号化されることはありません。これは、これらの情報が Microsoft Networks メカニズムを使用してローカルで取得されるためです。それ以外の情報については、リモート スクリーンからチャットの会話まですべて強力に暗号化されるため、ネットワーク トラフィックが他者から盗視されるのを防止できます。


AWRC パスワード

AWRC がインストールされたローカル マシンの管理者は、[オプション] ダイアログ ボックスで、AWRC を実行するためのパスワードを設定できます。これにより、他のユーザが AWRC を無断で実行することを防止できます。
コンピュータ使用上の多くの場合と同様に、このパスワードは特定のハッカーからの攻撃を完全に抑制するものではありません。ただほとんどの場合、このパスワードで十分です。
AWRC をアンインストールする場合は、このパスワードを事前に解除しておく必要があります。パスワードを削除しておかないと、AWRC を再インストールする際に同じパスワードを入力しないと処理を続行できません。


デスクトップ

[デスクトップ] タブでは、リモート コンピュータのスクリーンの更新を見ることができます。また、リモート デスクトップとの対話が可能です。
AWRC でキャプチャされたイメージ上をマウスでクリックまたはダブルクリックすると、リモート コンピュータ上の同じ位置でクリック操作またはダブルクリック操作が再現されます。マウスの移動についても同じことがいえます。
[リモート キーボードのアクティブ/非アクティブ] オプションを有効にすると、ローカル システム上で入力したすべてのキーがリモート システム上で再現されます。この機能は、国際キーボードのキーの組み合わせにも対応しています。ただし、すべてのキーの組み合わせが正確に再現されるのは、両システムのキーボードで共通の配列が使用されている場合に限られます。
[リモート キーボードのアクティブ/非アクティブ] オプションはデフォルトで有効になっていますが、[オプション] ダイアログ ボックスで設定を変更することもできます。

スクリーンの更新速度は、[最速] (ほぼリアルタイム) から [一時停止] (スクリーン更新なし) までの範囲で指定することができます。

[リモート画面の保存] ボタンをクリックすると、スクリーン キャプチャが BMP 形式で保存されるので、後で必要なときに確認することができます。

デスクトップの色は、[オプション] ダイアログ ボックスで好みの色に変更することができます。指定可能な色は以下のとおりです。

· 16 色 (4 ビット)
· 256 色 (8 ビット)
· 65536 色 (16 ビット)
· トゥルー カラー (24 ビット)
· トゥルー カラー (32 ビット)

4 ビットと 8 ビットは、通信状態が悪い場合に適しています。デフォルトでは、16 ビットに設定されています。AWRC は、リモート コンピュータまたはローカル コンピュータで、パレット ベースのスクリーン デスクトップも、16 ビット、24 ビット、32 ビットの各トゥルー カラーもサポートしています。


一般

[一般] タブには、リモート システムの特性に関する包括的な情報が表示されます。

· オペレーティング システム:説明 (インストールされているサービス パックを含む)、登録済みユーザ、登録済み組織、シルアル番号、ローカル時刻、最終起動、稼働時間
· プロセッサ:製造元、ベンダ ID、CPU 名、ファミリ、モデル、ステッピング、実周波数、標準周波数
· BIOS:包括的な SMBIOS ROM 情報 (利用可能な場合: 最近の BIOS では利用可能な場合が多い)
AWRC は以前からよく用いられていた速度の遅い (非推奨) API を使用しないので、SMBIOS ROM はすぐに ROM から読み込まれます。まれに SMBIOS ROM 情報が利用可能でないことがありますが、AWRC は他のソースから BIOS の詳細情報を取得しようとします。
· メモリ:合計物理メモリ、空物理メモリ、合計ページ ファイル、空ページ ファイル、など
· ディスプレイ アダプタ:モデル、チップセット、DAC、メモリ、BIOS、スクリーン メトリックス、フォント解像度、利用可能なビデオ モード
· 論理ローカル プリンタ


ハードウェア デバイス

Windows のコントロール パネルから [システム] アプレットを起動すると、ローカル マシン上のハードウェアに関する情報が表示されます。[ハードウェア デバイス] タブのリストにも同じような情報が表示されますが、このリストにはリモート マシンから直接取得されたいくつかの詳細情報も含まれます。


プロセス

[プロセス] タブには、リモート システム上のプロセスの一覧が表示されます。

プロセス グリッドの右クリック メニューからは、以下の操作を実行できます。

· プロセスの停止:リモート システム上の不要なプロセスを停止できます。プロセスの中には停止するとリモート マシンが極端に不安定になるものもありますので、使用する際は注意してください。
· リモート シャットダウン:電源を落としても安全な状態にコンピュータをシャットダウンします。AWRC は、すべてのファイル バッファをディスクにフラッシュし、実行中のプロセスが終了するまで待機します。シャットダウンの要求に応じないプロセスについては、強制的に終了します。
· リモート電源オフ:前記のオプションと同じようにコンピュータをシャットダウンし、電源オフ機能によってシステムの電源をオフにします。
· リモート リブート:リモート コンピュータをシャットダウンした後で再起動します。

メモ
1. これらのオプションは、デフォルト デスクトップがリモートでアクティブの場合にのみ動作します。
2. これらのオプションは、接続時にのみ右クリック メニューに表示されます。


サービス

[サービス] タブには、リモート コントロール マネージャ データベースのサービスの一覧が表示されます。

表示されるサービスの種類は以下のとおりです。
· カーネル デバイス ドライバ
· ファイル システム ドライバ
· 自身のプロセスの中で動作しているサービス、デスクトップとの対話の可否
· プロセスを他のプロセスと共有しているサービス、デスクトップとの対話の可否

サービス グリッドの右クリック メニューからは、リモート サービスに対して以下の操作を実行できます。

サービス停止、サービス起動、サービス一時停止、一時停止サービスの復帰、サービス アンロード
これらの機能は非常に強力ですがシステムを不安定にさせる可能性もありますので、操作を実行する前に十分に確認するようにしてください。特に、サービスをアンロードする際は細心の注意を払ってください。サービスの中には、リモート システムを正常に動作させるために必要不可欠なものが含まれています。

メモ:これらのオプションは、接続時にのみ右クリック メニューに表示されます。


物理メモリ ビューア

通常、オペレーティング システムはコードを実行するためにリニア アドレスを物理アドレスにマッピングします。マッピングはページ テーブルを設定することで作成されます。タスクの切り替えが発生すると、プロセスは物理アドレス空間の領域にマッピングする新しいページ セットを受け取ります。そのページがディスク上にあるときは、そこから物理メモリ空間へと読み込まれます。プロセスが物理アドレスを認識したり影響を与えることはありませんが、これらの情報を見ることが可能なのは興味深いものです。

物理メモリの領域の中には長期にわたって安定しているものもありますが、ほとんどの領域は常に変化しています。いずれにせよ、物理メモリを調べることは良い練習にもなり、洞察力を高めることができるでしょう。

メモ:Windows® Server 2003 SP1、Windows® Server 2003 x64 64-Bit、および Windows® XP Pro x64 64-Bit SP1 では、物理メモリを取得できるのは 0x000C0000 ～ 0x000FFFFF の範囲に限られます。


共有

共有とは、リモート コンピュータが他のコンピュータに利用を許可したリソースです。リソースには、ドライバ、印刷キュー、通信デバイス、インタープロセス通信デバイスなどがあります。
共有は、リモート コンピュータで Client for Microsoft Networks が動作していて、ファイルやプリンタの共有が有効になっていれば、ファイアウォールがこの設定をブロックしない限り、いつでも見ることができます。
名前の前に $ 記号が付いたリソースは、(通常の方法では) 外部から見ることはできません。


ポート検出

リモート コンピュタ上のどのプログラムが外部にポートを開いているか疑問に思ったこともあるでしょう。
この情報は、リモート コンピュータのセキュリティ評価を行う上で非常に重要です。

市場に出回っている既存のソフトウェアでは、この種の情報を取り扱っていません。この種の情報をローカル マシンから取得する技術を開発したのは、弊社が初めてです (受賞ソフトウェア AWSPS)。さらには、リモート マシンからこの種の情報を取得することができるのは AWRC が初めてです。


接続中およびリスニング ポート

このグリッドには、ローカル システム上のすべての接続中ポートとリスニング ポートが表示されます。
[プロトコル] 列は、TCP (Transmission Control Protocol) または UDP (User Datagram Protocol) のいずれかのプロトコルを示します。TCP 接続は一時的なもので、接続がクローズ (closed) 状態に移行するとき (またはその直後) に終了します。

[ローカル アドレス] 列は、TCP 接続または UDP リスナのローカル IP アドレスとローカル ポートを示します。TCP 接続がリッスン (listening) 状態の場合、またはノードに関連付けられた IP インタフェースの接続 (UDP リスナのデータグラム) を UDP リスナが許可しようとしている場合は、ローカル IP アドレスの値は 0.0.0.0 になります。

[リモート アドレス] 列は、TCP 接続または UDP リスナに関連付けられたリモート IP アドレスとリモート ポートを示します。

[状態] 列は、以下のいずれかの状態を示します。

syn送信 (synSent) | アクティブ オープンを示します。
syn受信 (synReceived) | サーバがクライアントから SYN を受信したことを示します。
確立 (established) | クライアントがサーバの SYN を受信し、セッションが確立したことを示します。
リッスン (listening) | サーバが接続を受け入れる準備ができていることを示します。
finWait1 | アクティブ クローズを示します。
timeWait | クライアントはアクティブ クローズの後でこの状態に切り替わります。
closeWait | パッシブ クローズを示します。サーバがクライアントから最初の FIN を受信したことを示します。
finWait2 | クライアントがサーバからの最初の FIN の承認を受信したことを示します。
lastAck | サーバが自身の FIN を送信している状態であることを示します。
クローズ (closed) | サーバがクライアントから ACK を受信し、接続が終了したことを示します。

メモ

－ クライアントが接続を終了しても、ソケットは closeWait 状態のまま残っている場合があります。これは、サーバがまだソケットを開いたままであることを示します。
－ 接続が timeWait 状態にあるのは、最大で 4 分間です。


TCP 統計情報

再送信タイムアウト アルゴリズム
このアルゴリズムは未応答オクテットの再送信タイムアウト値を決定するために使用されます。
アルゴリズムの種類には以下のものがあります。
constant
rsre (MIL-STD 1778、付録 B)
vanj (Van Jacobson アルゴリズム)
other (上記以外)

最小再送信タイムアウト (msec)
TCP 実装によって許可された再送信タイムアウトの最小値 (ミリ秒単位) です。

最大再送信タイムアウト (msec)
TCP 実装によって許可された再送信タイムアウトの最大値 (ミリ秒単位) です。

接続最大数
接続最大数が "ダイナミック" でない場合には、この値は TCP 接続の合計数の限度を示します。

アクティブ オープン
TCP 接続がクローズ (closed) 状態から syn送信 (synSent) 状態に直接移行した回数です。

パッシブ オープン
TCP 接続がリッスン (listening) 状態から syn受信 (synReceived) 状態に直接移行した回数です。

失敗接続試行
TCP 接続が syn送信 (synSent) 状態または syn受信 (synReceived) 状態からクローズ (closed) 状態に直接移行した回数と、TCP 接続が syn受信 (synReceived) 状態からリッスン (listening) 状態に直接移行した回数を加えたものです。

リセット接続
TCP 接続が確立 (established) 状態または closeWait 状態からクローズ (closed) 状態に直接移行した回数です。

現在の接続
現在の状態が確立 (established) または closeWait の TCP 接続の数です。

受信セグメント数
受信したセグメントの合計数 (エラーで受信したものも含む) です。この値には、現在確立している接続で受信したセグメントも含まれます。

送信セグメント数
送信されたセグメントの合計数です (現在の接続で送信されたものも含む)。ただし、再送信されたオクテットのみで構成されるセグメントは除きます。

再送信セグメント数
以前に送信された 1 つまたは複数のオクテットを含む、送信済み TCP セグメントの数です。

エラー受信セグメント数
エラー (不正な TCP チェックサムなど) で受信したセグメントの合計数です。

RST フラグ付き送信セグメント
RST フラグを含む、送信済み TCP セグメントの数です。


UDP 統計情報

受信データグラム数
UDP クライアントに配信された UDP データグラムの合計数です。

ポートなし
宛先ポートにクライアント アプリケーションが存在しない受信 UDP データグラムの合計数です。

受信エラー数
宛先ポートにアプリケーションが存在しなかったという以外の理由で配信できなかった受信 UDP データグラムの数です。

送信データグラム数
該当するエンティティから送信された UDP データグラムの合計数です。


ICMP 統計情報

メッセージ
受信 － エンティティが受信した ICMP メッセージの合計数です。この値には、ICMP 受信エラーも含まれます。
送信 － 該当するエンティティが送信を試みた ICMP メッセージの合計数です。この値には、ICMP 送信エラーも含まれます。

エラー数
受信 － エンティティが受信したメッセージの中で、ICMP 固有のエラー (不正な ICMP チェックサム、不正な長さなど) と見なされた ICMP メッセージの数です。
送信 － バッファ不足など、ICMP 内で見つかった問題が原因で、該当するエンティティによって送信されなかった ICMP メッセージの数です。この値には、ICMP レイヤの外で発見されたエラー (たとえば、IP が出力データグラムをルーティングできない場合など) は含まれません。

相手先未到達
受信 － ICMP 相手先未到達メッセージの受信数です。
送信 － ICMP 相手先未到達メッセージの送信数です。

時間超過
受信 － ICMP 時間超過メッセージの受信数です。
送信 － ICMP 時間超過メッセージの送信数です。

パラメータ問題
受信 － ICMP パラメータ問題メッセージの受信数です。
送信 － ICMP パラメータ問題メッセージの送信数です。

送信抑制
受信 － ICMP 送信抑制 (ソース クエンチ) メッセージの受信数です。
送信 － ICMP 送信抑制 (ソース クエンチ) メッセージの送信数です。

リダイレクト数
受信 － ICMP リダイレクト メッセージの受信数です。
送信 － ICMP リダイレクト メッセージの送信数です。ホストの場合、この値は常に 0 になります (ホストはリダイレクトを送信しないため)。

エコー数
受信 － ICMP エコー要求メッセージの受信数です。
送信 － ICMP エコー要求メッセージの送信数です。

エコー応答
受信 － ICMP エコー応答メッセージの受信数です。
送信 － ICMP エコー応答メッセージの送信数です。

タイムスタンプ
受信 － ICMP タイムスタンプ要求メッセージの受信数です。
送信 － ICMP タイムスタンプ要求メッセージの送信数です。

応答タイムスタンプ
受信 － ICMP タイムスタンプ応答メッセージの受信数です。
送信 － ICMP タイムスタンプ応答メッセージの送信数です。

アドレス マスク
受信 － ICMP アドレス マスク要求メッセージの受信数です。
送信 － ICMP アドレス マスク要求メッセージの送信数です。

アドレス マスク応答
受信 － ICMP アドレス マスク応答メッセージの受信数です。
送信 － ICMP アドレス マスク応答メッセージの送信数です。


ルーティング テーブル

IP
該当するルートの宛先 IP アドレスです。値が 0.0.0.0 のエントリは、デフォルトのルートを意味します。テーブルには、1 つの宛先に対して複数のルートが表示されます。ただし、これらの複数のエントリへのアクセスは、使用中のネットワーク管理プロトコルで定義されたテーブル アクセス メカニズムに依存しています。

インタフェース インデックス
該当するルートの次ホップへ到達するために経由するローカル インタフェースを一意に識別するためのインデックス値です。

経路メトリック 1 (プライマリ)

該当するルートの優先経路メトリックです。メトリックの意味はルーティング メカニズムによって決定されます。

経路メトリック 2-5 (予備)
該当するルートの予備経路メトリックです。メトリックの意味はルーティング メカニズムによって決定されます。

ゲートウェイ アドレス
該当するルートの次ホップの IP アドレスです。ブロードキャスト メディアを経由することで実現されるインタフェースに結合されたルートの場合、このフィールドの値はそのインタフェースのエージェントの IP アドレスになります。

ルート タイプ
以下のいずれかの値になります。
ダイレクト － 直接ネットワーク (またはサブネットワーク) に接続するルートです。
インダイレクト － ローカル ホスト/ネットワーク/サブ ネットワークに接続しないルートです。
無効 － 無効なルートです。
その他 － 上記以外のルートです。

ルーティング メカニズム
該当するルートが準拠しているメカニズムです。以下のいずれかの値になります。
その他 － 下記以外です。
ローカル － 手動設定エントリなどの非プロトコル情報です。
netmgmt － ネットワーク マネージメント プロトコル経由で設定されます。
icmp － ICMP 経由で取得されます (たとえば、リダイレクト、および以下のゲートウェイ ルーティング プロトコル)
egp、ggp、hello、rip、is-is、es-is、ciscoIgrp、bbnSpfIgp、ospf、bgp

経路時間 (秒)
該当するルートが最後にアップデートされてから、または正しいと決定されてからの経過時間 (秒単位) です。

IP ルート マスク
[IP] フィールドの値と比較される前に、宛先アドレスと論理積をとるためのマスクを示します。

MIB ルート情報
ルーティング メカニズムによって決定された、該当するルートを管理している特定のルーティング プロトコルに固有の MIB 定義の情報です。この情報が表示されない場合、値は 0.0 に設定されます。


DNS サーバ

DNS サーバとは、FQDN (1) と IP アドレスのマッピングを管理しているコンピュータのことです。
ほとんどの DNS サーバが特定のゾーン (2) に対して権威があり (3)、その他すべての DNS 情報をキャッシュします。

(1) FQDN (Fully Qualified Domain Name: 完全修飾ドメイン名) とは、ドメインの名前空間ツリーにおける位置を省略せずに完全に記述したドメイン名のことです。
(2) 権威情報は、"ゾーン" という単位で構成され、これらのゾーンは自動的に複数のネーム サーバに分散させて管理することができます。各ネーム サーバは、ゾーン内のデータの冗長サービスを提供します。
(3) ネーム サーバは、名前空間の中で完全な情報を有している特定の領域 (ゾーン) に対して "権威がある" といいます。


強靭なルート

デフォルトでは、ルーティング テーブル内のルートは恒久的なものではありません。これらのルートは、コンピュータを再起動したときに失われます。Windows NT、2000、XP、2003 では、コンソール プログラム route.exe をコマンド route -p ip_address と共に使用することでルートを固定することができます。


IP 統計情報/設定

IP ルータとして稼動
該当するエンティティが IP ゲートウェイとして動作するかどうかを示します。エンティティによって受信され、アドレス指定されていないデータグラムの転送に関しての情報です。IP ゲートウェイはデータグラムを送信しますが、IP ホストは送信しません (ホストを経由してソースルーティングされたデータグラムを除く)。

デフォルト TTL
TTL (Time-To-Live) 値がトランスポート レイヤ プロトコルによって提供されない場合、該当するエンティティを始点とするデータグラムの IP ヘッダの TTL フィールドにこのデフォルト値が挿入されます。

受信パケット数
インタフェースから受信された入力データグラムの合計数 (エラーで受信されたものも含む) です。

受信ヘッダ エラー数
IP ヘッダのエラーが原因で破棄された入力データグラムの数です。エラーには、不正なチェックサム、バージョン番号不一致、TTL 超過、IP オプションの処理中に発見されたエラーなどが含まれます。

受信アドレス エラー
IP ヘッダの宛先フィールド内の IP アドレスが該当するエンティティで受信されるには不適切であったため破棄された入力データグラムの数です。この値には、無効なアドレス (たとえば、0.0.0.0) やサポートされていないクラス (たとえば、Class E) のアドレスも含まれます。IP ゲートウェイとして動作しないためデータグラムを転送しないエンティティの場合、この値には、宛先アドレスがローカル アドレスではないために廃棄されたデータグラムが含まれます。

転送データグラム数
該当するエンティティが最終的な IP 宛先ではなかったため、最終的な宛先に転送するルートを探そうと試みられた入力データグラムの数です。IP ゲートウェイとして動作していないエンティティの場合、この値には、該当するエンティティを経由してソースルーティングされ、かつソースルーティング オプション処理が成功したパケットのみが含まれます。

受信した不明なプロトコル
正常に受信されたにもかかわらず、プロトコルが不明またはサポートされていないために破棄されたローカル アドレス データグラムの数です。

破棄された受信パケット数
処理の継続を妨げる問題がなかったにもかかわらず、(バッファ スペースの不足などが原因で) 廃棄された入力 IP データグラムの数です。再構築の待機中に破棄されたデータグラムは含まれません。

配信された受信パケット数
IP ユーザ プロトコル (ICMP を含む) に正常に配信された入力データグラムの合計数です。

出力リクエスト数
ローカル IP ユーザ プロトコルが送信要求に応じて IP に提供した IP データグラムの合計数です。[転送データグラム数] のデータグラムは含まれません。

破棄された送信パケット数
宛先への送信を妨げる問題がなかったにもかかわらず、(バッファ スペースの不足などが原因で) 廃棄された出力 IP データグラムの数です。この値には、[転送データグラム数] のパケットのうち、この "破棄" 基準に当てはまるパケットも含まれます。

ルートなし出力パケット
宛先に送信するルートが見つからなかったため破棄された IP データグラムの数です。この値には、[転送データグラム数] のパケットのうち、この "ルートなし" 基準に当てはまるパケット (すべてのデフォルト ゲートウェイがダウンしていたためホストがルーティングできなかったデータグラムを含む) も含まれます。

再構築タイムアウト (秒)
該当するエンティティで再構築を行うまでに受信フラグメントを維持する時間 (秒) です。

再構築が必要
該当するエンティティで再構築が必要な受信 IP フラグメントの数です。

再構築成功
再構築が成功した IP データグラムの数です。

再構築障害
IP 再構築アルゴリズムによって検知された障害 (たとえば、タイムアウトやエラーなど) の数です。

フラグメンテーションに成功したデータグラム数
該当するエンティティでフラグメンテーションに成功した IP データグラムの数です。

フラクメンテーションに失敗したデータグラム数
該当するエンティティでフラグメンテーションが必要であったものの失敗したため (たとえば、"フラグメンテーション不可" のフラグが設定されていた場合など) 破棄された IP データグラムの数です。

作成されたフラグメント
該当するエンティティでのフラグメンテーションで生成された IP データグラム フラグメントの数です。

破棄されたルーティング数
有効であるにもかかわらず廃棄されたルーティング エントリの数です。破棄された理由の 1 つとして、その他のルーティング エントリ用のバッファ スペースの確保が考えられます。


インストール済みプロトコル

ローカル マシンにインストールされているすべての送信プロトコルとプロトコル チェーンに関する情報が表示されます。
表示順序は、プロトコルのエントリがサービス プロバイダによって Winsock DLL に登録された順序、またはそれ以降に発生した並べ替えの順序に対応しています。

プロトコル詳細

1. アドレス ファミリ
以下のいずれかになります。

AF_UNSPEC | 指定なし
AF_UNIX | ローカル － ホスト (パイプ、ポータル)
AF_INET | Internetwork: UDP、TCP など
AF_IMPLINK | arpanet imp アドレス
AF_PUP | pup プロトコル: BSP など
AF_CHAOS | CHAOS プロトコル
AF_IPX | IPX および SPX
AF_NS | XEROX NS プロトコル
AF_ISO/AF_OSI | ISO プロトコル
AF_ECMA | European Computer Manufacturer Association
AF_DATAKIT | datakit プロトコル
AF_CCITT | CCITT プロトコル: X.25 など
AF_SNA | IBM SNA
AF_DECnet | DECnet
AF_DLI | ダイレクト データ リンク インタフェース
AF_LAT | LAT
AF_HYLINK | NSC Hyperchannel
AF_APPLETALK | AppleTalk
AF_NETBIOS | NetBios スタイルのアドレス
AF_VOICEVIEW | VoiceView
AF_FIREFOX | FireFox
AF_UNKNOWN1 | 未確認
AF_BAN | Banyan
AF_ATM | ネイティブ ATM サービス
AF_INET6 | Internetwork Version 6
AF_CLUSTER | Microsoft Wolfpack
AF_12844 | IEEE 1284.4 WG AF
AF_IRDA | IrDA
AF_NETDES | Network Designers OSI & ゲートウェイ対応のプロトコル

2. プロトコル

アドレス ファミリに依存するプロトコル パラメータの値です。AF_INET/AF_INET6 では、以下のいずれかになります。

IPPROTO_IP | IP のダミー
IPPROTO_HOPOPTS | IPv6 ホップバイホップ オプション
IPPROTO_ICMP | Control Message Protocol
IPPROTO_IGMP | Group Management Protocol
IPPROTO_GGP | Gateway^2 (非推奨)
IPPROTO_IPV4 | IPv4
IPPROTO_TCP | TCP
IPPROTO_PUP | PUP
IPPROTO_UDP | UDP
IPPROTO_IDP | XNS IDP
IPPROTO_IPV6 | IPv6
IPPROTO_ROUTING | IPv6 ルーティング ヘッダ
IPPROTO_FRAGMENT | IPv6 フラグメンテーション ヘッダ
IPPROTO_ESP | IPsec ESP ヘッダ
IPPROTO_AH | IPsec AH
IPPROTO_ICMPV6 | ICMPv6
IPPROTO_NONE | IPv6 次ヘッダなし
IPPROTO_DSTOPTS | IPv6 宛先オプション
IPPROTO_ND | Net Disk Protocol (非公式)
IPPROTO_RAW | Raw IP パケット

3. ソケット タイプ

ソケット タイプ パラメータの値です。以下のいずれかになります。

SOCK_STREAM | ストリームです。メッセージ境界のないバイト ストリームとしてデータを送信するプロトコルです。
SOCK_DGRAM | データグラムです。接続なしのプロトコルです。仮想回線セットアップがありません。通常、信頼保障はありません。
SOCK_RAW | Raw です。IP ヘッダー情報を参照可能なプロトコルです。
SOCK_RDM | Reliably-Delivered Message です。データ内にメッセージ境界を保持するプロトコルです。
SOCK_SEQPACKET | シーケンス パケット ストリームです。基本的には SOCK_RDM と同じプロトコルです。

4. 接続なし

プロトコルが接続なし (データグラム) サービスを提供しているかどうかを示します。提供していない場合は、プロトコルは接続指向のデータ転送をサポートします。

5. 保障された配信

送信されたすべてのデータが対象の宛先に到着することを保障します。

6. 保障されたオーダ

送信された順序でデータが到着し、再び繰り返されないことを保障します。この特性はデータが常に配信されることを意味するわけではありませんが、すべてのデータが送信順序で配信されることを保障します。

7. メッセージ指向

メッセージ境界をサポートします。メッセージ境界の概念のないストリーム指向のプロトコルとは対照的です。

8. 擬似ストリーム

メッセージ指向のプロトコルでありながら、メッセージ境界はすべての受信において無視されます。これは、アプリケーションがプロトコルによるメッセージ フレームを要求しないときに便利です。

9. 安全に終了

(安全な) 2 段階終了をサポートします。設定されていない場合、強制終了されます。

10. 早められたデータ

早められた (緊急) データをサポートします。

11. 接続データ

接続データをサポートします。

12. 接続断データ

接続断データをサポートします。

13. ブロードキャスト サポート

ブロードキャスト メカニズムをサポートします。

14. マルチポイント サポート

マルチポイントまたはマルチキャスト メカニズムをサポートしている場合、制御面およびデータ面が示され、ルーティングまたは非ルーティングのいずれかになります。

15. QoS サポート

QoS (Quality of Service) 要求をサポートします。

16. 単一方向送信

プロトコルは送信方向に単一方向性を持ちます。

17. 単一方向受信

プロトコルは受信方向に単一方向性を持ちます。

18. IFS ハンドル

プロバイダから返されたソケット ディスクリプタがオペレーティング システム IFS (Installable File System) ハンドルであるかどうかを示します。

19. 部分メッセージ

MSG_PARTIAL フラグは WSASend および WSASendTo でサポートされます。

20. プロバイダ フラグ

プロトコル カタログの中で該当するプロトコルがどのように表されているかについての情報です。フラグ値は、以下のようになります。

PFL_MULTIPLE_PROTO_ENTRIES | 複数の動作を実装することのできる (特定プロバイダからの) 単一プロトコルの 2 つ以上のエントリのうちの 1 つであることを示します。
PFL_RECOMMENDED_PROTO_ENTRY | 複数の動作を実行することのできるプロトコルの推奨されるエントリ、または最も頻繁に使用されるエントリであることを示します。
PFL_HIDDEN | このフラグが設定されると、プロトコルのエントリが隠されます。
PFL_MATCHES_PROTOCOL_ZERO | ソケットまたは WSASocket のプロトコル パラメータの値が 0 の場合、該当するエントリに一致します。

21. プロバイダ ID

サービス プロバイダ ベンダによってプロバイダに割り当てられたグローバル一意識別子です。この値は、1 つ以上のサービス プロバイダが特定のプロトコルを実装可能なインスタンスで役立ちます。

22. カタログ エントリ ID

各プロトコル構造に対して WS2_32.DLL によって割り当てられた一意の識別子です。

23. チェイン エントリ数

プロトコル チェーンを形成するカタログ エントリ識別子の数値リストです。

24. バージョン

プロトコルのバージョン識別子です。

25. 最大ソケット アドレス長

アドレス長の最大値です。

26. 最小ソケット アドレス長

アドレス長の最小値です。

27. プロトコル最大オフセット

ソケットおよび WSASocket にプロトコル パラメータの値を渡すときに追加可能な最大値です。すべてのプロトコルが値の範囲を許可しているわけではありません。その場合、パラメータの値は 0 になります。

28. ネットワーク バイト順

Big-Endian (ビッグエンディアン) または Little-Endian (リトルエンディアン) のいずれかです。

29. セキュリティ スキーマ

採用されているセキュリティ スキーマのタイプを示します (もしあれば)。

30. メッセージ サイズ

プロトコルでサポートされている最大メッセージ サイズです。この値は、ホストのローカル インタフェースから送信可能なメッセージの最大サイズを示しています。メッセージ フレームをサポートしていないプロトコルの場合、指定のアドレスに送信可能な実際の最大サイズは小さくなります。受信メッセージの最大サイズを決定する標準的な基準はなく、以下の特別な値が定義されています。

0 | プロトコルがストリーム指向であるため、メッセージ サイズの概念は適用されません。
0x1 | 最大送信メッセージ サイズは、基礎となるネットワーク MTU (Maximum sized Transmission Unit) に依存しているため、ソケットがバインドされるまでわかりません。
0xFFFFFFFF | プロトコルはメッセージ指向ですが、送信可能なメッセージの最大サイズに制限はありません。


アドレス情報テーブル

IP
該当するエントリのアドレス情報に関連する IP アドレスです。

インタフェース インデックス
該当するエントリが適用可能なインタフェースを一意に識別するためのインデックス値です。

サブネット マスク
該当するエントリの IP アドレスに関連付けられたサブネット マスクです。マスクの値は、すべてのネットワーク ビットが 1、すべてのホスト ビットが 0 に設定された IP アドレスになります。

IP 非ユニキャスト アドレス上の LSB
該当するエントリの IP アドレスに関連付けられた (論理) インタフェースでデータグラムを送信するために使用される IP ブロードキャスト アドレスにおける最低限重要ビットの値です。たとえば、インターネットの標準的なオールワン ブロードキャスト アドレスが使用されている場合、値は 1 になります。この値は、サブネット、および (論理) インタフェース上のエンティティによって使用されるネットワーク ブロードキャスト アドレスの両方に適用されます。

再構築可能な IP データグラムの最大
該当するエンティティが、インタフェース上の受信 IP フラグメント データグラムから再構築可能な IP データグラムの最大サイズです。


ネットとメディア テーブル

IP アドレスから物理アドレスへのマッピングに使用される IP アドレス変換表です。

インタフェース インデックス
該当するエントリの等価性が有効なインタフェースです。

メディア依存の物理アドレス
メディア依存の物理アドレスです。

IP アドレス
メディア依存の物理アドレスに対応する IP アドレスです。

マッピング タイプ
マッピング タイプです。以下のいずれかの値になります。
static
dynamic
invalid
other (上記以外)


インタフェース

インデックス
インタフェースを識別するための一意な値です。

説明
インタフェースに関する情報です。この情報には、製造元、製品名、ハードウェア インタフェースのバージョンが含まれます。

タイプ
プロトコル スタック内のネットワーク レイヤの直下にある物理/リンク プロトコルによって区分されるインタフェースのタイプです。

MTU
インタフェース上で送信/受信可能なデータグラムの最大サイズです (オクテットで指定)。

速度
インタフェースの現在の処理能力の推定値 (ビット/秒) です。処理能力が変化しないインタフェース、または正確な推定値が計測不能なインタフェースの場合、名目上の処理能力が表示されます。

アダプタ物理アドレス
プロトコル スタック内のネットワーク レイヤの直下にあるプロトコル レイヤにおけるインタフェースのアドレスです。

管理者ステータス
インタフェースの目的のステータスです。up、down、testing のいずれかの値になります。testing ステータスの場合、通過可能な処理パケットがないことを示します。

処理ステータス
インタフェースの現在の処理ステータスです。up、down、testing のいずれかの値になります。testing ステータスの場合、通過可能な処理パケットがないことを示します。

バイト受信
インタフェースで受信されたオクテットの合計数 (フレーム文字を含む) です。

配信されたユニキャスト パケット数
高次のレイヤ プロトコルに配信されたサブネットワーク ユニキャスト パケットの数です。

配信された非ユニキャスト パケット数
高次のレイヤ プロトコルに配信された非ユニキャスト (サブネットワーク ブロードキャストまたはサブネットワーク マルチキャスト) パケットの数です。

破棄された入力パケット
高次のレイヤ プロトコルに配信する妨げとなるエラーがないにもかかわらず破棄された入力パケットの数です。パケットが破棄された理由の 1 つとして、バッファ スペースの不足が考えられます。

エラー入力パケット
高次のレイヤ プロトコルに配信する妨げとなるエラーを含む入力パケットの数です。

破棄された不明プロトコル入力パケット
プロトコルが不明またはサポートされていないために破棄された、インタフェースを介して受信されたパケットの数です。

バイト送信
インタフェースから送信されたオクテットの合計数 (フレーム文字を含む) です。

要求されたユニキャスト パケット数
高次のプロトコルがサブネットワーク ユニキャスト アドレスに転送するように要求したパケットの合計数 (破棄されたり、送信されなかったパケットを含む) です。

要求された非ユニキャスト パケット数
高次のプロトコルが非ユニキャスト (サブネットワーク ブロードキャストまたはサブネットワーク マルチキャスト) アドレスに転送するように要求したパケットの合計数 (破棄されたり、送信されなかったパケットを含む) です。

破棄された出力パケット数
送信の妨げとなるエラーがないにもかかわらず破棄された出力パケットの数です。パケットが破棄された理由の 1 つとして、バッファ スペースの不足が考えられます。

エラー破棄出力パケット数
エラーが原因で送信されなかった出力パケットの数です。

出力パケット キュー
出力パケット キューの長さ (パケット単位) です。

MIB 固有の情報
インタフェースを実現するために使用されている特定のメディア固有の MIB 定義情報です。この情報が表示されない場合、値は 0.0 に設定されます。


ファイル システム

[ファイル システム] タブでは、今まで Windows エクスプローラで取り扱ってきたメンテナンス作業のほとんどを行うことができます。さらに、AWRC には、Windows エクスプローラにはない特別な機能も用意されています。また、リモート システムが他ユーザに対して共有を公開していない場合、ネットワークで Windows エクスプローラを使用して操作を行うことはできませんが、AWRC ではそれが可能になります。

· ダウンロード ファイル:まずファイルとフォルダ ツリーをクリックして選択します (複数のファイルを選択する場合は、Shift キーまたは Ctrl キーを押しながらクリックします)。次に、右クリックしてポップアップ メニューを表示し、[ダウンロード ファイル]、[圧縮] または [ダウンロード ファイル]、[未圧縮] の順にクリックします。[圧縮] を選択すると、ダウンロードするファイルが圧縮されてない場合に、ネットワークのトラフィック量とダウンロード時間が大幅に削減されます。サイズの大きいファイルでは圧縮自体に時間がかかるので、高速の LAN では [未圧縮] オプションを選択したほうがよいでしょう。ダウンロードが完了したら、ダウンロード ファイルの保存先を指定する必要があります。

· アップロード ファイル:まず、右クリックしてポップアップ メニューを表示し、[アップロード ファイル]、[圧縮] または [アップロード ファイル]、[未圧縮] の順にクリックします。次に、リモート システムにアップロードするファイルとフォルダ ツリーを選択して、[OK] をクリックします。アップロードが開始されると、処理開始時にリモート システムで選択したディレクトリにファイルとフォルダ ツリーが転送されます。[圧縮] を選択すると、アップロードするファイルが圧縮されてない場合に、ネットワークのトラフィック量とアップロード時間が大幅に削減されます。サイズの大きいファイルでは圧縮自体に時間がかかるので、高速の LAN では [未圧縮] オプションを選択したほうがよいでしょう。

· 起動ファイル:[ファイル システム] タブのグリッドを右クリックして [起動ファイル] をクリックすると、(リモート システム上でのファイルの関連付けに従って) リモート ファイルを実行することができます。
ファイルの実行は以下の資格で行えます。
リモート インタラクティブ ユーザ:
リモート コンピュータにログオンするユーザの資格を使用します。
現在のユーザ:
自身がリモート コンピュータにログオンするための資格を使用します。
システム アカウント:
あたかもオペレーティング システムであるかのようにファイルを実行できます。
その他 (ユーザ/パスワード):
RunAs コマンドのように動作します。

ユーザ アカウントからファイルを実行すると、該当するアカウントのレジストリの HKEY_CURRENT_USER ハイブにアクセスできます。

· 選択されたファイルの Zip:ローカル システム上と同じようにリモートシステム上でも簡単にファイルを Zip (圧縮) できます。また、パスワードを設定することで、新たに作成した Zip ファイルの内容へのアクセスを制限することもできます。一定レベルの保護を実現するためにも、大文字と小文字、数字などを組み合わせて、できるだけ長い (8 文字以上を推奨) パスワードを設定するようにしてください。短いパスワードは専門のソフトウェアによって簡単に解読されてしまいます。このパスワードは他の Zip ユーティリティと互換性があります。指定の Zip ファイル名が既に存在している場合は、ファイルはその Zip ファイルに追加され、再作成されることはありません。Zip ファイルの保存先のディレクトリは正しく入力するようにしてください。指定したディレクトリが存在しない場合、自動的に作成されることはありません。

· 選択されたファイルの Unzip:リモート システム上のファイルを Unzip (解凍) するには、まず対象の Zip ファイルをクリックして選択し、右クリック メニューで [選択されたファイルの Unzip] をクリックします。ファイルに Zip 拡張子が付いている必要はありませんが、壊れていない実際の Zip ファイルでなければなりません。AWRC がリモート システム上で確認できるのは、ファイルの完全性だけです。完全性に問題があると、Unzip が失敗する可能性があります。Unzip には、以下のオプションが用意されています。
* 展開先ディレクトリ:存在しないディレクトリを入力しても、可能であれば自動的に作成されます。
* 上書きモード:[常に] － 同名のファイルは常に上書きされます。[しない] － 同名のファイルが存在する場合、そのファイルは展開されません。[ZIP 内が新しい場合] － 展開対象のファイルが既存のファイルより新しい場合にのみ既存のファイルを上書きします。[ZIP 内が古い場合] － 展開対象のファイルが既存のファイルより古い場合にのみ既存のファイルを上書きします。
* 読み込みのみを置換:Unzip 処理で読み込み専用のファイルを置換することを許可します。
* ディレクトリを再作成:ファイルの展開時に Zip ファイルのディレクトリ構造を維持する場合はオンにしてください。ディレクトリは保存先ディレクトリと相対的に作成されるようになります。オフにすると、すべてのファイルが保存先ディレクトリに展開されるため、[上書きモード] オプションを [常に] に設定している場合、同名のファイルが上書きされてしまいます。
* パスワード:ファイルを展開するためのパスワードを入力します。このパスワードは他のユーティリティによって作成された Zip アーカイブと互換性があります。

· ディレクトリの作成:ディレクトリを作成します。同名のディレクトリが既に存在する場合は作成することはできません。

· ファイルまたはディレクトリの名前変更:ファイルやディレクトリの名前は、変更後の名前が既存の名前と重複しない限り、自由に変更することができます。ただし、ファイルやディレクトリが一部のプロセスで使用されている場合、名前を変更することはできません。

· 選択されたファイルおよびディレクトリの削除:[可能であればゴミ箱に入れる] チェック ボックスをオフにしている場合、選択したファイルおよびディレクトリは完全に削除されてしまうので注意してください。完全に削除してしまうと、復元する方法はありません。[可能であればゴミ箱に入れる] チェック ボックスをオンにしていたとしても、常に削除したファイルおよびディレクトリがゴミ箱に入れられるとは限りません。そのため、ファイルおよびディレクトリを削除する際は、細心の注意を払うようにしてください。

· 選択されたファイルおよびディレクトリのコピー:コピーは 2 段階で行われます。まず、コピーするファイルをクリックして選択し、右クリック メニューで [選択されたファイルおよびディレクトリのコピー] をクリックします。AWRC ではコピー対象のファイルを内部的に保存します。正式なコピーは、右クリック メニューで [ファイルおよびディレクトリの貼り付け] をクリックした場合にのみ実行されます。[ファイルおよびディレクトリの貼り付け] をクリックする際は、事前にファイルのコピー先フォルダを表示している必要があります。

· 選択されたファイルおよびディレクトリの移動:移動は 2 段階で行われます。まず、移動するファイルをクリックして選択し、右クリック メニューで [選択されたファイルおよびディレクトリの移動] をクリックします。AWRC では移動対象のファイルを内部的に保存します。正式な移動は、右クリック メニューで [ファイルおよびディレクトリの貼り付け] を選択した場合にのみ実行されます。[ファイルおよびディレクトリの貼り付け] をクリックする際は、事前にファイルの移動先フォルダを表示している必要があります。

メモ:これらのオプションは、接続時にのみ右クリック メニューに表示されます。

[ファイル システム] タブには、現在の論理ドライブに関する有益な情報 (ファイル システム、タイプ、容量、シリアル番号、ラベル、空容量) も表示されます。


ユーザ

ユーザ アカウントの詳細が表示されます。

· ユーザ アカウント:ユーザ アカウントの名前です。

· パスワード経過期間:パスワードの最終更新日からの経過期間を示します。

· 権限レベル:ユーザ アカウントに割り当てられている権限のレベルです。権限レベルには、"管理者"、"ユーザ"、"ゲスト" があります。

· コメント:ユーザ アカウントに関連するコメントです。

· フラグ:いくつかの機能を決定します。

· フル ネーム:ユーザのフル ネームです。

· ワークステーション ログイン元:ユーザがログイン可能なワークステーションの名前です。8 台のワークステーションまで指定可能です (名前はコンマで区切ります)。1 台もワークステーションを指定していない場合は、"制限なし" と表示されます。

· 最終ログオン:ドメインの異なるバックアップ ドメイン コントローラ (BDC) から取得された場合、この値は同じにならないことがあります。正確な値を取得するには、ドメインの各 BDC に問い合わせる必要があります。最終ログオンの時間は、取得された値の中で最も大きい値が表示されます。

· 最終ログオフ:ドメインの異なるバックアップ ドメイン コントローラ (BDC) から取得された場合、この値は同じにならないことがあります。正確な値を取得するには、ドメインの各 BDC に問い合わせる必要があります。最終ログオフの時間は、取得された値の中で最も大きい値が表示されます。

· アカウント期限:特定の日付/時刻、または "無期限" と表示されます。

· ユーザ ID (RID):ユーザの相対 ID (RID) です。RID はユーザの作成時に Security Account Manager (SAM) によって決定されます。ユーザ アカウントは、ドメイン内の SAM で一意に定義されます。

· プライマリ グローバル グループ (RID):ユーザのプライマリ グローバル グループの相対 ID (RID) です。

· SID:各ユーザおよびグループは、セキュリティ識別子 (SID) と関連付けられています。
SID は以下の内容で構成されます。
· 改訂:この値は、特定の SID で使用されている SID 構造のバージョンを示します。Windows NT、Windows 2000、Windows XP によって生成された SID で使用される構造は改訂レベル 1 になります。
· 識別子機関:この値は、特定の種類のセキュリティ プリンシパルで SID を発行できる最高レベルの機関を示します。たとえば、グループ "Everyone" の SID の識別子機関の値は 1 になります (World Authority)。Windows NT、Windows 2000、Windows XP のアカウントまたはグループの場合、SID の識別子機関の値は 5 になります (NT Authority)。
· サブ機関:SID で最も重要な情報は、一連の 1 つまたは複数のサブ機関の値に含まれます。すべての値 (一連の値の中の最後の値を除く) が企業内のドメインを集合的に識別します (ドメイン識別子)。一方、最後の値は特定のアカウントまたはグループをドメインに対して相対的に識別します (RID: 相対識別子)。

· ドメイン:アカウント名が見つかったドメイン名、またはドメインがない場合はローカル マシン名です。

· サブ承認機関番号:SID に含まれているサブ承認機関の数です。

· SID 長:SID 長をバイト単位で示します。

· SID タイプ:SID のタイプには、"ユーザ"、"グループ"、"ドメイン"、"エイリアス"、"分かっているグループ"、"削除されたアカウント"、"無効"、"不明" があります。


グループ

リモート サーバ上の各ローカル グループおよびグローバル グループのアカウントに関する情報が表示されます。

· 名前:ローカル グループまたはグローバル グループの名前です。

· SID:各グループは、セキュリティ識別子 (SID) と関連付けられています。SID の詳細については、「ユーザ」を参照してください。

· コメント:ローカル グループまたはグローバル グループに関連付けられた注釈です。

· 属性:グローバル グループの以下の属性は、デフォルトでハードコードされています。
· 義務グループ:AdjustTokenGroups 関数の呼び出しによって、SID の "有効なグループ (Group Enabled)" 属性は取り消されることはありません。ただし、CreateRestrictToken 関数を使用すれば、"義務 SID" を "拒否のみ SID" に変換することは可能です。
· デフォルトで有効なグループ:SID はデフォルトで有効です。
· 有効なグループ:SID はアクセス チェックで有効になります。システムがアクセス チェックを実行する際、SID に適用する、アクセス許可およびアクセス拒否の ACE をチェックします。


パスワード ハッシュ

この機能は、システム管理者がシステムで適切なパスワードが使用されているかどうかを監査できるようにするために導入されました。システムを十分なテストを行わずに安全であると考えるのは賢明ではありません。多くの場合、システムは決して安全ではありません。パスワードはシステムを管理する上で基礎となる鍵になります。ユーザのパスワードの質を定期的に評価し、容易に推測できるパスワードを使用しているユーザには助言したほうがよいでしょう。

パスワードは NT テクノロジ システムでは、ハッシュとして以外、どこにも保存されません。

AWRC はパスワード ハッシュをリモートからすばやく取得することができます。これは、デフォルトの Syskey 保護が有効になっていても、Windows 2000 ネットワークのアクティブ ディレクトリ内にあっても可能です。

ハッシュから元のパスワードを復元することは常に可能です。数秒で終わるものもあれば、数日または数か月かかるものもありますが、時間が短いほど脆弱なパスワードであるといえます。L0phtCrack などのように、時間さえかければハッシュから元のパスワードを割り出すことができるソフトウェアも出回っています。

L0phtCrack を使用するのであれば、AWRC で保存したハッシュを L0phtCrack に入力できるようにするために、PWDUMP からインポートするオプションを選択してください。
メモ:PWDUMP は、lsass.exe アドレス空間に特別な DLL を読み込むことで、リモート コンピュータからハッシュをキャプチャすることができるコマンド ライン ユーティリティです。キャプチャしたハッシュはレジストリに格納されるので、リモート レジストリに接続すれば取得することができます。

脆弱なパスワードはハッシュから数分、場合によっては数秒で割り出されます。常に、! * { $ * # % などの文字、大文字と小文字、および数字を組み合わせて、長くて強力なパスワードを使用するようにしてください。すべてのパスワードはハッシュから割り出し可能ですが、できる限り難しくしておくことが賢明です。

(*) リモート コンピュータが 64 ビットのオペレーティング システムで動作している場合、この機能は使用できません。


チャット

AWRC には、リモート コンピュータ上のインターラクティブ ユーザとチャットをするための機能も備わっています。チャットを開始できるのはローカル コンピュータの側だけです。リモート コンピュータの側からチャットを開始することはできないようになっています。ただし、リモート コンピュータ上のインターラクティブ ユーザはチャット ウィンドウを閉じることでチャットを終了することはできます。


設定

[設定] タブの [オプション] ボタンをクリックすると、さまざまな機能のデフォルト値を設定することができます。
また、強力な暗号化環境を構築することも可能です。


一般

· リフレッシュ レート
[最速] から [一時停止] までの範囲で指定できます。[最速] を指定すると、スクリーンの更新はほぼリアルタイムで進行します。[一時停止] を指定すると、更新が停止します。

· デスクトップ色
16 色 (4 ビット)、256 色 (8 ビット)、65536 色 (16 ビット)、トゥルーカラー (24 ビット)、トゥルーカラー (32 ビット) のいずれかを指定できます。
通常は、トゥルーカラーまたは 16 ビット色を選択することをお勧めします。その他の色は、通信状態が悪い場合に適しています。

· リモートでの Ctrl+Alt+Del ホットキー
リモート コンピュータで Ctrl+Alt+Del を実行してログオン ボックスにアクセスできるようにするには、ローカル コンピュータでキーボード ショートカット (ホットキー) を設定する必要があります。デフォルトでは Ctrl+Alt+D に設定されていますが、必要に応じて、その他のキーの組み合わせに変更することもできます。
好ましい組み合わせは、文字キー、数字キー、またはファンクション キーのいずれか 1 つのキーと、Ctrl、Alt、Shift のうち少なくとも 2 つのキーを同時に押すことです。なお、文字キー、数字キー、またはファンクション キーだけを押すと、Ctrl+Alt が自動的に追加されるようになっています。新しいショートカットが利用可能かどうかは、ソフトウェアによって自動的にチェックされます。利用可能な場合は、[適用] ボタンをクリックして、変更内容を保存します。これで、次回から新しいショートカットでの操作が可能になります。
例:Ctrl+Alt+F9、Shift+Alt+1、Ctrl+Shift+Alt+Z

· フルスクリーン ホットキー
このホットキーを押すと、フルスクリーンから通常モードへ戻すことができます (通常モードからフルスクリーン モードに切り替えるには、 フルスクリーン ボタンをクリックします)。
デフォルトでは Ctrl+Alt+Z に設定されていますが、必要に応じて、その他のキーの組み合わせに変更することもできます。
好ましい組み合わせは、文字キー、数字キー、またはファンクション キーのいずれか 1 つのキーと、Ctrl、Alt、Shift のうち少なくとも 2 つのキーを同時に押すことです。なお、文字キー、数字キー、またはファンクション キーだけを押すと、Ctrl+Alt が自動的に追加されるようになっています。新しいショートカットが利用可能かどうかは、ソフトウェアによって自動的にチェックされます。利用可能な場合は、[適用] ボタンをクリックして、変更内容を保存します。これで、次回から新しいショートカットでの操作が可能になります。
例:Ctrl+Alt+F9、Shift+Alt+1、Ctrl+Shift+Alt+Z

· すべてのフォント サイズのリセット
すべてのテーブル上のユーザ定義のフォント サイズをリセットし、初期設定値に戻します。

· リモート ホスト履歴の消去
すべてのリモート ホスト履歴をリストから消去します。

· レイヤ化されたウインドウを見る
このチェック ボックスをオンにすると、リモート デスクトップ上に小さなツールチップが表示されます。ただし、リモート デスクトップ上でマウスが点滅して表示されるようになります。チェック ボックスをオフにすると、この点滅はすべてのコンピュータから消えます。ほとんどのユーザがマウスの点滅を好まないため、このオプションはデフォルトでオフに設定されています。

· 切断時にグリッドを消去
切断時にすべてのグリッドを消去するか、そのまま残しておくかを指定できます。そのまま残しておけば、事後分析に役立つでしょう。

· リモートからの承認リクエスト
このチェック ボックスをオンにすると、デフォルトで、リモート コンピュータに接続するたびに、リモート コンピュータ上に承認を要求するウィンドウが表示されるようになります。

· リモート キーボード動作
このチェック ボックスをオンにすると、デフォルトで、接続時にリモート キーボードにアクセスできるようになります。

· リモート マウスの動作を見る
リモート マウスの動作を必要に応じて監視することができます (デフォルトでは、オンに設定)。

· 永久的マウス ポインタ
このチェック ボックスをオンにすると、リモートコンピュータ上でマウスが無効の場合でも、ローカル ユーザはマウスの矢印カーソルを見ることができ、リモート デスクトップの動作がわかりやすくなります。

· ユーザ名とパスワードを自動入力
このチェック ボックスをオンにすると、接続時に使用しているユーザ名とパスワードがレジストリに保存され、プログラムの起動時に対応するボックスに自動的に入力されるようになります。しかし、パスワードを知らないユーザでもローカル コンピュータにアクセスできるようになるので、セキュリティ上安全とはいえません。
なお、チェック ボックスをオンにした場合、[ユーザ名] と [パスワード] の各ボックスの色が変化し、プログラムの終了時に警告が表示されます。

· フルスクリーン表示レートをメンテナンス:
フルスクリーン モードでは、リモート スクリーンの解像度縦横比はローカル スクリーンの解像度縦横比とは異なります。このチェック ボックスをオンにしないと、リモート スクリーンのローカル コンピュータ上でのイメージが歪曲することがあります。縦横比が異なるときには、ローカル スクリーンの一部が黒い帯として表示されます。

· デフォルト スケール
いつも同じマシンに接続する場合や、理想のスケールがわかっている場合は、ここで設定することで、接続するたびにそのスケールが適用されるようになります。

· 圧縮レベル
高速の LAN では [軽] を使用するほうが処理速度が速くなるでしょう。一方インターネット上では [強力] を使用してください。デフォルトでは [通常] に設定されています。これは、[軽] と [強力] の中間的な位置付けです。

· 接続タイムアウト
マシン間でのやりとりが行われない最大許容時間です。デフォルトでは 16 秒となっていますが、処理能力の低い環境、または負荷の高いシステムでは、短すぎるかもしれません。自然に接続が切断されることがある場合には、高い値 (最大 120 秒まで) を設定するようにしてください。なお、最小値は 10 秒です。


暗号化

暗号化接続を利用するには、まず秘密鍵 (プライベート キー) と公開鍵 (パブリック キー) のペアを生成する必要があります。
それには、ボックスにテキストを書き込むか貼り付けて、[キーの生成] ボタンをクリックします。セキュリティ面に不安がある場合は、入力したテキストを誰にも教えないでください。

生成された秘密鍵と公開鍵はレジストリに格納され、いつでも使用することができます。なお、秘密鍵は暗号化された状態でレジストリに格納されますが、これがセキュリティ面の確実な保障になるわけではありません。原則的には、ユーザが自身のローカル マシンの安全性に責任を持つ必要があります。AWRC が保障できるのは、ユーザが第三者に秘密鍵へのアクセスを許可しない限り、コンピュータ間でやりとりされる情報は解読されることはないということだけです。

キーのペアは、必要に応じていつでも生成し直すことができます。生成し直したキーは、次回の暗号化接続時から使用されます。

秘密鍵と公開鍵のペアを生成したら、[強力な暗号化を使用] チェック ボックスをオンにするだけで、暗号化接続を利用できるようになります。

暗号化接続時には、[接続] ボタンの下に赤い南京錠 (施錠) マークが表示されます。


リモート サービス

AWRC は接続時にリモート コンピュータ上でサービス プロセスを実行します。このサービスは、ローカル コンピュータから受信した指示を取り込み、準備し、ディスパッチする役割を果たします。この機能は、サービスの所在を隠すための機能に対するユーザからの要望に応えて導入されました。

ただし、最新の AWRCAC リリースでは、たとえ AWRC を隠していても検知し停止できるようになっています。これは設計上そうなっており、多くの場合、AWRCAC を回避する特別な AWRC ビルドを作成する正当な理由がないからです。

· ファイル名:
バイナリ名を変更することができます (デフォルトでは、awrexec.exe)。正しい構文であればどのようなファイル名にも変更可能です。たとえば、拡張子のないファイル名でも、たとえば My File Name のようなものでもかまいません。

· サービス名:
インストールするサービスの名前を指定します (最大で 256文字)。スラッシュ (/) とバックスラッシュ (\) はサービス名には使用できません。

· ディスプレイ名:
サービスを識別するためにユーザ インタフェース プログラムで使用されるディスプレイ名を指定します。指定可能なディスプレイ名の長さは最大で 256 文字です。ディスプレイ名を空白にした場合、ユーザ インタフェース プログラムは代わりにサービス名を表示します。


アップデート

AWRC は、手動 (デフォルト) でアップデートすることも、自動でアップデートすることもできます。アップデートが検出され、ユーザがそのアップデートを受け入れると、新しいソフトウェアが Web サイトから直接インストールされます。セットアップ プログラムやインストール プログラムを実行する必要はありません。アップデートによっては、従来のようにインストール プログラムを Web サイトからダウンロードできるようにはなっておらず、このオプションからしかインストールできないものもあります。そのため、定期的にアップデートをチェックすることをお勧めします。


パスワード

パスワードを入力しないと AWRC を起動できないようにするには、[AWRC のパスワードを設定する] チェック ボックスをオンにします。
次に、その下の 2 つのボックスにパスワードを入力して、[適用] ボタンをクリックします。
パスワードを解除するには、[AWRC のパスワードを設定する] チェック ボックスをオフにするだけです。


使用許諾契約書

本ソフトウェアをご使用になる前に以下の使用許諾契約書の条項を注意深くお読みください。

ATELIER WEB REMOTE COMMANDER (AWRC) 使用許諾契約書

登録前の評価期間
評価期間を過ぎて無断で本ソフトウェアを利用することはポルトガルの著作権法および国際著作権法に違反します。評価期間は 15 日または実行回数 30 回のいずれかを先に満たした時点で終了となります。

法的効力
本契約書はポルトガル共和国の法律に基づくものとします。

免責事項
本ソフトウェアおよび付属ファイルは、「現状有姿 (AS IS)」の形で提供されるものであり、明示あるいは黙示を問わず、運用上、商取引上、またその他のいかなる保証も伴いません。本ソフトウェアの動作環境はハードウェアまたはソフトウェアを問わず多種にわたるため、特定用途への適合性に関する保証は行われません。

お客様は、重要なデータの処理および管理を開始する前に、危険のないデータで十分にテストすることを義務付けられています。本ソフトウェアの運用上発生するいかなる損害に関する責任もお客様にあります。販売者の保証義務は、製品の交換または購入金額の返還に限られます。

評価版の配布
本ソフトウェアの配布が許諾されているのは評価版 (AWRC の [設定] タブで確認可能) に限られます。お客様は、本ソフトウェアの評価版および関連資料のコピーを必要な数だけ作成すること、本ソフトウェアの評価版のオリジナルのコピーを他のユーザに付与すること、本ソフトウェアの評価版および関連資料をオリジナルの状態のまま電子媒介で配布すること、が許諾されています。上記のいずれの事項にも料金は発生しません。

しかしながら、Atelier Web の書面による事前の許可なくして、このようなコピーを作成および配布することで使用料金を課したり要求すること、またその他の製品 (商業用如何を問わず) とともに本ソフトウェアおよび関連資料を配布することは固く禁じられています。

登録版
· 個人ユーザ/ワークグループ向けライセンス
本ソフトウェアを Microsoft Windows ワークグループ内で個人的に利用する (同じユーザが使用しているコンピュータであれば最大 2 台のコンピュータで利用可能) ことを目的とした個人ユーザ向けのライセンスです。
· 個人ユーザ/ドメイン向けライセンス
本ソフトウェアを Microsoft Windows ドメイン内またはワークグループ内で個人的に利用する (同じユーザが使用しているコンピュータであれば最大 2 台のコンピュータで利用可能) ことを目的とした個人ユーザ向けのライセンスです。
· 団体向けライセンス
企業または機関の Microsoft Windows ドメイン内またはワークグループ内で使用されているローカル エリア ネットワークで、ライセンスの詳細であらかじめ決められている台数のコンピュータに本ソフトウェアをインストールして利用することができる団体向けのライセンスです。


購入

前へ トップページ

AWRC は無料のソフトウェアではありません。使用許諾契約書の条項によって、評価目的のため 15 日間または 30 回実行分だけソフトウェアを無料で使用することが許諾されています。評価期間を過ぎて継続して使用する場合は、ソフトウェアを購入する必要があります。

購入情報

価格情報およびオンラインでの購入手続きについては、以下のサイトを参照してください。

http://www.shareedge.com/

また、その他のご質問についても、以下の宛先までお気軽にお問い合わせください。

contact@nextEDGEtech.com

登録ユーザの特典

· 評価版に設けられていた機能制限が取り除かれ、すべての機能を利用できる。
· AWRC のライセンスの種類に応じて、決められた数の AWRCAC (Atelier Web Remote Commander Access Control) ライセンスが無償で付与される。

AWRC 個人ユーザ向けライセンス: AWRCAC 1 ライセンス
AWRC 団体向けライセンス: AWRCAC 3 ライセンス
· 電子メールによるテクニカル サポートを無料で受けられる。
· メジャー リリースの最新情報が配信される。


よくある質問 (FAQ)

以下は、弊社サポート スタッフに実際に問い合わせのあった質問とその回答です。たいていの場合、回答はドキュメント内のいずれかのトピックで言及されています。
より詳細な最新の FAQ 集については、http://www.atelierweb.com/rcomm/faq.htm (英語) を参照してください。

リモート コンピュータ上で Ctrl+Alt+Del を実行するには?.
Ctr+Alt+D を押すことで Ctrl+Alt+Del (SAS: Security Attention Sequence) を実行することができます。このホットキーの組み合わせは、[オプション] ダイアログ ボックスで独自に定義することができます。

他のリモート コンピュータに接続できないのですが?
ローカル エリア ネットワークの場合もインターネットの場合も、Microsoft Networks が動作している、つまり Client for Microsoft Networks がローカル マシンおよびリモート マシンの両方にインストールされている必要があります。また、少なくともリモート マシン上でファイルとプリンタの共有が可能でなければなりません。
リモート コンピュータのプラットフォームが Windows XP Professional の場合は、ローカル アカウントの共有とセキュリティ モデルが "クラシック" に設定されている場合にのみアクセス可能です。この設定は、コントロール パネルから [管理ツール]、[ローカル セキュリティ ポリシー] の順にクリックし、[ネットワーク アクセス: ローカル アカウントの共有とセキュリティ モデル] で [クラシック - ローカル ユーザーがローカル ユーザーとして認証する] を選択することで有効にできます。また、Windows エクスプローラで [ツール]、[フォルダ オプション]、[表示] の順にクリックし、[簡易ファイルの共有を使用する] チェック ボックスをオフにしても、有効にすることができます。

AWRC ではどのポートが使用されますか?
AWRC はいかなるポートも開きません。ただ、Microsoft Networks が必要になります。Microsoft Networks では、135、137、138、139、または 445 のポートが使用されます。ただし、AWRC による処理は、TCP ポート 445 (Windows 2000、XP、Server 2003) または TCP ポート 139 (Windows NT 4: ポート 445が使用できない場合 Windows 2000、XP、Server 2003 でもこのポートが使用されます) を介してのみ実行されます。なお、ポート 135、137、138、および 139 (または 445) は、AWRC とは関係なく、ファイアウォールまたはルータによってブロックされることがあります。

AWRC はファイアウォールに透過的であると聞いたのですが、会社の LAN では動作しないのですが?
ファイアウォールが Microsoft Networks をブロックしています (特に、ポート 139 または 445)。「AWRC ではどのポートが使用されますか?」の質問を参照してください。

インターネットで AWRC を使用しても安全ですか?
Microsoft Networks は、特にポート 139 と 445 では、堅固なパスワードを使用している限り、セキュリティ面について心配することはありません。すべてのセキュリティはパスワードに基づいているため、悪意のある攻撃の標的とされたとしても、それはパスワード辞書攻撃によるものだけです。したがって、推測されにくい堅固なパスワードを使用することが重要になります。
また、AWRC では、強力な暗号化技術を利用することで、両エンド ポイント間のデータ通信を事実上傍受不可能にすることができます。

AWRC と GotoMyPC の違いは?
GotoMyPC はすべての接続履歴を記録し、データ フローは開発元の通信サーバを経由します。
GotoMyPC の多くの機能が AWRC に比べて脆弱で、その接続は遅く、スクリーン キャプチャの質もよくありません。

AWRC と pcAnywhere の違いは?
pcAnywhere を使用するためには、各リモート コンピュータに 20MB のプログラムをインストールしなければならず、既に他のソフトウェアでも利用可能な機能のために高い金額を支払わされます。

インターネットで他のコンピュータに接続するには?
同じルールが当てはまりますので、上記の関連する質問を参照してください。ローカル コンピュータおよびリモート コンピュータがルータやパーソナル ファイアウォールの背後にある場合は、以下の点を確認してください。
－ ローカル コンピュータのパーソナル ファイアウォールが、TCP ポート 445 または TCP ポート 139 (あるいはその両方) で外部への接続を許可していること。
－ リモート ネットワークのルータが、TCP ポート 445 または TCP ポート 139 (あるいはその両方) を接続先マシンのプライベート IP アドレスに転送していること。
リモート マシンのパーソナル ファイアウォールが、TCP ポート 445 または TCP ポート 139 (あるいはその両方) で内部への接続を許可していること。

接続を試行すると、"ネットワーク パスが見つかりません" というエラー メッセージが表示されるのですが?
接続は AWRC によってではなく Microsoft Networks によって行われます。このメッセージは、AWRC のエラーではありません。Microsoft の Web サイトまたは Google で該当する説明を検索してみてください。

XP Home Edition のラップトップに接続できないのですが?
XP Home Edition には接続できません。「システム要件」を参照してください。

AWRC をローカル コンピュータに接続することは可能ですか?
はい、可能です。AWRC はローカル システムの分析および管理を行う上での重要なツールともなります。AWRC には、ローカル システムの情報を表示したり、管理したりするための非常に優れた機能が備わっています。これらの操作は、ほとんどの場合、ローカル システムの操作を専門として開発された既存のツールでは行うことはできません。ローカル システムに接続するには、コンピュータ名または IP アドレスのいずれかを入力して、[接続] ボタンをクリックするだけです。

サードパーティの Web サイトからダウンロードした AWRC を実行すると、いくつかのエラーが表示されるのですが?
AWRC は、以下の弊社 Web サイトまたはミラー サイトからダウンロードするようにしてください。
http://www.atelierweb.com/rcomm/download.htm
http://atelierweb.swmirror.com (ミラー)
また、AWRC の日本語版については、以下のシェアエッジ Web サイト (弊社認定済み) からダウンロードしてください。
http://www.shareedge.com/modules/shareware/view_shareware.php?lid=20040917-001
リバース エンジニアリングによる AWRC の海賊版は正常に動作しません。特に、海賊版サイトの中には、AWRC をトロイの木馬と一緒に配布していることもあるので注意してください。

AWRC は Windows XP Service Pack 2 で動作しますか?
はい、正常に動作します。

AWRC は Longhorn で動作しますか?
Longhorn が正式にリリースされるまでには対応予定です。現時点では特に問題は予想されていません。弊社では、変更が必要な箇所についてもすべて把握しており、その準備に取りかかっています。


.topic 13

Atelier Web Remote Commander lets you manage and audit servers and workstations from your local computer and provide remote helpdesk support.
At first sight, this does not seem to bring anything new to the arena, since there are very powerful tools in the market that provide remote connection capabilities with good performance.

However, the very moment you install and try AWRC you will immediately notice that you are dealing with a completely different sort of tool.

AWRC does not require that you install any software on the remote machine, simply point and shoot. This turns the software particularly useful for accessing remote machines where no previous preparation has been made.
Unlike the competition, mostly concerned with viewing the remote desktop window, AWRC provides lots of powerful tools for remote management and audit. With such tools you will be able to perform operations on the remote system that the remote interactive user himself could only dream about. With AWRC you can know and do virtually anything on the remote computer!
AWRC is safe. A remote user, without Administrator privileges, can not gain higher privileges by controlling AWRC operation on the remote system.

.topic 8

These are the main features and capabilities of Atelier Web Remote Commander:

Access to the remote computer desktop enabling the launch of software with the mouse or keyboard.
Simulates all keystrokes on the remote keyboard computer.
Wakes-up from screen-savers with a mouse-click or keystroke. Deals with password protected screen-savers.
Simulates the security attention sequence (Ctrl+Alt+Del) on the remote to enable logon and on the default desktop. The default hotkey is Ctr+Alt+D.
Provides access to disks, partitions, folders and files. The partitions or folders are not required to be open shares.
Remote files or directories trees can be downloaded from the remote system.
Local files or directory trees can be uploaded to the remote system.
Programs can be launched on the remote with alternative credentials.
Files can be remotely zipped or unzipped.
New directories can be made and files and directories can be renamed.
Remote files and directories can be deleted, copied or moved.
Allows sending or receiving the Clipboard contents: text, pictures and other standard Windows Clipboard formats.
Provides partition information, namely File System, Type, Serial Number, Volume Label, Capacity and Free space.
Allows visualization of shares.
Allows visualization of users list and account details as well as Local and Global groups.
Allows instant retrieval of password hashes, for audit of strong password policy enforcement across the organization.
Allows visualization and management of services. Services can be started, stopped, paused, resumed and even unloaded.
Allows visualization of processes. Processes can be killed.
Allows remote Shutdown, Power-Off and Reboot.
System Information (Operating System, Processor, BIOS, Memory,.Display Adapter and Logical printers).
Complete and detailed Hardware Devices list.
Physical memory viewer.
Port Finder, which maps applications to open ports.
Provides a vast number of network related information on the remote computer, namely Connections and Listening Ports, TCP statistics, UDP statistics, ICMP statistics, Routing Table, DNS Servers, Persistent Routes, IP Statistics/Settings, Installed Protocols/Protocol Details, Addressing Information Table, Net to Media Table and Interface Statistics/Settings.
Chat facility for conversation with a remote interactive user.
Provides antialiased scaling of remote desktop for comfortable viewing on the local computer.
Uses Windows authentication, which guarantees that only individuals with Administrator privileges on the remote system are able to connect (strong passwords are obviously recommended).
Can use strong encryption to keep the information out of reach from prying eyes.
Request authorization feature for obtaining approval from remote before initiating operations.
The program can be prevented from launching until the correct password is entered.
The remote keyboard and mouse can be disabled during a connection, for the remote interactive user not interfere with the work in progress.
Transparent to Firewalls.
Works within the company's Microsoft Networks LANs and across the Internet.
Does not open any ports - it is absolutely transparent to any firewall, providing the Microsoft Networks operation is not blocked by the firewall.

.topic 9

You must have the following to use this product:

PC compatibles on local and remote systems with Pentium II/III 600 or higher. Pentium/AMD 1000 or higher recommended.
64 MB of RAM on local and remote machine (128 MB or higher, strongly recommended).
Windowsｮ NT 4.0 SP4 or later, Windowsｮ 2000, Windowsｮ XP, Windowsｮ XP Pro x64 64-Bit, Windowsｮ Server 2003 and Windowsｮ Server 2003 x64 64-Bit on the local system and Windowsｮ NT 4.0 SP4 or later, Windowsｮ 2000, Windowsｮ XP Pro, Windowsｮ XP Pro x64 64-Bit, Windowsｮ Server 2003, Windowsｮ Server 2003 x64 64-Bit on the remote system.
If the remote computer platform is Windowsｮ XP Pro, the access is only possible within the classical sharing and security model for local accounts.
This is enabled from Control Panel / Administrative Tools / Local Security Policy / Network access: Classic - local users authentic as themselves. It can also be enabled from Windows Explorer / Tools / Folder Options / View, unselecting the Simple File Sharing checkbox.
Your log-in credentials must have Administrator's privileges on the remote machine or, alternatively, you must be able to supply a User Name/Password of an account in the Administrator's group of the remote machine.
Microsoft Networks, i.e, Client for Microsoft Networks installed on both local and remote machines and File and Printer sharing enabled at least on the remote machine.

.topic 39

Enter the name or IP address of the remote machine on the box labelled Remote Host.
If necessary, enter the user name and password in the boxes User Name/Password.

If you want to use the keyboard on the remote computer tick the Remote Keyboard check box.

Press the Connect button.

If you want to request authorization from the remote before starting operations on it, check the box "Request authorization" before pressing the Connect button.

If you feel problems in connecting or believe that the software falls short of what is expected, proceed as follows:

1. Read carefully the Requirements and make sure your system and the remote system comply with them.
2. Read the FAQ or look for the expanded FAQ in our website at http://www.atelierweb.com/rcomm/faq.htm.
3. If still unsuccessful, contact ask through a form at http://www.atelierweb.com/support.htm. Do not contact us before performing steps 1 and 2, while it is a pleasure to receive your contact, odds are that the answer is already provided either in the Requirements or in the FAQ.

.topic 51

Right clicking on grids then selecting Save or Save As... (Save Grid or Save Grid As... in the File System page) saves the respective contents to a file. You can select a default file name through the Options.
Note: The information is saved in unformatted ASCII, all columns perfectly aligned with the required number of spaces (no tabs).

The remote desktop can also be saved in .BMP format by pressing the Save button on the Desktop page.

Right clicking on grids and selecting Copy to Clipboard copies the respective contents in text format to the clipboard.

You can also print any grid by right clicking on it and selecting Print This.
Note: Fixed Pitch fonts like Courier New (usually) keep the existing alignment, so only these are presented in the Font Settings of the preview.

.topic 29

You can increase or decrease the viewing area by pulling up or down a light green splitter placed between the upper bevelled panel and the lower control panel.

When you are connected, you can press the   button to enter into Full-Screen mode. In Full-Screen mode, the image of
the remote desktop completely covers the screen area of the local computer. To leave Full-Screen press Ctrl+Alt+Z, or the hotkey you have defined under Options.

When the remote screen resolution aspect ratio differs from the local screen resolution aspect ratio, the local image of the remote screen may become distorted. While in general this is not an issue, you can obviate it by selecting 'Maintain Full-Screen aspect ratio' under Options. In this case, the remote width and height receive the same amount of stretch and when the aspect ratio of the local screen differs from the remote screen an area to the bottom or to the right of the screen is left black to compensate for the different ratios.

.topic 40

The fonts of every grid can be resized by clicking the right mouse button over it and selecting Increase Font or Decrease Font.
The font sizes are maintained across sessions.

.topic 1050

The remote desktop screen can be scaled from 25% to 200% of the original size.
Scaling is passed through an antialiasing filter, so that most of the orginal details are kept.
The user can select a default scaling under Options.
In Full-Screen mode the scaling is done automatically but using the same antialiasing filter for maximum visual comfort.

.topic 1040

The local Clipboard contents can be sent to the remote computer and the remote Clipboard contents can be retrieved.
This is accomplished by using the spherical dark yellow buttons on the Desktop page.
AWRC can send and retrieve most standard clipboards formats including pictures and sounds.
Of course, private clipboard formats and OLE-aware formats are not directly transferable from system to system.

.topic 1030

AWRC may connect either with encryption disabled or encryption enabled.
Connections without encryption are good enough for many LAN environment where maintaining data confidentiality is not critical.

However, for connections across potential hostile networks, such as the Internet, AWRC provides very strong encryption, unbreakable either by current cryptography science or by brute force attacks with current hardware.

Encryption works in 2 stages:

In the initial stage, AWRC uses Elliptic-Curve asymmetric keys (equivalent to 1024-bit RSA strength)  to send a 352-bit Session Key to the remote.
First, AWRC sends its Public Key to the remote. The remote produces another key pair through a complex random algorithm, whose outcome is impossible to guess, then sends its own Public Key to the client encrypted with the client's Public key. The client decrypts the remote Public Key then sends the Session Key encrypted with the remote Public Key.

After that, all data exchange is Blowfish CBC encrypted with the 352-bit key length Session Key, no way to decipher it.
Since AWRC encryption and decryption are very fast, you may keep Strong Encryption always on without significant performance penalty.

AWRC encryption does not cover the Microsoft Networks negotiation and protocol itself. Shares and Services information are not encrypted as well, since they are retrieved locally using the Microsoft Networks mechanism. Other than these, everything else, from the remote screen to chat conversations are strongly encrypted and kept away from anyone watching the network traffic.

.topic 1200

If you are an Administrator on the local machine where AWRC is installed, you can prevent other users from launching AWRC by setting a password under Options.
Like most things in computing, the password will not deter a determined hacker, it is just good enough in most cases.
If you decide to uninstall AWRC, make sure you remove the password first. If you don't, the password will be requested the day you install AWRC again and you have to remember it in order to proceeed.

.topic 15

Here you will see screen updates from the remote computer and will be able to interact with the remote desktop.
Mouse clicks and double clicks are replicated on the remote computer on the same screen point you press the mouse buttons on the AWRC captured image. Mouse moves are replicated as well.
When you check the Remote Keyboard checkbox, all keys you press on the local system will be simulated on the remote system. This includes key combinations of International keyboards, though both sides must have compatible keyboard layouts for every key combination to replicate correctly.
Remote Keyboard is checked by default, you can change the setting from the Options menu.

Screen updating can range from Fastest (almost in real time) to Paused (no screen updating).

By pressing the Save button, screen captures can be saved in BMP format for later viewing.

From the Options menu you can select the color model that best fits your requirements:

16 Colors (4 bit)
256 Colors (8 bit)
65536 Color (16 bit)
True Color (24 bit)
True Color (32 bit)

The first and second are suited for problematic traffic conditions, the third is the default. AWRC supports palette-based screen desktops as well as 16-bit, 24-bit and 32-bit true-color either on remote or on local computer.

.topic 20

A comprehensive set of useful information whose purpose is providing a general picture of the remote system characteristics.

Operating System: Full description, including service packs installed, Registered User and Organization, Serial Number, Local Time, Last Boot time and Uptime.
Processor Information: Manufacturer, Vendor ID, CPU name, Family, Model, Stepping, Raw frequency and Norm frequency.
BIOS: Comprehensive SMBIOS ROM information, if available (most recent BIOS do have it available). SMBIOS ROM is instantly read from ROM - because the software does no use the slow (and deprecated) APIs we were accustomed. In the rare occasions that SMBIOS ROM information is not available, AWRC will dig to get some BIOS details from other sources.
Memory details: This includes Total Physical Memory, Free Physical Memory, Total Page File, Page File Free and other.
Display Adapter: Model, Chipset, DAC, Memory, BIOS, Screen Metrics, Font Resolution and Available Video Modes.
Logical Local Printers.

.topic 25

You know the sort of information you get from your local machine when you run the System applet from Control Panel. This is a similar list, but with a few extra details, taken directly from a remote machine.

.topic 27

Enumerates processes in the remote system.

The following operations can be performed from the right-click popup menu of the Processes grid:

Kill process: This is should kill even the more sticky process on the remote system. Be aware that killing some processes may cause serious instability on the remote machine. Use with caution.
Remote shutdown: Shuts down the computer to a point where it is safe to turn off the power. It will attempt to flush all file buffers to disk and wait a while for running processes to stop. Forcibly terminates processes that do not respond to the shut down request.
Remote Power-Off: Shuts down the computer as per the previous option, then turns off the power in systems with a power-off feature.
Remote Reboot: Shuts down, then restarts the remote computer.

Notes:
1. These options only work when the default desktop is active on the remote.
2. These options are only visible on the popup menu when a connection is established.

.topic 17

Enumerates and manages services in the remote Control Manager Database.

The following types of services are enumerated:
Kernel Device Drivers.
File System Drivers.
Services that run in their own process. Can interact or not with the desktop.
Services that share a process with other processes. Can interact or not with the desktop.

The following operations can be performed on remote services, by right clicking on the Services grid and selecting from the Popup menu:
Stop Service, Start Service, Pause Service, Resume Service or Unload Service.
These facilities are very powerful, the software will comply with your request, so make sure you know what you are doing. Particularly, take special care with UNLOADING services - Some services are deeply needed for the correct operation of the remote system.

Note: These options are only visible when a connection is established.

.topic 10

Typically, the operating system maps linear addresses to physical addresses in order to execute code. This mapping is made by setting up page-tables. Whenever a task switch occurs, a process receives a new set of pages which map to areas in the physical address space (when such pages are in disk they are loaded from there into the physical space). Although a process is never concerned or aware of physical addresses it is possible and interesting to have a look at them.

While some physical memory areas are fairly stable over time, most areas keep changing all the time. Either way, searching through the physical memory is a good exercise and provides useful insight.

Note: On Windowsｮ Server 2003 SP1, Windowsｮ Server 2003 x64 64-Bit and Windowsｮ XP Pro x64 64-Bit SP1 you can only retrieve physical memory within the range 0x000C0000 - 0x000FFFFF.

.topic 11

Shares are resources the remote computer makes available to other computers. Resources can be Drives, Print Queues, Communication devices or Interprocess Communication devices.
Shares are visible whenever the remote computer is using Client for Microsoft Networks, has File and Printer Sharing enabled and no firewall is blocking this setup.
When a resource receives a $ sign before its name, it is not visible to the outside World (by normal means).

.topic 21

Ever wonder which programs on the remote PC have ports opened to the outside world? The answer is probably yes.
This information is capital to complete your security assessment of the remote PC.

No other existing software can provide you with this sort of information. We know it, we were the first to find a way to obtain this sort of information from the local machine (with our award winning software AWSPS), now we are the first to obtain this information from a remote machine.

.topic 1060

This grid displays all connected or listening ports in the local system in a given moment.
The Proto column is for protocols, which can be either TCP (Transmission Control Protocol) or UDP (User Datagram Protocol). TCP connections are transient, they cease to exist when (or soon after) the connection makes the transition to the closed state.

The Local Address column shows the local IP address and local port for the TCP connection or UDP listener. For a TCP connection in the listen state or UDP listener that is willing to accept connections (datagrams for UDP listener) for any IP interface associated with the node, the value 0.0.0.0 is used for the local IP address.

The Remote Address column shows the remote IP address and remote port associated with the TCP connection or UDP listener.

The State column can take any of the following values:

Notes:

- The client may have terminated the connection and the socket still being shown in closeWait state. This may indicate that the server still keeps the socket open.
- A connection can stay in timeWait for a maximum of four minutes.

.topic 1070

Retransmission time-out algorithm
The algorithm used to determine the timeout value used for retransmitting unacknowledged octets.
This can be:
constant
rsre (MIL-STD 1778, appendix B)
vanj (Van Jacobson's algorithm )
other (none of the above)

Minimum retransmission time-out (msec)
The minimum value permitted by a TCP implementation for the retransmission timeout, measured in milliseconds.

Maximum retransmission time-out (msec)
The maximum value permitted by a TCP implementation for the retransmission timeout, measured in milliseconds.

Maximum number of connections
If the maximum number of connections is not dynamic, this represents limit on the total number of TCP connections.

Active Opens
The number of times TCP connections have made a direct transition to the synSent state from the closed state.

Passive Opens
The number of times TCP connections have made a direct transition to the synReceived state from the listen state.

Failed connection attempts
The number of times TCP connections have made a direct transition to the closed state from either the synSent state or the synReceived state, plus the number of times TCP connections have made a direct transition to the listen state from the synReceived state.

Reset connections
The number of times TCP connections have made a direct transition to the closed state from either the established state or the closeWait state.

Current connections
The number of TCP connections for which the current state is either established or closeWait.

Segments received
The total number of segments received, including those received in error. This includes also segments received on currently established connections.

Segments sent
The total number of segments sent, including those on current connections but excluding those containing only retransmitted octets.

Segments retransmitted
The number of TCP segments transmitted containing one or more previously transmitted octets.

Segments received in error
The total number of segments received in error (such as, bad TCP checksums).

Segments sent with RST flag
The number of TCP segments sent containing the RST flag.

.topic 1080

Datagrams received
The total number of UDP datagrams delivered to UDP clients.

No ports
The total number of received UDP datagrams for which there was no client application at the destination port.

Receive errors
The number of received UDP datagrams that could not be delivered for reasons other than the lack of an application at the destination port.

Datagrams sent
The total number of UDP datagrams sent from this entity.

.topic 1090

Messages
Received - The total number of ICMP messages that the entity received, including those counted as ICMP Receive errors.
Sent - The total number of ICMP messages that this entity attempted to send, including those counted as ICMP Send errors.

Errors
Received - The number of ICMP messages that the entity received but determined as having ICMP-specific errors (bad ICMP checksums, bad length, etc.).
Sent - The number of ICMP messages that this entity did not send due to problems discovered within ICMP such as a lack of buffers. This value should not include errors discovered outside the ICMP layer such as the inability of IP to route the resultant datagram.

Destination unreachable
Received - The number of ICMP Destination Unreachable messages received.
Sent - The number of ICMP Destination Unreachable messages sent.

Time exceeded
Received - The number of ICMP Time Exceeded messages received.
Sent - The number of ICMP Time Exceeded messages sent.

Parameter problems
Received - The number of ICMP Parameter Problem messages received.
Sent - The number of ICMP Parameter Problem messages sent.

Source quenches
Received - The number of ICMP Source Quench messages received.
Sent - The number of ICMP Source Quench messages sent.

Redirects
Received - The number of ICMP Redirect messages received.
Sent - The number of ICMP Redirect messages sent. For a host, this will always be zero, since hosts do not send redirects.

Echos
Received - The number of ICMP Echo Request messages received.
Sent - The number of ICMP Echo Request messages sent.

Echo replies
Received - The number of ICMP Echo Reply messages received.
Sent - The number of ICMP Echo Reply messages sent.

Timestamps
Received - The number of ICMP Timestamp Request messages received.
Sent - The number of ICMP Timestamp Request messages sent.

Timestamp replies
Received - The number of ICMP Timestamp Reply messages received.
Sent - The number of ICMP Timestamp Reply messages sent.

Address masks
Received - The number of ICMP Address Mask Request messages received.
Sent - The number of ICMP Address Mask Request messages sent.

Address mask replies
Received - The number of ICMP Address Mask Reply messages received.
Sent - The number of ICMP Address Mask Reply messages sent.

.topic 1100

IP
The destination IP address of this route. An entry with a value of 0.0.0.0 is considered a default route. Multiple routes to a single destination can appear in the table, but access to such multiple entries is dependent on the table-access mechanisms defined by the network management protocol in use.

Interface index
The index value that uniquely identifies the local interface through which the next hop of this route should be reached.

Route metric 1 (primary)

The primary routing metric for this route. The semantics of this metric are determined by the Routing mechanism.

Route metric 2-5 (alternate)
An alternate routing metric for this route. The semantics of this metric are determined by the Routing mechanism.

Gateway address
The IP address of the next hop of this route. (In the case of a route bound to an interface that is realized via a broadcast media, the value of this field is the agent's IP address on that interface.)

Type of route
Possible values are:
direct - route to directly connected (sub-)network
indirect - route to a non-local host/network/sub-network
invalid - an invalidated route
other - none of the above.

Routing mechanism
The mechanism via which this route was learned. Possible values are:
other - none of the following
local - non-protocol information, such as manually configured entries
netmgmt - set via a network management protocol
icmp - obtained via ICMP, for example, Redirect and following gateway routing protocols:
egp, ggp, hello, rip, is-is, es-is, ciscoIgrp, bbnSpfIgp, ospf, bgp

Route age (sec)
The number of seconds since this route was last updated or otherwise determined to be correct.

IP Route mask
Indicate the mask to be logical-ANDed with the destination address before being compared to the value in the IP field.

MIB Route info
A reference to MIB definitions specific to the particular routing protocol that is responsible for this route, as determined by the Routing mechanism. If this information is not present, its value is set to 0.0.

.topic 1110

A DNS server is a computer which stores FQDN(1)-to-IP-address mappings.
Most DNS servers are authoritative(2) for some zones(3) and perform a caching function for all other DNS information

(1) FQDN means Fully Qualified Domain Name, i.e, a domain name that indicates with absolute certainty its location in the domain namespace tree.
(2) A name server is said to be an Authority or Authoritative for the parts of the name space for which they have complete information.
(3) Authoritative information is organized into units called ZONEs, and these zones can be automatically distributed to the name servers which provide redundant service for the data in a zone.

.topic 1120

By default, the routes in the routing table are not permanent, they are lost when the computer is rebooted. In Windows NT, 2000, XP or 2003, it is possible to make some routes permanent using the console program route.exe with the command route -p ip_address.

.topic 1130

Acting as IP router
Indicates whether this entity is acting as an IP gateway in respect to the forwarding of datagrams received by, but not addressed to, this entity. IP gateways forward datagrams, but IP hosts do not (except those source-routed via the host).

Default TTL
The default value inserted into the Time-To-Live field of the IP header of datagrams originated at this entity whenever a TTL value is not supplied by the transport layer protocol.

Packets received
The total number of input datagrams received from interfaces, including those received in error.

Received header errors
The number of input datagrams discarded due to errors in their IP headers, including bad checksums, version number mismatch, other format errors, time-to-live exceeded, errors discovered in processing their IP options, etc.

Received address errors
The number of input datagrams discarded because the IP address in their IP header's destination field was not a valid address to be received at this entity. This count includes invalid addresses (for example, 0.0.0.0) and addresses of unsupported Classes (such as Class E). For entities that are not IP gateways and therefore do not forward datagrams, this counter includes datagrams discarded because the destination address was not a local address.

Datagrams forwarded
The number of input datagrams for which this entity was not their final IP destination, as a result of which an attempt was made to find a route to forward them to that final destination. In entities that do not act as IP gateways, this counter will include only those packets that were Source-Routed via this entity, and the Source-Route option processing was successful.

Unknown protocols received
The number of locally-addressed datagrams received successfully but discarded because of an unknown or unsupported protocol.

Received packets discarded
The number of input IP datagrams for which no problems were encountered to prevent their continued processing, but that were discarded (for example, for lack of buffer space). Does not include any datagrams discarded while awaiting reassembly.

Received packets delivered
The total number of input datagrams successfully delivered to IP user-protocols (including ICMP).

Output requests
The total number of IP datagrams that local IP user-protocols (including ICMP) supplied to IP in requests for transmission. Does not include any datagrams counted in Datagrams forwarded.

Discarded output packets
The number of output IP datagrams for which no problem was encountered to prevent their transmission to their destination, but that were discarded (for example, for lack of buffer space). This includes datagrams counted in Datagrams forwarded if any such packets met this (discretionary) discard criterion.

Output packet no route
The number of IP datagrams discarded because no route could be found to transmit them to their destination. This includes any packets counted in Datagrams forwarded that meet this "no-route" criterion, which includes any datagrams that a host cannot route because all of its default gateways are down.

Reassembly time-out (sec)
The maximum number of seconds that received fragments are held while they are awaiting reassembly at this entity.

Reassembly required
The number of IP fragments received that needed to be reassembled at this entity.

Reassembly successful
The number of IP datagrams successfully reassembled.

Reassembly failures
The number of failures detected by the IP reassembly algorithm (for whatever reason, such as timed out or errors).

Datagrams successfully fragmented
The number of IP datagrams that have been successfully fragmented at this entity.

Datagrams failing fragmentation
The number of IP datagrams that have been discarded because they needed to be fragmented at this entity but could not be (for example, because their Don't Fragment flag was set).

Fragments created
The number of IP datagram fragments that have been generated as a result of fragmentation at this entity.

Routing discards
The number of routing entries which were chosen to be discarded even though they are valid. One possible reason for discarding such an entry could be to free-up buffer space for other routing entries.

.topic 1140

All information about the collection of transport protocols and protocol chains installed on the local machine.
The order of presentation in the list "Installed Protocols" coincides with the order in which the protocol entries were registered by the service provider with the Winsock DLL, or any subsequent reordering that may have occurred.

Protocol details:

1. Address Family:
These can be:

2. Protocol:

Value of the protocol parameter which depends on the Address Family. For AF_INET/AF_INET6 this can be any of the following:

3. Socket Type:

Value of the socket type parameter. This can be any of the following:

4. Connectionless:

Specifies whether the protocol provides connectionless (datagram) service. Otherwise, the protocol supports connection-oriented data transfer.

5. Guaranteed Delivery:

Guarantees that all data sent will reach the intended destination.

6. Guaranteed Order:

Guarantees that data only arrives in the order in which it was sent and that it is not duplicated. This characteristic does not necessarily mean that the data is always delivered, but that any data that is delivered is delivered in the order in which it was sent.

7. Message Oriented:

Honors message boundaries預s opposed to a stream-oriented protocol where there is no concept of message boundaries.

8. Pseudo Stream:

A message-oriented protocol, but message boundaries are ignored for all receipts. This is convenient when an application does not desire message framing to be done by the protocol.

9. Graceful Close:

Supports two-phase (graceful) close. If not set, only abortive closes are performed.

10. Expedited Data:

Supports expedited (urgent) data.

11. Connect Data:

Supports connect data.

12. Disconnect Data:

Supports disconnect data.

13. Supports Broadcast:

Supports a broadcast mechanism.

14. Supports Multipoint:

If it supports a multipoint or multicast mechanism, control and data plane attributes are indicated and can be either rooted or non-rooted.

15. QoS Supported:

Supports quality of service requests.

16. Unidirectional Sends:

Protocol is unidirectional in the send direction.

17. Unidirectional Receives:

Protocol is unidirectional in the receive direction.

18. IFS Handles:

Socket descriptors returned by the provider are operating system Installable File System (IFS) handles.

19. Partial Messages:

The MSG_PARTIAL flag is supported in WSASend and WSASendTo.

20. Provider Flags:

Provides information about how this protocol is represented in the protocol catalog. The following flag values are possible:

21. Provider ID:

Globally unique identifier assigned to the provider by the service provider vendor. This value is useful for instances where more than one service provider is able to implement a particular protocol.

22. Catalog Entry ID:

Unique identifier assigned by the WS2_32.DLL for each protocol structure.

23. Number of Chain Entries:

Counted list of Catalog Entry identifiers that comprise a protocol chain.

24. Version:

Protocol version identifier.

25. Max Socket Address Length:

Maximum address length.

26. Min Socket Address Length:

Minimum address length.

27. Protocol Max Offset:

Maximum value that may be added to when supplying a value for the Protocol parameter to socket and WSASocket. Not all protocols allow a range of values. When this is the case this parameter is zero.

28. Network Byte Order:

This can be either Big-Endian or Little-Endian.

29. Security Scheme:

Indicates the type of security scheme employed (if any).

30. Message Size:

Maximum message size supported by the protocol. This is the maximum size that can be sent from any of the host's local interfaces. For protocols that do not support message framing, the actual maximum that can be sent to a given address may be less. There is no standard provision to determine the maximum inbound message size. The following special values are defined:

.topic 1150

IP
The IP address to which this entry's addressing information pertains.

Interface index
The index value that uniquely identifies the interface to which this entry is applicable.

Sub-net mask
The subnet mask associated with the IP address of this entry. The value of the mask is an IP address with all the network bits set to 1 and all the hosts bits set to 0.

LSB in IP non-unicast address
The value of the least-significant bit in the IP broadcast address used for sending datagrams on the (logical) interface associated with the IP address of this entry. For example, when the Internet standard all-ones broadcast address is used, the value will be 1. This value applies to both the subnet and network broadcasts addresses used by the entity on this (logical) interface.

Largest IP datagram can reassemble
The size of the largest IP datagram that this entity can reassemble from incoming IP fragmented datagrams received on this interface.

.topic 1160

The IP Address Translation table used for mapping from IP addresses to physical addresses.

Interface index
The interface on which this entry's equivalence is effective.

Media dependent physical address
The media dependent physical address.

IP address
The Ip address corresponding to the media-dependent physical address.

Type of mapping
The type of mapping. Can be any of the following:
static
dynamic
invalid
other, none of the above

.topic 1170

Index
A unique value identifying the interface.

Description
A textual string containing information about the interface. This string may include the name of the manufacturer, the product name, and the version of the hardware interface.

Type
The type of interface, distinguished according to the physical/link protocol(s) immediately below the network layer in the protocol stack.

MTU
The size of the largest datagram that can be sent/received on the interface, specified in octets.

Speed
An estimate of the interface's current bandwidth in bits per second. For interfaces that do not vary in bandwidth or for those where no accurate estimation can be made, this should contain the nominal bandwidth.

Adapter physical address
The interface's address at the protocol layer immediately "below" the network layer in the protocol stack.

Admin status
The desired state of the interface. This can be either up, down or testing. The testing state indicates that no operational packets can be passed.

Operational status
The current operational state of the interface. This can be either up, down or testing. The testing state state indicates that no operational packets can be passed.

Bytes received
The total number of octets received on the interface, including framing characters.

Packets delivered unicast
The number of subnetwork-unicast packets delivered to a higher-layer protocol.

Packets delivered non-unicast
The number of non-unicast (that is, subnetwork-broadcast or subnetwork-multicast) packets delivered to a higher-layer protocol.

Inbound packets discarded
The number of inbound packets that were chosen to be discarded even though no errors had been detected to prevent their being deliverable to a higher-layer protocol. One possible reason for discarding such a packet could be to free up buffer space.

Inbound packets with errors
The number of inbound packets that contained errors preventing them from being deliverable to a higher-layer protocol.

Inbound packets discarded unknown protocols
The number of packets received via the interface that were discarded because of an unknown or unsupported protocol.

Bytes transmitted
The total number of octets transmitted out of the interface, including framing characters.

Packets requested unicast
The total number of packets that higher-level protocols requested be transmitted to a subnetwork-unicast address, including those that were discarded or not sent.

Packets requested non-unicast
The total number of packets that higher-level protocols requested be transmitted to a non-unicast (that is, a subnetwork-broadcast or subnetwork-multicast) address, including those that were discarded or not sent.

Outbond packets discarded
The number of outbound packets that were chosen to be discarded even though no errors had been detected to prevent their being transmitted. One possible reason for discarding such a packet could be to free up buffer space.

Outbond packets with errors
The number of outbound packets that could not be transmitted because of errors.

Output packet queue
The length of the output packet queue in packets.

MIB specific information
A reference to MIB definitions specific to the particular media being used to realize the interface. If this information is not present, its value is set to 0.0.

.topic 18

From here you can perform most maintenance tasks you got used to do with Windows Explorer and a few others tasks Windows Explorer does not allow you (and when the remote system does not open shares to visitors you simply can not use Windows Explorer across the network, though you can still use AWRC!).

Download Files: First you select the files and folders trees with the left mouse button (press Shift or Ctrl keys, if more than one file). Then press the right mouse button to recall the popup menu and select Download Files/Compressed or Download Files/Uncompressed. When Compressed is selected, the amount of network traffic and download time can be drastically reduced when the files to download were not already compressed. Since the compression itself takes a long time on large files, on a fast LAN it may be preferable to use the Uncompressed option. When the download is completed you are requested to select were the downloaded file or files are going to.

Upload Files: First, you press the right mouse button to recall the popup menu and select Upload Files/Compressed or Upload Files/Uncompressed. Then you choose which files and folder trees you want to upload to the remote system and press OK. The uploading will start and the files and folder trees will be transferred to the directory that was selected in the remote system when you started the operation. When Compressed is selected, the amount of network traffic and upload time can be drastically reduced when the files to upload were not already compressed. Since the compression itself takes a long time on large files, on a fast LAN it may be preferable to use the Uncompressed option.

Launch File: Remote files can be launched (taking into account the File Association on the remote system) by right-clicking on the File System grid and selecting Launch File.
   You can launch files as:

Launching files from a user account provides access to the HKEY_CURRENT_USER hive of the Registry for that account.

Zip selected Files: You can zip files on the remote system as easily as on the local system. You can even use a password to restrict access to the contents of the newly created zip file. The password string should be large (8 or more characters. The more the better.) and with a mixture of characters (lower and upper case) and numbers to provide a comfortable degree of protection. Small passwords are easily recovered by some specialized software. The password is compatible with other Zip utilities. Note that, if the given Zip file name already exists the files will be added to it - the Zip file will not be recreated. You must enter a valid path for the Zip file, directories will not be created, if they don't already exist.

Unzip selected Files: To unzip a file on the remote system, first you select it with the left mouse button then right-click and select Unzip selected File. The file does not need to have a ZIP extension, but has to be a real and uncorrupted zip file. AWRC only can confirm it on the remote system. If the unzip fails this is a possible cause. Following options are available for unzipping:
* Directory where the files will be extracted: You may enter a non-existing directory, which will be created, if possible.
* Overwrite mode: Always - Files with same name are always overwritten; Never - The file will not be extracted if it would overwrite another file;  If is newer in ZIP - The file will only overwrite the existing one if the archived file is newer than the existing one; If is older in ZIP - The file will only overwrite the existing one if the archived file is older than the existing one.
* Replace Read-Only: Allows files with the read-only attribute to be replaced during the unzip operation.
* Recreate Directories: Check, if you want to use directory information in the zipfile when extracting files.  The directories will be created relative to the destination directory. If unchecked, all files will be extracted to the destination directory, which could possibly result in files of the same name overwriting each other if the Overwrite mode property is set to Always.
* Password: Enter here the password to extract the file. The password is compatible with Zip archives created by other utilities.

Make Directory: It will create a directory, unless it already existed.

Rename File or Directory: The rename will be effected unless the new name already existed. Sometimes, it is not possible to rename when the File or Directory is in use by some process.

Delete selected Files and Directories: Take care, if you uncheck the Recycle Bin box, the selection will be zapped. Chances are that nobody will be able to help you recover what you have just deleted. Even when checked, the Recycle Bin may not always be available to receive what you delete. Conclusion: Think twice before deleting anything.

Copy selected Files or Directories: Copying is made in 2 stages. First, you select with the mouse what you want to copy, press the right-mouse button and select Copy selected Files or Directories. AWRC will silently store what files you want to copy. The copy proper only happens when you right-click and select Paste Files and Directories. Make sure, you are positioned in the folder you want to copy the files to before selecting Paste Files and Directories.

Move selected Files or Directories: Moving is made in 2 stages. First, you select with the mouse what you want to move, press the right-mouse button and select Move selected Files or Directories. AWRC will silently store what files you want to move. The move proper only happens when you right-click and select Paste Files and Directories. Make sure, you are positioned in the folder you want to move the files to before selecting Paste Files and Directories.

Note: These options are only visible on the popup menu when a connection is established.

The File System Tab provides also some useful details about the current Logical Drive, namely: File System, Type, Capacity, Serial Number, Label and Free space.

.topic 16

Most User account details are provided:

User Account: The name of the User Account.

Password Age: Indicates the elapsed time since the password was last changed.

Privilege Level: The level of privilege assigned to the User Account. This can be Administrator, User or Guest.

Comment: Comment associated with the user account.

Flags: Determine several features.

Full Name: Contains the full name of the user.

Workstations can log from: Contains the names of workstations from which the user can log on. As many as eight workstations can be specified; the names must be separated by commas. If no workstation is specified there are no restrictions.

Last Logon: This value may not be the same when taken from different backup domain controllers (BDC) in the domain. To obtain an accurate value, you must query each BDC in the domain. The last logon occurred at the time indicated by the largest retrieved value.

Last Logoff: This value may not be the same when taken from different backup domain controllers (BDC) in the domain. To obtain an accurate value, you must query each BDC in the domain. The last logon occurred at the time indicated by the largest retrieved value.

Account expires: May contain either a date/time or "Never expires".

User ID (RID): Contains the relative ID (RID) of the user. The RID is determined by the Security Account Manager (SAM) when the user is created. It uniquely defines the user account to SAM within the domain.

Primary Global Group (RID): Contains the relative ID (RID) of the Primary Global Group for the user.

SID: Each user and group is associated with it a security identifier (SID).
The individual parts of a SID are as follows:
Revision: This value indicates the version of the SID structure used in a particular SID. The structure used in all SIDs created by Windows NT, Windows 2000 and Windows XP is revision level 1.
Identifier authority: This value identifies the highest level of authority that can issue SIDs for this particular type of security principal. For example, the identifier authority value in the SID for the group Everyone is 1 (World Authority). The identifier authority value in the SID for a specific Windows NT, Windows 2000 and XP account or group is 5 (NT Authority).
Subauthorities: The most important information in a SID is contained in a series of one or more subauthority values. All values up to but not including the last value in the series collectively identify a domain in an enterprise. This part of the series is the domain identifier. The last value in the series identifies a particular account or group relative to a domain. This value is the relative identifier (RID).

Domain: Name of the domain where the account name is found or local machine if there is no domain.

No. SubAuthorities: The count of subauthorities contained in the SID.

Length of SID: The length in bytes of the SID.

Type of SID: SIDs can be of type 'User', 'Group', 'Domain', 'Alias', 'Well Known Group', 'Deleted Account', 'Invalid' and 'Unknown'.

.topic 22

Provides information about each local and global group account on the remote server.

Names: Local or Global group names.

SID: Each group is associated with it a security identifier (SID). For more details on SID see Users.

Comment: A remark associated with the Local or Global Group.

Attribute: The following attributes of global groups are hardcoded by default:
Group Mandatory: The SID cannot have the Group Enabled attribute cleared by a call to the AdjustTokenGroups function. However, using the CreateRestrictToken function is possible to convert a mandatory SID to a deny-only SID.
Group Enabled by Default: The SID is enabled by default.
Group Enabled: The SID is enabled for access checks. When the system performs an access check, it checks for access-allowed and access-denied ACEs that apply to the SID.

.topic 26

We decided to include this tool to enable System Administrators to audit their systems for adequate passwords. It is not prudent to believe that your systems are safe without fully testing them. In most cases, the systems are not safe at all! Passwords are the fundamental lock on your systems, it is a good practice, provided your management approves, to regularly assess the quality of your users' passwords and provide feedback to users who select easy-to-guess passwords.

Passwords are not stored anywhere within NT technology systems, only their hashes.

AWRC is able to instantly retrieve the password hashes from the remote, even with the default Syskey protection activated and within the Active Directory on Windows 2000 networks.

With the hashes it is always possible to retrieve the original passwords, it can take from a few seconds to days or months. Some software, like L0phtCrack, given the time can work out the hashes and come up with the original passwords.

If using L0phtCrack, select the option to import from PWDUMP, in order to enter the AWRC saved hashes into L0phtCrack.
Note: PWDUMP is a command line utility which captures hashes from remote computers by loading a special DLL into lsass.exe address space, storing the captured hashes into the Registry then attempting a connection to the remote Registry to retrieve them.

Weak passwords are retrieved from the hashes in a matter of minutes, sometimes seconds. Always use long strong passwords in a mix of !,*,{,$,*,#,% characters, uppercase, lowercase English characters and digits! Although all passwords are retrievable from the hashes you should make it as hard as possible.

(*) This feature is not available when the remote computer is running a 64-bit operating system.

.topic 28

You can carry a live conversation with the interactive user on the remote computer. You should take the initiative for the Chat. AWRC does not allow the remote computer to take any initiative, you are in absolute command. The remote interactive user may, however, end the chat by closing the Chat window.

.topic 23

By clicking the Options button on the Configure page you can set defaut values for most features.
You can, as well, set up the Strong Encryption environment.

.topic 1000

Refresh rate:
This can range from Fastest to Paused. When you select Fastest, updates are processed almost in real time while in Paused updates are freezed.

Desktop Colors:
You can select 16 Colors (4-bit), 256 Colors (8-bit), 65536 Colors (16-bit), 24-bit True Color or 32-bit True Color.
Usually True Color or 16-bit Color are the best choices. The others are suitable for problematic traffic conditions.

Remote Ctrl+Alt+Del hotkey:
To issue Ctrl+Alt+Del on the remote computer to access the logon box you need to select a keyboard shortcut (also known as hotkey) on the local computer. The default is Ctrl+Alt+D, but alternatively you can select any other suitable key sequence.
Suitable sequences must have at least 2 each of Ctrl, Alt or Shift followed by a letter, number or function key. If you just press a letter, number or function key, the software will prefix those with Ctrl+Alt. Before accepting a new shortcut the software, will attempt to validate it. When validated you must press the Apply button to save and start using the new shortcut.
Examples are: Ctrl+Alt+F9, Shift+Alt+1 or Ctrl+Shift+Alt+Z

Full Screen hotkey:
This hotkey returns from full screen into normal mode (to enter into full screen mode from normal mode, press the   button).
The default is Ctrl+Alt+Z, but alternatively you can select any other suitable key sequence.
Suitable sequences must have at least 2 each of Ctrl, Alt or Shift followed by a letter, number or function key. If you just press a letter, number or function key, the software will prefix those with Ctrl+Alt. Before accepting a new shortcut the software, will attempt to validate it. When validated you must press the Apply button to save and start using the new shortcut.
Examples are: Ctrl+Alt+F9, Shift+Alt+1 or Ctrl+Shift+Alt+Z

Reset all font sizes:
Clears the user-defined font sizes for every table and re-establish the original values.

Clear Remote Host history:
Pressing this button, clears all past entries from the dropdown list.

View Layered Windows:
When checked you will be able to see the small tooltips on the remote desktop. However, the mouse will have a noticeable flicker effect on the remote desktop. When unchecked, the flicker will disappear in almost every computer. Most users seem to prefer the flicker free mouse, so the default for this option is unchecked.

Clear grids on disconnect:
You can either clear all grids on disconnect or leave them untouched. Leaving them untouched is useful for post-mortem analysis.

Request authorization from remote:
If you check this box, the default action is: whenever you connect to a remote computer a request for authorization window will appear on the remote computer.

Remote keyboard active:
Keep this option checked if you want access to remote keyboard upon connecting to be the default.

See remote mouse activity:
Remote mouse activity can be optionally monitored (monitoring is selected by default).

Permanent mouse pointer:
If checked, when the mouse is disconnected on the remote computer, the local user can still see an arrow mouse cursor for easier navigation on the remote desktop.

 Autofill User Name and Password:
If checked, the User Name and Password used to connect are saved in the Registry and will autofill the respective boxes when the program launches. Selecting this option is a security risk when people not supposed to know your password may have
access to the local computer. If selected, the User Name and Password boxes change color and a warning is shown when the program closes.

Maintain Full-Screen aspect ratio:
In Full-Screen mode, when the remote screen resolution aspect ratio differs from the local screen resolution aspect ratio, the local image of the remote screen may become distorted unless you keep this box checked. Some local screen area is left black when the aspect ratio are different.

Default scale:
When you connect always to the same machine or have found an ideal scaling you may set it here to be used on every connection.

 Compression level:
Within a fast LAN it may be faster to use Light compression, while across the internet you may try the Strong compression. The default is Normal, which is a tentative compromise between both.

Connection timeout:
This is the maximum allowed amount of time without any exchange between machines. The default is 16 seconds, which sometimes is too short in low bandwidth environments or stressed and overload systems. If you are experiencing spontaneous disconnects, try setting a higher value, up to 120 seconds. The minimum value is 10 seconds

.topic 1010

To use encryption, first you need to generate a Public/Secret key pair.
Write or paste some text on box then press the Generate Keys button. If you mind about security, do not reveal the text you have entered to anyone.

The Public and Secret keys will be stored in the Registry ready for use. The Secret key is stored in the Registry encrypted, however this is not the ultimate security measure. The principle is that, you are responsible for your local machine, AWRC only assures that what flows between both computers can not be unencrypted if and only if you do not provide any third-party access to the generated Secret key.

You can generate a different key pair, any time you want and it will be used for the following encrypted connection.

When you have a Public/Secret key pair, to use encrypted connections simply tick the Use Strong Encryption check box.

When a connection is encrypted a red padlock appears below the Connect button.

.topic 1180

Upon connection, AWRC launches a service process on the remote computer. This service is the workhorse that receives, prepares and dispatches the instructions received from the local computer. Some users, have been requesting facilities for hiding even more the whereabouts of this service and we have done it.

However, the latest AWRCAC release is still able to detect and stop AWRC no matter how hidden you have made it. This is by design, and in most cases there is no healthy reason to ask for an AWRC special build that circumvents the AWRCAC control.

File Name:
You can change the binary name, which defaults to awrexec.exe. Any file name with the correct syntax is acceptable, even a file name without extension, something like My File Name is acceptable.

Service Name:
Specifies the name of the service to install (up to a maximum of 256 characters). Forward-slash (/) and back-slash (\) are invalid service name characters.

 Display Name:
Specifies the display name to be used by user interface programs to identify the service. The string has a maximum length of 256 characters. If the Display Name is blank, user interface programs may display the Service Name instead.

.topic 1190

AWRC supports manual (the default) and automatic updates. When an update exists, and the user accepts to proceed with it, the new software is installed directly from the web with no need to run any setup or install program. Some updates may be installed only from here and not be available for download in our website in the traditional way through an install program, so you are recommended to check for updates regularly.

.topic 1210

To request a password when launching AWRC, check the box I want a password for AWRC.
Enter the password in the two boxes below, the press the Apply button.
To remove the password, just uncheck the box I want a password for AWRC.

.topic 3

These are true "Frequently Asked Questions" sent to our Support staff. In most cases the answer is already provided elsewhere within the documentation.
For an updated and more complete FAQ, point your browser to http://www.atelierweb.com/rcomm/faq.htm.

How can I produce Ctrl+Alt+Del on the remote computer.
You can produce Ctrl+Alt+Del (the security attention sequence) by pressing Ctr+Alt+D. Alternative Hot Key sequences can be selected from the Options menu.

Why am I unable to connect to other remote computers?
Either within a local area network or across the Internet, AWRC requires Microsoft Networks to be operative - Client for Microsoft Networks installed on both local and remote machines and File and Printer sharing enabled at least on the remote machine.
If the remote computer platform is Windows XP Professional, the access is only possible within the classical sharing and security model for local accounts. This is enabled from Control Panel / Administrative Tools / Local Security Policy / Network access: Classic - local users authenticate as themselves. You can obtain the same result from Windows Explorer / Tools / Folder Options / View and uncheck Use Simple File Sharing.

Which ports are used by AWRC?
AWRC does not open any ports, it simply requires Microsoft Networks. Microsoft Networks use ports 135, 137, 138, 139 or 445. However, operations performed by AWRC run only through TCP port 445 (Windows 2000, XP and Server 2003) or TCP port 139 (Windows NT 4. Windows 2000, XP and Server 2003 can use as well this port if port 445 is not available). Ports 135, 137, 138 and one of 139 or 445 can be blocked by the firewall or router without interfering with AWRC operation.

You say that AWRC is transparent to firewalls but I can't get it to work within my Company LAN!?
The firewall is blocking the use of Microsoft Networks, in particular port 139 or port 445. See the question Which ports are used by AWRC?.

How safe is AWRC for use across the Internet?
Microsoft Networks, in particular port 445 and even port 139 are safe when you have a good password. Since all security is based on the password, all exploits are just password-guess dictionary attacks. A good password will take millions of years to be guessed.
Additionally, AWRC may use strong encryption which makes virtually unbreakable the data exchange between both end-points.

How does AWRC compare with GotoMyPC?
GotoMyPC records all your connection habits and the data flow is passed through their communication servers.
The lot of features provided by GotoMyPC is feeble when compared with AWRC, their connections are slow and the screen capture is poor.

How does AWRC compare with pcAnywhere?
For pcAnywhere you have to install 20MB on each remote computer and pay good money for the sort of features already available everywhere.

How can I connect to another computer across the Internet?
The same rules apply, see the previous questions. If the local and remote computers are behind routers and personal firewalls you must make sure that:
The local computer personal firewall allows outgoing connections on TCP port 445 or/and TCP port 139.
The router on the remote network forwards TCP port 445 or/and TCP port 139 to the private IP address of the target machine.
The personal firewall of the remote machine allows incoming connections on TCP port 445 or/and port 139.

When trying to connect, I get the error "The Network Path was not found"?
The connection is made by Microsoft Networks not by AWRC. This is not an AWRC error. You have to search for possible explanations within the Microsoft site or, better, the Google Groups.

I have been trying and can not connect to my XP Home Edition laptop!?
You can not, have another look at the Requirements.

Is it possible to connect AWRC to the local computer?
It is possible and it is an important tool for local system analysis and operation. Bear in mind that AWRC has tremendous capabilities and will provide the sort of information and operation capabilities you are not obtaining in almost every case with tools developed exclusively for local system operations. To connect to the local system you simply enter its name or IP address and press the Connect button.

I have downloaded AWRC from a third-party site and the program produces some strange errors.
You must download AWRC from http://www.atelierweb.com/rcomm/download.htm or from sites that point to our mirror at http://atelierweb.swmirror.com. Reverse-engineered warez releases of this software never work as expected. Note in particular, that some warez sites have distributed at least one AWRC release with a trojan horse attached to it.

Will AWRC work in Windows XP Service Pack 2?
Absolutely, only better.

Will AWRC work in Longhorn?
By the time the real Longhorn is out, AWRC will be ready for it. No problems are expected, all necessary changes are understood, known and planned. We are working on the matter and following the preview releases.

.topic 6

You should carefully read the following terms and conditions before using this software.

LICENSE AGREEMENT FOR ATELIER WEB REMOTE COMMANDER

Evaluation Period before registration
Unregistered use of AWRC after the evaluation period is in violation of Portuguese and International Copyright laws. The evaluation period is 15-days or 30-executions, whichever comes first.

Governing Law
This agreement shall be governed by the laws of the Republic of Portugal.

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD 'AS IS' AND WITHOUT WARRANTIES AS TO PERFORMANCE OR MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. Because of the various hardware and software environments into which AWRC may be put, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data before relying on it. The user must assume the entire risk of using the program.  ANY LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.

Distribution of Evaluation Version
Provided that you verify that you are distributing the evaluation version (select the Configure tab while running AWRC to check) you are hereby licensed to make as many copies of the evaluation version of this software and documentation as you wish; give exact copies of
the original evaluation version to anyone; and distribute the evaluation version of the software and documentation in its unmodified form via electronic means. There is no charge for any of the above.

You are specifically prohibited from charging, or requesting donations, for any such copies, however made; and from distributing the software and/or documentation with other products (commercial or otherwise) without prior written permission.

Purchased Version:
One Single User/Workgroup license of AWRC allows the program to be
used by a single person who uses the software personally (maximum of
2 computers used by the same person) within a Microsoft Windows
Workgroup.
One Single User/Domain license of AWRC allows the program to be
used by a single person who uses the software personally (maximum of
2 computers used by the same person) within a Microsoft Windows
Domain or Workgroup.
One Company license of AWRC allows the program to be installed
on a Local Area Network to be used within Microsoft Windows Domains
or Workgroups of a Company or Site by the number computers specified
in the license details.

.topic 5

This is not free software. Subject to the terms of the License Agreement, you are hereby licensed to use this software for evaluation purposes without charge for a period of 15 days or 30 executions. In order to use this software after the evaluation period you are required to register it.

Ordering Information:

- For pricing information and register online, please visit: http://www.atelierweb.com/rcomm/order.htm

Any time, feel free to contact us through the contact forms at http://www.atelierweb.com/support.htm).

Registration entitles you:

To the unrestricted full featured release.
A single-user license entitles to a free license for AWRCAC
(Atelier Web Remote Commander Access Control). A company license
entitles to three free licenses for AWRCAC.
To receive by e-mail free technical support and advice.
To be directly informed of new major releases.