概要

トップページ 次へ

Atelier Web Remote Commander (AWRC) との接続には、リモート コンピュータでの管理者権限が必要になります。しかし、管理者権限が認証されていたとしても、ネットワーク全体にわたって無制限のアクセスを許可してよいとは必ずしも限りません。

たとえば、

多くの企業では、IT 部門のスタッフは、テクニカル サポートやメンテナンスのために、組織全体のすべてのコンピュータに対する管理者権限を持っています。
しかしながら、一般のユーザは自分のコンピュータが管理者によってネットワーク上からアクセスされて見られることを望んでいません。このようなユーザは、他者と共有する必要のあるフォルダのみをネットワーク上に開示し、その他のフォルダは他者の目から隠すために、Windows の共有メカニズムに頼ってきました。
AWRC は Windows の共有によって生み出される自然障壁を回避してしまうので、このメカニズムは成り立ちません。

もう 1 つの懸案事項は、パスワードとその信頼性に関するものです。
多くのユーザは侵入者から自分のコンピュータを守るための強力なパスワードを使用していないものです。パスワードさえ探り当てられれば、組織内のいくつかのコンピュータが侵入可能な状態にあることは少なくありません。一度リモート コンピュータに侵入するためのユーザ名とパスワードを知られると、そのコンピュータは管理者以上の力で完全に乗っ取られる可能性があります。なお、AWRC はリモート コンピュータでシステム権限によって動作するため、AWRC を使用すれば侵入者はあらゆる操作を跡を残さず秘密裏に行うことができてしまいます。

これらの理由から、AWRC が悪用されることなく、その力を存分に引き出せるようにするユーティリティが必要になりました。
企業の部署や管理者は重要な情報が保管されたコンピュータを有しながら、その危険には気付いていないものです。

これが、Atelier Web Remote Commander Access Control (AWRCAC) が開発された背景です。AWRCAC を使用すると、リモート コンピュータへの AWRC のアクセスをブロックまたは制限したり、そのログを記録したりすることが可能になります。


はじめに

前へ トップページ 次へ

AWRCAC を使用するには、まずリモート コンピュータに作成したディレクトリに AWRCAC.EXE をコピーして、そこから AWRCAC.EXE を実行する必要があります。
インストール プログラムを使用してソフトウェアをインストールすることをご希望であれば、弊社または取扱店までお問い合わせください。AWRCAC のダウンロード リンクをご提示いたします。

初めて AWRCAC を実行する場合は、アクセス リストを設定する必要があります。デフォルトでは、すべて拒否するように設定されています。次に、[設定] タブの設定を必要に応じて変更します。

AWRC の動作を停止する場合は、ロック ボタンを押します。ロック ボタンを押すと、システム トレイの AWRCAC アイコンに太い赤縞が表示されるようになります。

AWRC が動作している場合は、AWRCAC アイコンは緑縞で点滅します。ロック項目または拒否項目への接続が試みられているときも同じように点滅しますが、このことでデータやスクリーンショットが AWRC によって送信されるといった心配はありません。


AWRC 3.1 以前のリリース

AWRCAC の機能の大半は、AWRC 3.1 以前のリリースには対応していません。
特に理由がない限り、AWRC 3.1 以前のリリースによる操作をブロックするように AWRCAC を設定しておいてください。

古いリリース

AWRC 3.1 以前のリリースをブロックしておくと、接続して何らかの操作を実行しようとしても、接続が数秒で切断されます。事実上、接続は可能ですが、操作はまったく不可能になります。


ログの記録

AWRC による接続はすべてログに記録されます。
ログには、リモート コンピュータまたはローカル コンピュータへのログイン ユーザ名、コンピュータ名、IP アドレスに加え、接続中に実行された操作も詳細に記録されます。


ロック

ロック ボタンを押すと、

ロック

コンピュータ上で AWRC の動作が無効化され、接続も数秒で切断されます。これにより、いかなるデータもコンピュータから転送されなくなります。また、デスクトップ スクリーンショットが送信されることもありません。

ロックを解除するには、再びこのボタンを押します。

ロック解除


アクセス リスト

AWRC をコンピュータ上で操作できるユーザの数を制限する方法は 2 通りあります。

管理者権限を持つすべてのユーザのアクセスを拒否してからリストに (アクセスを許可するユーザの) 例外を追加するか、または管理者権限を持つすべてのユーザのアクセスを許可してからリストに (アクセスを拒否するユーザの) 例外を追加します。

2 つのオプションのうちどちらか一方しか使用することはできませんが、どちらを選択した場合でもリストの作成方法はまったく同じです。リストにユーザを追加するには、[追加] ボタンをクリックして、フォームに入力してから [OK] をクリックします。

たとえば、"シェアエッジ" というユーザをリストに追加してみましょう。アクセスを許可する IP アドレスの範囲は 192.168.1.100 ～ 192.168.1.105 です。この場合、コンピュータ名は "シェアエッジ" のデスクの場所によって異なるため空白にしておきます。フォームへの入力内容は以下のようになります。

リストへの追加

入力内容はアクセス リストで以下のように表示されます。

アクセス リスト


設定

スタートアップ時にロード:このチェック ボックスをオンにすると、[スタートアップ] メニューから AWRCAC がロードおよび実行されるようになります。

AWRC 3.1 リリース以前の処理:このチェック ボックスは (デフォルトのまま) オンにしておくことを強くお勧めします。アクセス リストまたは特定の機能へのアクセス制限は、AWRC 3.1 でのみ利用可能であり、ログも詳細には記録されないためです。このチェック ボックスをオンにすると、AWRC 3.1 以前のリリースがデータやスクリーンショットを取得しようとしても、接続が数秒で切断されるようになります。

以下のオプションは、AWRC 3.1 またはそれ以降のリリースでのみ動作します。

許可しない:

パスワード ハッシュの読み込み:このチェック ボックスをオンにすると、AWRC によってパスワード ハッシュが読み込まれることを防止できます。パスワード ハッシュを利用すれば、オリジナルのパスワードを再生成することが可能になります。脆弱なパスワードであれば瞬時に再生成されます。

ハードウェア デバイスの読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

ユーザおよびグループ情報の読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

シャットダウン、電源オフまたはリブート:このチェック ボックスをオンにすると、対応する操作をブロックできます。

ファイル システム タブ処理:このチェック ボックスをオンにすると、以下の操作を含め、AWRC の [ファイル システム] タブの使用をブロックできます。
· ファイルのダウンロード
· ファイルのアップロード
· ファイルの実行
· 選択したファイルの圧縮
· 選択したファイルの解凍
· ディレクトリの作成
· ファイル名またはディレクトリ名の変更
· 選択したファイルまたはディレクトリの削除
· 選択したファイルまたはディレクトリのコピー
· 選択したファイルまたはディレクトリの移動
· ファイルまたはディレクトリの貼り付け

システム一般情報の読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

以下のオプションは、AWRC 4.0 またはそれ以降のリリースでのみ動作します。

許可しない:

クリップボード　アップデートと読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

以下のオプションは、AWRC 4.5 またはそれ以降のリリースでのみ動作します。

許可しない:

ポート検出の読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

ポート統計情報の読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

ルーティング情報の読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。

IP/送信プロトコルの読み込み: このチェック ボックスをオンにすると、対応する操作をブロックできます。

インタフェースの読み込み:このチェック ボックスをオンにすると、対応する操作をブロックできます。


使用許諾契約書

本ソフトウェアをご使用になる前に以下の使用許諾契約書の条項を注意深くお読みください。

ATELIER WEB REMOTE COMMANDER ACCESS CONTROL (AWRCAC) 使用許諾契約書

法的効力
本契約書はポルトガル共和国の法律に基づくものとします。

免責事項
本ソフトウェアおよび付属ファイルは、「現状有姿 (AS IS)」の形で提供されるものであり、明示あるいは黙示を問わず、運用上、商取引上、またその他のいかなる保証も伴いません。本ソフトウェアの動作環境はハードウェアまたはソフトウェアを問わず多種にわたるため、特定用途への適合性に関する保証は行われません。

お客様は、重要なデータの処理および管理を開始する前に、危険のないデータで十分にテストすることを義務付けられています。本ソフトウェアの運用上発生するいかなる損害に関する責任もお客様にあります。販売者の保証義務は、製品の交換または購入金額の返還に限られます。

評価版の配布
本ソフトウェアの評価版は、Atelier Web Remote Commander (AWRC) の評価版に同梱してのみ配布できるものとします。
しかしながら、Atelier Web の書面による事前の許可なくして、このようなコピーを作成および配布することで使用料金を課したり要求すること、またその他の製品 (商業用如何を問わず) とともに本ソフトウェアおよび関連資料を配布することは固く禁じられています。

登録版
本ソフトウェアのライセンスは、本ソフトウェアを特定の 1 台のコンピュータでのみ使用することを許諾しています。ライセンスを購入して 1 年間経過すると、ライセンス所有者は別のコンピュータで使用するためのライセンスの無償発行を要求することが認められています。


購入

前へ トップページ

AWRCAC と AWRC はそれぞれ別個の製品です。AWRCAC は、評価用として AWRC に同梱されています。
使用許諾契約書の条項によって、評価目的のため 15 日間または 30 回実行分だけ AWRCAC ソフトウェアを使用することが許諾されています。

AWRC ユーザには、ライセンスの種類に応じて決められた数の AWRCAC ライセンスが無償で付与されます。

AWRC ライセンスの種類 | 無償で付与される AWRCAC ライセンスの数
個人ユーザ向けライセンス | 1
団体向けライセンス | 3

AWRC ユーザは、必要であれば AWRCAC ライセンスを 2 個または 10 個パックとして追加購入できます。この AWRCAC パックを購入できるのは、AWRC ユーザに限られます。なお、AWRC ユーザには詳細情報が通知されます。

AWRCAC ライセンスは、無期限かつ無償でアップグレードすることが可能です。


.topic 13

While connections with Atelier Web Remote Commander (AWRC) require Administrator's privileges on the remote machine, this does not necessarily imply that a remote computer must grant unlimited access to connections made across the network - even authenticated with Administrator's privileges.

For example:

In many companies, members of the IT department have Administrator's privilege on every computer across the organization in order to be able to provide technical support and maintenance when required.
However, regular users of these computers do not wish to have their machines open wide to any Administrator accessing the machine from the network. They were used to rely on the Windows sharing mechanism to expose to the network a number of folders they need to share with others and to keep everything else hidden from prying eyes.
Well, this simply does not work with AWRC, which bypasses the natural barrier imposed by windows shares.

Another case of concern is related to passwords and their reliability.
Most users don't use strong passwords to protect their machines against intruders. Simply by password guessing, it is not abnormal to find a few machines within an organization that can be penetrated. Once someone has an user name and password to enter a remote machine he will have full power over that machine, even more power than an Administrator - AWRC runs on the remote machine with System privileges: the intruder will be able to do anything that comes to mind - without leaving traces and without being audited.

For this sort of reasons, we found an utility was required to make organizations benefit from the power of AWRC, while lessening the possibility of abuse.
Some company departments and managers have computers where sensitive or critical information is stored - they can not afford any sort of risks!

This is the rationale behind Atelier Web Remote Commander Access Control (AWRCAC) : AWRCAC allows a remote computer to block, filter and log accesses from AWRC.

.topic 1040

To use AWRCAC all you have to do is create a directory on the remote computer, copy AWRCAC.EXE in there and run it.
Customers that find easier to install software through an install program may contact us and we will be provide a download link for a version of AWRCAC with install.

When you run AWRCAC for the first time you need to configure the Access Lists - the default is to Deny access to all. Then have a look at the Configuration page and change where needed.

In order to make sure no AWRC operation will take place you may press the padlock button down. The AWRCAC icon on the system tray appears with a large red strip.

When AWRC operations are taking place the AWRCAC icon flashes with green color strips. This flashing may occur as well for a short period when connections are being attempted within a locked or denied access context - this should not represent a concern, data or screen shots will not be sent by AWRC.

.topic 1050

Most AWRCAC features do not work with releases of AWRC older than 3.1.
Unless you have some reason to proceed otherwise, AWRCAC should be set to block the operation of AWRC releases prior to 3.1.

When you block releases of AWRC older than 3.1, they will be able to connect but will not be able to operate and the connection will die after a few seconds.

.topic 1000

All AWRC connections are logged.
Logging provides details about the user names used to log into the remote and local machines, the computer name and IP address, as well as what operations were being performed during the connection.

.topic 1010

When you press down the padlock button

AWRC will not be able to operate on your computer and the connection will die after a few seconds. No data will be transferred from the computer, not even a desktop screen shot will be sent.

To unlock press the padlock button again

.topic 1020

There are two alternatives ways to restrict to a selected number of people AWRC operations inside a computer.

You may either deny access to everyone with Administrator privileges then enter a list of exceptions (whom you allow to operate), or you allow everyone with Administrator privileges then consider the people you deny access to the computer using AWRC.

Although both options are mutually exclusive, the lists are build in exactly the same way. To add someone to the list you press the Add button, fill up the form then press Enter.

Suppose you want to allow access to someone named Clark, who is expected to access your computer from IPs in the range 192.168.1.100 till 192.168.1.105. In this case the computer name will vary, depending on where Clark is sitting, so you will leave it blank. The entry into the Access List will be filled as follows:

The entry will appear in the Access List as follows:

.topic 1030

Load at startup: When checked AWRCAC will load and run through the Startup menu.

Do not allow operation of pre-AWRC 3.1 releases: It is highly recommended to keep it checked (the default). The reason is that Access Lists or restricting access to certain features is only available with AWRC 3.1. The Log is not detailed as well. Keeping this box checked will prevent pre-AWRC 3.1 releases from retrieving data or even a screen shot and the connection will die after a few seconds.

The following options work only with AWRC 3.1 or later.

Do not allow:

Retrieve Password Hashes: Check it to prevent AWRC from retrieving password hashes. With the password hashes it is possible to recreate the original passwords - weak passwords are recreated in minutes.

Retrieve Hardware Devices: Check to block this operation.

Retrieve information on Users and Groups: Check to block these operations.

Shut-down, Power-off and Reboot: Check to block these operations.

File System tab operations: When checked blocks the use of the File System tab of AWRC, including the following operations:
Download Files
Upload Files
Launch File
Zip selected Files
Unzip selected File
Make Directory
Rename File or Directory
Delete selected Files and Directories
Copy selected Files and Directories
Move selected Files and Directories
Paste Files and Directories

Retrieve System General Information: Check to block this operation.

The following option work only with AWRC 4.0 or later.

Do not allow:

Clipboard update and retrieval: Check to block these operations.

The following options work only with AWRC 4.5 or later

Do not allow:

Retrieve Ports Finder: Check to block this operation.

Retrieve Ports Statistics: Check to block this operation.

Retrieve Routing Information: Check to block this operation.

Retrieve IP/Transport Protocols: Check to block this operation.

Retrieve Interfaces: Check to block this operation.

.topic 6

You should carefully read the following terms and conditions before using this software.

LICENSE AGREEMENT FOR ATELIER WEB REMOTE COMMANDER ACCESS CONTROL (AWRCAC)

Governing Law
This agreement shall be governed by the laws of the Republic of Portugal.

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD 'AS IS' AND WITHOUT WARRANTIES AS TO PERFORMANCE OR MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. Because of the various hardware and software environments into which AWRCAC may be put, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data before relying on it. The user must assume the entire risk of using the program.  ANY LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.

Distribution of Evaluation Version
AWRCAC evaluation version is distributed only within the Atelier Web Remote Commander (AWRC) evaluation version distribution.
You are specifically prohibited from charging, or requesting donations, for any such copies, however made; and from distributing the software and/or documentation with other products (commercial or otherwise) without prior written permission.

Purchased Version
One AWRCAC license allows the program to be used only on one appointed computer. After 365 days, the licensee may appoint a different computer and request another license to be issued free of charge.

.topic 5

AWRCAC is a separate product from AWRC. It is included within the AWRC distribution only for evaluation purpose.
Subject to the terms of the License Agreement, you are hereby licensed to use the AWRCAC software for evaluation purposes for a period of 15 days or 30 executions.

All customers of AWRC are entitled to a number of free AWRCAC licenses as follows:

AWRC customers may purchase additional AWRCAC licenses in packs of 2 or 10. AWRCAC packs are sold only to AWRC customers, who will be informed about the details.

AWRCAC licenses entitle to unlimited free life upgrades.