はじめに

今日のコンピュータ社会を取り巻く環境はめまぐるしく変化し続けています。特に、インターネットを介したウィルスやその他の悪質なソフトウェアの脅威は著しく増大しています。たとえば、電子メールは今日のビジネスにおいて欠くことのできないツールとなりましたが、電子メールを使用することでコンピュータは無限の脅威にさらされていることになります。

電子メールを利用したウィルス攻撃やハッキング行為は氷山の一角に過ぎません。サンフランシスコの Computer Security Institute (CSI) は、ネットワークの悪用の 60～80% が企業ネットワーク内部から発生していると推定しています。コンピュータのセキュリティ強化はロックやパスワードだけでは十分でありません。本当に安全な環境というのは常に変化しており、定期的なケアや監視が必要になります。


Nsauditor Network Security Auditor について

Nsauditor Network Security Auditor (以下「Nsauditor」といいます) は、ネットワークのセキュリティ監査を迅速かつ容易に実施できるネットワーク管理者向けのプログラムです。ポート スキャナやセキュリティ スキャナを含め、ネットワーク診断とネットワーク接続監視に役立つ多数の機能が備わっているため、トラフィックとプロトコルをリアルタイムで分析して、所有プロセス名、ロード済みモジュール、カーネル オブジェクト、メモリ詳細、リモート アドレス、接続状態など、システム上のすべての TCP/UDP エンドポイントに関する詳細情報を把握して適切に対処できるようになります。また、既知および未知のインターネット脅威を防御して不正な接続をブロックするファイアウォール システムや、監査結果レポートを生成するための機能も備わっています。日常的に使用できるパワフルなネットワーク セキュリティ監査ツールをお求めの場合は、ぜひ Nsauditor をお試しください。


主な機能

1. セキュリティ イベント分析に基づいた侵入検知システム

2. IP アドレス テーブルまたはルーティング テーブルが変更された場合のアラート通知

3. Ms RPC 監査

4. Sun RPC 監査

5. セキュリティ イベント ログ監視

6. ネットワーク監視

7. NetBios 監査

8. MS SQL サーバ監査

9. SNMP 監査

10. パケット フィルタ

11. LM/NTLM スパイダ (NTLMv1 サポート、LM パスワードの回復)

12. 不正アドレス検出

13. RBL (スパマのリアルタイム ブラック リスト) チェック

14. パケット エディタ (IP、ICMP、TCP、NETBIOS-SSN パケット解読)

15. セキュリティ イベント アラート

16. ポート スキャナ (TCP/UDP スキャナ)

17. Web プロキシ CGI スキャナ

18. リモート システム OS 検出

19. サービス プローブ

20. Ping (ICMP、TCP、UDP)

21. 経路追跡

22. Finger

23. Whois

24. DNS 照会

25. 電子メール有効性チェック

26. TCP/UDP ツール (クライアント/サーバ/ポート リダイレクタ)

27. ローカル IP、TCP、UDP、ICMP 統計

28. ローカル アドレス情報テーブル

29. メディア情報テーブルへのローカル ネット

30. プロセス監視

31. レポート生成

32. IP アドレス/ASN 国照会

33. IP ルーティング、ネット テーブル

34. MAC/ベンダ照会

35. トラフィック エミュレータ

36. HTTP トラフィック ジェネレータ

37. アドウェア スキャナ

38. リモート シャットダウン

39. IE キャッシュ エクスプローラ (IE CacheExplorer)

40. DHCP 参照

41. NetTaskExec

42. Windows サービス リモート制御

43. NetProcMon

44. リムーバブル ストレージ参照

45. RemoteNetStat

46. POST 送信

47. ファイアウォール制御

48. SIP UDP トラフィック ジェネレータ/フラッダ


機能紹介

§ セキュリティ イベント分析に基づいた侵入検知システム

セキュリティ イベント ログの分析に基づいた侵入検知システムにより、不正な侵入を検知します。

§ ファイアウォール制御

パーソナル ファイアウォールにより、ホーム ユーザと小規模事業者に最高レベルの保護を提供します。既知および未知のインターネット脅威を防御し、不正な接続をブロックします。

§ アラート

IP アドレス テーブルまたはルーティング テーブルが変更された場合に電子メールや音声で通知します。

§ セキュリティ イベント ログ監視

Windows NT/2000/XP またはワークステーションのセキュリティ イベント ログを監視して、侵入/攻撃の可能性が発生した場合に電子メールや音声で通知します。

§ ネットワーク監視

所有プロセス名とその詳細、リモート アドレス、接続状態、ホスト DNS 名、国、ネットワーク クラス、該当するサービス名とその説明など、すべての TCP/UDP エンドポイントに関する詳細情報を表示します。

§ NetBios 監査

NetBios 名 (サービスとコンピュータの名前) を調べます。特定 IP アドレス範囲内のネットワークをスキャンして、NetBios リソース共有サービスを提供するコンピュータの名前と NetBios 接続情報を表示します。

§ MS SQL サーバ監査

MS SQL サーバを実行しているコンピュータを監査します。

§ SNMP 監査

ノードのすべての SNMP MIB をチェックして、XML データベースに保存されている値を使用した SNMP コミュニティ名を監査します。

§ パケット フィルタ (対応プロトコル数は次回リリースで増える予定です)

ネットワーク パケットのフィルタリングと分析をリアルタイムで実行します。すべての IP、ICMP、TCP、UDP、NETBIOS-SSN パケット ヘッダ フィールド別のフィルタリングが可能です。

§ パケット エディタ (対応プロトコル数は次回リリースで増える予定です)

IP、ICMP、TCP、UDP、NETBIOS-SSN パケットを解読します。

§ Sun RPC 監査

Sun RPC を監査します。ONCRPC (Sun RPC) プロトコルを使用して、UNIX や Linux コンピュータのポート 111 で通常実行されるポートマッパ (Portmapper) デーモン/サービスにアクセスし、実行中のすべての登録デーモンのリストが表示される場所をダンプします。

§ MS RPC 監査

MSRPC (DCE RPC の Microsoft 実装版) を監査します。監査ダンプは、Windows RPC サービスによってエンドポイントとして使用される名前付きパイプのリストです。各パイプに関連付けられたインタフェース識別子は、該当するパイプが使用されたときに通常アクセスされるサービスを示しています。

§ ポート スキャナ (TCP/UDP スキャナ)

特定の TCP/UDP ポートが開かれ、接続が許可されているかどうかをチェックします。TCP スキャナは、通常、リモート コンピュータで Telnet や FTP などのサービスが実行されているかどうかをチェックするために使用されます。ポート スキャナの主な機能は、ユーザ定義のポート リストにメッセージを送信することです。受信した応答の種類によって、ポートが開かれているかどうかがわかります。ポート スキャナには以下のスキャン モードが用意されています。
接続スキャン、SYN ステルス、FIN ステルス、Ping スイープ、UDP スキャン、NULL スキャン、XMAS ツリー、IP プロトコル スキャン、ACK スキャン

§ トロイの木馬/バックドア検出

ポート スキャナによって検出されたオープン ポートの中に既知のトロイの木馬ポートが含まれている場合、リスト内で赤で表示されます。

§ CGI スキャナ

Web サーバに対して送信される CGI プローブを無効にします。プロキシ サーバから監査を実行している場合、そのプロキシから CGI プローブが実行されるようにスキャナを設定することができます。

§ リモート システム OS 検出

既知の TCP/UDP/ICMP パケット プローブおよび利用可能な OS フィンガープリントを使用して、リモート システムの OS を検出します。

  • アドウェア スキャナ

レジストリをスキャンして、ローカル コンピュータまたはネットワーク コンピュータにインストールされたアドウェア、マルウェア、およびスパイウェアを検出します。検出されたオブジェクトはその危険度に応じて色分けして表示されます (緑 - 安全、黄色 - 不明)。

§ 監査

ネットワーク サービスに既知の脆弱性がないかどうかをチェックして、監査レポートを作成します。

§ Ping

特定の IP アドレスが存在するかどうかをチェックします。アクセスを試みているホストがネットワークに接続されているかどうかがわかります。また、応答が返ってくるまでにかかる時間や、リモート ホストのオペレーティング システム情報もわかります。

§ 経路追跡

すべてのルータの IP アドレスを調べて、クライアント コンピュータからリモート ホストへの経路 (各ホップの特定のゲートウェイ コンピュータ) を追跡します。また、各ホップで要する時間を計算して表示します。このツールは、インターネット ネットワーク上の問題箇所を特定したり、インターネット自体について詳しく把握する上で役立ちます。

§ Finger

既知の Finger サービスを使用してユーザ情報を調べます。Finger ツールを使用すると、リモート ホストの "不正アドレス" 情報の取得が可能になります。

たとえば、prontomail.com の不正アドレスを取得するには、[Finger 入力] フィールドに「prontomail.com@abuse.net」と入力します。[Finger 応答] セクションに "abuse@mailcentro.com (for prontomail.com)" という結果が表示されます。

§ Whois

ドメイン、IP アドレス、または名前に関する情報を照会します。デフォルトでは入力した IP アドレスに応じた適切な Whois サーバが自動的に選択されるようになっていますが、特定の Whois サーバを手動で選択することもできます。

§ DHCP 参照

ローカル サブネットまたは LAN 上の DHCP サーバとその設定パラメータを調べます。

§ POST 送信

データや URL などの情報を POST 送信します。プログラムにはシンプルなデータベースが備わっているため、インターネットの最大の検索エンジン (ディレクトリ型) に自身の Web サイトを送信して、ドメインの Whois 情報を要求することができます。データの追加、編集、XML ファイルへの保存、XML ファイルからの読み込みも可能になっています。

§ NetTaskExec

ローカル コンピュータまたはネットワーク コンピュータでのプログラムやコマンドの実行スケジュールを設定します。

§ Windows サービス リモート制御

ネットワーク コンピュータの Windows サービスをリモートで制御 (開始/停止) します。

§ NetProcMon

ローカル コンピュータまたはネットワーク コンピュータ上のプロセスを監視します。不要なプロセスは停止することができます。

§ リムーバブル ストレージ参照

リモート ネットワーク コンピュータの USB デバイス、リムーバブル ストレージ、CD-ROM/DVD ドライブに関する情報 (状態、デバイスの種類、シリアル番号、リビジョン、デバイス名、製造元など) を表示します。

§ DNS 照会

IP アドレスをホスト名 (またはその逆) に変換して、エイリアスを取得します。MX や CNAME などの高度な DNS クエリを実行することができます。サポートされているクエリの種類は、A、NS、MD、MF、CNAME、SOA、MB、MG、MR、NULL、WKS、PTR、HINFO、MINFO、MX、TXT、AXFR、MAILB、MAILA、* です。

ホストがスパマのリアルタイム ブラックリスト ("RBL") に登録されているかどうかをチェックすることもできます。

§ TCP/UDP クライアント/サーバ/ポート リダイレクタ

一部のサービス、ファイアウォール、および侵入検知システムをテストしたり、プログラムのデバッグや他のネットワーク ツールの設定に役立つ情報を取得します。

§ ローカル IP、TCP、UDP、ICMP 統計

IP、TCP、UDP、ICMP の統計情報を表示します。統計情報を分析することで、ポート スキャン/プローブやネットワーク攻撃など、ネットワークにおけるさまざまな動作の検出が可能になります。

§ IP ルーティング、ネット テーブル

インタフェース-IP アドレス マッピング テーブル、IP 転送テーブル、および IP-物理アドレス マッピング テーブルに関する情報を取得して、テーブルの各 IP アドレスについて、アドレス、インタフェース インデックス、サブネット マスク、ブロードキャスト アドレス、処理可能なデータグラムのサイズなどの詳細情報を表示します。

§ リモート ネットワーク コンピュータ統計情報

リモート ネットワーク コンピュータの IP/ICMP/TCP/UDP/サーバの統計情報を表示します。

§ ローカル アドレス情報テーブル

利用可能なネットワーク インタフェースとその IP アドレス、ネットワーク マスク、ブロードキャスト アドレス、ブロードキャスト状態、実行状態、PPP 状態、ループバック状態、マルチキャスト状態を表示します。

§ ローカル ネット-メディア情報テーブル

利用可能なネットワーク アダプタとその MAC アドレス、サブネット マスク、ゲートウェイ、DNSサ ーバ、WINS サーバ、DHSP、インタフェース名などを表示します。

§ プロセス監視

コンピュータ上で実行中のプロセスのリストを表示して、選択したプロセスの詳細情報 (プログラム名、プロセス ID、実行可能ファイルのフルパス、ファイル作成者の名前、モジュール名、カーネル オブジェクト) を表示します。

§ MAC/ベンダ照会

アダプタ製造元の詳細情報を取得します。情報を照会するには、完全な MAC アドレス (例: 00:80:48:2A:83:41)、または MAC アドレスの最初の部分 (例: 00:80:48) を入力する必要があります。

§ トラフィック エミュレータ

IP/ICMP/TCP/UDP/HTTP トラフィックを生成して、高ネットワーク負荷環境下でサーバ、ルータ、およびファイアウォールの負荷テストを実行します。

クライアントの活動を簡単かつ迅速にシミュレートすることができます。

§ SIP UDP トラフィック ジェネレータ/フラッダ

SIP トラフィックを生成して、IP システム、SIP プログラム、および高ネットワーク負荷環境下で音声負荷テストを実行します。

§ HTTP トラフィック ジェネレータ

特定の URL に HTTP トラフィックを生成します。

§ リモート シャットダウン

ネットワーク コンピュータをリモートでシャットダウンまたは再起動します。シャットダウンまでの遅延時間を設定することも可能です。リモート シャットダウンを実行すると、指定したネットワーク コンピュータ上で実行中のアプリケーションはすべて終了します。

§ IE キャッシュ エクスプローラ (IE CacheExplorer)

コンピュータに保存されている Internet Explorer のクッキー、履歴、およびインターネット ファイルのリストを表示します。必要に応じて、クッキーやインターネット ファイルを削除したり、履歴をクリアしたりすることも可能です。


製品概要

Nsauditor は、ネットワーク コンピュータを監査および監視して、ハッカーの攻撃手段として利用される可能性のある脆弱性を発見することができるネットワーク セキュリティ スキャナです。ネットワーク監査、スキャン、監視に必要なツールはほとんど備わっています。その数は 45 を超え、例を挙げると、ネットワーク サービスの脆弱性チェック、すべての TCP/UDP エンドポイントとその関連プロセス情報の取得、NetBios 名の取得、MS SQL サーバの監査、アドウェア スキャン、ネットワーク パケットのリアルタイムでのフィルタリングと分析、リモート ネットワーク パフォーマンス監視、ネットワーク ステータス監視、Web プロキシ スキャン、パスワード監査、セキュリティ イベント ログの分析に基づいた侵入検知システム、インターネット脅威を防御して不正な接続をブロックするファイアウォール システム、IP アドレス照会、スニッフィング、コンピュータの列挙とアクセス取得、DNS 照会、Whois 照会、メール有効性チェック、HTTP トラフィック ジェネレータなどがあります。既知のセキュリティ脆弱性に関する組み込みのデータベースも備わっており、スキャン対象を指定したり、独自のエントリを追加することも可能になっています。Nsauditor を使用すると、インストール済みソフトウェア、共有、ユーザ、ドライブ、ホットフィックス、NetBios、RPC、SQL、SNMP、オープン ポートなど、さまざまな情報を取得することができます。また、ステルス ポート スキャン、HTTP/CGI サーバ監査、レジストリ監査などで使用する各種ネットワーク攻撃プローブを作成したり、パスワードやセキュリティ ポリシーを監査したりすることもできます。さらに、LM/NTLM パスワード ハッシュのスニッフィング、ブルートフォース攻撃、辞書攻撃により、脆弱なパスワードを特定することもできます。OS 検出も可能で、データベースにない OS フィンガープリントは自動的に作成されます。監査レポート (XML/HTML 形式) の生成機能も備わっているため、情報の把握に便利です。Nsauditor は豊富な機能を備えた完全なネットワーク ユーティリティ パッケージでありながら、驚くべき低価格で提供されています。


将来のバージョン

Nsauditor の将来のバージョンでは、システム整合性の監視機能、より高度なファイアウォール制御機能、ワイヤレス ネットワーク漏洩検出機能、パラサイト/トロイの木馬検出機能、パッチ マネージャ、トラフィック ジェネレータ、およびネットワーク シーン デザイナも実装され、セキュリティ監査の一連のチェックをスクリプト言語で実行可能になる予定です。同時に、構文強調表示機能とデバッガを備えたエディタも実装される予定です。


Nsauditor の登録

オンライン購入

Nsauditor は、試してから購入 (Try Before You Buy) することができるシェアウェアです。あらかじめ設けられた評価期間内であれば、無料でダウンロードして利用することができます。評価期間後も継続して製品を利用する場合は、ライセンスを購入して登録する必要があります。Nsauditor のライセンスは、シェアエッジの Web サイトからオンラインで購入することができます。 クレジット カードまたは銀行振込での購入が可能です。購入情報は暗号化通信により高度なセキュリティで保護されますので、第三者によって傍受されることはありません。 購入手続きが完了すると、製品を登録するための登録コードが電子メールで送信されます。

Nsauditor | Nsauditor | 価格
 | 1 ユーザ ライセンス | 5,659 円 (税込み)
 | 5 ユーザ ライセンス | 17,094 円 (税込み)
 | 10 ユーザ ライセンス | 29,914 円 (税込み)

登録コードの入力方法

登録コードを入力するには、Nsauditor のメイン ウィンドウで [登録] メニューの [登録コードの入力] をクリックするか、[Nsauditor バージョン情報] ダイアログ ボックス ([ヘルプ] -> [Nsauditor バージョン情報]) で [キー入力] をクリックします。[Enter Key (キー入力)] ダイアログ ボックスが表示されたら、ライセンス購入時の名前と登録コードを正確に入力し、[OK] をクリックします。これで登録は完了です。


使用許諾契約書

重要 - 以下の契約書を注意してお読みください。
本使用許諾契約書 (以下「本契約書」といいます) は、Nsauditor およびその関連資料 (以下「本ソフトウェア」といいます) に関してお客様と Nsasoft llc. (以下「Nsasoft」といいます) との間で締結される法的な契約書です。本ソフトウェアをインストールおよび使用することによって、お客様は本契約書の条項に拘束されることに同意されたものとします。同意されない場合は、本ソフトウェアのご使用をお控えください。

1. 使用許諾
お客様が本契約書のすべての条項を厳守される場合に限り、Nsasoft はお客様に対し、(a) 購入ライセンス数に準じた台数のコンピュータに本ソフトウェアをインストールして使用することを許諾します。

2. 制限
お客様は、本契約書で明示的に規定されている場合を除き、(a) 本ソフトウェアをレンタル、リース、貸与、サブライセンス、譲渡、またはその他の方法で再頒布すること、(b) 本ソフトウェアをリバース エンジニアリング、逆コンパイル、または逆アセンブルすること、(c) 本ソフトウェアを改変すること、および (d) 本ソフトウェアを必要以上に複製することは禁止されています。

3. 権利の留保
Nsasoft は、お客様に対して明示的に許諾していない権利をすべて留保します。Nsasoft は本ソフトウェアに関するすべての権利 (著作権を含みます) を保有しています。本ソフトウェアは許諾されるもので、販売されるものではありません。

4. 契約の終了
お客様が本契約書の条項に違反した場合、Nsasoft は、他の権利を害することなく本契約を終了することができます。

5. 免責
Nsasoft は、本ソフトウェアを何等保証もない現状有姿のまま瑕疵を問わない条件で提供しています。そのため、Nsasoft は、本ソフトウェアに関するいかなる保証 (商品性、特定の目的に対する適合性、信頼性または可用性、応答の的確性、使用結果、職人的努力、および過失の不存在についての保証、義務または条件を含みますがこれらに限定されません) も、明示、黙示、もしくは法律上のものであるかを問わず一切いたしません。本ソフトウェアの使用もしくは機能から生じるすべての危険は、お客様が負担しなければなりません。

6. その他の損害に関する免責
法律上許容される最大限において、Nsasoft およびその供給者は、本ソフトウェアの使用もしくは使用不能から生じる直接損害、間接損害、特別損害、付随的損害、懲罰的損害、または派生的損害 (逸失利益、機密情報もしくはその他の情報の喪失、事業の中断、設備の損傷、プライバシーの喪失、またはその他の金銭的損失を含みますがこれらに限定されません) に関して、たとえ、Nsasoft がこのような損害の可能性について示唆していた場合であっても、一切責任を負いません。

7. 責任および救済手段の制限
いかなる理由において生じる損害 (すべての直接損害または間接損害を含みますがこれらに限定されません) にもかかわらず、本契約書に基づく Nsasoft の責任およびお客様に対する唯一の救済手段は、合理的な信頼に基づくお客様の実際の損害額 (本ソフトウェアについてお客様が実際に支払った金額を上限とします) を限度とします。

8. 準拠法
本契約書は、日本国法に準拠するものとします。ただし、本ソフトウェアを日本以外で入手された場合は、各国・各地域の法律に準拠するものとします。

9. 完全合意、分離可能性
本契約書は、本ソフトウェアに関するお客様と Nsasoft との間の完全なる合意であり、本ソフトウェアに関する、以前のすべての口頭または書面 (オンラインでの書面または電子メールでの書面も含みます) による意思表示、提案、表明よりも優先して適用されます。Nsasoft のポリシーまたは声明の条項が本契約書の条項と異なる場合は、本契約書の条項が適用されます。本契約書の一部の条項が無効となったり、法的な強制力を失ったり、あるいは非合法と判断された場合でも、その他の条項には影響を与えることなく完全に有効性が保たれるものとします。

----------- 以下、英文 -----------

1.GRANT OF LICENSE. Nsasoft grants you the following rights provided that you comply with all terms and conditions of this EULA: You may install and use a reasonable number of copies of the Software on computers running Microsoft Windows 2000, Microsoft Windows XP or Microsoft Windows Server 2003.

2.RESERVATION OF RIGHTS AND OWNERSHIP. Nsasoft reserves all rights not expressly granted to you in this EULA. The Software is protected by copyright and other intellectual property laws and treaties. Nsasoft or its suppliers own the title, copyright and all intellectual property rights in and to the Software. The Software is licensed, not sold.

3.LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY. You may not reverse engineer, decompile, or disassemble the Software, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

4.NO RESALE, RENTAL, OR COMMERCIAL HOSTING. You may not sell, rent, lease, sublicense, assign, lend, or otherwise transfer any portion of the Software, or provide commercial hosting services with the Software.

5.LINKS TO THIRD PARTY SITES. You may link to third party sites through the use of the Software. The third party sites are not under the control of Nsasoft, and Nsasoft is not responsible for the contents of any third party sites, any links contained in third party sites, or any changes or updates to third party sites. Nsasoft is not responsible for webcasting or any other form of transmission received from any third party sites. If applicable, Nsasoft is providing these links to third party sites to you only as a convenience, and the inclusion of any link does not imply an endorsement by Nsasoft of the third party site.

6.NO SUPPORT.Nsasoft is not obligated to provide any maintenance or technical support services to you, in any form whatsoever, in connection with the Software.

7. NO REFUND.
Because the Software is provided free of charge during the Trial Period to allow potential customers to evaluate and test it before paying the license fee, Nsasoft enforces a strict no-refund policy. Please evaluate and test the Software carefully during the Trial Period. Once you pay the license fee, your payment is final and you may not be reimbursed.

8.ADDITIONAL SOFTWARE/SERVICES. Nsasoft is not obligated to provide updates to you in connection with the Software. However, if Nsasoft chooses to do so, this EULA applies to updates, supplements, add-on components, or Internet-based services components, of the Software that Nsasoft may provide to you or make available to you after the date you obtain your initial copy of the Software, unless Nsasoft provides other terms along with the update, supplement, add-on component, or Internet-based services component. Nsasoft reserves the right to discontinue any services provided to you or made available to you through the use of the Software.

9.TERMINATION.Without prejudice to any other rights, Nsasoft may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the Software, including all of its component parts.

10.DISCLAIMER OF WARRANTIES. To the maximum extent permitted by applicable law, Nsasoft and its suppliers provide the Software (if any) AS IS AND WITH ALL FAULTS, and hereby disclaim all other warranties and conditions, whether express, implied or statutory, including, but not limited to, any (if any) implied warranties, duties or conditions of merchantability, of fitness for a particular purpose, of reliability or availability, of accuracy or completeness of responses, of results, of workmanlike effort, of lack of viruses, and of lack of negligence, all with regard to the Software, and the provision of or failure to provide support or other services, information, software, and related content through the Software or otherwise arising out of the use of the Software. ALSO, THERE IS NO WARRANTY OR CONDITION OF TITLE, QUIET ENJOYMENT, QUIET POSSESSION, CORRESPONDENCE TO DESCRIPTION OR NON-INFRINGEMENT WITH REGARD TO THE SOFTWARE.

11.EXCLUSION OF INCIDENTAL, CONSEQUENTIAL AND CERTAIN OTHER DAMAGES. To the maximum extent permitted by applicable law, in no event shall Nsasoft or its suppliers be liable for any special, incidental, punitive, indirect, or consequential damages whatsoever (including, but not limited to, damages for loss of profits or confidential or other information, for business interruption, for personal injury, for loss of privacy, for failure to meet any duty including of good faith or of reasonable care, for negligence, and for any other pecuniary or other loss whatsoever) arising out of or in any way related to the use of or inability to use the SOFTWARE, the provision of or failure to provide Support OR OTHER Services, information, software, and related CONTENT through the software or otherwise arising out of the use of the software, or otherwise under or in connection with any provision of this EULA, even in the event of the fault, tort (including negligence), misrepresentation, strict liability, breach of contract or breach of warranty of Nsasoft or any supplier, and even if Nsasoft or any supplier has been advised of the possibility of such damages.

12.LIMITATION OF LIABILITY AND REMEDIES. NOTWITHSTANDING ANY DAMAGES THAT YOU MIGHT INCUR FOR ANY REASON WHATSOEVER (INCLUDING, WITHOUT LIMITATION, ALL DAMAGES REFERENCED HEREIN AND ALL DIRECT OR GENERAL DAMAGES IN CONTRACT OR ANYTHING ELSE), THE ENTIRE LIABILITY OF NSASOFT AND ANY OF ITS SUPPLIERS UNDER ANY PROVISION OF THIS EULA AND YOUR EXCLUSIVE REMEDY HEREUNDER (EXCEPT FOR ANY REMEDY OF REPAIR OR REPLACEMENT ELECTED BY NSASOFT WITH RESPECT TO ANY BREACH OF THE LIMITED WARRANTY) SHALL BE LIMITED TO THE GREATER OF THE ACTUAL DAMAGES YOU INCUR IN REASONABLE RELIANCE ON THE SOFTWARE UP TO THE AMOUNT ACTUALLY PAID BY YOU FOR THE SOFTWARE OR US$1.00. THE LIMITATIONS, EXCLUSIONS AND DISCLAIMERS SHALL APPLY TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, EVEN IF ANY REMEDY FAILS ITS ESSENTIAL PURPOSE.

13.ENTIRE AGREEMENT; SEVERABILITY. This EULA is the entire agreement between you and Nsasoft relating to the Software and supersedes all prior or contemporaneous oral or written communications, proposals and representations with respect to the Software or any other subject matter covered by this EULA. To the extent the terms of any Nsasoft policies or programs for support services conflict with the terms of this EULA, the terms of this EULA shall control. If any provision of this EULA is held to be void, invalid, unenforceable or illegal, the other provisions shall continue in full force and effect.


ツールバー

1. ツールバー


ツールバー

ツールバーには、Nsauditor で使用頻度の高いコマンドのボタン (ワークスペースを開く、ワークスペースを保存、実行、など) が配置されています。ツールバーを表示している場合、[表示] メニューの [ツールバー] の横にチェックマークが付きます。

1. ワークスペースを開く

2. ワークスペースを保存

3. 実行

4. 一時停止

5. 削除

6. 設定

7. 接続監視

8. レポート

9. ホーム

10. 新しいバージョンのチェック

11. バージョン情報

12. ヘルプ

1.　ワークスペースを開く - 保存済みのワークスペース ファイル (*.cgw) を開きます。

2.　ワークスペースを保存 - 設定の変更内容をファイルに保存します。

3.　実行 - 指定した監査プロセスを実行します。

4.　一時停止 - 実行中の監査プロセスを一時停止します。

5.　削除 - 実行中の監査プロセスを停止します。

6.　設定 - [Nsauditor オプション] ダイアログ ボックスを開きます。このダイアログ ボックスは以下の 5 つのタブで構成されています。

一般、スピーチ オプション、セキュリティ イベント、CGI 乱用、ファイアウォール

[一般] タブでは、未接続のエンドポイントおよび解決済み DNS 名の表示/非表示を切り替えることができます。また、[ネットワーク監視] テーブルの更新頻度 (デフォルトでは 1 秒) を指定することもできます。

[スピーチ オプション] タブでは、スピーチ レートやスピーチ ボリュームなどのスピーチ パラメータを設定することができます。

特定のテスト文字列を音声で再生するには、スピーチ レート、スピーチ ボリューム、およびフォーマットを指定します。また、音声の種類を指定することもできます。

再生を開始するには、[スピーク] ボタンをクリックします。再生を一時停止するには、[一時停止] ボタンをクリックします。

再生を停止するには、[再生] ボタンをクリックします。テスト文字列をクリアするには、[リセット] ボタンをクリックします。

必要なパラメータをすべて設定し、現在のセッションに変更内容を適用するには、[適用] ボタンをクリックします。適用後、今後のセッション用に変更内容を保存しておくには、ツールバーの [ワークスペースを保存] ボタンをクリックします。

変更を取り消して、ダイアログ ボックスを閉じるには、[キャンセル] ボタンをクリックします。

[セキュリティ イベント] タブでは、セキュリティ イベントを設定することができます。

特定のイベント ID のイベントを追加したり、削除したりすることができます。

イベントを追加するには、[イベント ID] フィールドと [イベント説明] フィールドに入力して、[イベント追加] ボタンをクリックします。イベントを削除するには、イベント リストからイベントを選択して、[イベント削除] ボタンをクリックします。

必要に応じて、システムにアクセスがあった場合の通知オプションを指定することもできます。

通知オプションには、[電子メールを送る] (電子メール アドレスを入力)、[メール サーバ] (メール サーバ アドレスを入力)、[アラートを送る] (ホスト名を入力)、[再生テキスト] (再生するテキストを入力)、および [再生ファイル] (再生する音声ファイルを選択) の 5 つが用意されています。

IP アドレス テーブルが変更された場合に通知するには、[IP アドレス テーブル変化の通知] チェック ボックスをオンにします。

ルーティング テーブルが変更された場合に通知するには、[ルーティング テーブル変化の通知] チェック ボックスをオンにします。

必要なパラメータをすべて設定し、現在のセッションに変更内容を適用するには、[適用] ボタンをクリックします。適用後、今後のセッション用に変更内容を保存しておくには、ツールバーの [ワークスペースを保存] ボタンをクリックします。

変更を取り消して、ダイアログ ボックスを閉じるには、[キャンセル] ボタンをクリックします。

[CGI 乱用] タブでは、CGI 乱用に関する詳細情報を設定することができます。

CGI グループから CGI を選択すると、選択した CGI のすべてのチェック プローブ (CGI 名と CGI 説明) が表示されます。CGI チェックのいずれかを選択すると、CGI 乱用詳細 (リスク レベル、乱用名、メソッド、ディレクトリ、R コード (戻りコード)、チェック URL、BagtraqID、コメント) が表示されます。

これらの既知のテストはプローブを作成するために使用されます。リストからその他のエージェントを選択することで、本当のユーザ エージェント名を隠すことができます (実際の送信元である Nsauditor 以外からプローブが送信されているように見えます)。

情報を追加、削除、または保存するには、それぞれ [追加]、[削除]、[乱用保存] ボタンをクリックします。

必要なパラメータをすべて設定し、現在のセッションに変更内容を適用するには、[適用] ボタンをクリックします。適用後、今後のセッション用に変更内容を保存しておくには、ツールバーの [ワークスペースを保存] ボタンをクリックします。

変更を取り消して、ダイアログ ボックスを閉じるには、[キャンセル] ボタンをクリックします。

7.　接続監視 - コンピュータ上で実行中のネットワーク接続とプロセス (アプリケーションとサービス) を表示します。詳細については、「ネットワーク監視」を参照してください。

8.　レポート - 監査レポートを作成します。

9.　ホーム - Nsauditor のホームページ (www.nsauditor.com) を開きます。

10.　新しいバージョンのチェック - Nsauditor の新しいバージョンをチェックします。

11.　バージョン情報 - [Nsauditor バージョン情報] ダイアログ ボックスを開きます。

12.　ヘルプ - Nsauditor のオンライン ヘルプを開きます。


セッション

1. ネットワーク監視

2. 監査

3. NetBios 監査

4. ネットワーク スキャナ

5. Web プロキシ スキャナ

6. アドウェア スキャナ

7. MsSql 監査

8. SNMP 監査

9. MsRPC 監査

10. SunRPC 監査

11. パケット フィルタ

12. LM/NTLM スパイダ


ネットワーク監視

ネットワーク監視は、コンピュータ上で実行中のネットワーク接続とプロセス (アプリケーションとサービス) を監視するためのツールです。[ネットワーク監視] テーブルには、所有プロセス名、リモート アドレス、接続状態など、すべての TCP/UDP エンドポイントに関する詳細情報が表示されます。

[プロセス] 列はプログラム名、[プロトコル] 列はプロトコルの種類、[ローカル アドレス] 列はローカル IP アドレス、[ローカル ポート] 列はローカル コンピュータの該当するプロセスで使用されているローカル ポート、[リモート アドレス] 列はリモート IP アドレス (該当するプロセスがリモート コンピュータと接続している場合 - それ以外の場合は N/A)、[リモート ポート] 列は該当するプロセスと接続しているリモート コンピュータのプロセスで使用されているポート (リモート コンピュータと接続していない場合は 0)、[状態] 列は接続状態、[ホスト名] 列はリモート ホスト名、[国] 列は国、[サービス名] 列はサービス名、[サービス説明] 列は該当するサービスの説明を示します。

下部のテーブルには、実行中のタスクの詳細情報 (タスク名、説明、進捗、状態、レベル、通知) が表示されます。

複数のタスクを実行している場合、選択したタスクに応じて、上部のテーブルの情報が切り替わります。

ネットワーク監視を停止するには、[削除] ボタンをクリックします。

テーブルを右クリックしたときに表示されるポップアップ メニューには、以下のコマンドが用意されています。

接続を閉じる - 選択したプロセスの接続を閉じます。

プロセスを閉じる - プロセスを終了します。

プロセス プロパティ - [プロセス詳細] ダイアログ ボックスを開きます。

Who Is リモート ホスト (TCP 接続のみ) - [Whois リゾルバ] ダイアログ ボックスを開きます。

ホスト経路トレース (TCP 接続のみ) - [ネットワーク経路] ダイアログ ボックスを開きます。

アドレス乱用 - リモート ホストの不正アドレスを表示します。

RBL チェック - ホストがスパマのリアルタイム ブラックリスト ("RBL") に登録されているかどうかをチェックします。

高度な情報 - [データ表示] ダイアログ ボックスを開きます。

名前を付けて保存 - データをテキスト ファイル形式で保存します。

行のコピー - 選択した行をコピーします。

すべてコピー - すべての行をコピーします。

テーブルでプロセスをダブルクリックすると、そのプロセスの [プロセス詳細] ダイアログ ボックスが表示されます。

[データ表示] ダイアログ ボックスには、ローカル ポート情報 (ローカル ポート、サービスとその説明) やリモート ポート情報 (リモート ポート、サービスと説明) が表示されます。


監査

監査は、ネットワーク サービスに既知の脆弱性がないかどうかをチェックするためのツールです。監査が完了すると、監査レポートが作成されます。TCP と UDP のいずれか、またはその両方を監査対象として指定することができます。TCP を監査するには [TCP] チェック ボックスをオンにし、UDP を監査するには [UDP] チェック ボックスをオンにします。

ネットワークの監査に使用するポートを指定するには、[拡張 TCP ポート] ([拡張 UDP ポート]) チェック ボックスをオンにします。ポートを追加するには、[ポート追加] ボタンをクリックして、[ポート] ダイアログ ボックスで目的のポートを選択します。

FTP 脆弱性を監査するには、[FTP 脆弱性] チェック ボックスをオンにします。このオプションでは、FTP 脆弱性とパスワードの安全性をチェックすることができます。SMTP 脆弱性を監査するには、[SMTP 脆弱性] チェック ボックスをオンにします。このオプションでは、SMTP 脆弱性と SMTP リレーをチェックすることができます。Telnet 脆弱性を監査するには、[Telnet 脆弱性] チェック ボックスをオンにします。このオプションでは、Telnet 脆弱性とパスワードの安全性をチェックすることができます。POP3 脆弱性を監査するには、[POP3 脆弱性] チェック ボックスをオンにします。このオプションでは、POP 脆弱性とパスワードの安全性をチェックすることができます。

Net Bios 設定を監査するには、[NetBios] チェック ボックスと関連チェック ボックス ([NetBios 名、共通情報]、[ユーザ ログの読込み]、[ユーザ リスト] など、一部またはすべて) をオンにします。

TCP サービスを監査するには、[TCP サービス] チェック ボックスと関連チェック ボックス ([Who Is]、[Finger] など、一部またはすべて) をオンにします。

HTTP 脆弱性を監査するには、[HTTP 脆弱性] チェック ボックスをオンにします。

UDP サービスを監査するには、[UDP サービス] チェック ボックスと関連チェック ボックス ([MS RPC]、[Sun RPC]、[SNMP 脆弱性]、[プラグ&プレイ] など、一部またはすべて) をオンにします。

スキャン モードを変更するには、[接続] または [同期] のいずれかのオプションを選択します。出力レポートの形式を変更するには、[XML] または [HTML] のいずれかのオプションを選択します。

[プロファイル名] フィールドにはプロファイル名が表示されます。既存のプロファイルを読み込むには、[プロファイル読込] ボタンをクリックして、該当するファイルを選択します (プロファイル ファイルの形式は XML です)。

デフォルトのプロファイルを読み込むには、[デフォルト設定] ボタンをクリックします。プロファイルを上書き保存するには、[プロファイル保存] ボタンをクリックします。プロファイルを別のファイルに保存するには、[名前を付けて保存] ボタンをクリックします。

監査を開始するには、[監査開始] ボタンをクリックします。監査が完了すると、"SECURITY AUDIT COMPLETED (セキュリティ監査完了)" というメッセージが右側のテーブルの一番下に表示されます。監査レポートを表示するには、ツールバーの [レポート] ボタンをクリックします。

ダイアログ ボックスを閉じるには、[キャンセル] ボタンをクリックします。

インタフェースを読み込むには、[ローカル I/F] ボタンをクリックします。このボタンをクリックすると、[利用可能なネットワーク インタフェース] ダイアログ ボックスが表示されます。

[ターゲット ホスト] ボタンをクリックすると、[ホスト範囲と認証の選択] ダイアログ ボックスが表示されます。

監査を開始すると、[ネットワーク監査] ダイアログ ボックスが閉じられ、監査プロセスを示すパネルが表示されます。

左側のパネルには、選択したすべての TCP/UDP ポートが表示されます。右上のパネルには、リモート ホストの設定 (リモート アドレス、リモート ポート、情報、バナー、トロイの木馬、サービス名、サービス説明) が表示されます。右下のパネルには、実行中の監査プロセスに関する情報が表示されます。


NetBios 監査

NetBios 監査は、NetBios 名 (サービスとコンピュータの名前) を調べるためのツールです。NetBios リソース共有の設定が間違っていると、セキュリティ上の重大な問題に発展するおそれがありますので、このツールで監査することをお勧めします。

監査プロセスを開始するには、IP アドレス範囲 (開始 - 終了) を指定して、ツールバーの [実行] ボタンをクリックします。この際、開始 IP アドレスと終了 IP アドレスの第 1～第 3 オクテットは同じにする必要があります。

監査プロセスが完了すると、一段目のテーブルに IP アドレス、マシン、ワークグループ、共有、イーサネット アドレス、アダプタ製造元に関する情報が表示されます。二段目左側のテーブルには、ワークステーション ユーザ、ワークステーション グループ、ワークステーション マシンに関する情報が表示されます。このテーブルは、選択したオプション（[ユーザ]、[ユーザ ログ]、[マシン]、[グループ]） に応じて内容が切り替わります。二段目右側のテーブルには、ワークステーション情報が表示されます。このテーブルは、選択したオプション ([NB 名]、[サービス]、[プログラム]、[情報]、[ホットフィックス]、[実行]、[URL]) に応じて内容が切り替わります。3 段目左側のテーブルには、アカウント ポリシに関する情報 (ポリシ、セキュリティ設定) が表示されます。3 段目右側のテーブルには、共有リソースに関する情報が表示されます。このテーブルは、選択したオプション ([共有]、[隠れた共有]、[接続]、[ブラウザ ヘルパ オブジェクト) に応じて内容が切り替わります。

ブラウザ ヘルパ オブジェクトは、ブラウザが起動するたびにロードされるオブジェクトです。このようなオブジェクトはブラウザと同じメモリ コンテキストで実行され、利用可能なウィンドウやモジュールで任意の動作を実行します。たとえば、ブラウザ ヘルパ オブジェクトの中には、コンピュータにフックをインストールして、ユーザのメッセージや行為を監視するものがあります。

[ブラウザ ヘルパ オブジェクト] オプションを選択すると、パラサイトやトロイの木馬を含むブラウザ ヘルパ オブジェクトを調べることができます。

監査プロセスは、ツールバーの [削除] ボタンでいつでも停止することができます。なお、コンピュータの監査にはかなりの時間がかかることがあります (特に、広範囲の IP アドレスを設定している場合)。


ネットワーク スキャナ

ネットワーク スキャナは、大規模なネットワークや単一のホストをスキャンすることができるツールです。このツールは、raw IP パケットを使用して、ネットワーク上で稼動しているホスト、そのホストが提供しているポート、実行中のオペレーティング システムなど、ネットワークの重要な特徴を判別します。

以下のスキャン モードが用意されています。

接続 - 最も基本的なスキャン モードです。connect() システム コールを使用して、ホスト上のすべてのリスニング ポートへの接続を開きます。ポートがリッスンしていない場合は、connect() コールは失敗します。

このスキャン モードは、ターゲット ホストにログが残るため検出されやすくなります。

SYN スキャン - このスキャン モードでは、完全な TCP 接続は開きません。実際の接続を開く代わりに、SYN パケットを送信して応答を待ちます。SYN/ACK パケットが返信されてきた場合のポートはリッスン状態です。RST パケットが返信されてきた場合のポートは非リッスン状態です。SYN/ACK パケットが返信されてきた場合、さらに RST パケットを返信して接続を閉じます。常にこのパケットの構築が可能なわけではありません。このスキャン モードでは、ターゲット ホストにログが残ることはほとんどありません。

FIN スキャン - SYN スキャンでステルス性を確保できない場合に使用します (SYN スキャンは一部のプログラムによって検出されることがあるため)。FIN スキャンでは、FIN パケットを送信して応答を待ちます。ポートが閉じている場合、RST パケットが返信されてきます。このスキャン モードは、Windows 95/NT を実行しているシステムに対しては動作しません。

Ping スイープ - Ping はネットワーク上のホストの稼動状況を調べるために使用します。指定した IP アドレスに ICMP エコー要求パケットを送信して、応答があったホストは稼動していることになります。エコー要求がブロックされる場合、この方法は利用できません。その場合は、TCP ACK パケットが送信されます。

UDP スキャン - UDP スキャンは開かれた UDP ポートを特定するために使用します。各ポートには 0 バイトの UDP パケットが送信されます。ポートが閉じている場合、"ICMP port unreachable" メッセージが返信されてきます。それ以外の場合、ポートは開いていると判断できます。ICMP エラー メッセージの発行頻度は制限されているため、UDP スキャンには時間がかかることがあります。

Null スキャン - このスキャン モードでは、すべてのフラグをオフにしたパケットを送信して応答を待ちます。

X マス ツリー- このスキャン モードでは、FIN、URG、および PUSH フラグのみをオンにしたパケットを送信して応答を待ちます。ポートが閉じている場合、RST パケットが返信されてきます。

IP スキャン (IP プロトコル スキャン) - このスキャン モードは、特定のホストでサポートされている IP プロトコルを調べるために使用します。ターゲット ホストの各プロトコルには、IP パケットが送信されます。プロトコルがサポートされていない場合、"ICMP protocol unreachable" メッセージが返信されてきます。ただし、プロトコル未達メッセージを返信しないホストも一部存在します。その場合、すべてのプロトコルがサポートされていると見なされてしまいます。

ACK スキャン - このスキャン モードでは、指定したポートに ACK パケットを送信します。RST パケットが返信されてきた場合、ポートは "フィルタリングされていない" (閉じている) と見なされます。何も返信されてこない場合、ポートは "フィルタリングされている" (開いている) と見なされます。

スキャン レベルは以下の中から調整することができます。

アグレッシブ スキャン - 1 ホストにつき 5 分でタイムアウトします。応答は 1.25 秒以上待ちません。

通常スキャン - デフォルトのスキャン レベルです。ネットワークに過負荷がかからない程度に迅速に実行します。

丁寧なスキャン - コンピュータがクラッシュする可能性が軽減されます。0.4 秒間隔でパケットを送信します。

[スキャン オプション] セクションの [ポート範囲] フィールドで、 参照ボタンをクリックして、ポート範囲を指定します。

[ローカル インタフェース] ボタンをクリックすると、[利用可能なネットワーク インタフェース] ダイアログ ボックスが表示されます。

[ターゲット ホスト] ボタンをクリックすると、[ホスト範囲と認証の選択] ダイアログ ボックスが表示されます。

[ポート スキャン遅延]、[応答タイムアウト]、[ポート スキャン試行数]、および [パラレル スキャン ポート] フィールドの値は手動で変更することもできますが、指定したスキャン レベルに応じて自動的に切り替わります。また、[ファイアウォール済みポートの表示]、[クローズ済みポートの表示]、および [ポート バナーの表示] チェック ボックスのオン/オフの状態に応じて、スキャン結果に表示される内容が変わります。

[スキャン前に Ping] チェック ボックスをオンにすると、該当するパケット（上記の「Ping スイープ」を参照） がスキャン前に送信されます。

[オペレーティング システム検出/フィンガープリンティング] セクションには、以下のオプションが用意されています。

TCP オプション (プレフィックス : 長さ : 説明)

W : 3 : Window Scale Option

N : 1 : No Operation

M : 4 : Maximum Segment Size

T : 10 : Timestamps Option

E : 1 : End Options List

O : 2 : Selective ACK Permitted

S : 10 : Selective ACK Option

C : 6 : Tcp Echo Option

A : 6 : Tcp Echo ACK Option

K : 2 : POC Permitted Option

P : 3 : POC Service Option

X : 6 : TCP CC Options

Y : 6 : TCP CC New Options

Z : 6 : TCP CC Echo Options

U : 3 : TCP Alternate Checksum

デフォルトでは "WNMTE" に設定されていますが、必要に応じて変更してください。

オペレーティング システム検出 - このチェック ボックスをオンにすると、フィンガープリントが作成され、既知の OS フィンガープリントと比較して、スキャン対象にするシステムの種類を決定することができます。なお、フィンガープリントは自動的に作成されます。

TTL フィンガープリント有効化 - フィンガープリントに TTL フィールドを追加するには、TTL フィンガープリントを有効にする必要があります。この場合、OS 検出時に TTL が使用されます。

XML データベース内に適切な OS フィンガープリントを検出できない場合、新しい XML OS フィンガープリント エントリが XML データベースに作成され、システム名、OS ファミリ、および IP アドレスが設定されます。たとえば、Windows オペレーティング システムの場合は "Windows 192.168.0.2" と設定され、未知の OS ファミリの場合は "Unknown 192.168.0.2" と設定されます。

ユーザは XML データベースで OS フィンガープリントを検索して、有効な OS 名を設定することができます。

類似したオペレーティング システムのスキャン後、そのフィンガープリントを使用して OS ファミリを検索できるようになります。たとえば、スキャン対象の OS が "WindowsXP" で、XML データベースにその名前がない場合、"WindowsXP" の代わりに "Windows 192.168.0.2" という名前が使用されます (ホスト 192.168.0.2 の OS がスキャン対象のホストの OS に類似しているため)。

スキャン結果テーブルを右クリックしたときに表示されるポップアップ メニューには、以下のコマンドが用意されています。

名前を付けて保存 - データをテキスト ファイル形式で保存します。

すべてコピー - すべての行をコピーします。

閉じる - 選択した接続を閉じます。

Nsauditor の最大の特徴は以下の点にあります。

OS フィンガープリントの自動作成

OS フィンガープリントの XML データベース

TCP オプションの作成を可能にするユーザ インタフェース


Web プロキシ スキャナ

Web プロキシ スキャナは、Web サーバの脆弱性をチェックするためのツールです ([CGI 脆弱性のチェック] チェック ボックスをオフにしている場合、このスキャナはポート スキャナとして動作します)。

CGI プローブは Web サーバに対して送信されます。このツールには、CGI プローブの実行にプロキシを介すか、介さないかを指定できる機能 ([プロキシ有効化 (Enable Proxy)]) が備わっています。

[ホスト スキャン設定] セクションで、以下のパラメータを設定します。
コマンド - コマンドの種類 (GET、PUT、POST など) を指定します。
スキーム - プロトコルの種類 (http、ftp、gopher) を指定します。
ホスト - ホスト名を指定します (たとえば、Camelot、www.nsauditor.com)
URL - URL を指定します。
ユーザ エージェント - クライアント プログラム名 (Nsauditor/1.4、Mozilla/5.0、Mozilla/4.0 など) を指定します。
タイムアウト - 応答待機のタイムアウト間隔を指定します。
ポート - ポート番号を指定します (参照ボタンをクリックして、ポート番号を選択可能)。

[CGI 脆弱性のチェック] チェック ボックスをオンにすると、脆弱性をチェックするサービス (Common、Apache など) を選択できるようになります。Front Page または IIS を選択した場合、ターゲット ホストのオペレーティング システムは Windows である必要があります。オペレーティング システムのチェックには、Ping を使用してください。

プロキシを介して接続するには、[プロキシ有効化 (Enable Proxy)] チェック ボックスをオンにして、リストから匿名のプロキシ サーバを選択します。

ターゲット ホストに送信されるプローブは既述のパラメータに基づきます。各サービスについていくつかの既知の脆弱性テストがあります。

[Nsauditor オプション] ダイアログ ボックス ([オプション] -> [設定]) の [CGI 乱用] タブで、これらのテストを設定することができます。

CGI グループから CGI を選択すると、選択した CGI のすべてのチェック プローブ (CGI 名と CGI 説明) が表示されます。CGI チェックのいずれかを選択すると、CGI 乱用詳細 (リスク レベル、乱用名、メソッド、ディレクトリ、R コード (戻りコード)、チェック URL、BagtraqID、コメント) が表示されます。

これらの既知のテストはプローブを作成するために使用されます。リストからその他のエージェントを選択することで、本当のユーザ エージェント名を隠すことができます (実際の送信元である Nsauditor 以外からプローブが送信されているように見えます)。

情報を追加、削除、または保存するには、それぞれ [追加]、[削除]、[乱用保存] ボタンをクリックします。

[すべての応答を表示] チェック ボックスをオンにした場合、[応答リスト] テーブルにはすべての応答が表示されます。このチェック ボックスをオフにした場合は、オープン ポートの応答のみが表示されます。テーブルでエントリをダブルクリックすると、http ヘッダ、ソース、各応答のデータがそれぞれ下部のパネル (左、中央、右) に表示されます。


アドウェア スキャナ

アドウェア スキャナは、レジストリをスキャンして、ローカル コンピュータまたはネットワーク コンピュータにインストールされたアドウェア、マルウェア、およびスパイウェアを検出するためのツールです。検出されたオブジェクトはその危険度に応じて色分けして表示されます (緑 - 安全、黄色 - 不明)。

スキャンを開始する前に、アドウェア スキャン パラメータを指定する必要があります。ローカル コンピュータをスキャンするには、[ローカル マシンのスキャン] オプションを選択します。ネットワーク コンピュータをスキャンするには、[リモート コンピュータのスキャン] オプションを選択します。[リモート コンピュータのスキャン] オプションを選択すると、[ホスト範囲と認証の選択] ダイアログ ボックスが表示されます。

また、スキャンするレジストリ キーも指定する必要があります。[HKEY_CLASSES_ROOT (HKCR)/(CLSID/インタフェース)]、[HKEY_LOCAL_MACHINE (HKLM)/(CLSID/インタフェース)]、[HKEY_LOCAL_MACHINE (HKLM)/.../ブラウザ ヘルパ オブジェクト] のうち 1 つまたは複数のチェック ボックスをオンにします。


MsSql 監査

MsSql 監査は、MS SQL サーバ Pinger と MS SQL サーバ監査の 2 つのツールで構成されています。

MS SQL サーバが存在するかどうか確認するには、SQL サーバの IP アドレスと、サーバからの応答を待つタイムアウト間隔を指定して、[Ping SQL] ボタンをクリックします。

監査プロセスを開始する前に、MS SQL サーバに SQL リクエストを送信する必要があります。リクエストを設定するには、SQL リクエストを入力し、SQL サーバ名、ユーザ名、パスワードを指定します。リクエストを送信するには、[送信] ボタンをクリックします。指定したユーザ名とパスワードは SQL サーバ ログイン パラメータとして使用されます。

指定した XML データベースを使用してパスワードの安全性の監査するには、[監査] ボタンをクリックします。

ユーザ名とパスワードを追加または削除するには、nsmssqllogger.xml ファイルを編集するだけです。

この XML ファイルは、ログイン名リストとパスワード リストの 2 つのセクションで構成されています。


SNMP 監査

SNMP 監査は、ネットワークをスキャンして、SNMP サービスを実行しているノードを特定するためのツールです。

SNMP パラメータ

IP アドレス - ターゲット ホストの IP アドレス

コミュニティ - SNMP コミュニティ

オブジェクト ID - 登録済みオブジェクト ID

タイムアウト - タイムアウト間隔

再試行 - プローブ数

説明 - オブジェクトの説明

サポートされているコマンドリスト

Get - 選択したオブジェクト ID に適合する最初のオブジェクト パラメータを取得します。

Get Next - 選択したオブジェクト ID に適合する次のオブジェクト パラメータを取得します。

Walk - 選択したオブジェクト ID のすべてのノードを表示します。

監査 - コミュニティ名の監査プロセスを開始します。

上記のコマンドのいずれかを使用するには、該当するボタンをクリックするだけです。

結果テーブルには、Mib Obid、コミュニティ、タイプ、および値が表示されます。

結果テーブルを右クリックしたときに表示されるポップアップ メニューには、以下のコマンドが用意されています。

名前を付けて保存 - データをテキスト ファイル形式で保存します。

すべてコピー - すべての行をコピーします。

閉じる - [SNMP 監査] ダイアログ ボックスを閉じます。


MsRPC 監査

MsRPC 監査 は、MSRPC (DCE RPC の Microsoft 実装版) を監査します。監査ダンプは、Windows RPC サービスによってエンドポイントとして使用される名前付きパイプのリストです。各パイプに関連付けられたインタフェース識別子は、該当するパイプが使用されたときに通常アクセスされるサービスを示しています。

参照ボタンをクリックしてターゲット IP アドレスを指定し、ドロップダウン リストからトランスポート プロトコルを選択します。

サポートされているプロトコルの種類は、TCP/IP トランスポート、UDP/IP トランスポート、SMB 名前付きパイプ トランスポート、ローカル RPC トランスポート、HTTP トランスポートです。

指定した TCP ポートの情報をダンプするには、[IFID] ボタンをクリックします。

利用可能なすべてのポートの情報をダンプするには、[すべてのトランスポート プロトコル再帰] チェック ボックスをオンにして、[RPC ダンプ] ボタンをクリックします。


SunRPC 監査

SunRPC 監査は、Remote Procedure Call (RPC) サービスの脆弱性を調べるためのツールです。リモート コンピュータ上で実行中の脆弱な RPC サーバの存在を検出可能です。

このツールを使用すると、ポートマップ リストにポートマップをダンプすることができます。

ポートマップ リストには以下の情報が表示されます。

プログラム - ポートを使用しているプログラム名
バージョン
プロトコル - プロトコル名
ポート - ポート番号
説明 - ポートの説明
監査情報

監査を開始するには、ターゲット ホスト名または IP アドレスを入力して、[ポートマップ ダンプ] ボタンをクリックします。この際、プロトコルの種類 (TCP または UDP) を指定する必要があります。


パケット フィルタ

パケット フィルタは、ネットワーク パケットのフィルタリングと分析をリアルタイムで実行できるツールです。すべての IP、ICMP、TCP、UDP、NETBIOS-SSN パケット ヘッダ フィールド別のフィルタリングが可能です。

このツールを使用するには、まず、利用するインタフェースを選択する必要があります。

インタフェースを選択すると、[パケット フィルタ] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、フィルタリングに使用するパケット ヘッダを選択します。パケット ヘッダを選択 (選択解除) するには、[IP]、[ICMP]、[UDP]、[TCP]、[NETBIOS-SSN]、[DATA]、[SIZE] の各チェック ボックスをオン (オフ) にします。

[IP] チェック ボックスをオンにすると、[IP ヘッダ パラメータ] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、IP ヘッダ フィールド (ヘッダ長、先行、遅延、スループット、信頼性、合計長、識別、フラグ DF、フラグ MF、TTL、プロトコル) の有効化/無効化とその値の設定が可能です。

ソース アドレス (発信元アドレス) と相手先アドレスを追加するには、それぞれアドレスを指定して、[追加] ボタンをクリックします。

フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[ICMP] チェック ボックスをオンにすると、[ICMP ヘッダ パラメータ] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、ICMP ヘッダ フィールド (ICMP タイプ、ICMP コード) の有効化/無効化とその値の設定が可能です。フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[UDP] チェック ボックスをオンにすると、[UDP ヘッダ パラメータ] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、UDP ヘッダ フィールド (ソース ポート (発信元ポート)、相手先ポート、長さ (オクテット単位)) の有効化/無効化とその値の設定が可能です。

フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[TCP] チェック ボックスをオンにすると、[TCP ヘッダ パラメータ] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、TCP ヘッダ フィールド (ソース ポート (発信元ポート)、相手先ポート、データ オフセット、フラグ URG、フラグ ACK、フラグ PSH、フラグ RST、フラグ SYN、フラグ FYN、ウィンドウ、緊急ポインタ、TCP オプション) の有効化/無効化とその値の設定が可能です。

フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[NETBIOS SSN] チェック ボックスをオンにすると、[NetBios セッション ヘッダ パラメータ] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、NetBios セッション ヘッダ フィールド (タイプ、フラグ、長さ (オクテット単位)) の有効化/無効化とその値の設定が可能です。

フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[DATA] チェック ボックスをオンにすると、[パケット データ フィルタ オプション] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、指定した文字を含むパケットをフィルタリングすることが可能です。このオプションを使用するには、[以下のワードを含むパケットをフィルタ] チェック ボックスをオンにして、対象の文字を入力します。大文字/小文字を区別するかどうか指定することもできます。

フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[SIZE] チェック ボックスをオンにすると、[パケット サイズ オプション] ダイアログ ボックスが表示されます。

このダイアログ ボックスでは、指定したサイズでパケットをフィルタリングすることが可能です。

フィルタリングを開始するには、[フィルタ] ボタンをクリックします。

[キャプチャ スケジュールの設定] オプションは、将来のバージョンで実装予定です。

キャプチャのバッファ サイズを指定するには、ドロップダウン リストから目的のバッファ サイズを選択します。バッファの最小サイズは 32 KB、最大サイズは 8 MB です。

バッファが一杯になった場合にキャプチャを停止するには、[キャプチャを停止] オプションを選択します。キャプチャ バッファをラップするには、[キャプチャ バッファをラップ] オプションを選択します。

番号付けしたファイルにデータをキャプチャするには、[番号付けしたファイルにキャプチャ] チェック ボックスをオンにします。ファイルを指定するには、[参照] ボタンをクリックします。

フィルタリング処理を開始するには、[開始] ボタンをクリックします。

フィルタリング処理を開始すると、以下のテーブルが表示されます。

このテーブルには、フィルタリングされたパケットのプロトコル、ソース アドレス (発信元アドレス)、相手先アドレス、ソース ポート (発信元ポート)、相手先ポート、パケット サイズ、日時が表示されます。

テーブルでパケットをダブルクリックすると、パケット エディタが開き、該当するパケットのパケット ヘッダ フィールドとデータを編集することができます。


LM/NTLM スパイダ

LM/NTLM スパイダは、パスワードの監査、回復用のツールです。パスワードはコンピュータに脆弱性を生み出す原因の 1 つです。脆弱なパスワードは企業のセキュリティを脅かす危険因子となりますので、ネットワーク管理者にとって、ユーザが使用しているパスワードを監査して、その強度を把握することは重要な作業です。このツールを使用すると、パスワードの脆弱性を特定してアクセスすることができます。

このツールを使用するには、まず、利用するインタフェースを選択する必要があります。

インタフェースを選択すると、監査が開始されます。Nsauditor では、チャレンジ/レスポンス技術を使用して、暗号化されたハッシュを取得します。1 台のコンピュータがネットワーク上で別のコンピュータに接続し、認証しようとすると、チャレンジを受け取ります。SMB セッションのすべての NTLMv1 認証パケット (主に、Windows 95/98、Windows NT 4.0 コンピュータで使用) が取得され、テーブルに表示されます。

[名前] 列はユーザ名、[Lm Pwd] 列は復号化された LM パスワード、[Ntlm Pwd] 列は復号化された NTLM パスワード、[Lm 応答] 列はチャレンジで暗号化された接続ユーザのパスワード (この場合、DES 暗号化アルゴリズムが使用されます)、[Ntlm 応答] 列はチャレンジで暗号化された接続ユーザのパスワード (NTLMv1 認証では、NTLM ハッシュの暗号化に MD4 暗号化アルゴリズムが使用されます)、[チャレンジ] 列はチャレンジ文字列、[開始] 列と [完了] 列は取得処理の開始時刻と完了時間を示します。

SMB NTLMv1 認証セッション パケットの取得後、受け取った LM パスワード ハッシュを復号化するには、テーブルを右クリックして、[LM パスワード調査] コマンドをクリックします。以下のダイアログ ボックスが表示されます。

復号化に使用する文字セットを選択して、[OK] ボタンをクリックします。選択した文字セットのすべての組み合わせが試されます。そのため、文字セットの長さによっては、処理に時間がかかることがあります。

脆弱なパスワードほど復号化は容易になります。NTLM 監査は、NTLM ハッシュが強力なアルゴリズムに基づいており、大文字/小文字も区別されますので、さらに時間がかかります。そのため、このバージョンでは、NTLM パスワードの回復と SMB NTLMv2 (主に、Windows 2000/XP/2003 コンピュータで使用) パケットの取得はサポートされていません。これらの機能は将来のバージョンで実装予定です。


ツール

1. Ping

2. 経路追跡

3. DNS 照会

4. WhoIs

5. Finger

6. メール有効性

7. コンピュータ列挙

8. トラフィック エミュレータ

9. SIP UDP トラフィック ジェネレータ/フラッダ

10. HTTP トラフィック ジェネレータ

11. リモート シャットダウン

12. TCP クライアント/サーバ

13. TCP ポート リダイレクタ

14. UDP クライアント/サーバ


Ping

Ping は、特定の IP アドレス ([Ping ホスト] フィールドで指定) が存在するかどうかをチェックするためのツールです。このツールを使用すると、アクセスを試みているホストがネットワークに接続されているかどうかがわかります。また、応答が返ってくるまでにかかる時間や ([時間] 列に表示)、リモート ホストのオペレーティング システム情報 ([ゲスト OS] 列に表示) もわかります。

Ping 処理の結果をテキスト ファイル形式で保存するには、テーブルを右クリックして、ポップアップ メニューの [名前を付けて保存] コマンドを使用します。

Ping 処理を停止するには、[停止] ボタンをクリックします。


経路追跡

経路追跡は、すべてのルータの IP アドレスを調べて、クライアント コンピュータからリモート ホストへの経路 (各ホップの特定のゲートウェイ コンピュータ) を追跡するためのツールです。各ホップで要する時間を計算して表示することもできます。このツールは、インターネット ネットワーク上の問題箇所を特定したり、インターネット自体について詳しく把握する上で役立ちます。

追跡処理を開始するには、[対象ホスト] フィールドにホスト アドレスを入力して、[経路検出] ボタンをクリックします。

この際、以下のパラメータを設定可能です。

ホップ数 - 追跡するホップ数

タイムアウト - ルータからの応答を待つ最大時間

追跡処理の結果をテキスト ファイル形式で保存するには、テーブルを右クリックして、ポップアップ メニューの [名前を付けて保存] コマンドを使用します。

追跡処理を停止するには、[停止] ボタンをクリックします。


DNS 照会

DNS 照会は、IP アドレスをホスト名 (またはその逆) に変換して、エイリアスを取得するためのツールです。MX や CNAME などの高度な DNS クエリを実行することができます。サポートされているクエリの種類は、A、NS、MD、MF、CNAME、SOA、MB、MG、MR、NULL、WKS、PTR、HINFO、MINFO、MX、TXT、AXFR、MAILB、MAILA、* です。

標準クエリを実行するには、[問い合わせタイプ] ドロップダウン リストから [Standard Mode] を選択し、[DNS サーバ] フィールドに IP アドレスまたはホスト名を入力して、[解決] ボタンをクリックします。クエリの結果は数秒で表示されます。

非標準クエリを実行するには、[問い合わせタイプ] ドロップダウン リストから目的のレコードを選択し、[DNS クエリ] フィールドにクエリ、[DNS サーバ] フィールドに DNS サーバ アドレスを入力して、[解決] ボタンをクリックします。クエリの結果は [DNS 応答] セクションに数秒で表示されます。

DNS ツールを使用すると、ホストがスパマのリアルタイム ブラックリスト ("RBL") に登録されているかどうかをチェックすることができます。

この機能を使用するには、 [ネットワーク監視] テーブルで適切な IP アドレスを右クリックして、ポップアップ メニューの [RBL チェック] をクリックします。

独自の要求に作成するには、以下のアルゴリズムを使用します。

IP アドレス "127.0.0.2" が SORBS リアルタイム ブラックリストに登録されているかどうかチェックするには、[問い合わせタイプ] ドロップダウン リストから [Host address (A)] を選択して、[DNS クエリ] フィールドに逆の順序で IP アドレスを入力します。"127.0.0.2" の場合、".dnsbl.sorbs.net" が返されます。

結果は "2.0.0.127.dnsbl.sorbs.net" になります。

このツールでは、ホストまたはドメインについて以下の DNS レコードを要求することができます。

A ホスト アドレス

NS 信頼できるネーム サーバ

MD メールの宛先 (廃止 - MX を使用)

MF メールの転送先 (廃止 - MX を使用)

CNAME エイリアスの正式名

SOA オーソリティ ゾーンの開始位置

MB メールボックスのドメイン名 (実験的)

MG メール グループ メンバ (実験的)

MR 改名メールボックスのドメイン名 (実験的)

NULL null RR (実験的)

WKS 既知のサービスの説明

PTR ドメイン名ポインタ

HINFO ホスト情報

MINFO メールボックス/メーリング リスト情報

MX メール交換

TXT テキスト文字列

AXFR ゾーン全体の転送要求

MAILB メールボックス関連レコード (MB、MG、MR) の要求

MAILA メール エージェント RR の要求 (廃止 - MX を参照)

ALL 全レコードの要求


Whois

Whois は、世界中の WHOIS サーバと通信して、ドメイン登録情報を取得するためのクライアント ユーティリティです。特定の Whois サーバを手動で選択することもできますが、IP アドレス クエリがサポートされているため、入力した IP アドレスに応じた適切な Whois サーバが自動的に選択されます。このツールでは、ドメイン情報、IP アドレス、またはドメイン登録情報を照会することができます。

処理を開始するには、[Whois クエリ] フィールドにクエリを入力して、[クエリ] ボタンをクリックします。

クエリには、IP アドレス (127.0.0.1) またはホスト名 (nsauditor.com) のいずれかを入力します。

[Whois 応答] セクションに応答が表示されます。結果をテキスト ファイル形式で保存するには、[保存] ボタンをクリックします。ダイアログ ボックスを閉じるには、[閉じる] ボタンをクリックします。

[Whois サーバ自動検出] チェック ボックスをオンにした場合、指定した Whois クエリに応じた適切な Whois サーバが自動的に検出されます。


Finger

Finger は、既知の Finger サービスを使用してユーザ情報を調べるためのツールです。Finger ツールを使用するには、[Finger 入力] フィールドに「User@Host」と入力して、[Finger] ボタンをクリックします。[Finger 応答] セクションに結果が表示されます。

Finger ツールを使用すると、リモート ホストの "不正アドレス" 情報の取得が可能になります。

たとえば、prontomail.com の不正アドレスを取得するには、[Finger 入力] フィールドに「prontomail.com@abuse.net」と入力します。[Finger 応答] セクションに "abuse@mailcentro.com (for prontomail.com)" という結果が表示されます。


メール有効性

メール有効性は、電子メール アカウントの有効性をチェックするためのクライアント ユーティリティです。

以下の 2 種類のモードが用意されています。

VRFY - SMTP VRFY コマンドを使用してアカウントの有効性をチェックするために使用します。

EXPN - メール エイリアス (フルネームの場合でも可能) に登録されている実際の配信アドレスを調べるために使用します。

有効性のチェックを開始するには、[DNS サーバ] フィールドに DNS サーバ、[電子メール アドレス] フィールドに電子メール アドレスを入力して、[有効性確認] ボタンをクリックします。

有効性のチェック中、"セキュアな電子メール サーバからは何も情報は返されません" という警告メッセージが表示されることがあります。


コンピュータ列挙

コンピュータ列挙は、ドメイン内のコンピュータを列挙するためのツールです。このツールの動作は指定したパラメータによって異なります。たとえば、すべてのコンピュータ ([すべてのコンピュータ] を選択)、すべての SQL サーバのみ ([Microsoft SQL サーバ] を選択)、すべてのプライマリ ドメイン コントローラのみ ([プライマリ ドメイン コントローラ (PDC)] を選択)、バックアップ ドメイン コントローラのみ ([バックアップ ドメイン コントローラ (BDC)] を選択)、プライマリ ドメインのみ ([プライマリ ドメイン] を選択)、などを列挙対象として指定することができます。

複数のパラメータを指定すると、複数の種類のコンピュータが列挙されます。

処理を開始するには、列挙するコンピュータの種類を選択して、[リスト] ボタンをクリックします。

コンピュータをスタンドアロンで使用している場合、列挙結果には "<NetServersEnum />" とだけ表示されます。コンピュータをローカル エリア ネットワークまたは企業ネットワークの他のコンピュータに接続している場合、指定したパラメータに該当するすべてのコンピュータが XML 形式のレポートに列挙されます。

ダイアログ ボックスを閉じるには、[キャンセル] ボタンをクリックします。


トラフィック エミュレータ

トラフィック エミュレータは、IP/ICMP/TCP/UDP/HTTP トラフィックを生成して、高ネットワーク負荷環境下でサーバ、ルータ、およびファイアウォールの負荷テストを実行するためのツールです。クライアントの活動を簡単かつ迅速にシミュレートすることができます。

トラフィックを生成するには、発信元/相手先パラメータを指定します。パケット数も指定する必要があります。

ICMP パケットを生成するには、[ICMP] オプションを選択して、ICMP タイプと ICMP コードを指定します。

UDP または TCP パケット トラフィックを生成するには、[UDP] または [TCP] オプションを選択して、発信元ポートと相手先ポートを指定します。TCP パケットの場合、TCP フラグも指定する必要があります。

その他のトラフィックを生成するには、[その他] オプションを選択して、[プロトコル] ドロップダウン リストから目的のプロトコル名を選択します。利用可能なプロトコルは、icmp、igmp、ggp、ip、st、tcp、cbt、egp、igp、bbn-rcc-mon、nvp-ii、pup、ipv6-route、rvd などです。

エミュレーションを開始するには、[開始] ボタンをクリックします。処理を停止するには、[停止] ボタンをクリックします。

Windows XP SP2 を使用している場合、トラフィック エミュレータの一部の機能がブロックされる可能性があります。Windows 2000 では、すべての機能が問題なく動作します。


SIP UDP トラフィック ジェネレータ/フラッダ

SIP UDP トラフィック ジェネレータ/フラッダは、SIP トラフィックを生成して、IP システム、SIP プログラム、および高ネットワーク負荷環境下で音声負荷テストを実行するためのツールです。SIP クライアントとコール処理を簡単かつ迅速にシミュレートすることができます。

SIP トラフィックを生成するには、開始 IP 範囲、終了 IP アドレス、発信元/相手先ポートを指定します。発信元ポートのランダム化、SDP を含めるか否かの指定、送信パケット数の変更、SIP/SDP メッセージ テンプレートの変更も可能です。SIP メッセージの送信に使用できるメソッドは、INVITE、ACK、CANCEL、OPTIONS、REGISTER、BYE があります。 処理中には、パケット フィルタで送信 SIP パケットや受信 SIP 応答をキャプチャして、パケット エディタで分析することができます。

エミュレーションを開始するには、[開始] ボタンをクリックします。処理を停止するには、[停止] ボタンをクリックします。

Windows XP SP2 を使用している場合は、SIP フラッダの一部の機能がブロックされる可能性があります。Windows 2000 では、すべての機能が問題なく動作します。


HTTP トラフィック ジェネレータ

HTTP トラフィック ジェネレータは、特定の URL に HTTP トラフィックを生成するためのツールです。

[HTTP リクエスト パラメータ] セクションで、パケット数と 2 つのパケット間の間隔 (ミリ秒) を指定します。

トラフィックの生成を開始するには、[開始] ボタンをクリックします。生成処理を停止するには、[停止] ボタンをクリックします。


リモート シャットダウン

リモート シャットダウンは、ネットワーク コンピュータをリモートでシャットダウンまたは再起動するためのツールです。シャットダウンまでの遅延時間を設定することも可能です。リモート シャットダウンを実行すると、指定したネットワーク コンピュータ上で実行中のアプリケーションはすべて終了します。

ネットワーク コンピュータをシャットダウン後再起動するには、[シャットダウン後再起動] チェック ボックスをオンにします。

シャットダウンする 1 台または複数のコンピュータを指定するには、[マシンの追加] ボタンをクリックします。[ホスト範囲と認証の選択] ダイアログ ボックスが表示されます。

リモート シャットダウンを実行するには、必要なパラメータをすべて指定して、[実行] ボタンをクリックします。

テーブルには、リモート シャットダウンの結果が表示されます。[リモート アドレス] 列は指定したコンピュータの IP アドレスを示し、[情報] 列はシャットダウンのステータスを示します。


TCP クライアント/サーバ

TCP クライアント/サーバは、一部のサービス、ファイアウォール、および侵入検知システムのテストに便利なツールです。また、プログラムのデバッグや他のネットワーク ツールの設定にも使用することができます。

このツールは、クライアント/サーバ モードに応じて、TCP クライアントまたは TCP サーバとして動作します。[インタフェース] フィールドではローカル IP アドレス (サーバ モードの場合)、[相手先アドレス] フィールドでは接続先のサーバ アドレス (クライアント モードの場合)、[ポート] フィールドではローカル ポート (クライアント モードの場合、クライアントがバインドされているポート、サーバ モードの場合、サーバがバインドされているポート) を指定します。

[ピア] ドロップダウン リストでは接続したクライアントの IP アドレスとポートを指定します (サーバ モードの場合)。

サーバ モードでは、IP アドレスとポートの指定後、[リッスン] ボタンをクリックして、クライアントからの応答を待ちます。

接続完了後、メッセージを送信するには、[メッセージ] フィールドにメッセージを入力して、[送信] ボタンをクリックします。接続したクライアントを閉じるには (サーバ モードの場合)、[ピア] ドロップダウン リストから該当するクライアントを選択して、[クライアントを閉じる] ボタンをクリックします。

ホストの容認モードには、以下の 2 種類のモードが用意されています。

すべてを容認 - すべてのホストからの接続を容認します。

ホストで容認 - 特定のホストからの接続を容認します。容認ホストのリストにホストを追加するには、[容認ホスト] フィールドにホストの ＩＰ アドレスを入力して、[追加] ボタンをクリックします。


TCP ポート リダイレクタ

TCP ポート リダイレクタは、特定のポートで受信した TCP トラフィックを別のポートにリダイレクトできる便利なツールです。このツールは、通常、一部のサービス、ファイアウォール、および侵入検知システムのテストに使用します。また、プログラムのデバッグや他のネットワーク ツールの設定にも使用することができます。

接続が完了すると、[アクティブな接続] テーブルにアクティブな接続のパラメータが表示されます。接続したクライアントを閉じるには、ドロップダウン リストから該当するクライアントを選択して、[接続を閉じる] ボタンをクリックします。

[リダイレクション設定] セクションでは、TCP トラフィックをリダイレクトする IP アドレス ([リダイレクト アドレス]) とポート (リダイレクト ポート) を指定します。

ホストの容認モードには、以下の 2 種類のモードが用意されています。

すべてを容認 - すべてのホストからの接続を容認します。

ホストで容認 - 特定のホストからの接続を容認します。容認ホストのリストにホストを追加するには、[容認ホスト] フィールドにホストの ＩＰ アドレスを入力して、[追加] ボタンをクリックします。


UDP クライアント/サーバ

UDP クライアント/サーバは、一部の UDP サービス、ファイアウォール、および侵入検知システムのテストに便利なツールです。また、プログラムのデバッグや他のネットワーク ツールの設定にも使用することができます。

サーバを特定のポートにバインドするには、[インタフェース] フィールドにサーバの IP アドレス、[リッスン ポート] フィールドにポートを入力します。

上部のフィールドでは、クライアントのパラメータを指定します。[アドレス] フィールドではクライアントの IP アドレス、[ポート] フィールドではクライアントがバインドされているポートを指定します。

テキストを送信するには、[テキスト] フィールドにテキストを入力して、[送信] ボタンをクリックします。サーバからクライアントを切断するには、[切断] ボタンをクリックします。


統計情報

1. IP 統計情報

2. ICMP 統計情報

3. TCP 統計情報

4. UDP 統計情報

5. IP テーブル

6. Web ログ分析


IP 統計情報

IP 統計情報では、IP データグラムに関する情報を確認することができます。[IP 統計情報] ダイアログ ボックスには、IP データグラムの詳細情報 (転送有効/無効状態、デフォルト TTL、受信データグラム総数、ヘッダ エラーのため破棄された受信データグラム数、アドレス エラーのため破棄された受信データグラム数、転送された受信データグラム数、プロトコル エラーのため破棄された受信データグラム数、エラー以外の理由で破棄された受信データグラム数、正常受信データグラム数、送信データグラム総数、エラー以外の理由で破棄された送信データグラム数、経路不明で破棄された送信データグラム数、インタフェース数、ローカル ホスト IP アドレス数、など) が表示されます。

IP データグラムを受信するたびに、すべてのフィールドが自動的に更新されます。


ICMP 統計情報

ICMP 統計情報では、ICMP メッセージに関する情報を確認することができます。[ICMP 統計情報] ダイアログ ボックスには、ICMP メッセージの送受信の詳細情報 (メッセージ数、エラー数、未到達メッセージ数、TTL 超過メッセージ数、パラメータ　エラー メッセージ数、ソース クエンチ メッセージ数、リダイレクト メッセージ数、Echo メッセージ数、Echo 応答数、タイムスタンプ応答数、アドレス マスク メッセージ数、アドレス マスク応答数) が表示されます。

ICMP メッセージを受信するたびに、すべてのフィールドが自動的に更新されます。


TCP 統計情報

TCP 統計情報では、TCP セグメントに関する情報を確認することができます。[TCP 統計情報] ダイアログ ボックスには、TCP セグメントの詳細情報 (タイムアウト アルゴリズム、最小タイムアウト (ミリ秒)、最大タイムアウト (ミリ秒)、最大接続数、アクティブなオープン接続数、パッシブなオープン接続数、接続の失敗回数、接続のリセット回数、現在確立されている接続数、受信セグメント総数、送信セグメント総数、再送セグメント総数、エラーになった受信セグメント数、リセット フラグを含む送信セグメント数、累積接続数) が表示されます。

TCP セグメントを受信するたびに、すべてのフィールドが自動的に更新されます。


UDP 統計情報

UDP 統計情報では、UDP データグラムに関する情報を確認することができます。[UDP 統計情報] ダイアログ ボックスには、UDP データグラムの詳細情報 (データグラムの受信総数、受信ポートに対応アプリケーションのなかった受信データグラム数、ポート非対応以外でエラーになった受信データグラム数、データグラムの送信総数、リスニング接続数) が表示されます。

UDP データグラムを受信するたびに、すべてのフィールドが自動的に更新されます。


IP テーブル

IP テーブルでは、インタフェース-IP アドレス マッピング テーブル、IP 転送テーブル、および IP-物理アドレス マッピング テーブルに関する情報を確認することができます。[IP ルーティング テーブル] ダイアログ ボックスには、テーブルの各 IP アドレスの詳細情報 (アドレス、インタフェース インデックス、サブネット マスク、ブロードキャスト アドレス、処理可能なデータグラムのサイズ、など) が表示されます。

ダイアログ ボックスの情報を最新の情報に更新するには、[リフレッシュ] ボタンをクリックします。


Web ログ分析

Web ログ分析では、Apache Web サーバにより生成されたデフォルトの access.log ファイルを XML ファイルに変換して、出力 XML ファイルを分析することができます。

Apache ログ ファイルを XML ファイルに変換するには、[ソース ログ ファイル] フィールドで Apache ログ ファイルの場所、[出力 XML ファイル] フィールドで変換後の XML ファイルの保存先を指定して、[変換] ボタンをクリックします。分析を開始するには、[XML ログの選択] フィールドで変換後の XML ファイルを選択して、[分析] ボタンをクリックします。分析結果のテーブルには、IP アドレス、訪問数、ページ ビュー数、バイト、最初の訪問日時、国、ネット アドレス、長さ、などの情報が表示されます。テーブル上部には、合計訪問数、合計ページ ビュー数、および合計サイズが表示されます。


ユーティリティ

1. インタフェース

2. ネット設定

3. プロセス監視

4. レポート

5. IE キャッシュ エクスプローラ (IE CacheExplorer)

6. IP/ASN 国

7. MAC/ベンダ照会

8. パケット エディタ

9. ポート


インタフェース

インタフェースは、利用可能なネットワーク インタフェース パラメータ (ネットワーク マスク、ブロードキャスト アドレス、ブロードキャスト状態、実行状態、PPP 状態、ループバック状態、マルチキャスト状態) を取得するためのツールです。


ネット設定

ネット設定では、ローカル ホストとネットワークの情報を確認することができます。[ホスト ネットワーク情報] ダイアログ ボックスには、ホスト固定の情報 (ホスト名、ドメイン名、DNS サーバ リスト、ノード タイプ、スコープ ID、ルーティング有効/無効状態、プロキシ有効/無効状態、DNS 有効/無効状態) と、アダプタ単位の情報 (インタフェース名、アダプタ タイプ、IP アドレス、サブネット マスク、MAC アドレス、アダプタ名、自動設定有効/無効状態、Wins 有効/無効状態、など) が表示されます。

ダイアログ ボックスの情報を最新の情報に更新するには、[リフレッシュ] ボタンをクリックします。

アダプタ間を切り替えるには、[次へ] ボタンをクリックします。この場合、アダプタ情報に関するフィールドには次のアダプタのパラメータが表示されます。


プロセス監視

プロセス監視は、システム プロセス情報を監視するためのツールです。[プロセス監視] ダイアログ ボックスには、ローカル コンピュータ上で実行中のプロセス (アプリケーションとサービス) のリストが表示されます。

プロセス情報を監視するには、リストからプロセス名を選択します。[プロセス詳細] ダイアログ ボックスが表示されます。


レポート

レポート ツールでは、XML 形式または HTML 形式で生成されたすべてのネットワーク セキュリティ監査レポートのうち、任意のレポートを選択して、組み込みのレポート ビューアで開くことができます。

以下に HTML 形式のサンプル レポートを示します。

http://www.nsauditor.com/docs/reports/nsaudit.xml

レポートを開くには、[監査レポート] ダイアログ ボックスで目的のレポート ファイル名を選択して、[OK] ボタンをクリックします。

Adobe Acrobat をインストールしている場合、XML 形式または HTML 形式のレポートを PDF ファイルに変換することができます。その場合、[印刷] ダイアログ ボックス (レポートを右クリックして [印刷] をクリック) で、使用するプリンタとして [Adobe PDF] を選択します。


IE キャッシュ エクスプローラ (IE CacheExplorer)

IE キャッシュ エクスプローラでは、コンピュータに保存されている Internet Explorer のクッキー、履歴、およびインターネット ファイルのリストを確認することができます。必要に応じて、クッキーやインターネット ファイルを削除したり、履歴をクリアしたりすることも可能です。


IP/ASN 国

IP/ISN 国は、IP アドレスまたは AS (Autonomous System) 番号が割り当てられている国を特定するためのツールです。国を検索する際は、IP アドレスで検索することも、AS 番号で検索することも可能です。

国を検索するには、IP アドレスまたは AS 番号を入力して、[照会] ボタンをクリックします。入力した IP アドレスまたは AS 番号に該当する情報がデータベース内に見つかった場合、国名が下部のボックスに表示されます。見つからなかった場合は、IP アドレスまたは AS 番号が存在しないことを示すメッセージが表示されます。


MAC/ベンダ照会

MAC/ベンダ照会は、特定のデバイスのベンダ情報を照会するためのツールです。照会を開始するには、MAC アドレスを入力して、[照会] ボタンをクリックします。指定した MAC アドレスが有効であれば、該当する情報が下部のボックスに表示されます。


パケット エディタ

パケットエディタは、フィルタリングしたパケット ヘッダを編集するためのツールです。パケットをフィルタリングするには、[セッション] タブで [パケットフィルタ] を選択します。フィルタリングするパケットの設定が完了したら、[開始] ボタンをクリックして、フィルタリング処理を開始します。指定した条件に該当するパケットがテーブルに表示されます。このテーブルでパケットを右クリックすると、ポップアップ メニューが開き、以下のコマンドを実行することができます。

パケット編集 - パケット エディタを開きます。

名前を付けて保存 - データをテキスト ファイル形式で保存します。

すべてコピー - すべての行をコピーします。

パケット エディタでは、復号化したパケットを表示して、パケット ヘッダとデータを編集することができます。

パケット エディタの下部のセクションを右クリックしたときに表示されるポップアップ メニューには、以下のコマンドが用意されています。

すべて選択 - すべてのパケット データを選択します。

名前を付けて保存 - 選択したファイルにデータを保存します。

コピー - 選択範囲をクリップボードにコピーします。

貼り付け - クリップボードから貼り付けます。

ファイルから貼り付け - 選択したファイルからデータを貼り付けます。

閉じる - パケット エディタを閉じます。

パケット エディタはパケット分析にとても便利なツールです。わかりやすいユーザ インタフェースが採用されているため、操作も簡単です。


ポート

ポートは、オープン ポート (TCP/UDP) を検出するためのツールです。ダイアログ ボックスを開くと、[すべてのポート] オプションが選択されています。この場合、利用可能なすべてのポートが表示されます。各列はポート固有の情報を示しています。

サービス - 特定のポートを使用するサービス名

ポート - ポート番号

プロトコル - 接続に使用されているプロトコル

トロイの木馬 - ポートに関連するトロイの木馬名

説明 - 特定のポートを使用するサービスの説明

表示するポートをフィルタリングするには、該当するオプションを選択します。

[TCP ポート] オプションを選択すると、TCP 接続を使用するサービスのみが表示されます。

[UDP ポート] オプションを選択すると、UDP 接続を使用するサービスのみが表示されます。

[TCP トロイの木馬ポート] オプションを選択すると、TCP トロイの木馬を使用するサービスのみが表示されます。

[UDP トロイの木馬ポート] オプションを選択すると、UDP トロイの木馬を使用するサービスのみが表示されます。

すべてのポートを選択するには、[すべて選択] ボタンをクリックします。

すべてのポートを選択解除するには、[すべてクリア] ボタンをクリックします。


プロセス詳細

[プロセス詳細] ダイアログ ボックスの上部の 2 つのセクションには、モジュール詳細 (バージョン、ファイル バージョン) とプロセス詳細 (終了ステータス、関係マスク (Affinity Mask)、基本プライオリティ、プロセス ID、親プロセス ID) が表示されます。

[パス名] と [コマンドライン] セクションには、実行可能ファイルのパスとコマンドライン文字列が表示されます。

[ロード済み DLL] セクションには、ローズ済み DLL 情報 (モジュール パス、ファイル バージョン、ファイル サイズ、ファイル更新日、説明、など) が表示されます。

[ハンドル] セクションには、ハンドル情報 (ハンドル、タイプ、RefCount、アクセス マスク、名前) が表示されます。

ハンドル情報 - 選択したハンドル情報を表示します。

名前を付けて保存 - データをテキスト ファイル形式で保存します。

すべてコピー - すべての行をコピーします。

閉じる - ダイアログ ボックスを閉じます。


ホスト範囲と認証の選択

[ホスト範囲と認証の選択] ダイアログ ボックスでは、ホスト範囲と認証方法を指定することができます。
ホスト範囲を指定するには、[ホスト名/アドレス] オプションで特定のホスト名/アドレスを指定するか、[IP 範囲] オプションで開始 IP アドレスと終了 IP アドレスを指定するか、[IP アドレス リスト] オプションで IP アドレスのリスト ファイルを指定します。

認証方法を指定するには、3 種類の認証オプション ([ヌル セッション]、[現在の認証]、および [他の認証]) のうち、目的のオプションを選択します。

[他の認証] オプションを選択した場合、[ユーザ名] と [パスワード] フィールドにユーザ名とパスワードを入力する必要があります。この際、ユーザ名は "ドメイン\アカウント" または "アカウント" (現在のドメイン名を使用する場合) の形式で入力する必要があります。