AHPP - 製品概要

製品概要

Windows エクスプローラから HTML Password Protector へ AeroTags HTML Password Protector (AHPP) は、HTML およびテキスト ファイルをロックするためのユーティリティです。HTML またはテキスト ファイルをロックすると、パスワード確認ログイン ページで保護されます。ログイン ページのコードは自由にカスタマイズすることができるため、対象の Web サイトと同じ見た目を実現することができます。パスワードの検証は JavaScript によって行われます。これは、すべてのモデム ブラウザでサポートされているため、サーバが CGI や PHP をサポートしている必要はありません。

ファイルをロックするには、デスクトップ上の AHPP アイコンにドラッグします。次に、パスワードを入力して、[OK] ボタンをクリックします。これで、パスワードを入力しない限り、ファイル内の情報にアクセスすることはできなくなります。

同時に複数のファイルをロックしたり、ページの印刷やテキストの選択など、Internet Explorer の一部の機能を無効にしたりすることも可能です。

Web ページのワンクリック保護
AHPP の基本操作
コマンドライン パラメータ
登録ユーザの特典
連絡先

公式 Web サイト

AHPP の最新情報については、以下の公式 Web サイトを参照してください。
英語版: www.aerotags.com/products/ahpp.php
日本語版: www.shareEDGE.com

AeroTags HTML Password Protector に関心をお示しいただきありがとうございます。


AHPP - ワンクリック保護

Web ページのワンクリック保護

AeroTags HTML Password Protector (AHPP) は、"ワンクリック保護" テクノロジによって、HTML およびテキスト ファイルを簡単にパスワード保護できるように設計されています。

対象のファイルをデスクトップ上の AHPP アイコンにドラッグ アンド ドロップし、パスワードを入力して、[OK] ボタンをクリックするだけです。または、右クリック メニューの [AHPP でプロテクト] オプションを使用することもできます。

ファイルをデスクトップ上の AHPP アイコンにドラッグ アンド ドロップするか、右クリック メニューの [AHPP でプロテクト] オプションを使用すると、以下のウィンドウが表示されます。

このウィンドウでは、パスワードを入力して、[OK] をクリックするだけでファイルがロックされます。[入力を隠す] チェック ボックスをオンにすると、パスワードは入力時にアスタリスクで隠されて表示されます。

[プロテクトするファイルの選択] ボックスの [image] ボタンをクリックすると、別のファイルを選択したり、現在のファイルを表示または編集したりするためのオプションが表示されます。

[さらに] ボタンをクリックすると、その他のオプション (IE 機能の無効化など) を含む通常のウィンドウが表示されます。


AHPP - 基本操作

AHPP の基本操作

AeroTags HTML Password Protector (AHPP) は、HTML およびテキスト ファイルをパスワード保護するためのソフトウェアです。同じパスワードを使用するのであれば、同時に複数のファイルを処理することもできます。AHPP はウィザード スタイルのソフトウェアであるため、ステップバイステップ形式で簡単にファイルをロックすることが可能です。主なステップは以下の 4 つです。

  1. 保護対象のファイルの選択
  2. パスワードの作成
  3. ログイン ページのスタイルの選択
  4. 不要な IE 機能の無効化 (省略可能)

各ステップの基本操作については、以下を参照してください。

ステップ 1 - ファイルの選択

保護対象のファイルを選択するには、[追加] ボタンをクリックして、リストにファイルを追加します。リスト内のファイルを選択して [削除] ボタンをクリックすると、そのファイルがリストから削除されます。[すべて削除] ボタンをクリックすると、すべてのファイルがリストから削除されます。

ステップ 2 - パスワードの作成

ページのロックを解除するためのパスワードを入力します。アルファベットと数字を含めて、少なくとも 4 文字以上のパスワードを作成することをお勧めします。なお、パスワードは大文字と小文字を区別します。[入力を隠す] チェック ボックスを使用すれば、入力時にパスワードを表示したり、隠したりすることができます。

また、[ランダムなパスワードを生成] ボタンをクリックすれば、ランダムに生成されたパスワードが自動的に入力されます。しかし、記憶の容易さを考えると、パスワードは自分で作成したほうがよいでしょう。

ステップ 3 - ログイン ページのスタイル

テンプレートを使用すれば、ログイン ページの見た目を自由にカスタマイズすることができます。独自の Web ページ テンプレートを使用して、対象の Web サイトとまったく同じ見た目のログイン ページを作成することもできます。

このステップでは、既存のテンプレートまたは独自定義のテンプレートを指定することで、ログイン ページのスタイルを選択することができます。[プレビュー] ボタンをクリックすれば、選択したスタイルをブラウザで確認することができます。

[HTML ページ テンプレートの編集] ボタンをクリックすれば、テンプレートのソース コードを編集したり、新しいテンプレートを作成して保存したりするためのテンプレート エディタが表示されます。新たに作成したテンプレートを保存すると、自動的にテンプレート リストに追加されます。

ステップ 4 - 不要な IE 機能の無効化

不要な IE 機能の無効化

このステップでは、Internet Explorer (IE) 機能の一部を必要に応じて無効化することができます。

[右マウス ボタンおよびポップアップ メニューの無効化] - ユーザが Internet Explorer で右クリックしたときに表示されるポップアップ メニューを無効化するには、このチェック ボックスをオンにします。

[ページ印刷の無効化] - Internet Explorer の印刷機能 ([ファイル]/[印刷]) を無効化するには、このチェック ボックスをオンにします。

[ページ上のテキスト選択の無効化] - 保護ページでのテキストの選択を無効化するには、このチェック ボックスをオンにします。これにより、テキストを選択してコピーしたり、再利用することができなくなります。

[ステータス バー テキストの無効化] - ステータス バーのテキストを隠すには、このチェック ボックスをオンにします。これにより、画像やその他の情報の格納先を他のユーザから隠すことができます。

終了 - パスワード保護の完了

上記の 4 つのステップが完了したら、[完了] ボタンをクリックして、ファイルをロックします。ロックされたファイルのリストが表示されます。ファイル名を右クリックすると、ファイルを表示または編集したり、元のファイルに復元したりするためのオプションが表示されます。

公式 Web サイト (英語版)、公式 Web サイト (日本語版)


AHPP - ユーザ リスト

ユーザ リストの作成

AeroTags HTML Password Protector (AHPP) のユニークな機能の 1 つとして、ユーザ名とパスワードのリストの自動生成があります。自動生成の方法は以下のとおりです。

任意のユーザ名 (ログイン名) リストを Windows クリップボードにコピーし [ユーザ名リストをロード] ボックスに貼り付けるか、独自に入力します。次に、[OK] ボタンをクリックすると、各ユーザの一意のパスワードが自動的に生成されます。

また、[ユーザ名リストを生成] オプションを使用することもできます。この場合、指定した数のユーザ名 (ログイン名) が自動的に生成されます。ユーザ名の表示パターンは自由にカスタマイズすることができます。ただし、数字と置き換えるための $$$ マクロは必ず使用する必要があります。


AHPP - テンプレート エディタ

HTML テンプレート エディタ

HTML ページ テンプレート エディタでは、ログイン ページのスタイルをカスタマイズすることができます。テンプレート リストに表示されているテンプレートであれば、既存の HTML コードを自由に編集可能です。編集後 [OK] ボタンをクリックすると、「*** カスタム テンプレート ***」という新しいログイン テンプレートが自動的に作成されます。このスタイルは、保護ページのログイン画面で使用されます。

[プリセット] ボタンをクリックすると、テンプレートの内容を既存の (組み込み) プリセットのいずれかの内容に置き換えるためのウィンドウが表示されます。目的のスタイルのプリセットを選択して、必要に応じて編集することも可能です。

[HTML] ボタンをクリックすると、以下のメニューが表示されます。

[HTML] メニュー このメニューでは、HTML コードを管理 (HTML コードのインポートとエクスポート、新しいテンプレートとしての保存、Web ブラウザでのプレビュー) することができます。

重要: コードには、<AHPP_SCRIPT> タグを必ず含める必要があります (上記のスクリーンショットを参照)。なるべく、<HEAD> セクションに含めることをお勧めします。このタグは、AHPP によって管理され、パスワード保護スキームを利用する JavaScript に置き換えられます。このタグがないと、AHPP が正常に動作せず、エラー メッセージが表示されます。


AHPP - HTML プリセット

組み込みの HTML プリセット

[HTML プリセット] ウィンドウでは、既存のテンプレートのいずれかを選択して、テンプレート編集時のひな形として利用することができます。このウィンドウのリストには、組み込みのテンプレートのほかに、テンプレート エディタで独自に作成したテンプレートも含まれます。

[プレビュー] ボタンをクリックすると、Internet Explorer が起動し、選択したプリセットのスタイルが読み込まれます。プレビューは、ファイルを保護する前に、ログイン ページの表示形式を確認するのに便利です。


AHPP - コマンドライン パラメータ

コマンドライン パラメータ

AHPP には、Windows で操作しなくても、ファイルを保護することができるユニークな機能、つまり "コマンドライン パラメータ" が用意されています。また、使用頻度の高いオプションを自動化することも可能です。コマンドラインを使用すれば、時間を節約することができますが、必ずしも使用する必要はありません。

コマンドラインの使用方法は 3 種類あります。

それぞれの構文は以下のとおりです。

AHPP.EXE filename

AHPP.EXE [--list filename] [--file filename] [--password|--PASSWORD pass] [--random] [--style stylename] [--additional:[M,P,S,B]] [--quiet]

AHPP.EXE [-l filename] [-f filename] [-p|-P pass] [-r] [-s stylename] [-a:[M,P,S,B]] [-q]

1 番目の方法が最も一般的に使用されます。この方法では、保護対象のファイル名をパラメータで指定して AHPP を実行します。このコマンドラインを実行するだけで、ワンクリック保護のウィンドウが自動的に表示されます。

2 番目と 3 番目の方法は、AHPP で使用されるパラメータを設定できます。たとえば、各ページに同じパスワードを使用し、ファイルの種類も同じであれば、その作業を自動化することができます。パラメータの詳細については、以下の表を参照してください。

パラメータ | 説明
--list filename -l filaname | "filename" の部分にファイル名を指定することで、ファイルのリストをキューに読み込みます。[ファイル] メニューの [リストのロード] をクリックした場合と同じ動作をします。
--file filename -f filename | "filename" の部分にファイル名を指定することで、保護対象のファイルをリストに追加します。[追加] ボタンと同じ動作をします。"--file" パラメータは必要な数だけ使用することができます。
--password pass -p pass | "pass" の部分にパスワードを指定することで、パスワード フィールドにそのパスワードを入力します。また、[入力を隠す] チェック ボックスをオフにして、パスワードの入力文字がそのまま表示されるようにします。パスワードを隠すには、"--PASSWORD" パラメータ (すべての大文字) を使用します。
--PASSWORD pass -P pass | "--password" と同じように動作しますが、この場合、[入力を隠す] チェック ボックスをオンにします。つまり、パスワードはアスタリスクで隠されて表示されます。
--random -r | ランダムなパスワードを生成します。[ランダムなパスワードを生成] ボタンと同じ動作をします。
--userlist filename -u filename | ユーザ名とパスワードのリストを読み込んで、複数ユーザ保護モードを設定します。
--style stylename -s stylename | "stylename" にスタイル名を指定することで、ログイン ページのスタイルの決定します。指定したスタイルが存在しないと、何も起こらず、デフォルトのスタイルが適用されます。
--additional:[M,P,S,B] -a:[M,P,S,B] | その他の保護オプションのチェック ボックスをオンにします。 M: [右マウス ボタンおよびポップアップ メニューの無効化] チェック ボックスをオンにします。 P:[ページ印刷の無効化] チェック ボックスをオンにします。 S:[ページ上のテキスト選択の無効化] チェック ボックスをオンにします。 B:[ステータス バー テキストの無効化] チェック ボックスをオンにします。
--quiet -q | すべての必要なパラメータがコマンドラインで指定されていれば、AHPP は即座に保護処理を実行します。このとき、AHPP のウィンドウは表示されません。

例

1. AHPP のワンクリック保護のウィンドウを開きます (単一のファイルを保護する場合、この方法が最も速い)。

AHPP.EXE c:\www\index.html
AHPP.EXE "c:\Documents and Settings\Alisa\My web site\Seek a boy.htm"
2. AHPP を起動し、保護対象のファイルのリストに 3 つのファイルを追加します。
AHPP.EXE --file c:\www\index.html -f "c:\My web files\Test site\exitpage.htm" --file c:\readme.txt
3. AHPP を起動し、ファイル リストを読み込んで、パスワードを設定します。また、ページの印刷とテキストの選択の機能を無効にします。
AHPP.EXE -l c:\www\_spec\flist.txt -P MyPass -a:SP
4. CRAZY! Never use it!AHPP を起動し、ファイル リストを読み込んで、ランダム パスワードを設定し、すべての保護オプションを選択し、警告なしで保護処理を実行します。
AHPP.EXE --list c:\www\_spec\flist.txt --random -a:SPMB --quiet


AHPP - 購入方法

AHPP の購入方法

AeroTags HTML Password Protector (AHPP) ソフトウェアは、試してから購入 (Try Before You Buy) することができるシェアウェアです。あらかじめ設けられた評価期間内であれば、無料でダウンロードして利用することができます。ただし、評価版では一部の機能が無効化されています。評価期間を過ぎて継続して利用する場合は、ソフトウェアを購入して登録する必要があります。登録コードは、購入手続きの完了後、電子メールで受け取ることになります。

登録ユーザの特典

購入方法

AHPP は、以下のシェアエッジの購入フォームからオンラインで購入することができます。

シェアエッジ

その他の方法での購入をご希望の方は、以下のお問い合わせフォームまたは電子メールからご連絡ください。

お問い合わせフォーム: https://www.shareedge.com/modules/contact/

電子メール: contact@nextEDGEtech.com


AHPP - 特典

登録ユーザの特典

ほとんどのユーザにとって、ソフトウェアを登録する一番の理由としては、試用版の機能制限を解除し、購入を促すわずらわしいメッセージをなくすことになるかもしれません。 たとえば、AHPP の評価版では、パスワード保護したすべてのページに小さな広告が挿入されます。また、ソフトウェアを起動するたびに購入を促すメッセージが表示されます。

そのほかにも、ソフトウェアを登録すると、テクニカル サポートを優先的に受けられるようになり、マイナー アップグレードが無料で提供されます。また、各種製品に関する最新ニュースが電子メールで配信されます。

最後に、お客様によるソフトウェアの登録は、ソフトウェアをアップデートしたり、新しい製品を開発したりしていく上での弊社スタッフのやる気と活力の源となります。


AHPP - シリアル キーを紛失した場合

シリアル キーを紛失した場合

万一、AeroTags HTML Password Protector (AHPP) の登録コード (シリアル キー) を紛失した場合、または利用できなくなった場合は、contact@nextEDGEtech.com 宛にご連絡ください。ご連絡の際は、購入時の購入 ID、電子メール アドレスなど、登録内容の詳細を必ずご記載していただきますようお願いいたします。確認が取れ次第、新しい登録コードを無料で発行し、電子メールで送信いたします。

AHPP の購入方法
連絡先


AHPP - 連絡先

連絡先

Web サイト

AHPP の日本語版に関する最新情報および最新バージョンのダウンロードについては、シェアエッジの Web サイト (www.shareEDGE.com) を参照してください。シェアエッジでは、開発元のアップデートに応じて、できる限り迅速に日本語版対応できるよう努めております。

電子メール

電子メールによるご連絡の際は、contact@nextEDGEtech.com をご利用ください。どのようなご質問にも 3 営業日以内にご回答いたします。

電話
原則として、電話によるサポートは行っておりません。

電子メールまたはシェアエッジのオンラインお問い合わせフォーム (https://www.shareedge.com/modules/contact/) をご利用いただきますようご協力お願いいたします。

ほかにも、メーリング リストや検索可能な知識ベースをご利用いただくことも可能ですが、この場合は英語での情報になります。メーリング リストまたは知識ベースの検索については、http://www.aerotags.com (英語) を参照してください。


AHPP - テクニカル サポート

テクニカル サポート

AeroTags HTML Password Protector (AHPP) の登録ユーザは、電子メールによるテクニカル サポートを無料で受けることができます。お気軽に contact@nextEDGEtech.com 宛にお問い合わせください。どのようなご質問にも 3 営業日以内にご回答いたします。

登録を済ませていない方の質問についても、こころよく対応しております。ただし、その場合、登録ユーザの方が優先となりますので、ご回答が若干遅れますことご了承ください。


AHPP - アップグレード

AHPP のアップグレード

AeroTags HTML Password Protector (AHPP) の登録ユーザは、ソフトウェアを最新バージョンに無料でアップグレードすることができます。最新バージョンをダウンロードしてコンピュータにインストールするだけです。古いバージョンをアンインストールする必要はありません。なお、登録コードはアップグレードを行っても維持されます。

AHPP の最新ファイル (EXE-file) のダウンロード
公式 Web サイト (英語版)、公式 Web サイト (日本語版)
万一、登録コードを紛失した場合、または利用できなくなった場合は、contact@nextEDGEtech.com 宛にご連絡ください。新しい登録コードを無料で発行し、電子メールで送信いたします。ご連絡の際は、購入時の購入 ID、電子メール アドレスなど、登録内容の詳細を必ずご記載していただきますようお願いいたします。


AHPP - その他の製品

AeroTags Software 社のその他の製品

AeroTags Software 社は、Web サイトの保護、向上、また HTML コードのセキュリティ強化を目的とした Web マスタ向けのさまざまなソフトウェアを提供しています。製品ラインアップは、AeroTags Software 社の Web サイト (www.aerotags.com) からご確認いただけます。すべての製品に評価版が用意されていますので、お気軽にお試しください。
AeroTags TagsLock Pro - Web サイトの情報の盗用を防止し、メール アドレス収集ソフトウェアによるアドレス収集をブロックできる Web マスタ向けのユーティリティです。出力 HTML ファイルをカスタマイズするためのオプションが多数備わっています。AHPP と一緒に使用することを強く推奨しています。

AeroTags Html2Zip - WinZip と同じような機能が備わっており、HTML ファイルを 90% 以上の圧縮率で ZIP アーカイブに圧縮することができます。ディスク スペースの節約はもちろん、Web ページの読み込みが格段に速くなるなど処理能力の向上を図ることが可能です。

AHPP のアップグレード
AHPP の基本操作
連絡先