はじめに

今日のコンピュータ社会を取り巻く環境はめまぐるしく変化し続けています。特に、インターネットを介したウィルスやその他の悪質なソフトウェアの脅威は著しく増大しています。たとえば、電子メールは今日のビジネスにおいて欠くことのできないツールとなりましたが、電子メールを使用することでコンピュータは無限の脅威にさらされていることになります。

電子メールを利用したウィルス攻撃やハッキング行為は氷山の一角に過ぎません。サンフランシスコの Computer Security Institute (CSI) は、ネットワークの悪用の 60～80% が企業ネットワーク内部から発生していると予測しています。コンピュータのセキュリティ強化はロックやパスワードだけでは十分でありません。本当に安全な環境というのは常に変化しており、定期的なケアや監視が必要になります。


ShareAlarmPro について

ShareAlarmPro は、ネットワーク管理者やネットワーク ユーザが共有フォルダ/リソースを簡単に監視できるようにするネットワーク ツールです。ShareAlarmPro を使用すると、セキュリティ保護された共有や機密ファイルにアクセスを試みているユーザの監視、共有フォルダへのネットワークからのアクセスの検出とログ記録、セキュリティ イベントの監視、コンピュータで特定のイベントが発生した場合のアラーム表示、開かれているファイルの監視、ファイルを開いているユーザとの接続の切断、ネットワーク ユーザのアクセスの拒否、コンソール メッセージの送信、選択したフォルダ内の変更の追跡とログ記録、といったことが可能になります。ShareAlarmPro では、共有フォルダ/リソースへのリモート接続が検出されると、その旨が通知されます。また、共有フォルダ/リソースにアクセスしているリモート ユーザのワークステーション名、ユーザ名、パス、OS、アクセス許可、および接続確立時間の情報が表示されます。必要であれば、新しい接続が検出されたときにアラーム音を鳴らしたり、特定の音声ファイルを再生したりすることもできます。ShareAlarmPro には、セキュリティ イベント ログの分析に基づいた侵入者検知システムが含まれています。セキュリティ イベント ログの監視機能では、Windows 2000/XP/2003 サーバまたはワークステーションのセキュリティ イベント ログを監視して、特定のイベントが発生した場合にそのイベントの詳細を示したポップアップ ウィンドウが表示されるようにすることができます。また、LAN 上のコンピュータを簡単に参照したり、すべての共有リソースを標準共有または隠し共有にかかわらず表示したり、リモート ワークステーション上の共有リソースへの接続を表示したりすることもできます。ShareAlarmPro には、共有リソースへの不正な接続をブロックするファイアウォール制御機構が含まれています。また、検出されたすべてのイベント (共有フォルダへのアクセス、セキュリティ イベント) は HTML 形式のログに記録されるようになっています。他にも、ワークステーション上のすべての共有を管理・監視したり、コンピュータのデフォルト共有を無効化/有効化したり、ワークステーションをネットワークから隠したり、ワークステーション上の各共有リソースに現在接続しているユーザの数を表示したりする機能も備わっています。


主な機能

§ セキュリティ イベント分析に基づいた侵入者検出システム

ShareAlarmPro には、セキュリティ イベント ログの分析に基づいた侵入者検知システムが含まれています。

§ 共有リソースの監視

ShareAlarmPro では、共有リソースへのリモート接続が検出されると、その旨が通知されます。また、共有リソースにアクセスしているリモート ユーザのワークステーション名、ユーザ名、パス、OS、アクセス許可、および接続確立時間の情報が表示されます。

§ ファイアウォール制御

ShareAlarmPro には、既知および未知のインターネット脅威を防御し、不正な接続をブロックするファイアウォール制御機構が含まれています (ホーム ユーザおよびスモール ビジネス ユーザ向け)。

§ セキュリティ イベント ログの監視

セキュリティ イベント ログの監視機能によって、Windows NT/2000/XP サーバまたはワークステーションのセキュリティ イベント ログが監視され、疑わしい侵入や攻撃が検出されると通知されます。

§ ネットワーク リソースの監視

ネットワーク リソースの監視機能によって、ネットワーク コンピュータの共有および隠し共有に関する詳細情報が表示されます。ネットワーク コンピュータへのアクセスには、ユーザが指定したユーザ名とパスワードが使用されます。

§ フォルダ内の変更のログ記録

フォルダの監視機能によって、選択したフォルダ内の変更が追跡され、そのログが記録されます。


操作方法

ShareAlarmPro は、自分のコンピュータへのネットワークからの接続を監視したり、セキュリティ イベントを検出したりするためのアプリケーションです。ユーザ インターフェイスはシンプルで使いやすく設計されています。簡単な設定だけで、コンピュータへのアクセスやセキュリティ イベントを検出するたびに通知されるようになるため、不正なアクセスからコンピュータを保護することができます。

セッション

[セッション] タブをクリックすると、ShareAlarmPro のメイン ウィンドウのリストがセッション リストに切り替わります。セッション リストには、その時点で共有リソースに接続しているすべてのアクティブなセッションが表示されます。このリストでは、自分のワークステーションに接続しているリモート ユーザのワークステーション名、ユーザ名、アクセス パス、OS の種類、アクセス許可、および接続確立時間を確認することができます。自分のワークステーションへのリモートからの接続が検出されるたびに、その接続に関する情報がリストに追加されていきます。また、リモートから新しい接続が確立されると、リモート ワークステーションの名前を示したバルーン チップが表示され、システム トレイの ShareAlarmPro アイコンが点滅します。[ 設定] ダイアログ ボックスでサウンド通知を有効にしている場合は、アラーム音でも通知されます。

リストを右クリックすると、ポップアップ メニューが表示されます。このポップアップ メニューでは、選択した接続を閉じたり ([接続を閉じる])、リモート ワークステーション/ユーザをブラック リストに追加したり ([ホストをブロック]/[ユーザをブロック]) することができます。[ブラック リストの表示/編集] をクリックすると、ブラック リストを管理するための小さなダイアログ ボックスが表示されます。なお、ブラック リストに登録したワークステーション/ユーザからは自分のコンピュータにいっさい接続できなくなります。また、選択したホストにメッセージを送信することもできます ([メッセージ送信])。

共有

[共有] タブをクリックすると、ShareAlarmPro のメイン ウィンドウのリストが共有リストに切り替わります。共有リストには、その時点のコンピュータ上のすべての共有リソースが表示されます。

このリストでは、共有名、現在ネットワークから共有リソースに接続しているユーザの数、および共有リソースのパスを確認することができます。

リストを右クリックすると、ポップアップ メニューが表示されます。このポップアップ メニューでは、リソースの共有を停止したり ([共有停止])、共有フォルダを開いたり ([フォルダを開く])、フォルダのプロパティを表示したり ([プロパティ]) することができます。

イベント

[イベント] タブをクリックすると、ShareAlarmPro のメイン ウィンドウのリストがイベント リストに切り替わります。イベント リストには、検出されたすべてのセキュリティ イベントが表示されます。検出対象に含めるイベントの種類は、[ 設定] ダイアログ ボックスで指定することができます。このリストでは、検出されたイベントの種類、検出時間、および詳細を確認することができます。なお、イベントの詳細は長すぎてウィンドウに収まりきらない場合があります。この場合、リストを右クリックして、ポップアップ メニューで [詳細を見る] をクリックすると、すべての説明を見ることができます。また、同じポップアップ メニューからは、イベント リストをクリアしたり ([すべて消去])、ログを表示したり ([ログを見る]) することもできます。

近くのコンピュータを参照

[近くのコンピュータを参照] タブをクリックすると、ShareAlarmPro のメイン ウィンドウのリストが近くのコンピュータのリストに切り替わります。このリストでは、ツリーから目的のコンピュータを選択したり、ホスト名を入力して [GO!] をクリックするだけで、対応する情報をすぐに確認することができます。リモート ホストにアクセスする際は、[ 設定] ダイアログ ボックスで設定したログイン ユーザ名とパスワードが使用されます。 そのログイン ユーザ名とパスワードのユーザに選択したリモート ホストでの管理者権限がない場合は、共有と接続に関する情報は不完全になります。

フォルダ監視

[フォルダ監視] タブをクリックすると、ShareAlarmPro のメイン ウィンドウのリストが監視フォルダのリストに切り替わります。このリストでは、フォルダを監視対象として追加したり、監視中のフォルダを削除したりすることができます。このリストに追加したフォルダ内の変更は追跡され、ログに記録されます。追跡する変更の種類は、[設定] ダイアログ ボックスで指定することができます。

セッション ログを表示

[セッション ログを表示] ボタンをクリックすると、セッション ログがデフォルトの Web ブラウザで表示されます。

イベント ログを表示

[イベント ログを表示] ボタンをクリックすると、イベント ログがデフォルトの Web ブラウザで表示されます。

フォルダ監視のログを表示

[フォルダ監視のログを表示] ボタンをクリックすると、フォルダ監視のログがデフォルトの Web ブラウザで表示されます。

ShareAlarmPro では、共有への接続、およびセキュリティ イベントに関するすべての情報が HTML 形式のログとして保存されるようになっています。ログ ファイルは一定サイズに達すると上書きされます。なお、ログ ファイルのサイズは、[ 設定] ダイアログ ボックスで指定することができます。


ShareAlarmPro の設定

ShareAlarmPro の [設定] ダイアログ ボックスは以下のタブで構成されています。

1. 一般

2. 対処

3. 近くのコンピュータを参照

4. イベント

5. フォルダ監視

[一般] タブ

[一般] タブでは、ShareAlarmPro の主な動作を設定することができます。以下のオプションが用意されています。

システム起動時に開始 – このチェック ボックスをオンにすると、Windows の起動時に ShareAlarmPro が自動的に開始されるようになります。チェック ボックスをオフにした場合は、手動で開始する必要があります。

開始時にトレイに最小化 – このチェック ボックスをオンにすると、ShareAlarmPro は開始時にシステム トレイに最小化されるようになります。

デフォルト共有を無効化 – Windows W2K/XP/2003 コンピュータでは、システム上の各ドライブに対し自動的に共有が作成されるようになっています。これらの共有は目に見えませんが、ドメイン管理者からは完全に制御することが可能です。高レベルなネットワーク セキュリティを実現しようとするのであれば、これらのデフォルト共有を無効にすることが賢明です。共有フォルダから共有を単に削除することは簡単ですが、その場合、コンピュータを再起動したときに、削除したはずの共有が自動的に回復されてしまいます。このチェック ボックスをオンにすると、これらのデフォルト共有を恒久的に無効にすることができます。

ホストをネットワークから隠す – このチェック ボックスをオンにすると、自分のコンピュータがネットワークを参照している他のユーザから見えなくなるため、ワークステーションのセキュリティ レベルを向上させることができます。

空のアクセス パスの接続を表示 – このチェック ボックスをオンにすると、ネットワークへのログインには成功したにもかかわらず、共有リソースにはアクセスしていないセッションがセッション リストに表示されるようになります。チェック ボックスをオフにした場合は、共有リソースにアクセスしたセッションのみが表示されます。

セッション ログ サイズ – セッションのログ ファイルのサイズを設定することができます。

イベント ログ サイズ – イベントのログ ファイルのサイズを設定することができます。

フォルダ監視ログ サイズ – フォルダ監視のログ ファイルのサイズを設定することができます。

[対処] タブ

[対処] タブでは、アクセス検出時の通知方法を設定することができます。

サウンド通知を有効化 – このチェック ボックスをオンにすると、アクセス検出時に音で通知されるようになります。単にシンプルなアラーム音を鳴らすことも、任意の音声ファイルを再生することも可能です。

接続ユーザにメッセージを送信 – このチェック ボックスをオンにすると、自分のコンピュータにアクセスしてきた他のユーザにメッセージが送信されるようになります。

[近くのコンピュータを参照] タブ

[近くのコンピュータを参照] タブの設定は、[近くのコンピュータを参照] ツールで使用されます。

このタブでは、ネットワークの参照時に使用する認証タイプを指定することができます。[現在のログイン/パスワードを使用] オプションを選択すると、現在システムにログインしているユーザのログイン ユーザ名とパスワードが使用されます。[以下の情報を使用] オプションを選択すると、使用するログイン ユーザ名とパスワードを入力することができます。

[イベント] タブ

[イベント] タブでは、監視するセキュリティ イベントを指定することができます。

[イベントを検出したらポップアップを表示] チェック ボックスをオンにすると、指定したイベントを検出するたびに、そのイベントの詳細を示したポップアップ ウィンドウが表示されるようになります。チェック ボックスをオフにした場合は、イベントの情報はイベント リストに記録されるだけになります。

[フォルダ監視] タブ

[フォルダ監視] タブでは、フォルダ監視機能によって追跡する変更の種類を指定することができます。


将来のバージョン

ShareAlarmPro の将来のバージョンでは、システムの整合性の監視機能、レジストリが変更されたときのアラーム機能、より高度なファイアウォール制御機構、およびウィルスやトロイの木馬の検出機能も実装される予定です。


ShareAlarmPro の登録

オンライン購入

ShareAlarmPro は、試してから購入 (Try Before You Buy) することができるシェアウェアです。あらかじめ設けられた評価期間内であれば、無料でダウンロードして利用することができます。評価期間後も継続して製品を利用する場合は、ライセンスを購入して登録する必要があります。ShareAlarmPro のライセンスは、シェアエッジの Web サイトからオンラインで購入することができます。 クレジット カードまたは銀行振込での購入が可能です。購入情報は暗号化通信により高度なセキュリティで保護されますので、第三者によって傍受されることはありません。 購入手続きが完了すると、製品を登録するための登録コードが電子メールで送信されます。

2047 円 (税込み価格)

今すぐ購入

登録コードの入力方法

登録コードを入力するには、ShareAlarmPro のメイン ウィンドウで [登録] メニューの [登録コード入力] をクリックするか、[ShareAlarmPro バージョン情報] ダイアログ ボックス ([ヘルプ] -> [ShareAlarmPro バージョン情報]) で [キー入力] をクリックします。[Enter Key (キー入力)] ダイアログ ボックスが表示されたら、ライセンス購入時の名前と登録コードを正確に入力し、[OK] をクリックします。これで登録は完了です。


使用許諾契約書

重要 - 以下の契約書を注意してお読みください。
本使用許諾契約書 (以下「本契約書」といいます) は、ShareAlarmPro およびその関連資料 (以下「本ソフトウェア」) に関してお客様と Nsasoft llc. (以下「Nsasoft」といいます) との間で締結される法的な契約書です。本ソフトウェアをインストールおよび使用することによって、お客様は本契約書の条項に拘束されることに同意されたものとします。同意されない場合は、本ソフトウェアのご使用をお控えください。

1. 使用許諾
お客様が本契約書のすべての条項を厳守される場合に限り、Nsasoft はお客様に対し、(a) 本ソフトウェアを 1 台のコンピュータにインストールして使用すること、および (b) 保管用として本ソフトウェアの複製を 1 部作成することを許諾します。

2. 制限
お客様は、本契約書で明示的に規定されている場合を除き、(a) 本ソフトウェアをレンタル、リース、貸与、サブライセンス、譲渡、またはその他の方法で再頒布すること、(b) 本ソフトウェアをリバース エンジニアリング、逆コンパイル、または逆アセンブルすること、(c) 本ソフトウェアを改変すること、および (d) 本ソフトウェアを必要以上に複製することは禁止されています。

3. 権利の留保
Nsasoft は、お客様に対して明示的に許諾していない権利をすべて留保します。Nsasoft は本ソフトウェアに関するすべての権利 (著作権を含みます) を保有しています。本ソフトウェアは許諾されるもので、販売されるものではありません。

4. 契約の終了
お客様が本契約書の条項に違反した場合、Nsasoft は、他の権利を害することなく本契約を終了することができます。

5. 免責
Nsasoft は、本ソフトウェアを何等保証もない現状有姿のまま瑕疵を問わない条件で提供しています。そのため、Nsasoft は、本ソフトウェアに関するいかなる保証 (商品性、特定の目的に対する適合性、信頼性または可用性、応答の的確性、使用結果、職人的努力、および過失の不存在についての保証、義務または条件を含みますがこれらに限定されません) も、明示、黙示、もしくは法律上のものであるかを問わず一切いたしません。本ソフトウェアの使用もしくは機能から生じるすべての危険は、お客様が負担しなければなりません。

6. その他の損害に関する免責
法律上許容される最大限において、Nsasoft およびその供給者は、本ソフトウェアの使用もしくは使用不能から生じる直接損害、間接損害、特別損害、付随的損害、懲罰的損害、または派生的損害 (逸失利益、機密情報もしくはその他の情報の喪失、事業の中断、設備の損傷、プライバシーの喪失、またはその他の金銭的損失を含みますがこれらに限定されません) に関して、たとえ、Nsasoft がこのような損害の可能性について示唆していた場合であっても、一切責任を負いません。

7. 責任および救済手段の制限
いかなる理由において生じる損害 (すべての直接損害または間接損害を含みますがこれらに限定されません) にもかかわらず、本契約書に基づく Nsasoft の責任およびお客様に対する唯一の救済手段は、合理的な信頼に基づくお客様の実際の損害額 (本ソフトウェアについてお客様が実際に支払った金額を上限とします) を限度とします。

8. 準拠法
本契約書は、日本国法に準拠するものとします。ただし、本ソフトウェアを日本以外で入手された場合は、各国・各地域の法律に準拠するものとします。

9. 完全合意、分離可能性
本契約書は、本ソフトウェアに関するお客様と Nsasoft との間の完全なる合意であり、本ソフトウェアに関する、以前のすべての口頭または書面 (オンラインでの書面または電子メールでの書面も含みます) による意思表示、提案、表明よりも優先して適用されます。Nsasoft のポリシーまたは声明の条項が本契約書の条項と異なる場合は、本契約書の条項が適用されます。本契約書の一部の条項が無効となったり、法的な強制力を失ったり、あるいは非合法と判断された場合でも、その他の条項には影響を与えることなく完全に有効性が保たれるものとします。

----------- 以下、英文 -----------

1.GRANT OF LICENSE. Nsasoft grants you the following rights provided that you comply with all terms and conditions of this EULA: You may install and use a reasonable number of copies of the Software on computers running Microsoft Windows 2000, Microsoft Windows XP or Microsoft Windows Server 2003.

2.RESERVATION OF RIGHTS AND OWNERSHIP. Nsasoft reserves all rights not expressly granted to you in this EULA. The Software is protected by copyright and other intellectual property laws and treaties. Nsasoft or its suppliers own the title, copyright and all intellectual property rights in and to the Software. The Software is licensed, not sold.

3.LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY. You may not reverse engineer, decompile, or disassemble the Software, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

4.NO RESALE, RENTAL, OR COMMERCIAL HOSTING. You may not sell, rent, lease, sublicense, assign, lend, or otherwise transfer any portion of the Software, or provide commercial hosting services with the Software.

5.LINKS TO THIRD PARTY SITES. You may link to third party sites through the use of the Software. The third party sites are not under the control of Nsasoft, and Nsasoft is not responsible for the contents of any third party sites, any links contained in third party sites, or any changes or updates to third party sites. Nsasoft is not responsible for webcasting or any other form of transmission received from any third party sites. If applicable, Nsasoft is providing these links to third party sites to you only as a convenience, and the inclusion of any link does not imply an endorsement by Nsasoft of the third party site.

6.NO SUPPORT. Nsasoft is not obligated to provide any maintenance or technical support services to you, in any form whatsoever, in connection with the Software.

7.ADDITIONAL SOFTWARE/SERVICES. Nsasoft is not obligated to provide updates to you in connection with the Software. However, if Nsasoft chooses to do so, this EULA applies to updates, supplements, add-on components, or Internet-based services components, of the Software that Nsasoft may provide to you or make available to you after the date you obtain your initial copy of the Software, unless Nsasoft provides other terms along with the update, supplement, add-on component, or Internet-based services component. Nsasoft reserves the right to discontinue any services provided to you or made available to you through the use of the Software.

8.TERMINATION. Without prejudice to any other rights, Nsasoft may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the Software, including all of its component parts.

9.DISCLAIMER OF WARRANTIES. To the maximum extent permitted by applicable law, Nsasoft and its suppliers provide the Software (if any) AS IS AND WITH ALL FAULTS, and hereby disclaim all other warranties and conditions, whether express, implied or statutory, including, but not limited to, any (if any) implied warranties, duties or conditions of merchantability, of fitness for a particular purpose, of reliability or availability, of accuracy or completeness of responses, of results, of workmanlike effort, of lack of viruses, and of lack of negligence, all with regard to the Software, and the provision of or failure to provide support or other services, information, software, and related content through the Software or otherwise arising out of the use of the Software. ALSO, THERE IS NO WARRANTY OR CONDITION OF TITLE, QUIET ENJOYMENT, QUIET POSSESSION, CORRESPONDENCE TO DESCRIPTION OR NON-INFRINGEMENT WITH REGARD TO THE SOFTWARE.

10.EXCLUSION OF INCIDENTAL, CONSEQUENTIAL AND CERTAIN OTHER DAMAGES. To the maximum extent permitted by applicable law, in no event shall Nsasoft or its suppliers be liable for any special, incidental, punitive, indirect, or consequential damages whatsoever (including, but not limited to, damages for loss of profits or confidential or other information, for business interruption, for personal injury, for loss of privacy, for failure to meet any duty including of good faith or of reasonable care, for negligence, and for any other pecuniary or other loss whatsoever) arising out of or in any way related to the use of or inability to use the SOFTWARE, the provision of or failure to provide Support OR OTHER Services, information, software, and related CONTENT through the software or otherwise arising out of the use of the software, or otherwise under or in connection with any provision of this EULA, even in the event of the fault, tort (including negligence), misrepresentation, strict liability, breach of contract or breach of warranty of Nsasoft or any supplier, and even if Nsasoft or any supplier has been advised of the possibility of such damages.

11.LIMITATION OF LIABILITY AND REMEDIES. NOTWITHSTANDING ANY DAMAGES THAT YOU MIGHT INCUR FOR ANY REASON WHATSOEVER (INCLUDING, WITHOUT LIMITATION, ALL DAMAGES REFERENCED HEREIN AND ALL DIRECT OR GENERAL DAMAGES IN CONTRACT OR ANYTHING ELSE), THE ENTIRE LIABILITY OF NSASOFT AND ANY OF ITS SUPPLIERS UNDER ANY PROVISION OF THIS EULA AND YOUR EXCLUSIVE REMEDY HEREUNDER (EXCEPT FOR ANY REMEDY OF REPAIR OR REPLACEMENT ELECTED BY NSASOFT WITH RESPECT TO ANY BREACH OF THE LIMITED WARRANTY) SHALL BE LIMITED TO THE GREATER OF THE ACTUAL DAMAGES YOU INCUR IN REASONABLE RELIANCE ON THE SOFTWARE UP TO THE AMOUNT ACTUALLY PAID BY YOU FOR THE SOFTWARE OR US$1.00. THE LIMITATIONS, EXCLUSIONS AND DISCLAIMERS SHALL APPLY TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, EVEN IF ANY REMEDY FAILS ITS ESSENTIAL PURPOSE.

12.ENTIRE AGREEMENT; SEVERABILITY. This EULA is the entire agreement between you and Nsasoft relating to the Software and supersedes all prior or contemporaneous oral or written communications, proposals and representations with respect to the Software or any other subject matter covered by this EULA. To the extent the terms of any Nsasoft policies or programs for support services conflict with the terms of this EULA, the terms of this EULA shall control. If any provision of this EULA is held to be void, invalid, unenforceable or illegal, the other provisions shall continue in full force and effect.