著作権情報

本ドキュメントのいかなる部分も、FarStone Technology, Inc の書面による許諾を受けることなく、その目的を問わず、どのような形態であっても、複製、譲渡、検索システムへの格納、および他言語への翻訳を行うことは禁止されています。

FarStone は、お客様に対し、HackerSmacker ソフトウェア (以下、「本ソフトウェア」) の 1 部のコピーを 1 台のコンピュータで使用することを許諾します。本ソフトウェアをネットワーク上にインストールしたり、同時に複数のユーザで使用する場合は、各ユーザまたは各コンピュータごとに追加のライセンスを購入する必要があります。

商標

FarStone™ および HackerSmacker™ は FarStone Technology, Inc. の商標です。Microsoft®、Windows®、および MS-DOS® は Microsoft Corporation の登録商標です。本ドキュメントに記載のその他の製品名は、各社の商標または登録商標である可能性があります。

FarStone Technology, Inc.

U.S. 本社

15 Hammond Dr., Suite 304

Irvine, CA 92618

電話番号: (949) 458-3666

テクニカル サポート

本ソフトウェアのテクニカル サポートおよび製品アップグレードのお問い合わせについては、FarStone Web サイト (www.farstone.com) のオンライン フォームからご連絡ください。なお、本ソフトウェアの日本語版のテクニカル サポートは、株式会社ネクステッジ テクノロジー (contact@nextEDGEtech.com) によって提供されています。参考のため、本ドキュメントの「よくある質問 (FAQ)」のほかにも、FarStone Web サイトに最新の FAQ 集 (http://www.farstone.com/home/ensite/support/faqfw.shtml) が用意されています。テクニカル サポートへのお問い合わせの前に、これらの情報をご確認ください。

Copyright© 2002-2005 FarStone Technology, Inc. All rights reserved.
Japanese Localization by nextEDGE Technology, Inc.

© 2003-2005 FarStone Technology, Inc. All rights reserved.


HackerSmacker 製品紹介

  • HackerSmacker はなぜ必要か?

一般的に、ファイアウォールを設定していない状態では、コンピュータへの入口をハッカーに開放しているようなものです。つまり、パスワード、オンライン ショッピング時に入力したクレジット カード番号、第三者には見られたくないドキュメントなど、あらゆる個人情報がハッカーに盗まれる可能性があります。このような状態では、ダイヤルアップ、ブロードバンド、または DSL 接続にかかわらず、コンピュータをインターネットに接続するたびにリスクが伴うことになります。

  • なぜアンチウィルス ソフトウェアだけでは十分でないのか?

多くの人々が、コンピュータに付属のアンチウィルス ソフトウェアがコンピュータをハッカーから完全に保護してくれるものと誤解しています。アンチウィルス ソフトウェアでは、ハッカーからの直接的な攻撃からコンピュータを保護することはできません。

  • HackerSmacker はどのように動作するのか?

HackerSmacker は、データの盗用者やハッカーからコンピュータを保護するための包括的なセキュリティ ソリューションを提供します。HackerSmacker では、あらかじめ定義されたセキュリティ ルールに基づいて、ネットワークからのコンピュータへの不正アクセスを完全に遮断することができます。また、ネットワーク アクティビティを監視・制御したり、ログに記録したりすることもできます。


主な機能と利点

リアルタイム ネットワーク保護のためのソリューション

  • リアルタイム ポート サービス管理
  • ハッカー、トロイの木馬、ワームをブロック可能
  • 侵入者から見つからないようにインターネットからコンピュータを隠蔽可能
  • 許可したアプリケーションだけがインターネットに接続可能
  • 共有フォルダ/ファイルにアクセスしているユーザを監視可能
  • 侵入者の所在を追跡可能
  • インターネット アプリケーションのネットワーク アクティビティを監視可能

安全なインターネット サーフィンのためのソリューション

  • リアルタイム Web コンテンツ フィルタリング
  • リアルタイム URL フィルタリング

システムのクリーンアップのためのソリューション

  • Windows スタートアップ プログラムを編集可能
  • プライバシ情報 (一時フォルダ、IE 履歴など) を簡単に消去可能


HackerSmacker のインストール

HackerSmacker をインストールするには

1. ダウンロード ファイルに含まれる Setup.exe ファイルをダブルクリックして実行します。

2. 使用許諾契約書を読み、同意する場合は、[使用許諾契約の条項に同意します] を選択して、[次へ] をクリックします。

3. シリアル番号を入力して、[次へ] をクリックします。

4. HackerSmacker のインストール先フォルダを指定します。デフォルトで設定されているフォルダをそのまま使用することも、別のフォルダを指定することもできます。

5. [インストール] をクリックして、インストールを開始します。コンピュータの性能によっては、インストール処理に数分かかることもあります。

6. インストールが完了したら、[完了] をクリックして、インストール ウィザードを閉じます。コンピュータをすぐに再起動する場合は [はい]、後で手動で再起動する場合は [いいえ] をクリックします。コンピュータを再起動するまでは、HackerSmacker を使用することはできません。


システム要件

  • オペレーティング システム:Microsoft® Windows® 2000/XP
  • CPU:Intel Pentium 3/Celeron、AMD K6/Athlon/Duron、または互換プロセッサ
  • RAM:32MB RAM 以上 (Windows® 2000 の場合)、128MB RAM 以上 (Windows XP の場合)
  • ハード ディスク空き容量:50 MB
  • ディスプレイ アダプタ:Super VGA (800 X 600) 以上
  • Windows Internet Explorer 5.5 以上


HackerSmacker の製品登録

HackerSmacker の製品登録を行うには

1. メイン ウィンドウの左上のアイコンをクリックして、バージョン情報ページに切り替えます。

2. [登録] をクリックします。FarStone Web サイトの製品登録ページが表示されたら、画面上の指示に従って登録処理を進めてください。


HackerSmacker のアンインストール

HackerSmacker をアンインストールするには

[スタート] メニューから [すべてのプログラム]、[HackerSmacker]、[HackerSmacker 3.0 アンインストール] の順にクリックして、アンインストール ウィザードの指示に従って操作します。

メモ: HackerSmacker を実行中の場合、アンインストール ウィザードによって強制的に終了させられます。HackerSmacker をロックしている場合、パスワードを入力してロックを解除しない限り、アンインストールを開始することはできません。


HackerSmacker の実行

HackerSmacker のインストールが完了した時点では、プログラムによって自動的にコンピュータが保護されるように設定されています。そのため、自動実行機能を無効にしていない限り、コンピュータを起動するたびにプログラムを実行する必要はありません。

HackerSmacker を実行するには

l デスクトップの HackerSmacker ショートカットをダブルクリックします。

l [スタート] メニューから [すべてのプログラム]、[HackerSmacker 3.0]、[HackerSmacker3.0] の順にクリックします。

関連トピック

  • HackerSmacker のメイン ウィンドウ


HackerSmacker の自動実行機能の有効化/無効化

自動実行機能の設定を変更するには、以下の手順に従います。

  1. HackerSmacker メイン ウィンドウの左側のツールバーで [概要] ボタンをクリックします。

  2. 右側のオプション パネルで [設定] タブに切り替えます。

  3. 自動実行機能を有効にするには、[Windows スタートアップ時に HackerSmacker を起動] チェック ボックスをオンにします。 自動実行機能を無効にするには、このチェック ボックスをオフにします。


HackerSmacker トレイ アイコン

HackerSmacker を起動すると、Windows のシステム トレイに [image] アイコンが表示されます。このアイコンは、HackerSmacker の現在のモードに応じて変化します。 各モードの詳細については、以下の表を参照してください。

HackerSmaker は正常に動作しています。

HackerSmaker は一時的に無効化されています。

HackerSmaker はネットワーク接続をブロックしています。

システム トレイのアイコンを右クリックすると、ファイアウォールの有効化/無効化を切り替えたり、ネットワーク トラフィックをブロックしたりするためのオプションが表示されます。

  • HackerSmacker を開く:HackerSmacker が最小化されている場合にメイン ウィンドウを表示します。
  • ファイアウォールの有効化/ファイアウォールの無効化:HackerSmacker を一時的に有効または無効にします。
  • すべてのトラフィックをブロック:コンピュータのネットワーク接続を切断します。
  • バージョン情報:HackerSmacker のバージョン情報を表示します。
  • 終了:HackerSmacker を終了します。

関連トピック

  • ショートカット


警告ポップアップへの応答

HackerSmacker では、以下の 2 種類の警告ポップアップが表示されるようになっています。

アプリケーションがインターネットにアクセスを試みた場合の警告

1 つ目のポップアップは、インターネット アプリケーションに関する警告です。

この警告ポップアップは、以下のいずれかの場合に表示されます。

  • インターネット アプリケーションが初めてインターネットにアクセスを試みた場合
  • インターネット アプリケーションのアクセス ルールを "問い合わせる" に設定している場合 (詳細については、「アプリケーション ルールのカスタマイズ」を参照)

インターネットにアクセスを試みているアプリケーションに関する情報を注意部深く読み、許可するかブロックするかを決定してください。

特定のアプリケーションを信頼し、永久的にアクセスを許可する場合は、[選択を記憶し、次回問い合わせしない] チェック ボックスをオンにして、[許可] をクリックします。

イベント発生時の警告

[概要] オプション パネルの [設定] タブで [何かリスクを検出したら知らせる] チェック ボックスをオンにしている場合、HackerSmacker ファイアウォールでコンピュータへの疑わしいアクセスが検出されると警告が表示されます。

警告の内容を注意深く読み、脅威レベルやリスクを把握したら、対処方法を決定してください。

関連トピック

  • アプリケーション ルールのカスタマイズ


HackerSmacker のメイン ウィンドウ

HackerSmacker のメイン ウィンドウには、以下のインターフェイスが用意されています。

  • ツールバー:メイン ウィンドウの左側のツールバーには、[概要]、[ファイアウォール]、[SafeSurf]、[ファイル共有]、[マイツールボックス] の 5 つのボタンが配置されています。
  • オプション パネル :右側のオプション パネルには、ツールバーの各ボタンに対応したオプションが表示されます。 HackerSmacker のすべての設定はこのオプション パネルで行うことができます。
  • ショートカット:ショートカットを使用すると、ファイアウォールの有効化/無効化をすばやく切り替えたり、オプションの設定をロック/アンロックすることができます。
  • ネットワーク トラフィック ウィンドウ:コンピュータのネットワーク データフローを示すグラフが表示されます。
  • バージョン情報:FarStone および HackerSmacker に関する情報が表示されます。

関連トピック

  • HackerSmacker の実行


ツールバー

HackerSmacker のメイン ウィンドウの左側には、以下のツールバーが用意されています。

[概要] ボタンをクリックすると、対応するオプションが右側のオプション パネルに表示されます。詳細については、「オプション パネル - 概要」を参照してください。

[ファイアウォール] ボタンをクリックすると、対応するオプションが右側のオプション パネルに表示されます。詳細については、「オプション パネル - ファイアウォール」を参照してください。

[SafeSurf] ボタンをクリックすると、対応するオプションが右側のオプション パネルに表示されます。詳細については、「オプション パネル - SafeSurf」を参照してください。

[ファイル共有] ボタンをクリックすると、対応するオプションが右側のオプション パネルに表示されます。詳細については、「オプション パネル - ファイル共有」を参照してください。

[マイツールボックス] ボタンをクリックすると、対応するオプションが右側のオプション パネルに表示されます。詳細については、「オプション パネル - マイツールボックス」を参照してください。

関連トピック

  • HackerSmacker のメイン ウィンドウ


オプション パネル

メイン ウィンドウのツールバー ボタンをクリックすると、各ボタンに対応するオプションが備わったオプション パネルが表示されます。

  • 概要 - [概要]、[ログ]、[設定] の 3 つのタブで構成され、システムの概要、ログを確認したり、プログラムの自動起動オプションやロック/アンロック用のパスワードを設定したりすることができます。
  • ファイアウォール - [セキュリティ レベル]、[アプリケーション ルール]、[オンライン アプリケーション] の 3 つのタブで構成され、ファイアウォールのルールを設定することができます。
  • SafeSurf - [ポップアップ ブロッカ]、[URL フィルタ]、[Internet Explorer オプション] の 3 つのタブで構成され、安全で快適なインターネット ライフを楽しめるよう、迷惑なポップアップ広告や有害 Web サイトをブロックすることができます。
  • ファイル共有 - [共有フォルダ]、[セッション] の 2 つのタブで構成され、ローカル コンピュータ上の共有フォルダや、ネットワーク セッションを管理することができます。
  • マイツールボックス - [スタートアップの編集]、[プライバシ クリーナ]、[IP トラッカ] の 3 つのタブで構成され、プライバシ情報を消去したり、特定の IP アドレスを追跡したりすることができます。

関連トピック

  • HackerSmacker のメイン ウィンドウ


概要

[概要] オプション パネルは以下のタブで構成されます。

[概要] タブ - インターネット セキュリティに関する設定や、システム セキュリティに関する統計情報の概要が表示されます。詳細については、「設定の概要および統計情報の表示」を参照してください。

[ログ] タブ - ファイアウォールのログが表示されます。詳細については、「HackerSmacker ファイアウォールのログの表示」を参照してください。

[設定] タブ - HackerSmacker の一般的なオプションを設定することができます。詳細については、「HackerSmacker のその他の設定」を参照してください。

関連トピック

  • オプション パネル - ファイアウォール
  • オプション パネル - SafeSurf
  • オプション パネル - ファイル共有
  • オプション パネル - マイツールボックス


ファイアウォール

[ファイアウォール] オプション パネルは以下のタブで構成されます。

[セキュリティ レベル] タブ - セキュリティ レベルの設定やシステムの高度な設定など、ネットワーク セキュリティに関する設定を変更することができます。 詳細については、「ネットワーク セキュリティに関する設定のカスタマイズ」を参照してください。

[アプリケーション ルール] タブ - アプリケーションがインターネットにアクセスしたときの HackerSmacker の動作を設定することができます。詳細については、「アプリケーション ルールのカスタマイズ」を参照してください。

[オンライン アプリケーション] タブ - ネットワークに現在アクセス中のすべてのプログラムが表示されます。 詳細については、「オンライン アプリケーションの表示」を参照してください。

関連トピック

  • オプション パネル - 概要
  • オプション パネル - SafeSurf
  • オプション パネル - ファイル共有
  • オプション パネル - マイツールボックス
  • HackerSmacker ファイアウォールでコンピュータへの不正侵入をブロック


SafeSurf

[SafeSurf] オプション パネルは以下のタブで構成されます。

[ポップアップ ブロッカ] タブ - さまざまな迷惑広告をブロックすることができます。詳細については、「インターネット広告のブロック」を参照してください。

[URL フィルタ] タブ - 特定の Web サイトへのアクセスを制限することができます。 詳細については、「有害 Web サイトに対するアクセス制限」を参照してください。

[Internet Explorer オプション] タブ - IE Web ブラウザのプロパティをデフォルトの状態に回復することができます。 詳細については、「IE ブラウザの修正」を参照してください。

関連トピック

  • オプション パネル - 概要
  • オプション パネル - ファイアウォール
  • オプション パネル - ファイル共有
  • オプション パネル - マイツールボックス


ファイル共有

[ファイル共有] オプション パネルは以下のタブで構成されます。

[共有フォルダ] タブ - ローカル ネットワーク上の共有フォルダを管理することができます。 詳細については、「共有フォルダの管理」を参照してください。

[セッション] タブ - コンピュータ間のネットワーク セッションを管理することができます。詳細については、「ネットワーク セッションの管理」を参照してください。

関連トピック

  • オプション パネル - 概要
  • オプション パネル - ファイアウォール
  • オプション パネル - SafeSurf
  • オプション パネル - マイツールボックス


マイツールボックス

[マイツールボックス] オプション パネルは以下のタブで構成されます。

[スタートアップの編集] タブ - コンピュータの起動時に自動的に実行されるプログラムを制御 (有効化/無効化) することができます。 詳細については、「コンピュータ起動時の自動実行プログラムの制御」を参照してください。

[プライバシ クリーナ] タブ - プライバシ保護のためプライバシ情報を含むファイルを消去することができます。詳細については、「プライバシ情報の消去」を参照してください。

[IP トラッカ] タブ - 特定の IP アドレスの情報を検索することができます。 詳細については、「特定の IP アドレスの追跡」を参照してください。

関連トピック

  • オプション パネル - 概要
  • オプション パネル - ファイアウォール
  • オプション パネル - SafeSurf
  • オプション パネル - ファイル共有


ショートカット

HackerSmacker をロック/アンロックするためのショートカット

HackerSmacker のメイン ウィンドウの右上には、プログラムのオプション設定をロック/アンロックするためのショートカット [image] が配置されています。このショートカットの使い方の詳細については、「HackerSmacker のオプション設定のロック」を参照してください。

Hacker Smacker ファイアウォールを有効化/無効化、およびトラフィックをブロックするためのショートカット

ネットワーク トラフィック ウィンドウの下部には、HackerSmacker ファイアウォールを有効化/無効化、およびすべてのトラフィックをブロックするためのショートカットが配置されています。

ボタンの色と用途は以下のとおりです。

  • 赤 - すべてのトラフィックをブロック

疑わしいデータ フローを見つけた場合に、このボタンをクリックして、コンピュータ間の通信を即座に停止することができます。

このボタンをクリックすると、赤ランプが点灯し、システム トレイのアイコンが [image] に変わります。このショートカットの使い方の詳細については、「コンピュータのすべてのトラフィックをブロック」を参照してください。

  • 黄 - ファイアウォールを有効化

HackerSmacker ファイアウォールが無効になっている場合に、このボタンをクリックして、再び有効にすることができます。このボタンをクリックすると、黄ランプが点灯し、システム トレイのアイコンが通常の状態 [image] に戻ります。このショートカットの使い方の詳細については、「HackerSmacker ファイアウォールの有効化/無効化」を参照してください。

  • 緑 - ファイアウォールを無効化

このボタンをクリックして、HackerSmacker ファイアウォールを一時的に無効にすることができます。このボタンをクリックすると、緑ランプが点灯し、システム トレイのアイコンが [image] に変わります。このショートカットの使い方の詳細については、「HackerSmacker ファイアウォールの有効化/無効化」を参照してください。

関連トピック

  • HackerSmacker のメイン ウィンドウ


ネットワーク トラフィック ウィンドウ

ツールバーの下部には、以下に示すネットワーク トラフィック ウィンドウが配置されています。

ネットワーク トラフィック ウィンドウには、コンピュータの受信/送信データの総計を示すグラフが表示されます。このグラフによって、ハッカーからの攻撃を早期に検知することができます。ネットワーク トラフィックの量が急激に増加した場合、ハッカーから攻撃を受けている可能性があります。詳細なデータフロー情報 (バイト数) については、[概要] オプション パネルの [概要] タブの [ネットワーク アクティビティ] セクションで確認することができます。

関連トピック

  • HackerSmacker のメイン ウィンドウ
  • 設定の概要および統計情報の表示


バージョン情報

メイン ウィンドウの左上のアイコンをクリックすると、バージョン情報ページが表示されます。

このページには、FarStone Technology, Inc. および HackerSmacker のバージョン情報に関する情報が表示されます。

また、FarStone ホームページ、製品アップデート、サポート センター、製品登録へのリンクも用意されています。

関連トピック

  • HackerSmacker のメイン ウィンドウ


HackerSmacker のオプション設定のロック

HackerSmacker の設定が権限のないユーザに勝手に変更されないように、プログラムのオプションをロックすることができます。

HackerSmacker のオプション設定のロック

1. HackerSmacker のオプション設定をロックするには、メイン ウィンドウのロック/アンロック ショートカットをクリックします。パスワードが未設定の場合は、パスワードを設定するためのダイアログ ボックスが最初に表示されます。

2. パスワードを入力します。パスワードは確認のため 2 回入力する必要があります。

3. [OK] をクリックして、パスワード保護を有効にします。

4. パスワードの設定が成功した旨のメッセージが表示されたら、[OK] をクリックします。HackerSmacker のオプション設定がロックされたら、ショートカット アイコンが [image] に変わります。

メモ: 設定したパスワードは、[概要] オプション パネルの [設定] タブの [ロック/アンロック] セクションでいつでも変更することができます。「HackerSmacker のその他の設定」を参照してください。

HackerSmacker のオプション設定のアンロック (ロック解除)

1. HackerSmacker のオプション設定をアンロックするには、ショートカット アイコンをもう一度クリックします。

2. パスワードを入力するためのダイアログ ボックスが表示されたら、正しいパスワードを入力します。

メモ: パスワードが未設定の場合、デフォルトのパスワードはブランクになります。

3. [OK] をクリックして、HackerSmacker のオプション設定をアンロックします。オプション設定がアンロックされると、ショートカット アイコンが [image] に変わります。

関連トピック

  • ショートカット
  • HackerSmacker のその他の設定


設定の概要および統計情報の表示

HackerSmacker では、受信/送信を問わずすべてのインターネット接続の状況、およびプログラムのコンピュータ保護に関する動作が記録されます。潜在的な問題を特定するためにも、これらの情報は定期的に確認するようにしてください。

設定の概要と統計情報を表示するには

メイン ウィンドウのツールバーで [概要] ボタンをクリックして、オプション パネルの [概要] タブをクリックします。

[概要] タブには、以下の情報が表示されます。

  • インターネット セキュリティに関する設定

[インターネット セキュリティ] セクションでは、保護機能の現在の状態 (有効/無効) をすばやく把握することができます。各機能を有効化/無効化する方法については、以下のトピックを参照してください。

- ファイアウォールおよびアプリケーション制御を有効化/無効化する方法については、「HackerSmacker ファイアウォールでコンピュータへの不正侵入をブロック」を参照してください。

- ポップアップ ブロッカを有効化/無効化する方法については、「インターネット広告のブロック」を参照してください。

- 共有監視を有効化/無効化する方法については、「共有フォルダの管理」を参照してください。

メモ: ファイアウォールを無効にすると、アプリケーション制御も同時に無効になります。

  • ネットワーク アクティビティの表示

[ネットワーク アクティビティ] セクションでは、出力 (送信) データ/入力 (受信) データ、および現在の転送速度に関する詳細な情報を確認することができます。なお、メイン ウィンドウのネットワーク トラフィック ウィンドウには、この情報に基づいたグラフが表示されます。

  • 統計情報

HackerSmacker では、全体的なネットワーク アクティビティの統計情報のほかにも、ユーザのインターネットの使用状況、共有フォルダ、およびプログラムの動作に関するリアルタイムの情報が記録されます。

[統計情報] セクションでは、以下の情報を確認することができます。

セキュリティ レベル | ファイアウォールの現在のセキュリティ レベル
アクティブな接続 | アクティブな TCP 接続または UDP 接続の数
オンライン アプリケーション | インターネットを現在使用中のインターネット アプリケーションの数
セッション | 共有フォルダまたは共有プリンタにアクセスしている LAN ユーザの数
共有フォルダ | ネットワーク上で共有されているローカル フォルダの数
ログ | 起動後にログに記録されたイベントの数
広告ブロック数 | 起動後にブロックされたポップアップ ウィンドウおよび URL の数
既知アプリケーション | 設定済みのアプリケーション ルールに基づいて HackerSmacker で制御されているインターネット アプリケーションの数

関連トピック

  • オプション パネル - 概要
  • ネットワーク トラフィック ウィンドウ
  • HackerSmacker ファイアウォールのログの表示
  • HackerSmacker ファイアウォールでコンピュータへの不正侵入をブロック


HackerSmacker ファイアウォールのログの表示

HackerSmacker では、ユーザがアクセスした Web サイトに関する情報、設定済みのファイアウォール ルール/アプリケーション ルールに基づいてファイアウォールによってとられた対処、および [概要] タブの [統計情報] セクションに報告されたアクティビティに関する詳細が自動的に記録されます。

ログを表示するには

1. メイン ウィンドウのツールバーで [概要] ボタンをクリックして、オプション パネルの [ログ] タブをクリックします。

2. [ログ] タブの左側のリストで、以下のログ アイテムのうち目的のアイテムを選択します。選択したアイテムに応じて、右側の情報が切り替わります。

  • ネットワーク ログ: 設定済みのファイアウォール ルールに基づいたネットワーク通信 (方向、ソース IP アドレス、およびプログラムによってとられた対処を含む)

  • アプリケーション ログ: TCP 接続または UDP 接続の利用を試みたインターネット アプリケーション、およびアプリケーション ルールに基づいてプログラムによってとられた対処

  • Web サイト ログ: コンピュータからアクセスした URL

ログ情報のクリア

すべてのログ情報は、手動で削除しない限り、[ログ] タブに蓄積されていきます。

ログ情報をクリアするには

1. メイン ウィンドウのツールバーで [概要] ボタンをクリックして、オプション パネルの [ログ] タブをクリックします。

2. [ログ] タブの左側のリストで、クリアするログ アイテムを選択して、[クリア] をクリックします。

関連トピック

  • オプション パネル - 概要
  • 設定の概要および統計情報の表示


HackerSmacker のその他の設定

HackerSmacker では、HackerSmacker の起動方法、通知モード、およびパスワード保護に関する設定を変更できるようになっています。

HackerSmacker のその他の設定を変更するには

メイン ウィンドウのツールバーで [概要] ボタンをクリックして、オプション パネルの [設定] タブをクリックします。

[設定] タブには、以下のオプションが用意されています。

  • Windows スタートアップ時に HackerSmacker を起動

このチェック ボックスをオンにすると、コンピュータを起動するたびに HackerSmacker も自動的に起動されるようになります。

  • スタートアップ時にシステム トレイに最小化

このチェック ボックスをオンにすると、HackerSmacker は起動後すぐにシステム トレイに最小化されるようになります。

  • 何かリスクを検出したら知らせる

このチェック ボックスをオンにすると、コンピュータが攻撃を受けている場合、または不正なプログラムがネットワークにアクセスしようとしている場合に、通知メッセージが表示されるようになります。

  • 音で通知する

このチェック ボックスをオンにすると、コンピュータが攻撃を受けている場合、または不正なプログラムがネットワークにアクセスしようとしている場合に、音で通知されるようになります。

  • スタートアップ時に HackerSmacker を自動ロックする

このチェック ボックスをオンにすると、HackerSmacker は起動時に自動的にロックされるようになります。ただし、このオプションを使用するには、あらかじめパスワードを設定しておく必要があります。

パスワードを設定または変更するには、[パスワードの設定] をクリックします。

プログラムのロック/アンロックに関する詳細については、「HackerSmacker のオプション設定のロック」を参照してください。

関連トピック

  • オプション パネル - 概要


HackerSmacker ファイアウォールでコンピュータへの不正侵入をブロック

HackerSmacker ファイアウォールは、オンライン攻撃、不正な接続試行、悪質な Web コンテンツ、ポート スキャン、およびその他の疑わしい動作からコンピュータを保護します。

これらの保護を利用するには、まず HackerSmacker ファイアウォールを有効にする必要があります。

HackerSmacker ファイアウォールを有効にするには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [ファイアウォールの有効化] チェック ボックスをオンにします。

関連トピック

  • オプション パネル - ファイアウォール
  • 設定の概要および統計情報の表示
  • HackerSmacker ファイアウォールについて


HackerSmacker ファイアウォールについて

HackerSmacker ファイアウォールを有効にすると、LAN またはインターネットを介したコンピュータ間の通信、およびコンピュータ上のインターネット アプリケーションで使用されているすべてのポートが監視されるようになります。HackerSmacker では、以下の機能を使用して、コンピュータを保護します。

セキュリティ レベル | HackerSmacker には、あらかじめ定義された 3 種類のセキュリティ レベルのルールが用意されています。ほとんどのユーザにとって、このデフォルトの設定だけで十分なセキュリティが得られます。これらの設定だけでは十分でない場合は、独自にセキュリティ設定をカスタマイズすることもできます。独自に設定可能なルールは、ポート管理、ゾーン制御、高度なトラフィック ルールです。
アプリケーション ルール | HackerSmacker では、インターネットに初めてアクセスしようとするプログラムを検出すると警告ポップアップを表示し、そのプログラムをアプリケーション リストに自動的に追加します。この際、各プログラムごとにアクセル ルールを設定することができます。また、プログラムを手動でリストに追加して、そのアクセス ルールを指定することもできます。
オンライン アプリケーション | HackerSmacker では、インターネットを現在使用中のすべてのインターネット アプリケーションをスキャンして、各プログラムが使用しているポートやプロトコルに関する情報を表示できるようになっています。

ネットワーク セキュリティ ルールの優先順位について

ネットワーク セキュリティ ルールは、その種類に基づいて、規定の優先順位で処理されるようになっています。具体的には、(1) ポート管理ルール、(2) トロイの木馬対策ルール (トロイの木馬対策ルールはデフォルトのファイアウォール ルールであり、カスタマイズできません)、(3) ゾーン制御ルール、(4) 現在のセキュリティ レベルの事前定義ルール、(5) 独自に追加したカスタマイズ トラフィック ルールの順序で処理されます。

該当するルールが見つかった場合、その時点で通信が許可またはブロックされ、残りのすべてのルールは無視されます。該当するルールが見つからない場合、その通信はブロックされます。

関連トピック

  • オプション パネル - ファイアウォール
  • 設定の概要および統計情報の表示
  • HackerSmacker ファイアウォールでコンピュータへの不正侵入をブロック


HackerSmacker ファイアウォールの有効化/無効化

HackerSmacker ファイアウォールを有効にすると、LAN またはインターネットを介したコンピュータ間の通信、およびコンピュータ上のインターネット アプリケーションで使用されているすべてのポートが監視されるようになります。

HackerSmacker ファイアウォールを有効にするには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [ファイアウォールの有効化] チェック ボックスをオンにして、ファイアウォールを有効にします。

HackerSmacker ファイアウォールが特定の IP アドレスを正しくブロックしているか確認する場合など、Hacker Smacker ファイアウォールを一時的に無効にすることもできます。

HackerSmacker ファイアウォールを一時的に無効にするには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [ファイアウォールの有効化] チェック ボックスをオフにして、ファイアウォールを無効にします。

また、メイン ウィンドウのショートカットを使用すれば、HackerSmacker ファイアウォールの有効化/無効化の設定をすばやく切り替えることができます。詳細については、「ショートカット」を参照してください。

関連トピック

  • ネットワーク セキュリティに関する設定のカスタマイズ
  • セキュリティ レベルの変更
  • 高度なファイアウォール設定のカスタマイズ


ネットワーク セキュリティに関する設定のカスタマイズ

[ファイアウォール] オプション パネルの [セキュリティ レベル] タブでは、ネットワーク セキュリティに関する設定をカスタマイズするためのオプションが用意されています。これらのオプションでは、HackerSmacker ファイアウォールの有効化/無効化、セキュリティ レベルの変更、および高度なファイアウォール設定のカスタマイズが可能です。

[追加設定] ボタンをクリックすると、ポート管理、ゾーン制御、および高度なトラフィック ルールの設定のための [追加設定] ダイアログ ボックスが表示されます。

ルールの優先順位は、(1) ポート管理ルール、(2) トロイの木馬対策ルール (トロイの木馬対策ルールはカスタマイズできません)、(3) ゾーン制御ルール、(4) 現在のセキュリティ レベルの事前定義ルール、(5) 独自に追加したカスタマイズ トラフィック ルールになります。

該当するルールが見つかった場合、その時点で通信が許可またはブロックされ、残りのすべてのルールは無視されます。該当するルールが見つからない場合、その通信はブロックされます。

関連トピック

  • オプション パネル - ファイアウォール
  • アプリケーション ルールのカスタマイズ
  • オンライン アプリケーションの表示
  • HackerSmacker ファイアウォールについて


セキュリティ レベルの変更

HackerSmacker には、スライダを上下に動かしてセキュリティ レベルを変更することができるオプションが備わっています。 デフォルトでは、セキュリティ レベルは [中] に設定されています。

セキュリティ レベルを変更するには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. スライダを上下にドラッグして、目的のセキュリティ レベルに設定します。

各レベルのデフォルトのルールについては、以下の表を参照してください。

低 | ネットワーク/インターネットにアクセスしようとするすべてのプログラムに対して、アクセスを許可するかどうかを確認する警告ポップアップが表示されます。トロイの木馬に対するガードが有効です。ほとんどのインターネット アプリケーションでの入力 (受信) トラフィックが許可されます。このセキュリティ レベルは、ファイアウォールの設定に精通している上級ユーザ向けです。
中 | ネットワーク/インターネットにアクセスしようとするすべてのプログラムに対して、アクセスを許可するかどうかを確認する警告ポップアップが表示されます。トロイの木馬に対するガードが有効です。ファイル/プリンタの共有、および ICMP Ping のみが許可されます。このセキュリティ レベルは、一般的なホーム ユーザ向けです。
高 | ネットワーク/インターネットにアクセスしようとするすべてのプログラムに対して、アクセスを許可するかどうかを確認する警告ポップアップが表示されます。トロイの木馬に対するガードが有効です。すべてのポートへの入力 (受信) トラフィックがブロックされます。このセキュリティ レベルは、コンピュータを接続しているネットワーク サーバが正しく保護されていない場合に推奨されます。

関連トピック

  • HackerSmacker ファイアウォールについて
  • ネットワーク セキュリティに関する設定のカスタマイズ
  • HackerSmacker ファイアウォールの有効化/無効化
  • 高度なファイアウォール設定のカスタマイズ


高度なファイアウォール設定のカスタマイズ

セキュリティ レベルのオプションだけでは十分でないときのために、システムの設定 (ポート管理、ゾーン制御、および高度なトラフィック ルールの設定) をカスタマイズするためのオプションも用意されています。

高度なセキュリティ設定をカスタマイズするには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [追加設定] をクリックします。

[追加設定] ダイアログ ボックスは以下のタブで構成されます。

  • ポート管理 - すべてのポートが閉じられたときに特定のポートを開きます。
  • ゾーン制御 - HackerSmacker ファイアウォールで信頼するコンピュータを指定します。
  • 詳細ルール - あらかじめ定義されたルールに加え、付加的トラフィック ルールを設定します。

関連トピック

  • ネットワーク セキュリティに関する設定のカスタマイズ
  • HackerSmacker ファイアウォールの有効化/無効化
  • セキュリティ レベルの変更


ポート管理

コンピュータのセキュリティ保護の一環として、HackerSmacker ファイアウォールを有効にしたときに、デフォルトですべてのポートが閉じられるようになっています。この状態では、コンピュータへの未許可のアクセス要求はすべてブロックされます。コンピュータへのアクセスを許可するためには、ポートを開く必要があります。

ポートとは、簡単に説明すると、データの送受信を行うための通り道のようなものです。たとえば、インスタント メッセージでやり取りしている相手が写真などのファイルを送信してきた場合、HackerSmacker ファイアウォールによって、その写真をコンピュータに取り込むために要求を許可するかどうか確認されます。また、インターネットを介して友人とネットワーク ゲームをしている場合、ゲーム用のポートを開くことで、ファイアウォールはゲーム情報のコンピュータへの受信を許可できるようになります。

ポート番号

各ポートにはアドレスのような番号が割り当てられています。プログラムやサービスの多くに "固定アドレス"、つまり、あらかじめ定義されたポート番号が設定されています。プログラムやサービスの正しいボート番号は、製造元のマニュアルや Web サイトで確認することができます。詳細については、Microsoft Web サイト (http://www.microsoft.com/japan/) で、Windows ファイアウォールでポートを開く方法を参照してください。

特定のプログラム用に開くポートを決定するには

通常、プログラムに設定されている "固定アドレス" がそのプログラム用に開くポートになります。

正しいポートがわからない場合でも、HackerSmacker では簡単に調べることができます。その場合、メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [オンライン アプリケーション] タブをクリックします。オンライン アプリケーションのリストには、プログラムがリッスンしている TCP ポートが表示されます。プログラムがコンピュータにアクセスできるようにするには、その TCP ポートを開く必要があります。

以下の例では、BitSpirit プログラムはポート 16881 をリッスンしているため、BitSpirit にアクセスを許可するには ポート 16881 を開きます。

ポートを開くリスク

特定のプログラム用にポートを開いてコンピュータへのアクセスを許可するたびに、コンピュータはセキュリティ面で脆弱になります。ポートを開くことは、ファイアウォールに穴を開けるようなものです。多くの穴が存在すると、ファイアウォールによる保護も意味をなさないものとなってしまいます。不正侵入者の多くはインターネットをスキャンするソフトウェアを使用して、接続の脆弱部分を見つけ出します。したがって、多くのポートを開いている場合は、これらの侵入者の被害を受ける可能性が高くなるので注意する必要があります。

ポートを開くときにセキュリティ リスクを軽減するには

本当に必要なポートのみを開き、作業が終了したらすぐにポートを閉じてください。疑わしいアクセスにはくれぐれもポートを開かないようにしてください。

コンピュータ上のポートを管理するには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [追加設定] をクリックします。

3. [ポート管理] タブをクリックします。

[ポート管理] タブのリストには、HackerSmacker で管理可能なデフォルトのポートがあらかじめ表示されています。このリストで、新しいポートを追加したり、既存のポートを削除したり、ポートのプロパティを編集したりすることができます。

新しいポートを開くには

1. [新規] をクリックします。

2. ポート名とその説明を入力します。

3. ポート番号を入力します。

4. [これらのポートを開く] チェック ボックスをオンにします。

5. [OK] をクリックします。

既存のポートを開くには

開きたいポートが既にリストに存在する場合、ポート名の横のチェック ボックスをオンにします。

または、ポート名を選択した状態で [編集] をクリックし、[これらのポートを開く] チェック ボックスをオンにして、[OK] をクリックします。

既存のポートを編集するには

1. ポート名を選択して、[編集] をクリックします。

2. ポート名、説明、およびポート番号を編集して、[OK] をクリックします。

既存のポートを削除するには

ポート リストから削除するポートを選択して、[削除] をクリックします。

メモ: ポートをリストから削除してしまうと、次回同じポートを開く場合に手動で追加し直す必要があります。

関連トピック

  • HackerSmacker ファイアウォールについて
  • ネットワーク セキュリティに関する設定のカスタマイズ
  • 高度なファイアウォール設定のカスタマイズ
  • ゾーン制御
  • 高度なトラフィック ルールの設定
  • オンライン アプリケーションの表示


ゾーン制御

ネットワーク ゾーンとは、特定のコンピュータ グループの IP アドレスの範囲です。 IP アドレスの範囲を指定して、その範囲に該当するすべてのコンピュータとの間の接続ルール (許可またはブロック) を設定することができます。 ここで設定した接続ルールは、セキュリティ レベルの設定の影響は受けません。 たとえば、特定のコンピュータとの接続を許可した場合、セキュリティ レベルが [高] に設定されていたとしても、そのコンピュータとは自由に通信できるようになります。

ネットワーク ゾーン ルールでコンピュータを分類するには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [追加設定] をクリックします。

3. [ゾーン制御] タブをクリックします。

ゾーン関連のタスク

  • 単一のコンピュータの追加
  • コンピュータ グループの追加
  • ネットワーク アドレスを使用してコンピュータを追加
  • 既存のゾーンの編集

関連トピック

  • 高度なファイアウォール設定のカスタマイズ
  • 高度なトラフィック ルールの設定
  • ポート管理


単一のコンピュータの追加

ネットワーク ゾーンのリストに単一のコンピュータを追加して、そのコンピュータとの接続ルールを指定するには、以下の手順に従います。

1. [ゾーン制御] タブで [新規] をクリックします。

2. 対象のコンピュータの名前を入力します。

3. [タイプ] ドロップダウン リストから [単一アドレス] を選択します。

4. 対象のコンピュータの IP アドレスを入力します。

5. [対処] セクションで、接続ルール (許可またはブロック) を指定します。

6. [OK] をクリックします。

関連トピック

  • コンピュータ グループの追加

  • ネットワーク アドレスを使用してコンピュータを追加
  • 既存のゾーンの編集


コンピュータ グループの追加

開始 IP アドレス (数値が最小) と終了 IP アドレス (数値が最大) を指定して、コンピュータ グループを追加することができます。この場合、指定した IP アドレスの範囲に含まれるすべてのコンピュータが対象となります。

メモ: ほとんどすべての場合、IP アドレスの 4 つの番号のうち最初の 3 つは同じになります。

コンピュータ グループを追加するには

1. [ゾーン制御] タブで [新規] をクリックします。

2. 対象のコンピュータ グループの名前を入力します。

3. [タイプ] ドロップダウン リストから [スコープ] を選択します。

4. [開始] ボックスに、開始 IP アドレス (数値が最小) を入力します。

5. [終了] ボックスに、終了 IP アドレス (数値が最大) を入力します。

6. [対処] セクションで、対象のコンピュータ グループに適用する接続ルール (許可またはブロック) を指定します。

7. [OK] をクリックします。

関連トピック

  • 単一のコンピュータの追加
  • ネットワーク アドレスを使用してコンピュータを追加
  • 既存のゾーンの編集


ネットワーク アドレスを使用してコンピュータを追加

IP アドレスとサブネット マスクを指定して、単一のサブネット ネットワーク上のすべてのコンピュータを追加することができます。ここで指定する IP アドレスには、対象のサブネット上の任意のアドレスを使用することができます。

ネットワーク アドレスを使用してコンピュータを追加するには

1. [ゾーン制御] タブで [新規] をクリックします。

2. [名前] ボックスに、グループ名としての名前を入力します。

3. [タイプ] ドロップダウン リストから [アドレス/マスク] を選択します。

4. [IP アドレス] ボックスに、対象のサブネット上の任意のコンピュータの IP アドレスを入力します。

メモ: [IP アドレス] ボックスでは、IP アドレスの範囲として解釈されるように指定することもできます。つまり、4 つの番号のうち最後が 0 の IP アドレスを入力することができます。たとえば、「192.168.1.0」と入力した場合、「192.168.1.1」から「192.168.1.255」の範囲のすべてのアドレスが含まれることになります。

5. [サブネット マスク] ボックスに、対象のサブネット マスクを入力します。.

メモ: サブネット マスクは、ほとんどの場合、「225.225.225.0」になります。

6. [対処] セクションで、対象のコンピュータ グループに適用する接続ルール (許可またはブロック) を指定します。

7. [OK] をクリックします。

関連トピック

  • 単一のコンピュータの追加

  • コンピュータ グループの追加

  • 既存のゾーンの編集


既存のゾーンの編集

既存のゾーンのプロパティとその接続ルールは、必要に応じて、いつでも編集することができます。

既存のゾーンを編集するには

1. [ゾーン制御] タブで、対象のゾーンを選択して、[編集] をクリックします。

2. ゾーンのプロパティとその接続ルールを編集します。

3. [OK] をクリックします。

追加したコンピュータを削除するには、削除するコンピュータを選択して、[削除] をクリックするだけです。

関連トピック

  • 単一のコンピュータの追加
  • コンピュータ グループの追加
  • ネットワーク アドレスを使用してコンピュータを追加


高度なトラフィック ルールの設定

高度なトラフィック ルールは、ポート管理、ゾーン制御、およびセキュリティ レベルの設定の付加的ルールとして位置付けられています。すべてのルールの中で優先度は最も低く、上級ユーザ向けの設定です。

高度なルールを扱うには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [セキュリティ レベル] タブをクリックします。

2. [追加設定] をクリックします。

3. [詳細ルール] タブをクリックします。

[詳細ルール] タブでは、既存のルールの有効化/無効化、新しいルールの追加、既存のルールの編集、既存のルールの削除、およびルールの処理順序 (優先度) の指定が可能です。

既存のルールを有効/無効にするには

ルール名の横のチェック ボックスのオン/オフを切り替えて、[OK] をクリックして、設定を有効にします。

ルールの順序を変更するには

1. 順序を変更するルールを選択して、以下のいずれかのボタンをクリックします。

  • 選択したルールを直前のルールの前に処理するには、[上へ] をクリックします。
  • 選択したルールを直後のルールの前に処理するには、[下へ] をクリックします。

2. ルールの移動が終了したら、[OK] をクリックします。

既存のルールを削除するには

削除するルールを選択して、[削除] をクリックします。

関連するその他のタスク

  • HackerSmacker ファイアウォールについて
  • ネットワーク セキュリティに関する設定のカスタマイズ
  • 高度なファイアウォール設定のカスタマイズ
  • 新しいトラフィック ルールの追加
  • 既存のトラフィック ルールの編集

関連トピック

  • ポート管理
  • ゾーン制御


新しいトラフィック ルールの追加

[詳細ルール] タブのリストには、今まで追加した既存のルールが表示されます。このリストには、必要に応じて、いつでも新しいルールを追加することができます。

メモ:ここで追加したルールは、最も優先順位が低くなります。

新しいトラフィック ルールを追加するには

1. [詳細ルール] タブで、[新規] ボタンをクリックして、[高度なカスタム ルール] ダイアログ ボックスを開きます。

2. [名前] ボックスに、ルールの名前を入力します。後で見分けやすいように、わかりやすい名前を入力することをお勧めします。

3. [説明] ボックスに、ルールの説明を入力します。

4. [方向] ドロップダウン リストからトラフィックの方向を選択します。

5. [プロトコル] ドロップダウン リストからルールの対象とするプロトコルを選択します。

このドロップダウン リストからは 5 種類のプロトコルを選択することができます。各プロトコルの簡単な説明については、以下の表を参照してください。

IP | Internet Protocol の略です。IP ではデータグラムと呼ばれるパケットのフォーマットとアドレス スキームを指定します。たいていのネットワークでは、IP と高位のプロトコルである TCP (Transmission Control Protocol) を組み合わせて、宛先と送信元との間の仮想接続を確立します。 IP 自体は郵便システムのようなものです。つまり、小包の住所を指定して、郵便局に渡すことはできますが、受取人との直接的なやり取りはありません。一方、TCP/IP では、メッセージの送受信ができるように、2 つのホスト間の接続を確立します。
TCP | Transmission Control Protocol の略です。インターネット プロトコル群の中でも中核となるプロトコルの 1 つです。TCP を使用すると、ネットワーク上のコンピュータのプログラムは別のコンピュータとの接続を確立し、データの送信が可能になります。1 つのエンドポイントから送信されたデータは、同じ順序で他のコンピュータで受信されます。この際、データが喪失するようなことはありません。また、同じコンピュータ上の異なるアプリケーション (Web サーバやメール サーバ) からのデータも区別されます。
UDP | User Datagram Protocol の略です。TCP と同じで、IP ネットワークのトランスポート層に属す接続なしのプロトコルです。UDP/IP は、TCP/IP とは異なり、エラー回復サービスはほとんど提供しません。その代わりとして、IP ネットワーク上でデータグラムを直接送受信することができます。主には、ネットワーク上でメッセージをブロードキャスト配信するために使用されます。
ICMP | Internet Control Message Protocol の略です。インターネット プロトコルの拡張で、主に、ネットワーク上のコンピュータのオペレーティング システムでエラー メッセージの送信のために使用されます。たとえば、要求されたサービスが利用できない場合、またはホストやルータにアクセスできない場合などのエラー メッセージが該当します。PING コマンドでは、ICMP を使用して、インターネット接続をテストします。ICMP エコー要求メッセージを送信し、(エコー応答メッセージを受信し、) ホストにアクセスできるか、ホストへの (ホストからの) パケットの到達時間を調べます。
IGMP | Internet Group Management Protocol の略です。インターネット プロトコル マルチキャスト グループのメンバシップを管理するために使用される通信プロトコルです。IGMP は、マルチキャスト グループ メンバシップを確立するために、IP ホスト、および隣接するマルチキャスト ルータで使用されます。このプロトコルのメカニズムによって、ホストは、ホスト メンバシップ レポートを使用して、ローカル ルータに特定のマルチキャスト グループ宛のメッセージを受信する旨を通知できるようになります。

6. 選択したプロトコルに応じて、IP アドレス、サブネット マスク、ポート情報など、必要な情報を入力します。

7. [上の条件に一致したら] セクションで、上記の条件を満たした場合のアクセス ルールを指定します。

8. [このルールを有効にする] チェック ボックスをオンにすると、このトラフィク ルールが有効になります。

9. [OK] をクリックします。

関連トピック

  • 既存のトラフィック ルールの編集


既存のトラフィック ルールの編集

既存のトラフィック ルールは、必要に応じて、いつでも編集することができます。

既存のトラフィック ルールを編集するには

1. [詳細ルール] タブで、編集するルールを選択して、[編集] をクリックします。

2. ルールのプロパティを編集します。

3. [OK] をクリックします。

関連トピック

  • 新しいトラフィック ルールの追加


アプリケーション ルールのカスタマイズ

HackerSmacker では、インターネットまたはローカル ネットワークに初めてアクセスしようとするプログラムを検出すると警告ポップアップを表示し、そのプログラムをアプリケーション リストに自動的に追加します。

デフォルトでは、警告ポップアップでのユーザの応答に基づいて、各プログラムのアクセス ルールが設定されるようになっています。設定済みのアクセス ルールはこのリストで変更することができます。

プログラムのアクセス ルールを変更するには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [アプリケーション ルール] タブをクリックします。

2. アクセス ルールを変更するプログラムを選択して、[許可]、[ブロック]、[問い合わせる] のうち目的のボタンをクリックします。

許可: フル アクセスを許可します。プログラムがインターネットまたはローカル ネットワークにアクセスしようとしても、警告ポップアップは表示しません。

ブロック: すべてのアクセスをブロックします。プログラムはインターネットまたはローカル ネットワークにアクセスすることはできません。

問い合わせる: 次回プログラムがインターネットまたはローカル ネットワークにアクセスしようとしたときに警告ポップアップを表示します。

メモ: 警告ポップアップの詳細については、「警告ポップアップへの応答」を参照してください。

また、プログラムを手動でリストに追加して、そのアクセス ルールを指定することもできます。

インターネット プログラムを手動で追加するには

1. メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [アプリケーション ルール] タブをクリックします。

2. [追加] をクリックします。[新しいアプリケーション ルール] ダイアログ ボックスが表示されます。

3. [参照] をクリックして、プログラムの実行可能ファイルのパスを指定します。

ヒント:実行可能ファイルの拡張子は、通常、.exe または .dll です。

4. そのプログラムのアクセス ルールを指定します。

5. [OK] をクリックします。

関連トピック

  • オプション パネル - ファイアウォール
  • HackerSmacker ファイアウォールについて
  • ネットワーク セキュリティに関する設定のカスタマイズ
  • オンライン アプリケーションの表示
  • HackerSmacker ファイアウォールのログの表示


オンライン アプリケーションの表示

HackerSmacker では、インターネットを現在使用中のインターネット アプリケーションをスキャンして、使用しているポートやそのデータフローに関する情報を表示できるようになっています。

オンライン アプリケーションを表示するには

メイン ウィンドウのツールバーで [ファイアウォール] ボタンをクリックして、オプション パネルの [オンライン アプリケーション] タブをクリックします。

[オンライン アプリケーション] タブのリストには、 アクティブなすべてのインターネット アプリケーションに関する情報がツリー形式で表示されます。アプリケーション名をクリックすると、ツリーが展開され、そのアプリケーションのインストール ディレクトリ、使用している TCP/UDP ポート、およびそのポートでのデータフローが表示されます。

すべてのポートでのデータフローを監視することで、コンピュータへの不正侵入を早期に発見することができます。何らかの不正侵入の兆候が現れたら、コンピュータのすべてのトラフィックをブロックして、不正侵入による影響を最小に抑えることができます。

関連トピック

  • HackerSmacker ファイアウォールについて
  • オプション パネル - ファイアウォール
  • ネットワーク セキュリティに関する設定のカスタマイズ
  • アプリケーション ルールのカスタマイズ


インターネット広告のブロック

インターネット サーフィン中、フローティング広告、ポップアップ広告、ポップアンダ広告、フラッシュ バナー広告など、さまざまな広告が表示されて悩まされるといったことはよくあることです。HackerSmacker のポップアップ ブロッカを使用すると、これらの広告の大部分を削除することができ、安全で快適なインターネット ライフを楽しむことができるようになります。

メモ: この機能を使用するには、IE 5.0 以上が必要になります。

HackerSmacker のポップアップ ブロッカを有効にするには

1. メイン ウィンドウのツールバーで [SafeSurf] ボタンをクリックして、オプション パネルの [ポップアップ ブロッカ] タブをクリックします。

2. [ポップアップ ブロッカの有効化] チェック ボックスをオンにします。

ポップアップ ブロッカを使用するには

1. [ポップアップ ブロッカ] タブで、以下のうち 1 つまたは複数のチェック ボックスをオンにします。

  • Flash 広告の消去

Flash 広告をブロックします。

  • ポップアップ/ポップアンダの消去

ポップアップ広告およびポップアンダ広告をブロックします。

  • バナー広告の消去

バナー広告をブロックします。

  • 音で通知する

広告のブロック時に音で通知します。

  • Ctrl+クリックでポップアップ ブロッカを無効にする

ポップアップ ブロッカをすばやく無効にします。ポップアップ ブロッカが有効になっている状態で、特定の Web ページの広告だけブロックせずにそのまま表示したい場合、Ctrl キーを押しながらリンクをクリックすると、そのページに対して一時的にポップアップ ブロッカを無効にすることができます。

2. 必要なチェック ボックスをオンにしたら、[適用] をクリックして、設定を有効にします。

関連トピック

  • オプション パネル - SafeSurf
  • 設定の概要および統計情報の表示
  • 有害 Web サイトに対するアクセス制限
  • IE ブラウザの修正


有害 Web サイトに対するアクセス制限

HackerSmacker の URL フィルタを使用すると、ブラックリストに登録した URL へのアクセスをブロックすることができます。

HackerSmacker の URL フィルタを使用するには

メイン ウィンドウのツールバーで [SafeSurf] ボタンをクリックして、オプション パネルの [URL フィルタ] タブをクリックします。

リストに URL を追加すると、その URL にはコンピュータからアクセスできなくなります。

URL は、必要に応じて、いつでも追加、削除、または編集することができます。

URL をブラックリストに追加するには

1. [URL フィルタ] タブで [追加] をクリックします。[URL フィルタ] ダイアログ ボックスが表示されます。

2. アクセスをブロックするページを Web ブラウザで開きます。

3. Web ブラウザのアドレス バーから URL アドレスをコピーし、[URL フィルタ] ダイアログ ボックスに貼り付けます。

4. [OK] をクリックします。

ブラックリストの URL を編集するには

1. 編集する URL をリストから選択して、[編集] をクリックします。

2. URL アドレスを編集して、[OK] をクリックします。

URL をブラックリストから削除するには

削除する URL をリストから選択して、[削除] をクリックします。

関連トピック

  • オプション パネル - SafeSurf
  • インターネット広告のブロック
  • IE ブラウザの修正


IE ブラウザの修正

悪質なプログラムによって Internet Explorer の設定が変更されてしまった場合、それらの設定を修正することができます。

IE ブラウザを修正するには

1. メイン ウィンドウのツールバーで [SafeSurf] ボタンをクリックして、オプション パネルの [Internet Explorer オプション] タブをクリックします。

2. 修正するアイテムを選択して、[編集] をクリックします。

3. [IE 設定] ダイアログ ボックスで修正後のコンテンツを入力します。Internet Explorer のデフォルトの値に回復するには、[デフォルト] をクリックします。

4. [OK] をクリックします。

関連トピック

  • オプション パネル - SafeSurf
  • インターネット広告のブロック
  • 有害 Web サイトに対するアクセス制限


共有フォルダの管理

共有監視機能を使用すると、ローカル コンピュータ上の共有フォルダでのアクティビティを監視することができ、共有フォルダの管理が容易になります。

共有監視を有効にするには

1. メイン ウィンドウのツールバーで [ファイル共有] ボタンをクリックして、オプション パネルの [共有フォルダ] タブをクリックします。

2. [共有監視の有効化] チェック ボックスをオンにします。

共有フォルダの管理

[共有フォルダ] タブのフォルダ リストには、共有フォルダに関する以下の情報が表示されます。

  • 名前:対象のフォルダの共有名

メモ: 共有名とは、ネットワーク上でのフォルダ名のことで、自分のコンピュータ上でのフォルダ名とは区別されます。共有名はフォルダに共有属性を設定するときに指定します。

  • 位置:ローカル コンピュータ上の対象のフォルダのパス

  • コメント: 共有フォルダに関するコメント

共有フォルダの把握および管理を容易に行えるよう、リストのカラム ヘッダをクリックして各カラムを並べ替えることができるようになっています。

特定のフォルダへのアクセスの監視

各フォルダを選択して、そのフォルダのアクセス ステータスを監視することができます。 選択したフォルダを他のユーザが開いていると、そのユーザの情報がユーザ リストに表示されます。不正なユーザがフォルダにアクセスしている場合は、共有を停止することもできます。

フォルダの共有を停止するには

共有を停止するフォルダをリストから選択して、[共有の停止] をクリックします。

メモ: 1. ユーザ共有フォルダの共有を停止した場合、共有属性は永久的に取り消されます。再びそのフォルダを共有するには、Windows で手動で設定する必要があります。

2. システム共有フォルダの共有を停止した場合、共有属性は一時的に取り消されるだけです。HackerSmacker を終了すると、その共有属性は回復します。

関連トピック

  • オプション パネル - ファイル共有
  • 設定の概要および統計情報の表示


ネットワーク セッションの管理

セッション監視機能を使用すると、自分のコンピュータとローカル ネットワーク上の他のユーザのコンピュータとの間の通信を監視することができます。

セッション監視を有効にするには

1. メイン ウィンドウのツールバーで [ファイル共有] ボタンをクリックして、オプション パネルの [セッション] タブをクリックします。

2. [セッション監視の有効化] チェック ボックスをオンにします。

自分のコンピュータと他のネットワーク ユーザのコンピュータとの間のセッションの表示

[セッション] タブのリストには、自分のコンピュータに接続している他のすべてのネットワーク ユーザに関する以下の情報が表示されます。

  • ユーザ -- 自分のコンピュータに接続している他のネットワーク ユーザの名前
  • コンピュータ -- 自分のコンピュータに接続している他のユーザのコンピュータの名前
  • オープン ファイル -- 自分のコンピュータで開かれているファイルの数
  • 接続時間 -- セッションが確立されてから経過した時間

疑わしいセッションを見つけたら、そのセッションを閉じることもできます。

セッションを閉じるには

閉じるセッションを選択して、[セッションを閉じる] をクリックします。

関連トピック

  • オプション パネル - ファイル共有


スタートアップ プログラムの編集

スタートアップ プログラムの編集機能を使用すると、コンピュータの起動時に自動的に実行するプログラムを選別することができます。本当に必要なプログラムだけを残し、その他を除外すれば、コンピュータのロード時間が短縮されます。

スタートアップ プログラムを編集するには

1. メイン ウィンドウのツールバーで [マイツールボックス] ボタンをクリックして、オプション パネルの [スタートアップの編集] タブをクリックします。

2. コンピュータの起動時に自動的に実行する必要のないプログラムがある場合は、そのチェック ボックスをオフにします。

3. リストの編集が完了したら、[適用] をクリックして、設定を有効にします。

関連トピック

  • オプション パネル - マイツールボックス


プライバシ情報の消去

コンピュータや Web サイトでは、ユーザがインターネット サーフィンを行うたびに、その履歴や個人情報が保持されるようになっています。たとえば、Web サイトのフォームで入力または選択した内容が該当します。また、最後にアクセスした Web ページや、使用しているコンピュータの種類といった情報も含まれます。これらのプライバシに関する情報は、コンピュータ上に一時ファイルとして格納されます。悪質なサイトやスパイウェアの中には、これらの記録を利用して、プライバシ情報を盗み出そうとするものもあります。HackerSmacker では、プライバシ情報が悪用されることがないよう、これらの一時ファイルを消去できるようになっています。

プライバシ情報を消去するには

1. メイン ウィンドウのツールバーで [マイツールボックス] ボタンをクリックして、オプション パネルの [プライバシ クリーナ] タブをクリックします。

2. 消去するアイテムのチェック ボックスをオンにします。すべてのアイテムを消去する場合は、[すべて選択] をクリックします。

HackerSmacker で消去可能なファイルまたはフォルダは以下のとおりです。

インターネット一時ファイル | インターネットから受信したデータが格納された Temporary Internet Files フォルダ
IE クッキー | アクセスした Web サイトに関する情報が格納された小さなファイル
IE アドレス バーのオートコンプリート履歴 | 最近アクセスした Web サイトのアドレスが格納された URL 履歴
IE オートコンプリート フォーム | Internet Explorer での入力情報が格納されたフォルダ
IE お気に入り | ユーザがお気に入りとして登録した Web サイトまたはフォルダのリストが格納されたフォルダ
一時システム ファイル | 使用中のメモリをその他の目的で使用できるよう解放するため、またはプログラムが特定の機能を実行したときにデータの喪失を避けるため、システム情報を一時的に格納したファイル
ごみ箱 | Windows ごみ箱内のアイテム - ハード ディスクから何らかのアイテムを削除すると、そのアイテムはごみ箱に移動されます。ごみ箱内のアイテムは、コンピュータから完全に削除するまで蓄積されていきます。
最近使用したドキュメント ファイル フォルダ | 最近使用したファイルのショートカットが格納されたフォルダ
ファイルまたはフォルダの検索履歴 | 最近検索したファイルまたはフォルダに関する情報
コンピュータの検索履歴 | 最近検索したコンピュータに関する情報
ネットワーク接続履歴 | 最近接続したコンピュータに関する情報
IE 履歴 | 最近表示した Web ページに関する情報が格納されたフォルダ
オートコンプリート パスワード | 以前に入力したパスワード - オートコンプリート機能を使用すると、入力したパスワードがコンピュータに記憶されるようになります。
プログラムの実行履歴 | Windows スタート メニューの [ファイル名を指定して実行] コマンドで実行したことのあるプログラムのリスト
最後のユーザ履歴 | コンピュータに最後にログインしたユーザの履歴 - Windows ではコンピュータに最後にログインしたユーザの履歴が保持され、次回コンピュータを起動したときにそのユーザの設定がデフォルトになります。
RAS 自動ダイヤル履歴 | ダイヤルアップ接続の履歴 - Remote Access Scripting を使用してインターネットに接続している場合、Windows では、使用したダイヤルアップ接続の履歴が保持されます。

3. 消去するアイテムの指定が終了したら、[消去] をクリックします。

メモ: 情報を確実に消去するには、コンピュータを再起動する必要がある場合があります。

関連トピック

  • オプション パネル - マイツールボックス


特定の IP アドレスの追跡

HackerSmacker の IP トラッカを使用すると、訪問者の IP やモジュール アクセスを追跡して、特定の IP アドレスを使用しているユーザを特定することができます。

特定の IP アドレスを追跡するには

1. メイン ウィンドウのツールバーで [マイツールボックス] ボタンをクリックして、オプション パネルの [IP トラッカ] タブをクリックします。

2. 追跡する IP アドレスを入力します。

3. [検索] をクリックします。結果は下部のボックスに表示されます。

関連トピック

  • オプション パネル - マイツールボックス


よくある質問 (FAQ)

[Q1]:HackerSmacker を正しくインストールできません。

[A]:HackerSmacker をインストールするにはコンピュータの管理者権限が必要になります。

[Q2]:HackerSmacker をアンインストールしたいのですが、管理者パスワードを忘れてしまったためアンインストールできません。

[A]: パスワードを忘れてしまった場合でも、HackerSmacker のインストール時に入力したシリアル番号を代わりのパスワードとして使用することができます。

[Q3]:HackerSmacker をインストールしましたが、ネットワーク上の共有フォルダ/ファイルへの他のユーザからのアクセスをブロックできません。

[A]:HackerSmacker のセキュリティ レベルが [低] または [中] に設定されていない確認してください。デフォルトのセキュリティ レベルは [中] です。LAN 上の共有フォルダ/ファイルへの他のユーザからのアクセスをブロックするには、セキュリティ レベルを [高] に設定する必要があります。なお、セキュリティ保護のため、インターネットを介したコンピュータからは、HackerSmacker のセキュリティ レベル (低/中/高) の設定に関係なく、共有フォルダ/ファイルにアクセスできないようになっています。

[Q4]:メール、ftp、http、smtp 用のポートを開く方法を教えてください。

[A]:これらのポートは、ポート管理機能を使用して開くことができます。ポート管理機能を使用するには、[ファイアウォール] オプション パネルの [セキュリティ レベル] タブで [追加設定] をクリックして、[ポート管理] タブを開きます。詳細については、「ポート管理」を参照してください。

[Q5]: HackerSmacker ではウィルスの攻撃からコンピュータを保護できますか?

[A]:HackerSmacker はアンチウィルス ソフトウェアではありません。ハッカーからの攻撃を検知してコンピュータを保護することはできますが、ウィルスからの攻撃には対処できません。

[Q6]:HackerSmacker に電子メール セキュリティに関する機能は備わっていますか?

[A]:現時点では、電子メール セキュリティに関する機能は備わっていませんが、将来のバージョンでの実装が検討されています。

[Q7]:HackerSmacker のセキュリティ レベルはカスタマイズ可能ですか?
[A]:HackerSmacker では、異なるセキュリティ要件を満たせるよう、3 種類のセキュリティ レベル (低/中/高) を設定できるようになっています。セキュリティ レベルを変更するには、スライドを上下にドラッグするだけです。なお、ユーザ定義の高度なセキュリティ ルールを作成することはできません。

[Q8]:Windows 2000 サーバで HackerSmacker を使用することはできますか?

[A]:HackerSmacker では、サーバ コンピュータの動作異常を引き起こす可能性のある 1024 より小さいポートを保護する仕様になっています。そのため、Windows 2000 サーバで HackerSmacker を使用することはお勧めできません。

[Q9]:ポップアップ ブロッカを有効にしましたが、一部の広告はまだ表示されます。

[A]:HackerSmacker のポップアップ ブロッカではほとんどの種類の広告をブロックできますが、ブロックできない広告も若干存在しています。

[Q10]:ポップアップ ブロッカによるポップアップ広告のブロックは、すべての Web ブラウザに対応していますか?

[A]:現時点では、Windows Internet Explorer 5.5 以上を使用している必要があります。将来のバージョンでは、その他のブラウザでも対応予定です。


テクニカル サポートと製品アップグレード

Hacker Smacker のテクニカル サポートおよび製品アップグレードのお問い合わせについては、FarStone Web サイト (www.farstone.com) のオンライン フォームからご連絡ください。なお、HackerSmacker 日本語版のテクニカル サポートは、株式会社ネクステッジ テクノロジー (contact@nextEDGEtech.com) によって提供されています。

参考のため、このヘルプ ファイルの「よくある質問 (FAQ)」のほかにも、FarStone Web サイトに最新の FAQ 集 (http://www.farstone.com/home/ensite/support/faqfw.shtml) が用意されています。テクニカル サポートへのお問い合わせの前に、これらの情報をご確認ください。

テクニカル サポート窓口

英語圏内

http://www.farstone.com/home/en/shtml/support_ticket.shtml

日本国内

contact@nextEDGEtech.com


使用許諾契約書

重要 - 以下の契約書を注意してお読みください。
本使用許諾契約書 (以下「本契約書」といいます) は、HackerSmacker およびその関連資料 (以下「本ソフトウェア」) に関してお客様と FARSTONE TECHNOLOGY, INC. (以下「FARSTONE」といいます) との間で締結される法的な契約書です。本ソフトウェアをインストールおよび使用することによって、お客様は本契約書の条項に拘束されることに同意されたものとします。同意されない場合は、本ソフトウェアのご使用をお控えください。

1. 使用許諾
お客様が本契約書のすべての条項を厳守される場合に限り、FARSTONE はお客様に対し、(a) 本ソフトウェアを 1 台のコンピュータにインストールして使用すること、および (b) 保管用として本ソフトウェアの複製を 1 部作成することを許諾します。

2. 制限
お客様は、本契約書で明示的に規定されている場合を除き、(a) 本ソフトウェアをレンタル、リース、貸与、サブライセンス、譲渡、またはその他の方法で再頒布すること、(b) 本ソフトウェアをリバース エンジニアリング、逆コンパイル、または逆アセンブルすること、(c) 本ソフトウェアを改変すること、および (d) 本ソフトウェアを必要以上に複製することは禁止されています。

3. 権利の留保
FARSTONE は、お客様に対して明示的に許諾していない権利をすべて留保します。FARSTONE は本ソフトウェアに関するすべての権利 (著作権を含みます) を保有しています。本ソフトウェアは許諾されるもので、販売されるものではありません。

4. 契約の終了
お客様が本契約書の条項に違反した場合、FARSTONE は、他の権利を害することなく本契約を終了することができます。

5. 免責
FARSTONE は、本ソフトウェアを何等保証もない現状有姿のまま瑕疵を問わない条件で提供しています。そのため、FARSTONE は、本ソフトウェアに関するいかなる保証 (商品性、特定の目的に対する適合性、信頼性または可用性、応答の的確性、使用結果、職人的努力、および過失の不存在についての保証、義務または条件を含みますがこれらに限定されません) も、明示、黙示、もしくは法律上のものであるかを問わず一切いたしません。本ソフトウェアの使用もしくは機能から生じるすべての危険は、お客様が負担しなければなりません。

6. その他の損害に関する免責
法律上許容される最大限において、FARSTONE およびその供給者は、本ソフトウェアの使用もしくは使用不能から生じる直接損害、間接損害、特別損害、付随的損害、懲罰的損害、または派生的損害 (逸失利益、機密情報もしくはその他の情報の喪失、事業の中断、設備の損傷、プライバシーの喪失、またはその他の金銭的損失を含みますがこれらに限定されません) に関して、たとえ、FARSTONE がこのような損害の可能性について示唆していた場合であっても、一切責任を負いません。

7. 責任および救済手段の制限
いかなる理由において生じる損害 (すべての直接損害または間接損害を含みますがこれらに限定されません) にもかかわらず、本契約書に基づく FARSTONE の責任およびお客様に対する唯一の救済手段は、合理的な信頼に基づくお客様の実際の損害額 (本ソフトウェアについてお客様が実際に支払った金額を上限とします) を限度とします。

8. 準拠法
本契約書は、日本国法に準拠するものとします。ただし、本ソフトウェアを日本以外で入手された場合は、各国・各地域の法律に準拠するものとします。

9. 完全合意、分離可能性
本契約書は、本ソフトウェアに関するお客様と FARSTONE との間の完全なる合意であり、本ソフトウェアに関する、以前のすべての口頭または書面 (オンラインでの書面または電子メールでの書面も含みます) による意思表示、提案、表明よりも優先して適用されます。FARSTONE のポリシーまたは声明の条項が本契約書の条項と異なる場合は、本契約書の条項が適用されます。本契約書の一部の条項が無効となったり、法的な強制力を失ったり、あるいは非合法と判断された場合でも、その他の条項には影響を与えることなく完全に有効性が保たれるものとします。

-------------以下、英文-------------

FARSTONE TECHNOLOGY, INC. (FARSTONE) END USER LICENSE AGREEMENT FOR HackerSmacker, HEREAFTER REFERRED TO AS THE "SOFTWARE"

PLEASE READ CAREFULLY: THE USE OF THIS "SOFTWARE" IS SUBJECT TO THE "SOFTWARE" LICENSE TERMS OF FARSTONE AND OTHER LICENSORS WHOSE SOFTWARE MAY BE BUNDLED WITH THIS PRODUCT.

BY YOUR USE OF THE "SOFTWARE" INCLUDED WITH THIS PRODUCT YOU AGREE TO THE LICENSE TERMS REQUIRED BY THE LICENSOR OF THE "SOFTWARE", AS SET FORTH BELOW. IF YOU DO NOT AGREE TO THE LICENSE TERMS APPLICABLE TO THE "SOFTWARE", YOU MAY RETURN THE ENTIRE UNUSED PRODUCT FOR A FULL REFUND.

LICENSE AND WARRANTY:

The software that accompanies this license (the "Software") is the property of FARSTONE or its licensors and is protected by copyright law. While FARSTONE continues to own the Software, you will have certain rights to use the Software after your acceptance of this license. Except as may be modified by a license addendum which accompanies this license, your rights and obligations with respect to the use of this Software are as follows:

A. Single User License:

(a) use the "Software" on a single computer system or network, and only by a single user at a time. If you wish to use the "Software" for more users, you will need an additional License for each user.

(b) make one copy of the "Software" in machine-readable form solely for back-up purposes, provided you reproduce FarStone's copyright proprietary legends. Notwithstanding the foregoing, the "Software" may be used on the home, laptop or other secondary computer of the principal user of the "Software", and an additional copy of the "Software" may be made to support such use. As used in this License, the "Software" is "in use" when it is either loaded into RAM or installed on a hard disk or other permanent memory device. The "Software" may be "in use" on only one computer at any given time. (Different License terms and fees are applicable for networked or multiple user applications.) As a specific condition of this License, you agree to use the "Software" in compliance with all applicable laws, including copyright laws, and that you will not copy, transmit, perform or distribute any audio or other content using the "Software" without obtaining all necessary Licenses or permissions from the owner of the content.

B. Multiple User License: Make one copy of the "Software" in machine-readable form solely for back-up purposes, provided you reproduce FarStone's copyright proprietary legends.

You must acquire and dedicate a License for each separate computer on which any part or portion of the "Software" is installed or run As used in this License, the "Software" or any part or portion of the "Software" is "in use" when it is either loaded into RAM or installed on a hard disk or other permanent memory device including any networked or shared environment where either direct or indirect connections are made through software or hardware which pools or aggregates connections.

As a specific condition of this License, you agree to use the "Software" in compliance with all applicable laws, including copyright laws, and that you will not copy, transmit, perform or distribute any audio or other content using the "Software" without obtaining all necessary Licenses or permissions from the owner of the content.

C. Restrictions:You may not distribute copies of the "Software" to others or electronically transfer the "Software" from one computer to another over a network. You may not post or otherwise make available the "Software", or any portion thereof, in any form, on the Internet. You may not use the "Software" in a computer service business, including in time-sharing applications. The "Software" contains trade secrets and, in order to protect them, you may not decompile, reverse engineer, disassemble, or otherwise reduce the "Software" to a human-perceivable form. YOU MAY NOT MODIFY, ADAPT, TRANSLATE, RENT, LEASE, LOAN, RESELL FOR PROFIT, DISTRIBUTE, NETWORK OR CREATE DERIVATIVE WORKS BASED UPON THE "SOFTWARE" OR ANY PART THEREOF.

D. Limited Warranty: FarStone warrants that the media on which the Software is distributed will be free from defects for a period of thirty (30) days from the date of delivery of the Software to you. Your sole remedy in the event of a breach of this warranty will be that FarStone will, at its option, replace any defective media returned to FarStone within the warranty period or refund the money you paid for the Software. FarStone does not warrant that the Software will meet your requirements or that operation of the Software will be uninterrupted or that the Software will be error-free.

THE ABOVE WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO STATE.

E. Limitation of Liability: IN NO EVENT WILL FARSTONE OR ITS LICENSORS BE LIABLE TO YOU FOR ANY INCIDENTAL, CONSEQUENTIAL OR INDIRECT DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR LOSS OF DATA, EVEN IF FARSTONE OR A LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. Some states do not allow the exclusion or limitation of special, incidental, or consequential damages, so the above limitation or exclusion may not apply to you.

F. General: You acknowledge that you have read this Agreement, understand it, and that by using the "Software" you agree to be bound by its terms and conditions. You further agree that it is the complete and exclusive statement of the agreement between FarStone and you, and supersedes any proposal or prior agreement, oral or written, and any other communication between FarStone and you relating to the subject matter of this Agreement. No additional or any different terms will be enforceable against FarStone unless FarStone gives its express consent, including an express waiver of the terms of this Agreement, in writing signed by an officer of FarStone. You assume full responsibility for the use of the "Software" and agree to use the "Software" legally and responsibly.

Should any provision of this Agreement be declared unenforceable in any jurisdiction, and then such provision shall be deemed severable from this Agreement and shall not affect the remainder hereof. FarStone reserves all rights in the “Software?not specifically granted in this Agreement.

Should you have any questions concerning this Agreement, you may contact FarStone by writing to:

FarStone Technology, Inc.

Legal Department

15Hammond,Suite304

Irvine, CA 92618

© 2003-2004 FarStone Technology, Inc. All rights reserved.


コンピュータのすべてのトラフィックをブロック

すべてのトラフィックをブロックすると、自分のコンピュータと他のコンピュータとの間の通信が完全に遮断されます。通信を完全に遮断することで、コンピュータが何らかの攻撃を受けている場合、トロイの木馬が無断で個人情報を送信している場合、不正なユーザがコンピュータへのアクセスを試みている場合など、その被害を最小限に留めることができます。

この機能を使用すると、コンピュータ間のすべての通信が停止し、外部からは一切アクセスできなくなります。

この機能は、何らかのセキュリティ上の問題を発見した場合に、一時的措置として使用することを意図して用意されています。問題が解決すれば、コンピュータ間の通信を簡単に回復することができます。

すべてのインターネット トラフィックを停止するには

HackerSmacker のメイン ウィンドウの [image] ショートカットの左側のボタンをクリックするだけです。

このボタンをクリックすると、赤ランプが点灯し、すべてのトラフィックが停止します。トラフィックを元の状態に回復するには、ショートカットの中央のボタンをクリックします。

関連トピック

  • ショートカット