概要

この製品は、ウェブ開発者、デザイナ、インストラクタ、ホーム ユーザを含むあらゆるタイプのユーザに提供できるようデザインされています。

Flash Video MXは、ビデオ ファイルや DVD ファイルを Internet Explorer 上で高品質で再生可能な小さなサイズの Flash ファイルに変換する、使いやすくプロフェッショナルなプログラムです。このプログラムは、ほとんどあらゆる種類のビデオ ファイルに対応しています。Flash Video MX を使用して、特別なエフェクト、動画のオープニングとエンディングを追加したり、ビデオ品質、フレーム レートおよびオーディオ エフェクトを編集したり、Flash ファイルに多機能なコントロール バーを追加したり、元のオーディオをお気に入りの音楽に置き換えて Flash ファイルを出力したりすることができます。ビデオ ファイルの Flash ファイルへの変換は 2、3 度クリックするだけで終わります!

Moyea Flash Video MXのメイン インタフェース:

ビデオ ファイルを Flash ファイルに変換するプロフェッショナルなプログラム、Flash Video MX へようこそ!


主な特長

◆多機能の Flash 再生コントロール バー
停止ボタン、音量調節およびプロセス バー、プリローダなどのさまざまなパラメータを使用して、ユーザ独自のコントロール バーを指定できます。パラメータを変更することにより、再生前に動画をプリロードしたり、十分なデータが累積したときに動画を再生したり、ループ再生することができます。

◆SWF 圧縮により高品質の変換を実現
効率的な変換プログラミング アルゴリズムにより、ファイル サイズを最小にして、最高の画質が得られます。

◆使いやすい
非常に使いやすいユーザ インタフェースにより、使い方を学ぶ必要もなく、すぐにビデオ ファイルを Flash ファイルに変換できます。

◆ユーザがオープニングおよびエンディングとして Flash ファイルを追加し、選択したオープニングの前および選択したエンディングの後にビデオ ファイルを追加することができます。
ユーザーが導入部とクレジットを動画のオープニングとエンディングに追加することができます。動画のオープニングと選択したビデオの始点との間にビデオファイルをビデオ フィーチャーとして追加できます。

◆プレビュー機能により、ビデオを簡単かつ正確にキャプチャ
Flash ファイルの最初のフレームと最後のフレームを正確にキャプチャします。ビデオ ファイル、ロゴ、キャプション、オープニングとエンディングを別々にプレビューし、Flash 動画をすばやく簡単に編集できます。

◆複数のビデオおよびオーディオ オプションを含み、自分のプロジェクトを保存
フレーム レートとビデオ サイズを調整できるため、望みどおりの最高のエフェクトを持つ再生を実現できます。元の音声の音声サンプル レート、ビット レート、オーディオ チャンネル、フェードイン / フェードアウト エフェクトおよび音量を変更できます。プロジェクトで共通に使用される設定により、選択が簡単になります。プロジェクトには、Flash Video MX で設定したすべての設定 (ソース ビデオのファイル パス、ビデオおよびオーディオ設定、プレーヤー設定、透過、動画のオープニングとエンディングなど) が保存されます。

◆アニメート ロゴ、透明な背景およびキャプション
Flash Video MX では、ビデオに画像 (サポート アニメーション) および透過テキストを追加できます。透過を表示する場所を決め、透過の位置を決めることができます。画像の透過は、PNG や GIF などの透過属性を持つ画像に対応しています。GIF アニメーションを使用して、アニメートした透過を作成できます。

◆強力で使いやすいバッチ機能を含む
複数のファイルを一度に変換できるため、多数のファイルの変換が容易に行えます。

◆多彩な出力ファイル オプション
Flahs Video MX では、SWF、FLV、HTML、JPG ファイルなどの複数のファイル タイプを使用できます。アクセサリ ファイルを作成するかどうかを選択できます。

◆ビデオの切り取りと特別なビデオ エフェクトの追加
選択するオフセットを設定してビデオのコンテンツを切り取り、ビデオ上の黒い点やその他の不具合を取り除くことができます。所定の 16:9 および 4:3 のアスペクト比を基準として、ビデオのアスペクト比を設定できます。雪、星、木の葉、トンボ、金魚など、さまざまなビデオ エフェクトを使用して、ビデオをアニメーション化することができます。

-----------------------------------------------------------------------------------------------------------

Flash Video MX の中にある直接変換機能の主な特徴についても上に記載されているリストの中に含まれます。


システム要件

◆ Windows NT4.0 + SP6/2000/XP (Vista 互換)

◆ 64MB メモリ (128MB 推奨)

◆ 512MB 以上のハードディスク容量

◆ Windows 互換のモニタ (800 x 600 以上の解像度)

◆ Windows 互換のマウスとキーボード

◆ Windows 互換の Sound Blaster

◆ Microsoft DirectX 9.0 以上 ([スタート] をクリックして、[ファイル名を指定して実行] を選択し、「dxdiag」と入力すると、DirectX 診断ツールのダイアログ ボックスにバージョン番号が表示されます。)

◆ Quick Time ファイルをサポートする Quick Time 6.0 以上

◆ Windows Media Player 9.0 以上


インストールとアンインストール

試用版はリテール版とは異なるため、リテール版をインストールする場合は、まず試用版を削除してください。登録コードはリテール版でのみ有効です。登録コードおよびリテール版を入手されたい場合は、今すぐ購入をクリックして、ソフトウェアをお買い求めください。

バージョン 4.0 以上のプログラムのインストールを実行する場合は、ウィザードが Flash Video MX を既にコンピュータにインストールしているか、または Flash Video MX を実行しているかを検出して、ファイルの削除 (コンピュータにインストールされているプログラムの削除) を求めるプロンプトを表示します。[はい] をクリックすると、問題なくプログラムをインストールできます。

インストール

アンインストール


Flash Video MX のインストール

インストール

Flash Video MXをインストールするセットアップ プログラムを実行します。

ステップ 1:インストールの準備

Flash Video MX インストーラをダウンロードした後、インストールを開始するためにダブルクリックします。Flash Video MX をインストールする前にアプリケーションをすべて閉じることをお勧めします。[次へ] をクリックして、操作を続けます。

ステップ 2:ライセンス使用許諾契約書:

ライセンス使用許諾契約書を注意してよくお読み下さい。同意する場合は、[同意します] をクリックして、インストールを続けます。同意しない場合は、[同意しません] をクリックして、インストールを終了します。

ステップ 3:インストール ディレクトリ

ハードディスクに Flash Video MX ファイルを保存するディレクトリを指定します。[次へ] をクリックして、操作を続けます。

ステップ 4:開始メニュー フォルダの選択

次の開始メニュー フォルダプログラムのショートカットを作成するように選択します。[次へ] をクリックして、操作を続けます。

ステップ 5:追加タスクの選択

デスクトップ アイコンとクイック起動アイコンの作成を選択します。[次へ] をクリックして、操作を続けます。

ステップ 6:インストール準備完了

設定を変更しない場合は、[インストール] をクリックして、Flash video MXのインストールを続行します。設定を見直して変更する可能性がある場合は、[戻る] をクリックします。

ステップ 7:インストール

Flash Video MX がコンピュータにインストールされます。インストールを終了したい場合は、[キャンセル] をクリックします。

ステップ 8:インストールの終了

インストール後、すぐにプログラムを開く場合は、[アプリケーションの起動] を選択します。インストールを終了するには、[終了] をクリックします。元のインタフェースに戻るには、[戻る] をクリックします。

これで、プログラムが使用できるようになりました!


アンインストール

Windows の [スタート] メニューをクリックし、[プログラム] フォルダを選択、Flash Video MXを見つけて、[Flash Video MXのアンインストール] をクリックします。プログラムをアンインストールするかどうかを聞かれたら、[はい] をクリックします。

コントロール パネルに進んでプログラムをアンインストール (削除) することもできます。


クイック スタート

Flash ファイルを作成するための簡単なステップ

Flash Video MX を使用してビデオ を Flash 動画に変換するのは簡単です。次の 9 つの簡単なステップに従うだけですぐに開始できます。

ステップ 1:ファイルの入力

ステップ 2:ビデオの調整

ステップ 3:ビデオの切り取り

ステップ 4:ビデオおよびオーディオ設定

ステップ 5:出力ファイルとエフェクト

ステップ 6:プレイヤ設定

ステップ 7:その他

ステップ 8:動画の開始と終了

ステップ 9:変換の開始

Flash Video MX の詳細設定については、ユーザ設定およびメニューを参照してください。

FLV プレイヤの設定については、プレイヤ API を参照してください。

出力ファイルのコーデック設定については、コーデックについてを参照してください。


ファイルの入力

この章は、主に簡単で有効的なファイルの入力方法を説明します。

ビデオを読み込むには、以下の手順に従います。

ステップ 1:Flash Video MX を起動した後、 [image] ボタンをクリックします。 ドロップダウン ボタンをクリックし、[ビデオを読み込む] を選択して、MPEG、WMV、AVI、MOV、RM、VOB、3GP、DV のようなビデオ ファイルを Flash Video MX にインポートできます。下記の画像は、フォーマットの詳細を表しています。

ステップ 2:コンピュータのハードディスクまたは周辺機器から変換するファイルを見つけます。ファイルを選択した後で右下の [開く] ボタンをクリックするか、ファイルをダブルクリックして、プログラム に入力します。

ビデオ ファイルを追加した後、ビデオは自動的に再生され、[動画のプロパティ] パネルにビデオのプロパティが表示されます。このプロパティには、サイズ、フレーム レート、再生時間、音声チャンネルおよび音声サンプル レートなどがあります。

入力ビデオ ファイルがコンピュータにインストールされたコーデックでサポートされている場合、ファイルはプログラムにロードされます。コンピュータに入力ファイルに対応したコーデックがない場合、適切なコーデックをダウンロードして、入力ファイルを問題なくロードできるようにすることを求めるポップアップ ウィンドウが表示されます。

-----------------------------------------------------------------------------------------------------------------------


ビデオの調整

再生: ビデオ ファイルを再生します。

一時停止: 現在のフレームでビデオの再生を停止します。

停止: ビデオの再生を停止します。

前のフレーム: 現在のビデオの前のフレームに戻ります。

次のフレーム: 現在のビデオの次のフレームに進みます。

始点: バーをドラッグして、変換するビデオの始点を設定します。[開始時間] フィールドに有効な値を入力し、 [image] を押して、ビデオを開始する正確な時間を設定することもできます。

終点: バーをドラッグして、変換するビデオの終点を設定します。[終了時間] フィールドに有効な値を入力し、 [image] を押して、ビデオを終了する正確な時間を設定することもできます。

注:

緑色の線は、変換を選択した部分を示します。始点と終点を設定すると、Flash Video MX は、選択した部分だけを再生します。

始点を設定する: 現在のフレームを変換するビデオの始点に設定します。

終点を設定する: 現在のフレームを変換するビデオの終点に設定します。

サムネイル: 現在のフレームを Flash のサムネイルとして設定します。キャプチャしたフレームをサムネイル パネルに表示できます。

[サムネイル] パネルで画像をクリックして、ファイル フォーマット、圧縮およびサムネイル ファイルのサイズなどのサムネイル設定を変更できます。[ファイル] > [ユーザー設定] を選択して、関連設定を変更することもできます。

輝度: バーをドラッグして、必要なエフェクトを選択します。デフォルトに戻すには、[リセット] を押します。

コントラスト: バーをドラッグして、必要なエフェクトを選択します。デフォルトに戻すには、[リセット] を押します。

インターレース解除:インターレース ビデオは多くのプレーヤーで完全には再生できないため、［インターレース解除］ はインターレース ビデオでインターレース アーキファクトを除去する方法の 1 つです。

反転: ビデオを縦方向に反転させます。


ビデオの切り取り

切り取り: サイズを指定します。ビデオを切り取るには、次の 2 つの方法があります。

  • 点線で囲まれたフレームをドラッグして、切り取るビデオ サイズを指定する
  • 左、右、上、下の 4 つの位置の値を調整する

ビデオの切り取り中、[切り取り画像サイズ] および [切り取りアスペクト比] を参照して、変換用に適切なビデオを切り取りできます。

すべて選択: フルサイズのビデオを選択します。


ビデオおよびオーディオ設定

ビデオ フレーム サイズ、フレーム レート、エンコード品質、オーディオ サンプリング レート、音量などのビデオおよびオーディオ設定を [ファイル設定] で指定できます。

Flash Video エンコード プロファイル: 出力ファイルに希望する品質を選択します。エンコード プロファイルを選択すると、ビデオ設定とオーディオ設定が同時に変わります。ソース ファイルのデータに応じて、[モデム品質]、[低品質]、[中品質] および [高品質] の 4 種類の設定を利用できます。それぞれの設定に異なるビデオ設定とオーディオ設定が含まれます。プリセットの設定が要件に合わない場合は、ビデオ設定とオーディオ設定を変更することもできます。設定を変更すると、プロファイルが [カスタム] に変わります。変更を行った後、設定をプロジェクトとして保存して、次回ビデオで同じ設定を行うときにこの設定を表示できます。

ビデオ設定

ビデオ エンコード プロファイル、ビデオ サイズ、フレーム レート、ビデオ エンコード品質、フェードインおよびフェードアウト エフェクトなどを設定することによって、ビデオ エフェクトを設定できます。ただし、通常はデフォルト設定で十分満足できます。ビデオ エフェクトを変更したいと思わなければ、設定を行う必要はありません。

サイズ変更:元のビデオ サイズを変更したくない場合は、このオプションをオフのままにします。幅と高さがグレイ表示になります。ビデオのサイズを変更する場合は、このボックスをオンにし、有効な値を入力するか、値を調節してビデオの幅とビデオの高さのボックス内の値を変更します。

比率を維持: ここで言う比率とは、ビデオの切り取りウィンドウから見ることのできる切り取ったビデオの縦横比です。これは、切り取ったビデオ サイズで出力ビデオ サイズを計算するのに役立ちます。[比率を維持] ボックスをオンにすると、ビデオの幅または高さを変更して、関連サイズを得ることができます。特別なビデオ サイズを設定したい場合は、[比率を維持] をオフにしてください。[比率を維持] ボックスをオンにすると、ビデオ サイズは指定した幅に応じて調整されます。

フレーム レート:元のエフェクトを維持する場合は、元の設定のままにします。ファイル サイズを小さくしたい場合は、ご使用のビデオに適切なフレームレートを選択します。

注:

フレーム レートを下げると、ビデオの動きに十分な滑らかさが得られない場合があります。

キーフレーム間のフレーム:カスタム キーフレーム設定値を選択する必要がある場合は、キーフレーム間隔を小さくすると、ファイル サイズが大きくなることに注意してください。

ビデオ コーデック:Flash Video MXで利用できるビデオ コーデックは Sorenson H.263、およびOn2 VP6の 2 種類です。Flash Video MX Pro のみが On2 VP6 with Alpha をサポートしています。Flash Video MX と DVD to Flash Video Converterはサポートしていないので注意してください。

フェードイン:ファイルが再生を開始するときに、ビデオ画像がフェードインするように設定します。

フェードアウト:再生が終了するときに、ビデオ画像がフェードアウトするように設定します。

ビデオ エンコード品質:ビデオ データの品質を選択します。品質を決めるために、[ビデオ ビット レート] および [出力ファイルの推定サイズ] を参照できます。[カスタム] を選択すると、好みに合わせてビデオ ビット レートを変更できます。通常、ビデオ ビット レートを高くすると、ファイルの品質が向上し、出力ファイル サイズが大きくなります。出力ファイル サイズが大きすぎると思われる場合は、ビデオ ビット レートを下げて、ファイル サイズを小さくすることができます。

開始前にビデオ ファイルを追加: [開始時間] で選択したビデオの開始前にビデオ ファイルを追加できます。このビデオは、動画のオープニングと選択したビデオの開始の間に表示されます。

終了後にビデオ ファイルを追加: [終了時間] で選択したビデオの終了時にビデオ ファイルを追加できます。このビデオは、選択したビデオの終了と動画のエンディングの間に表示されます。

プロパティを表示するために、広告、警告または特定のビデオを追加できます。コンテンツを好きなように充実させることができます。

オーディオ設定

作成した Flash ファイルにオーディオを含めたい場合は、[音声を収録する] をオンにします (ビデオにオーディオが含まれる場合、チェックボックスは自動的に有効になります)。サンプリング レート、オーディオ チャンネル、フェードインおよびフェードアウト エフェクトを設定できます。ただし、通常はデフォルト設定で十分満足できます。特別なオーディオ エフェクトを得たいと思わなければ、変更する必要はありません。

サンプル レート: 他のオプションを選択できる場合、使用するオーディオ データに適切なサンプリング レートを選択します。通常、[22050] および [44100] を使用できます。

ビット レート: 他のオプションを選択できる場合、使用するオーディオ データに適切なビット レートを選択します。

チャンネル: 使用するオーディオ データのオーディオ チャンネルを選択します。通常、モノラルと標準ステレオの 2 種類を利用できます。

音量: 出力音量が低すぎると思われる場合は、出力音量のパーセンテージを上げます。出力ファイルの音量として、元の音量の 25% ～ 400% を設定できます。

フェードイン:ファイルが再生を開始するときに、オーディオがフェードインするように設定します。

フェードアウト:再生が終了するときに、オーディオがフェードアウトするように設定します。

オリジナル音声の置き換え: 元のオーディオをコンピュータのハードディスクにあるオーディオ ファイルに置換します。これにより、ビデオに音楽を追加して、Flash MTV を作成できます。

音声ループ:音声をビデオの長さに合わせます。音声の再生時間がビデオよりも短い場合は、音声をリプレイすることができます。


出力設定

[出力設定] インターフェイスが表示されている場合、プレイヤは [プレイヤ設定] タブと [その他] タブの下に自動的にリアルタイムのエフェクトを表示し、画面にサムネイルを表示します。[フロート] および [取り付け] ボタンについては、プレイヤ設定を参照してください。

[出力設定] の下には、[エクスポート設定]、[プレイヤ設定] および [その他] の 3 つのタブがあります。

[エクスポート設定] により、出力ファイル名を指定し、作成されるファイルを選択できます。

エクスポート先:出力するファイル名を変更します。ポップアップ ウィンドウで出力ファイル名を変更することができます。jpg ファイル、html ファイルなどの拡張子は反映されません。

次のオプションをチェックして、Flash Video MX で関連ファイルを作成できるようにします。

FLV ファイルの作成:指定した設定で FLV ファイルを作成します。このオプションをオフにすると、[SWF ファイルの作成] が自動的にオンになります。

サムネイル ファイルの作成:出力ファイルのサムネイル ファイルを作成します。[ファイル] メニューの下のユーザー選択設定でサムネイル ファイル形式を指定できます。

SWF ファイルの作成:2 種類の SWF ファイルがあり、1 つはビデオを埋め込んだファイルで、もう 1 つは FLV ファイルを再生する FLV プレイヤです。ビデオを埋め込んだ SWF ファイルを作成するオプションをオンにすると、[その他] タブでビデオ エフェクトを追加できます。FLV プレイヤとして SWF を作成するオプションをオンにすると、ビデオ エフェクトが無効になります。オプションをオフにすると、[HTML ファイルの作成] がグレイ表示になり、[FLV ファイルの作成] オプションが自動的にオンになります。

SWF ファイルにビデオを組み込む:このオプションを選択すると、他のファイルを使用することなく SWF を再生でき、[外部 FLV ファイルを再生する] をオンにしていても、FLV ファイルが SWF ファイルと同じフォルダにあることを確認する必要はありません。

外部 FLV ファイルを再生する:このオプションで作成された SWF ファイルは FLV ファイル用のプレイヤです。FLV ファイルが SWF ファイルと同じフォルダにあることを確認する必要があります。そうしないと、SWF ファイルをダブルクリックしても、プレイヤしか取得できません。[FLV ファイルの作成] をオンにし、[外部 FLV ファイルを再生する] を選択すると、[その他] タブの下の [ビデオ エフェクト] が無効になっています。

HTML ファイルの作成: Web ページを作成し、そこからソース コードを見つけて、ユーザー独自の Web ページの関連コードを作成するために使用します。[SWF ファイルの作成] オプションがオフになっている場合、このオプションはグレイ表示になります。

独自の FLV プレイヤの使用方法について:テキストをクリックすると、SWF ファイルの FLV プレイヤとしての使用に関するページが表示されます。この FLV プレイヤとしての SWF ファイルは、Web サイトで複数の FLV ファイルを再生するために適用できます。このオプションはリテール版でしか使用できない点に注意してください。

最初のフレームの jpg ファイルを出力用に作成する ("出力ファイル名"+"_FirstFrame.jpg"):このオプションをオンにした場合、最終出力ファイル名で始まり、"_FirstFrame" で終わる jpg ファイルが作成されます。たとえば、最終出力ファイル名が "MagLev" の場合、生成されるファイルは MagLve_FirstFrame.jpg になります。出力ビデオと同じサイズのこのファイルは、作成された FLV ファイルまたはビデオを埋め込んだ SWF ファイルと同じフォルダに置くと自動的にビデオに統合できます。

最初のフレームのファイルとサムネイル ファイルの違い:
1. ファイル名:最初のフレーム ファイルのファイル名はﾌﾟレフィックスとして出力ファイル名、サフィックスとして "_FirstFrame" を含み、一方、サムネイル ファイル名は Flash 出力ファイルと同じです。
2. 画像サイズ:最初のフレーム ファイルの寸法 (幅と高さ) は、Flash ファイルの寸法と同じになります。サムネイル ファイルの幅と高さは、[ファイル] > [ユーザー設定] を選択するか、[サムネール] ボタンをクリックした後、[サムネイル] パネルで画像をダブルクリックして指定できます。
3. 機能:最初のフレーム ファイルはビデオに自動的に統合して、ビデオの冒頭に黒い画面が表示されるのを防ぐことができます。サムネイル ファイルは、HTML コードを変更して、ビデオの最初のフレームとして使用できます。サムネイルの画像サイズを変更できるため、ビデオの内容を紹介する画像として使用できます。


プレイヤ設定

フロート:プレイヤでポップアップ ウィンドウを表示し、このウィンドウで [ファイル設定] で設定したサイズでビデオをプレビュー表示できます。ウィンドウをドラッグして、スケール モード、最小幅および最小高さが自分のニーズに合うかどうかを確認できます。

プレイヤ上でマウスを右クリックし、メソッドを選択することにより、ウィンドウを常にウィザード プログラムの上部に表示するかどうかを指定できます。ウィンドウが上部に表示されるように設定されている場合、ビデオを右クリックすると、ウィンドウを上部に表示するコマンドを無効にするために使用する [標準] オプションが表示されます。ウィンドウが標準に設定されている場合、右クリック メニューは [上部に表示] になります。

ポップアップ ウィンドウが表示されると、[フロート] ボタンが [取り付け] に変わります。

取り付け:ポップアップ ウィンドウをウィザード プログラムにもう一度挿入します。ポップアップ ウィンドウの右上隅の [閉じる] ボタンをクリックすることにより、ポップアップ ウィンドウをもう一度挿入することもできます。ウィンドウがもう一度挿入されると、[取り付け] ボタンが [フロート] ボタンに置き換わります。

[プレイヤ設定] タブの下で、右列の詳細な説明により、プレイヤのコントロール バーのスタイルと対応するパラメータを指定できます。

Flash プレイヤ プロファイルの選択:プレイヤの通常使用のためにプリセットのプロファイルの 1 つを選択します。このプロファイルには、プロファイル名のすぐ下の設定 ([スケール モード]、[コントロール バー設定]、[クリック ナビゲーション] に関する設定) および同じ列のその他のパラメータだけが含まれます。選択されたコントロール バーのスタイルは、このプロファイルには含まれません。

名前を付けて保存:指定した変更を任意のプロファイル名で新しいプロファイルに保存します。ドロップダウン メニュー ボタンをクリックすると、[保存]、[名前を付けて保存]、[名前の変更]、および [削除] が表示されます。プリセットのプロファイルでは、使用できるのは [名前を付けて保存] だけです。

コントロール バー:コントロール バーのスタイルを選択します。コントロール バーを含めない場合は、[なし] を選択します。ニーズに合うように新しいコントロール バーが追加されます。[なし] を選択すると、[コントロール バー設定] がグレイ表示になります。

中央の列では、プレイヤに関するさまざまなパラメータを利用できます。リストにいくつかのパラメータがあります。 をクリックして、FLV プレイヤの使い方に関するページで他のパラメータを見ることもできます。

注:

自動巻戻しには優先順位が設定されています。自動巻戻しをオンにした場合、大きな [再生] ボタンまたは [リプレイ] ボタンが無効になり、ビデオがループ再生されます。

[リプレイ] ボタンや大きな [再生] ボタンなどの一部のパラメータは、同時には実現できません。[リプレイ] ボタンを表示するように選択すると、大きな [再生] ボタンのスタイルが自動的に [なし] に設定されます。大きな [再生] ボタンの表示を選択すると、[リプレイ] ボタンのチェックボックスがオフになります。

一部のパラメータ ([映像上にプレイヤを配置]、[プレイヤを自動非表示]、[ディレイの非表示] など) は、1 つにまとめられています。[映像上にプレイヤを配置] をオンにすると、他の 2 つのオプションも有効になります。

参考のために、下に一部のパラメータを示します。

コントロール バー設定

プレイヤの整列:コントロール バーを画面の上または下に表示します。

映像上にプレイヤを配置:コントロール バーをビデオの画面上に表示します。このオプションがオンの場合、[プレイヤの自動非表示] 機能も自動的にオンになります。[プレイヤの自動非表示] をオフにすることもできますが、ビジュアル エフェクトに影響が出る場合があります。

プレイヤの自動非表示:コントロール バーを表示しておく時間を設定します。一定時間内にカーソルが画面に移動しない場合、コントロール バーが画面に表示されなくなります。

パネル カラー:ビデオに合った好みの色を選択します。

音量:ファイルの再生が始まるときに表示されるコントロール バー上の音量バーの初期パーセンテージ値を設定します。オーディオ設定で音量を設定してある場合、このオプションで設定するパーセンテージがオーディオ設定の音量のパーセンテージになります。

一時停止モード

最初のフレームで一時停止:ビデオの最初のフレームで画面を停止させます。動画のオープニング設定を選択した場合、ビデオを再生するコマンドを実行するか、[再生] ボタンをクリックするまで、動画のオープニングがループ再生されます。

最後のフレームで一時停止:ビデオの最後のフレームで画面を停止させます。動画のエンディング設定を選択すると、プレイヤは、ビデオが最後まで再生されたときに動画のリプレイを停止することができます。

注:

コントロール バーを選択せずに、[最初のフレームで一時停止] を適用すると、他の方法でビデオ ファイルの再生を続行しなければなりません。プリローダーまたは自動巻戻しが選択されていると、最初のフレームでの一時停止が機能しない場合があります。

リプレイ

リプレイを表示:ビデオが最後に達したときに、[リプレイ] ボタンを表示します。[最初のフレームで一時停止] または [最後のフレームで一時停止] をオンにしないでこのオプションをオフにした場合、画面はビデオの最初のフレームに戻ります。

テキスト再生:[リプレイ] ボタンに表示する文字を入力します。

大きい再生ボタン:ビデオの再生を一時停止または停止するときに、大きな再生ボタンのスタイルを表示します。大きな再生ボタンのさまざまなスタイルを比較したい場合は、コントロール バーの [一時停止] ボタンをクリックして、大きな再生ボタンを表示できます。最初のフレームで一時停止するように設定し、大きな再生ボタンのスタイルを選択して、エフェクトを比較することもできます。

プリローダー:[なし] 以外のプリローダーのスタイルを選択して、ビデオ全体がロードされた後に、ビデオ全体を再生するようにします。プリローダーのエフェクトを比較するには、[自動ロード] のチェックボックスをオフにします。

バッファ時間:データを再生する前にバッファする時間を設定します。十分なデータがダウンロードされない場合、Flash プレイヤは Flash データ全体のロードを待つことなく、再生を開始します。

アスペクトを維持:[アスペクトを維持] がオンで [スケール モード] が [ステージ] のときにウィンドウをドラッグすると、コントロール バーがステージに合わせて幅を広げ、ビデオはアスペクト比を維持し、必要に応じて境界線が追加されます。


その他

ユーザ キャプション:ビデオにキャプションを追加します。この機能をオフにすると、下記のユーザ キャプションに関するオプションがグレイ表示になります。

キャプション:ビデオにユーザの所有権を示すために表示するテキストを入力します。入力した文字に関する詳細オプションを利用する場合、 [image] ボタンをクリックして、好みのフォントを選択します。

配置:キャプションの原点の位置を選択します。通常、9 つのオプションを利用できます。

補正:値を変更して、キャプションの正確な位置を指定します。

ロゴ:ビデオにロゴ / 透過を追加します。[参照] ボタンをクリックして、ハードディスクからロゴ アイコンを選択します。アニメーションがサポートされていますが、ロゴのアニメート エフェクトは出力にしか表示されません。

配置:ロゴの原点の位置を選択します。

補正:値を変更して、ロゴの正確な位置を指定します。[上] および [左] は原点からの距離、[幅] および [高さ] はロゴのサイズを表します。

注:

真ん中の [image] を「押し下げた」状態の場合、透過画像の元のアスペクト比を維持します。

透明:色を透明に設定したくない場合は、[なし] をクリックします。[選択] をクリックすると、透明度に関するポップアップ ウィンドウが表示されます。透明色を選択する方法は 2 つあります。

  • マウスを使って左の画像から画素をクリックすると、ウィンドウの左下部分に色が表示されます。
  • 画像で使用できる場合は、[R] (赤)、[G] (緑) および [B] (青) のボックスの値を変更して、透明色を設定します。

許容誤差:バーをドラッグして、透明色の許容誤差を変更し、好みのエフェクトを獲得します。

ビデオ エフェクト:雪、花、木の葉などのアニメートしたエフェクトをビデオに追加できます。[ビデオ エフェクト] ドロップダウン メニューをクリックして、好みのエフェクトを選択します。Flash Video MX の Web サイトで適宜、追加のエフェクトをリリースしていきます。Flash Video MX の Web サイトにアクセスして、いつでも無料でビデオ エフェクトを更新していただくことができます。SWF ファイルが選択されていなくても、プレビュー パネルでビデオ エフェクトをプレビューできます。ただし、[エクスポート設定] タブでいずれかの種類の SWF ファイルを選択すると、出力 SWF ファイルでビデオ エフェクトが有効になります。

背景カラー:出力ファイルの背景色を設定します。

注:

FLV のキュー ポイントを指定する場合、左下隅の [バッチ エンコーダ] をクリックして、Flash Video MX バッチ エンコーダ を使用してください。開始メニュー フォルダの下にある Flash Video MX バッチ エンコーダ ショートカットをクリックして、バッチ エンコーダを実行することもできます。

1 度に実行できるのは、1 つのプログラムだけです。[バッチ エンコーダ] をクリックすると、プログラムからウィザード プログラムを終了することを通知されます。


動画の開始と終了

開始設定と終了設定は、ビデオを埋め込んだ SWF ファイルを生成するオプションを選択した場合にだけ使用できます。

フロート:動画のオープニングと動画のエンディングのエフェクトをポップアップ ウィンドウでプレビュー表示します。

取り付け: ウィンドウをウィザード プログラムにもう一度挿入します。

テンプレート:動画のオープニングまたは動画のエンディングを追加しない場合は、[なし] を選択します。[なし] の下の他のテンプレートをクリックして、動画のオープニングと動画のエンディングの設定を変更できます。異なるテキスト フォントとビデオ エフェクトで他のテンプレートを追加して、参照用に名前を変えることができます。また、追加したテンプレートを削除できます。

映像開始の設定:[映像開始の設定] にはタイトル、ディレクタおよび説明が含まれます。動画の作成情報や簡単な紹介を追加することができます。 をクリックして、好きなフォントを選択できます。情報を入力した後、[再生] ボタンをクリックして、エフェクトをプレビューします。

テキスト エフェクト: 好みのエフェクトを選択します。[サークル]、[サークル イン]、[サークル ウェーブ イン] など複数のエフェクトを使用できます。

背景: 動画のオープニングの背景の色を設定します。画像または Flash を動画の開始時の背景として選択できます。[カラー] をクリックして、フェードインする背景の色を選択します。

ストレッチ: 画像 / Flash のアスペクト比が出力ファイルのアスペクト比と異なる場合に、背景の画像 / Flash を出力ファイルの画面いっぱいに表示します。背景に [なし] を選択した場合は、このオプションはグレイ表示になります。

アスペクト比:背景画像のアスペクト比を保ちます。表示画面の比率が画像 / Flash の比率と異なる場合、このオプションをオンにすると、出力ファイルのアスペクト比と背景のアスペクト比に応じて、画像 / Flash が画面の横方向および縦方向に引き伸ばされ、境界線が追加されます。背景に [なし] を選択した場合は、このオプションはグレイ表示になります。

テキスト エフェクト: パネルの横にある [再生] ボタンをクリックして、指定した設定でエフェクトをプレビューできます。

映像終了の設定: 動画のクレジット、スポンサー情報などをエンディングとして追加できます。 をクリックして、好きなフォントを選択することもできます。また、テキスト エフェクトと背景設定を指定できます。情報を入力した後、[再生] ボタンをクリックして、エフェクトをプレビューできます。


変換の開始

変換の開始:すべての設定を終えた後、[開始] をクリックして変換を開始すると、変換の終了を知らせるメッセージが表示された後に、指定したディレクトリにファイルが作成されています。出力フォルダは自動的に開きます。

変換をキャンセルしたい場合は、[キャンセル] をクリックします。

Flash Video MXによって変換されたビデオ ファイルは、Macromedia Flash バージョン 7.0 以上で再生できます。


ユーザ設定

右上隅の [ファイル] ボタンをクリックし、[ユーザ設定] をクリックすると、サムネイル設定と Flash 設定の確認を求めるポップアップ ウィンドウが表示されます。

サムネイル出力フォーマット: JPEG、GIF、および BMP を使用できます。サムネイル画像の詳細設定を見るには、 [image] ボタンをクリックします。

  • バーを希望するエフェクトの下にドラッグし、バーの下のボックスの値を参照します。
  • バーの下のボックスの値を調整します。この値は圧縮の比率を示しています。

サムネイル サイズ: 希望のスタイルを選択し、サイズを画素または実際のサイズで選択します。[サイズ (px)] を選択すると、[幅] と [高さ] だけを使用できます。[実/印刷サイズ] を選択すると、[単位] と [解像度] が表示されます。

ビデオ設定: このオプションは、[サイズ変更] オプションの [元の比率を維持] チェックボックスをオフにした場合にだけ機能します。出力ファイルのサイズが切り取ったファイルのサイズと一致しない場合は、ドロップダウン リストをクリックしてファイルを引き伸ばすか、画像の元の縦横比を維持することができます。

引き伸ばす: 出力ビデオの画面のフルサイズまで画像を引き伸ばします。出力アスペクト比がクロップしたアスペクト比と異なると、画像がゆがむ場合があります。切り取り後のアスペクト比は、ビデオの切り取りウィンドウで見ることができます。出力アスペクト比は、ビデオ設定で設定したビデオ サイズから求められます。

元の比率を維持: 画像のアスペクト比を維持します。このオプションを選択すると、画像をゆがませることなく、縦または横に引き伸ばして画面サイズに合わせます。

swf 出力ファイルのバージョン番号: ファイルの SWF バージョンの "8"または "7" を選択します。

出力 swf ファイルを圧縮する: 指定したフォルダにファイルを生成する前に swf ファイルを圧縮するかどうかを選択します。

出力ファイルの上書き: 出力ファイル名が出力フォルダにあるファイルの名前と同じである場合は、必要に応じて、[問い合わせ]、[スキップ]、[置換] または [名前の変更] を選択します。

問い合わせ: 同一の名前が検出されると、ファイルの名前を変更するか、ファイルを上書きするか、変換をキャンセルするかの操作を選択するように求めるポップアップが表示されます。[問い合わせ] をオンにすると、下記のポップアップ ウィンドウのオプションは無効になりません。

スキップ: このオプションは、バッチ エンコーダの場合のみ有効です。シングル エンコーダでは、[スキップ] オプションは [名前の変更] オプションと同じです。

置換: 宛先フォルダのファイルを作成したファイルに置換します。

名前の変更: プログラムは、元の名前をプレフィックスとし、順番に番号を追加するという規則で、自動的に有効な名前を作成します。現在のファイル名と番号の間には、アンダースコア (_) が入ります。

ポップアップ ウィンドウを表示しないようにするオプションのチェックボックスをオンにした場合、[スキップ]、[置換] および [名前の変更] オプションだけを使用できます。このオプションには、操作およびポップアップ エラー メッセージの選択を求める照会メッセージが含まれます。このオプションをオフにして、[スキップ]、[置換] または [名前の変更] を選択すると、エラーが発生したときに、エラー メッセージで通知されます。変換時にポップアップ ウィンドウを表示しないようにするチェックボックスをオンにした場合、プログラムは自動的にユーザが上で選択する指示に従う可能性があります。

注:

このボックスをオンにすると、選択できるのは [スキップ]、[置換] または [名前の変更] だけです。


メニュー

ファイル:右上隅の [image] ボタンをクリックすると、[プロジェクトを開く]、[保存]、[名前を付けて保存]、[ユーザー設定] および [終了] オプションが表示されます。Alt + F キーを押して、オプションを表示することもできます。

プロジェクトを開く:[ファイル] ボタンをクリックし、[プロジェクトを開く] をクリックして、保存したプロジェクトを参照します。ファイルをクリックした後、キーボードで O キーを押してブラウザを開くこともできます。ソース パスに保存したソース ファイルが削除されたり、他のフォルダに移されると、プログラムからソース ファイルが存在しないことが通知され、プロジェクトをロードできません。

保存:シングル エンコードで .fvx 拡張子を付けて、すべての設定をプロジェクトとして保存します。カスタマイズした設定を保存して、プログラムを実行するときにプロジェクトを開くことができます。ソース ファイルのパス、開始時間、輝度、切り取り設定、ユーザー設定、ビデオ サイズ、オーディオ サンプリング レート、コントロール バーの設定、出力設定、オープニングとエンディングなど、これらはごく一部ですが、これらの設定を含め、あらゆる設定を保存します。

名前を付けて保存:プロジェクトを開いて、設定を変更したら、現在の設定を新しいプロジェクトとして保存できます。プロジェクトで定義した特定の名前が同じプロジェクトに存在せず、ロードされる場合、プログラムは別の名前または別のファイル パスとして保存することを通知します。

ユーザ設定:プログラムでユーザー設定を編集します。SWF 圧縮でサムネイルの詳細設定を指定できます。詳細については、ユーザー設定を参照してください。

終了:プログラムを終了します。

ヘルプ:右上隅の [image] ボタンをクリックすると、[ヘルプ]、[サポート]、[アクティベーション]、[更新] および [バージョン情報] オプションが表示されます。Alt + H キーを押して、オプションを表示することもできます。

ヘルプ:シングル エンコーダに関するヘルプ ファイルを読みます。

サポート:サポート センターのリンクを開きます。

アクティベーション:プログラムを登録します。

更新:アップデート バージョンを利用できるかどうかを検出します。

バージョン情報: プログラム バージョンなどのソフトウェア情報を表示します。


よくある質問

よくある質問 (FAQ)

プログラムの使用時に問題があった場合はまず、よくある質問 (FAQ) を参照してください。FAQ では、プログラムで発生しやすい問題を挙げて、適切な対処方法を紹介しています。このプログラムを使用してデジタル ライフを満喫する前に、FAQ を一通りご覧いただくことを強くお勧めします。

参照しやすいように、下記の 2 種類の FAQ を提供しています。

購入に関してよくある質問

サポートに関してよくある質問

その他のご質問がある場合は、サポートにお問い合わせいただくか、注文番号 (ソフトウェアをご購入いただいた場合)、プログラム バージョン、ご使用の OSを記載し、可能であれば発生した状況のスクリーンショットまたは設定または変換のプロファイル設定のスクリーンショットを添付した説明と共にお送りください。


サポートに関してよくある質問

1. このソフトウェアは Mac OS X や Vista をサポートしていますか?

このソフトウェアは現在、Mac OS X では動作しません。サポートしているのは、Windows NT4.0 + SP6/2000/XP 以上 (Vista を含む) のみで、Windows 98 や Windows Me には対応していません。

2. ビデオにどのような設定ができますか?

[動画のオープニング] にはタイトル、ディレクタおよび説明が含まれます。これは、動画の作成情報と動画の簡単な紹介のためにあります。ユーザ独自の Flash で新しいテンプレートが有効になっています。[動画のオープニング] および [動画のエンディング] を動画に追加するのとは別に FLASH VIDEO MX では、ユーザ キャプション、ユーザ ロゴ、さまざまなスタイルのコントロール ボタン、背景の色、およびさまざまな特殊ビデオ エフェクトを追加できます。編集した結果をプレビューして、いつでも変更できます。また、ビデオを追加して、動画のオープニングとインポートしたビデオの選択した始点との間に表示したり、ビデオを追加して、インポートしたビデオの選択した終点と動画のエンディングの間に表示することもできます。

3. Flash Video MX をアップグレードするにはどうすればいいのですか?

Flash Video MX を実行しているときに、ご使用のコンピュータがインターネットに接続されている場合、プログラムは自動的に最新バージョンを検出して、アップグレードするように催促します。また、右上隅の [ヘルプ] ボタンをクリックし、[更新] をクリックして、アップデート バージョンを利用できるかどうかを確認することもできます。もちろん、いつでも弊社の Web サイトにアクセスして、このプログラムのアップデート バージョンがあるかどうかを確認できます。現在コンピュータにインストールされているバージョンを確認するには、右上隅の [ヘルプ] ボタンをクリックし、[バージョン情報] をクリックして、プログラムに関する情報を表示します。

4. v2.5 から v3.3 にアップグレードしましたが、v2.5 のコントロール バーを見つけることができませんでした。どうすれば、古いコントロール バーを入手できますか?

弊社ではコントロール バーのスタイルをアップグレードして、古いコントロール バーはメイン プログラムに合うように削除しました。コントロール バーの位置と色をご使用のビデオに合うように変更できます。Flash Video MX v4.0 以上の [ミュート] ボタン、プロセス バー、およびその他の要素などのコントロールを削除することができます。コントロール バーにはさらに多くの機能があります。詳細については、「プレイヤ設定」を参照してください。古いコントロール バーの一部の特殊なスタイルを希望される場合は、弊社までご連絡ください。そうすれば、弊社で将来お客様のニーズに合わせることができます。

5. お気に入りの音楽をビデオに追加できますか?

はい。Flash Video MX では、オリジナルのオーディオを新しいオーディオ ファイルに置き換えることができます。[オーディオおよびビデオ設定] インタフェースで、コンピュータから新しいオーディオ ファイルを選択して、オリジナルのオーディオ ファイルを置き換えることができます。新しいオーディオ ファイルの長さが十分でない場合は、[オーディオをループ再生] を選択して、オーディオをループ再生することができます。この特別な機能を使用して、お客様独自の Flash MTV を作成できます。

6. プリローダーはどのように使うのですか?

v4.0 以上では、[出力設定] インタフェースの [プレイヤ設定] タブの下でプリローダーのスタイル、プリローダーのプリセット プロファイルを選択できます。

7. SWF と FLV はどう違うのですか?

SWF フォーマットには制限があります。フレームの数は 16000 以内でなければなりません。SWF ファイルに 16000 を超えるフレームが含まれていても、Flash プレイヤは 16000 番目よりも後のフレームを再生しません。ただし、FLV フォーマットにはそのような制限はなく、このソフトウェアでは FLV ファイル用の統合された FLV プレイヤ (SWF フォーマット) を作成します。

8. どうすれば画像の真ん中のロゴを消すことができますか?

このロゴは、試用/デモ版に限り表示されます。

9. FrontPage で Flash を使う方法を教えてください。

(a). サンプル コードを変更する
FrontPage で Flash を使用するには、任意の <object> <embed> コードを .swf に使用します。次に例を示します。

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=4,0,0,0" ID=banner_2000_08_15_b WIDTH=468 HEIGHT=60>
<PARAM NAME=movie VALUE="http://www.yoursite.com/SDD.swf">
<PARAM NAME=quality VALUE=high>
<PARAM NAME=bgcolor VALUE=#000099>
<EMBED src="http://www.yoursite.com/SDD.swf" quality=high bgcolor=#000099 WIDTH=468 HEIGHT=60 TYPE="application/x-shockwave-flash" PLUGINSPAGE= "http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash">
</EMBED></OBJECT>

ファイル名 (2 個所)、幅と高さ (2 個所) および背景の色 (2 個所) を変更できます。このコード (オブジェクトと埋め込みタグの間およびこれらを含むすべて) をコピーします。

(b). FrontPage を開く
Flash ファイルを挿入する html ファイルを FrontPage で開きます。出力フォーマットが SWF の場合、この html ファイルが SWF ファイルと同じフォルダにあることを確認してください。出力フォーマットが FLV の場合、この html ファイルが FLV ファイルおよび SWF ファイルと同じフォルダにあることを確認してください (プログラム設定で SWF ファイルの作成を選択した場合)。

[コード] モードを選択して、FrontPage で上記のコードを HTML コードに貼り付け、次に Flash を挿入します。

Flash フォーマットで [挿入] > [画像] > [動画] をクリックして、ページに挿入する Flash ファイルを選択することもできます。

10. PowerPoint で Flash を使う方法を教えてください。

(a). Flash ビデオ ファイルを PowerPoint に挿入する
 PowerPoint を開いて、新しいスライドを作成します。
メイン メニュー バーから [表示] > [ツールバー] > [Visual Basic] を選択します。
Visual Basic のツールバーから、[コントロール] テキストボックス アイコンを選択して、[コントロール] ツールボックスを選択します。[詳細コントロール] アイコンを選択し、リストを下へスクロールして [Shockwave Flash オブジェクト] を選択します。
スライド上に任意の寸法で長方形を描きます。
描いたばかりの長方形を右クリックして、[プロパティ] を選択します。これにより、動画プロパティのリストが開きます。

(b). ビデオを埋め込む
ビデオを埋め込むには、[プロパティ] ボックスで、次の変更を行います。

· 動画の埋め込み:この値を [True] に変更
· 高さ:この値を使用する Flash ビデオ動画の正しい寸法に変更 (この場合 150)
· 幅:この値を使用する Flash ビデオ動画の正しい寸法に変更 (この場合 200)
· ループ :[False] に変更 (ビデオをループ再生したい場合を除く。ループ再生したい場合は [True] のまま)
· 動画:.swf 動画の絶対パスを入力

(c). ビデオを表示する

ビデオを表示するには、メイン メニューから [スライドショー] > [実行] を選択します。ビデオを埋め込んだスライドで、ビデオが再生されます。

11. html ページに swf を埋め込む方法を教えてください。

Flash Video MX の [ファイル] タブに [HTML をエクスポート] オプションがあります。このチェックボックスをオンにすると、Flash Video MX は自動的にエンコードしている SWF を再生するための html コードを出力します。

これを自分で実行する場合、effect.swf を Web ページに埋め込むコードの例を次に示します。

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=4,0,0
,0" id="effect" WIDTH="100%" HEIGHT="100%">
<PARAM NAME="movie" VALUE="effect.swf">
<PARAM NAME="quality" VALUE="high">
<PARAM NAME="bgcolor" VALUE="#000000">
<EMBED src="effect.swf" quality="high" bgcolor="#000000" WIDTH="100%"
HEIGHT="100%" TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_
Version=ShockwaveFlash">
</EMBED>
</OBJECT>

<EMBED> タグと <OBJECT> タグの両方で [高さ] と [幅] の値を
動画の寸法に設定します。画面いっぱいに広がるエフェクトの場合、この値を "100%" に設定します。

<OBJECT> タグは Internet Explorer 固有のタグで、<EMBED> タグは
NetScape を含めた他のほとんどのブラウザ用です。このため、すべてのブラウザで Flash SWF を正しく表示するには、
両方のタグが必要です。両方のタグの属性が一致することを
確認してください。そうしないと予期せぬ動作が生じる場合があります。

詳細については、
http://www.macromedia.com/support/flash/ts/documents/tn4150.htmlを参照してください。

12. ビデオの最初のフレームに表示されるサムネイルおよびユーザーが動画を再生するためにクリックする大きな再生ボタンを表示したいと思います。どうすればいいですか?

この機能は、バージョン 4.0 以上に含まれています。[エクスポート設定] タブで最初のフレーム ファイルの作成を選択し、[出力設定] インターフェイスの [プレイヤ設定] タブで大きな再生ボタンのスタイルを選択します。

ビデオの最初のフレームに他の画像を使用したい場合、リテール版をお持ちであれば、独立した FLV プレイヤを使用することもできます。希望のコントロール バーのスタイルを 1 つ選択し、ルート フォルダに置いて、関数が有効になるように Web ページのコードを変更します。HTML コードの例を次に示します。

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="660" height="240">
<param name=movie value="flvplayer.swf">
<param name=flashvars value="playerOpts=targetClip*MagLev.flv*s||pauseAtFirstFrame*false*b||autoLoad*false*b||thumbNail*sunset.jpg*s">
<param name=quality value=high>
<embed src="flvplayer.swf" flashvars="playerOpts=targetClip*MagLev.flv*s||pauseAtFirstFrame*false*b||autoLoad*false*b||thumbNail*sunset.jpg*s" quality=high pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="660" height="240">
</embed>
</object>

ビデオを表示するには赤色のファイル名を変更します。Web ページ上で再生したい場合は、ファイルを同じフォルダに置いたことを確認します。

13. ビデオにサブタイトルを追加する方法を教えてください。

バッチ モードを実行してください。直接インストール フォルダに進んで、BatchCVT.exe をダブルクリックするか、デスクトップ アイコンをダブルクリックして、[バッチ エンコーダ] をクリックし、以下の手順に従います。
1. [キュー ポイント] タブに進み、クリックしてキュー ポイントを追加します。
2. [名前] を [my::title] に変更し、再生バーをサブタイトルを表示するタイム ポイントにドラッグします。
3. パラメータの右で [+] ボタンをクリックして、名前を [t] に変更し、次にそのフレームに表示したいテキストを入力します。
4. パラメータの [+] ボタンをクリックし、名前を [d] に変更して、テキストを表示する時間を選択します。この時間は、ミリ秒で表示してください。
リテール版を購入された場合、[subColor*255,255,255*c||subSize*10*i||subHeight*10*i] を追加して HTML コードを変更することによって、サブタイトルのデフォルトの色、サイズ、高さを変更できます。次に例を示します。

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="660" height="240">
<param name=movie value="hello.swf">
<param name=flashvars value="playerOpts=targetClip*hello.flv*s||subColor*255,255,255*c||subSize*20*i||subHeight*20*i">
<param name=quality value=high>
<embed src="hello.swf" flashvars="playerOpts=targetClip*hello.flv*s||subColor*255,255,255*c||subSize*20*i||subHeight*20*i" quality=high pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="660" height="240">
</embed>
</object>

独立した SWF ファイルを FLV プレイヤとして使用するか、FLV ファイルと一緒に作成された SWF ファイルを使用することができます。色、サイズ、高さなどの設定を変更する関数を利用できるのは、リテール版の Flash Video MX 4.0 以上だけです。出力ファイルは FLV フォーマットでなければなりません。

14. 直接 VOB を読み込むのと IFO を読み込むのとは何が違うの?

コンピュータに DVD フォルダがある場合、および DVD ROM へ DVD を挿入している場合は、[DVD の読み込み] ボタンをクリックしてファイルをプログラムへインポートすることを推奨します。通常、DVD には VOB、IFO、BUP と 3 種類のフォーマットのファイルがあります。VOB ファイルにはビデオとオーディオ データが含まれています。IFO ファイルにはナビゲーションが含まれていて、BUP は DVD のバックアップ ファイルとなります。
[DVD ローダの実行] を選択し、IFO ファイルを選択すると、エフェクトは VOB ファイルを直接読み込むよりもより良いものになります。IFO ファイルにより、Flash Video MX は IFO ファイルを検知し、抽出した VOB データにアクセスします。
DVD ファイルについては、絶対に VOB を直接開かず、IFO を開いてください。

その他のご質問がある場合は、サポートにお問い合わせいただくか、注文 ID (ソフトウェアをご購入いただいた場合)、プログラム バージョン、ご使用の OS、説明を記載し、必要であれば発生した状況のスクリーンショットまたは設定または変換のプロファイル設定のスクリーンショットを添付してお送りください。


プレイヤ API

はじめに

バージョン 2.5.1 以降の Flash Video MX では、独立した SWF または対応する FLV に依存してのみ再生可能な SWF を作成できます。どちらのタイプのファイルにも同じプログラミング インタフェースが含まれます。これらのインタフェース機能によってプレイヤを制御できます (再生、一時停止、停止、シーク、コントロール バーの色の変更等の操作など)。また、コントロール バーを使って、プログラムであらゆる種類のイベント (キュー ポイント イベントや [再生] ボタンまたは [停止] ボタンをクリックするときのイベントなど) を操作できます。

  • Flash Video MX Pro 、Flash Video MX Pro の中の DVD の直接変換機能、Flash Video MX によって作成されるフォーマットのタイプ

Flash Video MXは互いに独立して、影響を与えることのない 2 つのタイプのフォーマットを作成します。

a) 独立した SWF ファイル

特長:

    • ビデオが SWF ファイルに埋め込まれている
    • ファイル サイズが大きい
    • 他のファイルに依存することなく独立して再生
    • ダウンロードするときにプログレッシブ ダウンロードを利用して監視可能
    • 整数フレーム レート
    • フレーム数が 16000 フレームに制限される (Flash Video MX は 16000 フレームを超える SWF を作成できますが、Flash プレイヤは 16000 番目より後の残りのフレームを再生できません。Flash Video MX は、ビデオが 16000 フレームを超えるかどうかを伝えることができます。)
    • 16000 フレーム以内のフレームをシーク可能

b) 対応する FLV に依存する FLV ファイルおよび SWF プレイヤ ファイル

特長:

    • ビデオが FLV ファイルとして保存される
    • FLV ファイルは Flash プレイヤで直接再生できないため、SWF プレイヤが必要
    • ダウンロードするときにプログレッシブ ダウンロードを利用して監視可能
    • 浮動小数点フレーム レート
    • 再生時間に制限なし
    • キーフレームのみシーク

一般条件でタイプ b のみ推奨

  • プログラミング インタフェース
タイプ a とタイプ b の両方とも同じプログラミング インタフェースに対応しています。ビデオの主要シーンに thePlayer という名前の変数があります。これはthePlayer オブジェクトのインスタンスです。このオブジェクトは次のメソッドおよびイベントに対応しています。

thePlayer オブジェクトのメソッドの概要

thePlayer オブジェクトのイベントの概要

プログラミング インタフェースの使い方に例があります。

関連項目:

Moyea FLV プレイヤの使い方


thePlayer オブジェクトのメソッドの概要

メソッド

説明

Play()

ビデオを再生します

Pause()

現在のフレームで停止します

Stop()

再生を停止します

Seek(t)

ビデオの特定の時間にシークします。t は、Double型です

SetMute(b)

ミュート機能を設定します。b はブール型です

GetMute()

現在のミュート設定を取得します。戻り値はブール型です

SetVolume(v)

音量を設定します。v は 0～100 の範囲の整数型です。0 は無音、100 は最も大きな音量です。

GetVolume()

音量設定を取得します。戻り値は整数です

GetState()

現在の再生ステータスを取得します。戻りステータス文字列は、「play」、「pause」および「stop」です

GetTime()

現在の再生プロセスを取得します。戻り値はDouble型 (秒) です

GetDuration()

ビデオ再生時間を取得します。戻り値はDouble型 (秒) です

SetDebloking(l)

ブロック解除機能を設定します。I の範囲は次のとおりです

0: 必要に応じてビデオ コンプレッサにブロック解除フィルタを適用します

1: ブロック解除を適用しません

2: 常にブロック解除を適用します

(ブロック解除機能は常にファイル入力で適用されるため、このメソッドはファイルの入力には使用できません)

SetSmoothing(b)

スムージング機能を設定します。b はブール型です (スムージング機能は常にファイル入力で適用されるため、このメソッドはファイルの入力には使用できません)

SetVisible(b)

プレイヤを表示するかどうかを設定します。b はブール型です。プレイヤを非表示に設定した場合、プレイヤがマウス カーソルの無効を検知すると、自動的にコントロール バーが表示されます。

GetVisible()

プレイヤが表示されるかどうかを確認します。コントロール バーが自動的に非表示になり、コントロール バーが非表示に設定されている場合、戻り値は false です。

SetEnabled(b)

コントロール バーの UI の有効/無効を設定します。コントロール バーの UI が無効の場合、上のボタンはすべて無効になります

GetEnabled()

コントロール バーの UI が有効か無効かを確認します。

SetColor(c)

コントロール バーの色を設定します (cは整数です。たとえば、0xFF0000 は赤)。c が未定義に設定されている場合、コントロール バーは半透明になります。

AddListener(l)

イベントの Listener オブジェクトを Listener リストに追加します。オブジェクト l はonEventメソッド (sender、type、name、info) を実装する必要があり、sender はイベントの dispatcher です。type はイベント型で Flash Video MX プレイヤのイベントは常に「MoyeaPlayer」の型を持ちます。name は、イベント名で、info はイベントのその他の情報です

RemoveListener(l)

Listener リストからオブジェクト I を削除します。これでオブジェクト I はイベントを受け取ることができません。

DispatchEvent(event_type, event_name, info)

イベントを送信します。Listener リスト内のすべてのオブジェクトがイベントを受け取ることができます。event_type は dispatcher により定義される型です。event_name は dispatcher により定義される名前です。info は dispatcher により定義されるデータです

関連項目:

thePlayer オブジェクトのイベントの概要

プログラミング インタフェースの使い方

Moyea FLV プレイヤの使い方


thePlayer オブジェクトのイベントの概要

イベント

概要

onPlayPausePress

[再生] ボタンまたは [一時停止] ボタンが押されています

onReplayPress

[リプレイ]ボタンが押されています

onStopPress

[停止]ボタンが押されています

onProcBarDragStart

ユーザがプロセス バーのドラッグを開始します

onProcBarDragging

ユーザがプロセス バーをドラッグしています

ドラッグ操作中、このようなイベントを何回もトリガーできます

onProcBarDragEnd

ユーザがプロセス バーのドラッグを停止します

onMuteSwitch

[ミュート]ボタンが押されています

onPlayStart

コントロール バーが初期化され、再生準備ができています

このようなイベントは最初にロードするときにだけトリガーされ、リプレイなどのその他の場合にはトリガーされません

onMetaData

ロード時にメタデータ付きの FLV がこのようなイベントをトリガーします。イベント オブジェクト データには次の情報が含まれる場合があります。

info.duration: ビデオの継続時間

info.width: ビデオの横サイズ

info.height: ビデオの縦サイズ

info.videocodecid: ビデオ コーデック ID

ビデオ コーデック ID の選択可能な値:

2: Sorenson H.263

3: Screen video

4: VP6

5: VP6 with alpha

6: Screen Video V2

info.audiocodecid: オーディオのコーデック ID

オーディオ コーデック ID の選択可能な値:

0 = 非圧縮

1 = ADPCM

2 = MP3

5 = Nellymoser 8kHz モノラル

6 = Nellymoser

info.canSeekToEnd: 最後のフレームがキーフレームかどうかを表示

info.lasttimestamp: 最後のフレームのタイム スタンプ

info.videodatarate: ビデオのデータ転送速度

info.videodatarate: オーディオのデータ転送速度

info.metadatacreator: メタデータの作成者

info.cuePoints: キュー ポイント リスト

onPlaying

再生時に何回もトリガーされました

onPlayEnd

再生終了時にトリガーされました

onBufferEmpty

バッファが空のときにトリガーされました

b ファイルの入力に有効

onBufferFull

バッファがいっぱいのときにトリガーされました

b ファイルの入力に有効

onCuePoint

キュー ポイント イベント

イベント オブジェクト datainfo には、次の情報が含まれます。

info.name: キュー ポイントの名前

info.type: キュー ポイント、イベントまたはナビゲーションの種類

info.time: キュー ポイントの時間

info.parameters["param_name"]: キュー ポイントのパラメータ

param_name: エンコード時のパラメータ設定の名前

関連項目:

thePlayer オブジェクトのメソッドの概要

プログラミング インタフェースの使い方

Moyea FLV プレイヤの使い方


プログラミング インタフェースの使い方

最初に SWF を MovieClip にロードして、thePlayer 変数にアクセスできるようにします。loadMovie または MovieClipLoader を使用します。

var mc = createEmptyMovieClip("mc", getNextHighestDepth());

mc.loadMovie("xxx.swf");

var thePlayer = mc.thePlayer;

次に、thePlayer 変数を使用して、メソッドにアクセスします。コントロール バー イベントを処理するために、次のようなコードを書くことができます。

var listener: Object = new Object();

listener.onEvent = function(sender, type, name, info)

{

//senderは thePlayer

if (name == "onCuePoint") { //必要に応じて他のイベントを処理

trace("onCuePoint Event: name=" + info.name + ", type=" + info.type + ", time=" + info.time);

}

}

thePlayer.AddListener(listener);

関連項目:

thePlayer オブジェクトのメソッドの概要

thePlayer オブジェクトのイベントの概要

Moyea FLV プレイヤの使い方


FLV キュー ポイントの操作

FLV ファイルにキュー ポイントを埋め込むことができます。FLV ファイルをプリセット タイムポイントで再生すると、onCuePoint イベントがトリガーされます。Flash Video MX によって提供されるプレイヤを適用したくない場合は、アクション スクリプトを適用して、FLV を再生できます。このスクリプトのコーディングは次のようになります。

var nc = new NetConnection(); //NetConnection オブジェクトを構築

nc.connect(null); //接続を確立

var ns = new NetStream(nc); //nc 付きの NetStream オブジェクトを構築

videoScr.attachVideo(ns); //videoScr はシーンに置かれたビデオ インスタンス

ns.play("xxx.flv"); //ビデオを再生するために、xxx.flv は flv 名。これは絶対または相対 URL とすることが可能

ns.pause(true); //ビデオを一時停止

ns.pause(false); //ビデオの再生を再開

ns.seek(t); //t 秒にシーク

ns. onCuePoint = function(info)

{

trace(info.name); //キュー ポイント名を取得

trace(info.time); //キュー ポイントを秒で取得

trace(info.type); //キュー ポイント タイプ "イベント" または"ナビゲーション"

trace(info.parameters["param_name"]); //キュー ポイントの param_name 値を取得

}

Flash Video MX によって提供されるプレイヤを使用して FLV ファイルを再生する場合は、Cue Point イベントを次のように操作できます。詳細については、プレイヤ API のドキュメントを参照してください。

var listener:Object = new Object(); //イベント リスナー オブジェクトを構築

listener.onEvent = function(sender, type, name, info)

{

if (name == "onCuePoint") { //onCuePoint イベントを処理

trace(info.name); //キュー ポイント名を取得

trace(info.time); //キュー ポイントを秒で取得

trace(info.type); //キュー ポイント タイプ "イベント" または"ナビゲーション"

trace(info.parameters["param_name"]); //キュー ポイントの param_name 値を取得

}

}

thePlayer.AddListener(listener); //リスナーが"onCuePoint"イベントを取得できるようにイベント リスナーを追加


SWF キュー ポイントについて

通常、キュー ポイントは FLV ファイルにのみ存在します。しかし、Flash Video MX では、独立した SWF ファイルでキュー ポイントをエンコードできます。MovieClipLoader を適用して、このキュー ポイントを持った SWF を MovieClip にロードし、次に onLoadInit イベントを処理するときに、thePlayer のリスナー リストにリスナーを追加してください。

var mc = this.createEmptyMovieClip ("mc", this.getNextHighestDepth()); //新しい MovieClip を作成

var loader:MovieClipLoader = new MovieClipLoader(); //MovieClipLoader を作成

var loader_cb:Object = new Object(); //onLoadInit を処理するローダー コールバック オブジェクトを作成

var thePlayer = null;

loader_cb.onLoadInit = function(mc) // onLoadInit が呼び出されるときに、mc から thePlayer 変数を取得して、保存

{

thePlayer = mc.thePlayer; //変数を保存

mc._width = 400; //必要に応じて幅と高さを調節

mc._height = 300;

var listener:Object = new Object(); //thePlayer のイベントを待機するリスナー オブジェクトを構築

listener.onEvent = function(sender, type, name, info) //イベント処理手続き

{

trace(name);

}

thePlayer.AddListener(listener); //thePlayer のリスナー リストにリスナーを追加

}

loader.addListener(loader_cb); //onLoadInit を処理

loader.loadClip("xxx.swf", "mc"); //ビデオの swf をロード


Moyea FLV プレイヤの使い方

Flash Video MX のインストール フォルダに "Control" という名前のフォルダがあり、このフォルダでは SWF ファイルのそれぞれが FLV プレイヤになっています。これらの SWF ファイルは、Flash Video MX によって適用できるだけでなく、独立した FLV プレイヤでもあります。Flash Video MX によって作成された SWF ファイルは、独立した FLV プレイヤとなることもできます。FLV プレイヤとして作成された SWF ファイルと "Control" フォルダ内の SWF ファイルの違いは、"Control" フォルダ内の SWF ファイルの動作が Flash Video MX の設定によって、新しい SWF ファイルを作成するように変更されていることにあります。

必要なことは、この SWF ファイルを HTML ページに埋め込み、SWF ファイル パスから playerOpts と名付けられた文字列を渡して、コントロール バーの動作を制御することです。このページを次のようなコードで書くことができます。

<!--url's used in the movie-->
<!--text used in the movie-->
<!-- saved from url=(0013)about:internet -->
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="400" height="300">
<param name=movie value="mflvplayer.swf?playerOpts=targetClip*demo.flv*s">
<param name=quality value=high>
<embed src="mflvplayer.swf?playerOpts=targetClip*demo.flv*s" quality=high pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="400" height="300">
</embed>
</object>

mflvplayer.swf が青字になっていることにお気づきでしょうか。これは、独立した FLV プレイヤの 1 つです。

赤字で示された width="400" height="300" は、ビデオの幅と高さを示しています。

赤字の playerOpts=targetClip*demo.flv*s は、demo.flv がユーザーのビデオである場合に再生される FLV ファイルの名前を示します。targetClip、アスタリスクのセパレータおよび最後の "s" は何だろうと思われるかもしれません。

実際、playerOpts はそれほど簡単ではありません。PlayerOpts は複数のセグメントで構成され、それぞれのセグメントは "||" で分けられ、各セグメントにはコントロール バーのプロパティが含まれます。1 つのセグメントは、アスタリスク (*) で 3 つの部分に分けられます。最初の部分はプロパティ名、2 番目の部分はプロパティ値、3 番目の部分はプロパティのデータ型です。たとえば、 targetClip*demo.flv*s はセグメント、targetClip はプロパティ名、demo.flv はプロパティ値で "s" はこのプロパティの文字列の種類です。このセグメントは、コントロール バーでビデオを再生できるパスを指定します。この他にもプロパティがあります。"||" を使用してさまざまなセグメントを分離することにより、同時に複数のプロパティを設定できます。コードは次のようになります。

playerOpts=targetClip*demo.flv*s||panelColor*255,0,0*c

このようにして、targetClip プロパティを設定するときに、panelColor プロパティも設定します。panelColor はコントロール バーのカラーで、データ型はカラー "c" です。255,0,0 は RGB カラーです。プロパティ名とデータ型は大文字と小文字が区別されることに注意してください。

下の表はプロパティとその機能を示しています。

プロパティ

データ型

説明

targetClip

文字列:"s"

再生する FLV ファイルのパス。

scaleMode

文字列:"s"

コントロール バーをストレッチしたときに、ビデオをストレッチするかどうかを指定します。次のいずれかになります。
notcare:Flash プレイヤがストレッチを処理するかどうかに依存

no:サイズを変更しない

stage:幅をステージまで引き伸ばし、コントロール バーの元の高さを維持 (デフォルト)

pauseAtFirstFrame

ブール型:"b"

ビデオの再生を開始するときに、最初のフレームでビデオを一時停止するかどうかを指定します。true (デフォルト) は、最初のフレームで一時停止することを示し、false は自動的に再生することを示します。

pauseAtLastFrame

ブール型:"b"

ビデオの再生を終了するときに、最後のフレームでビデオを一時停止するかどうかを指定します。true は一時停止することを示し、false (デフォルト) は最初のフレームに戻ることを示します。

playerAlign

文字列:"s"

コントロール バーの位置を設定します。top は一番上で、bottom (デフォルト) は一番下です。

playerOverMovie

ブール型:"b"

コントロール バーを動画の前に表示するかどうかを設定します。デフォルト値は false です。

playerAutoHide

ブール型:"b"

コントロール バーを自動的に非表示にするかどうかを設定します。デフォルト値は false です。

hideDelay

整数型:"i"

コントロール バーを非表示にするまでの遅延時間をミリ秒で表示します。たとえば、hideDelay*1000*i
はマウスを 1 秒間動かさなかった場合にコントロール バーを非表示にすることを示します。

autoHideMouse

ブール型:"b"

マウス カーソルを自動的に非表示にするかどうかを設定します。

panelColor

カラー タイプ:"c"

コントロール バーの色を設定します。たとえば、
panelColor*255,0,0*c
はコントロール バーの色を赤に設定することを意味します。
255,0,0 は、R、G、B のカラー コンポーネントを示します。

一部のコントロール バーには、このプロパティが含まれません。このため、このようなコントロールバーでは、このプロパティを設定しても、効果が現れません。

bufferTime

浮動小数点:"f"

コントロール バーのバッファ時間を設定します。1.5 に設定すると、再生する前にデータを 1.5 秒間バッファします。デフォルト値は 5.0 です。

sndMute

ブール型:"b"

コントロール バーをミュートにするかどうかを設定します。デフォルト値は false です。

sndVolume

整数型:"i"

ビデオの再生を開始するときに、コントロール バーのボリュームのパーセンテージを設定します。設定できる値の範囲は 0 ～ 100 でデフォルト値は 100 です。

videoLink

文字列:"s"

画面をクリックするとリンクされたコンテンツが開かれるビデオ リンクを設定します (例:
videoLink*http://www.flash-video-mx.com*s)。

videoLinkTarget

文字列:"s"

ユーザがリンク付きのビデオをクリックしたときに、リンクしたコンテンツを表示するターゲット ウィンドウを指定します。

_self:現在のウィンドウに表示
_blank:新しいウィンドウに表示
_top:一番上のウィンドウに表示
_parent:親ウィンドウに表示

デフォルト値は _blank です。
たとえば、
videoLinkTarget*_blank*s
は、ユーザーがビデオ リンク付きの画面をクリックすると、リンクしたコンテンツを特定のリンクで新しいウィンドウに表示することを示します。

showReplay

ブール型:"b"

[リプレイ] ボタンを表示するかどうかを設定します。デフォルト値は false です。

textReplay

文字列:"s"

[リプレイ] ボタンの文字列を設定します。デフォルト値は [リプレイ] です。

autoLoad

ブール型:"b"

動画を自動的にロードするかどうかを設定します。
autoLoad が true の場合、SWF ファイルはプレイヤとして自動的に FLV ファイルをロードします。
autoLoad が false の場合、FLV ファイルは再生ボタンをクリックした後にロードされます。
デフォルト値は false です。

注: ビデオが SWF ファイルに埋め込まれている場合、動画は値に関係なく自動的にロードされます。

unloadOnStop

ブール型:"b"

再生が停止したときにビデオをアンロードするかどうかを設定します。

unloadOnStop が true の場合、[停止] ボタンをクリックすると、ビデオがアンロードされます。ビデオ データが完全にダウンロードされていない場合、ダウンロードされたビデオのデータはプレイヤから削除され、サムネイルを選択した場合はサムネイルが表示されるか、または黒い画面が表示されます。

unloadOnStop が false の場合、ビデオの最初のフレームが表示され、[停止] ボタンをクリックしても、ダウンロードしたビデオはアンロードされません。ビデオが完全にダウンロードされていない場合、ビデオの残りのデータがダウンロードされます。

autoRewind

ブール型:"b"

ビデオを自動的に巻き戻すかどうかを設定します。デフォルト値は false です。

urlOnEnd

文字列:"s"

ビデオの再生が終了したときにアクセスする URL を設定します。

urlOnEndBrowser

文字列:"s"

urlOnEnd を呼び出す方法を設定します。設定できる値は次のとおりです。

browser:ブラウザを使用して、urlOnEnd を開く

swf:Flash MovieClip から urlOnEnd をロードする

flv:urlOnEnd で指定された FLV ファイルを再生する

urlOnEndTarget

文字列:"s"

urlOnEndBrowser がブラウザの場合、urlOnEndTarget は urlOnEnd を参照するウィンドウ名です。

この値が swf の場合、urlOnEndTarget は urlOnEnd をロードする MovieClip の名前です。

この値が flv の場合、このプロパティは無視されます。

thumbNail

文字列:"s"

ビデオが再生される前にロードされるサムネイルを指定します。

bigPlay

文字列:"s"

SWF ファイルの URL を再生が一時停止または停止されたときに大きな [再生] ボタンを表示するように設定します。

playerExt

文字列:"s"

プレイヤの拡張子となる SWF ファイルの URL を設定します。ビデオをロードしているときに、playerExt で指定された swf がプレイヤによってロードされ、swf ファイルが拡張機能を実装します。

preLoader

文字列:"s"

再生する前にプリローダーがビデオ全体をロードするための SWF ファイルの URL を指定します。

showPlayer

ブール型:"b"

コントロール バーを表示するかしないかを設定します。デフォルト値は true です。

keepAspect

ブール型:"b"

ビデオをストレッチするときに、ビデオのアスペクト比を維持するように設定します。デフォルト値は false です。

movieID

文字列:"s"

onPlayURL に渡されるビデオの ID を設定します。

onPlayURL

文字列:"s"

ビデオの再生が開始するときにアクセスする URL を設定します。

movieID という名前のパラメータがこの URL に渡されます。

注: この URL にアクセスするときに、ブラウザ ウィンドウは表示されません。

minWidth

整数型:"i"

許容される最小幅。プレイヤの幅が最小幅よりも小さい場合、プレイヤの幅に合わせてストレッチされる代わりに、ビデオの左右 2 個所のサイドがカットされます。

デフォルト値は 0 で、ビデオの幅がプレイヤの幅と同じになります。

minHeight

整数型:"i"

許容される最小高さ。プレイヤの高さが最小高さよりも小さい場合、プレイヤの幅に合わせてストレッチされる代わりに、ビデオの上下 2 個所のサイドがカットされます。

デフォルト値は 0 で、ビデオの高さがプレイヤの高さと同じになります。

fscEvent

ブール型:"b"

プレイヤ イベントを fscommand に転送するかしないかを設定します。

この値は true の場合、プレイヤ イベントは fscommand(t, n) に転送されます。t はイベントの種類です。Flash Video MX によって提供されるプレイヤを使用する場合、t は常に MoyeaPlayer で、n はイベント名です。

subColor

カラー タイプ:"c"

サブタイトルのフォントの色を設定します。

subSize

整数型:"i"

サブタイトルのフォントのサイズを設定します。

subHeight

整数型:"i"

サブタイトルのボックスの高さを設定します。

noMuteBtn

ブール型:"b"

[ミュート] ボタンを非表示にするかどうかを設定します。

noStopBtn

ブール型:"b"

[停止] ボタンを非表示にするかどうかを設定します。

noProcBar

ブール型:"b"

プロセス バーを非表示にするかどうかを設定します。

noVolumeBar

ブール型:"b"

[音量調節] を非表示にするかどうかを設定します。

noTimeText

ブール型:"b"

ビデオ時間に関するテキストを非表示にするかどうかを設定します。表示形式は、[再生時間 / 合計時間] です。

playBtnAlign

文字列:"s"

大きな再生ボタンの位置調整。設定できる値は次のとおりです。

左上、中央上、右上、左中央、中央、右中央、左下、中央下、右下。

playBtnAlignX

整数型:"i"

大きな [再生] ボタンの x 座標を設定します。playBtnAlign が原点です。

playBtnAlignY

整数型:"i"

大きな [再生] ボタンの y 座標を設定します。playBtnAlign が原点です。

playBtnW

整数型:"i"

大きな [再生] ボタンの幅を設定します。

playBtnH

整数型:"i"

大きな [再生] ボタンの高さを設定します。

Moyea FLV プレイヤのサブタイトルのキュー ポイント フォーマット:

名前:"my::title"; 時間:バーをドラッグして、サブタイトルを表示するタイム ポイントを設定します。

パラメータ:
名前:"t"; 値:表示するテキストを入力します。
名前:"d"; 値:テキストを表示する時間の長さをパラメータ "t" (ミリ秒) で入力します。

サブタイトルの色、サイズ、高さを HTML コードで変更できます。

上記の独立したプレイヤのプロパティを設定するほかに、Action Scriptを理解している場合は、FLV プレイヤ API を適用して、これらのコントロール バーにイベント (再生または停止するイベント、ユーザが [一時停止] ボタンをクリックするときのイベントなど) を待機するよう設定することもできます。FLV プレイヤ APIを参照してください。


サポート

Flash Video MXソフトウェアのサポート センター

Flash Video MXソフトウェアの使い方について必要な情報は以下のとおりです。
製品のアップデートに関する情報は、www.shareEDGE.com (シェアエッジ)から提供されます。
電子メールによるお問い合わせ
Flash Video ソフトウェアについてのご質問がある場合や、これらのソフトウェアのご使用時に問題が発生した場合は、弊社技術スタッフに 株式会社ネクステッジテクノロジー カスタマサポートまでお問い合わせください。

Flash Video MX を使ってできること

  • ビデオ (avi、mpeg、wmv) を Flash SWF および FLV に変換
  • Web サイト用にストリーミング Flash 動画を作成
  • アニメーション ロゴ、画像、透過テキスト、ナビゲーション コントロール バーを追加
  • リアル タイムの帯域幅およびファイル サイズ推測
  • ビデオを FLV に変換
  • ビデオを圧縮 SWF に変換..


購入に関してよくある質問

1. 試用版と登録版では、何が違いますか?

試用版では、作成されたファイルに透過が入りますが、登録/リテール版では、弊社からのタイムリーなアフターセールス サービスを受けられます。試用版をお使いの場合、プログラムを起動するたびに [試用] ボタンが表示されます。リテール版では、[試用] ボタンはなく、最初にプログラムを起動するときに登録コードで登録する必要があるだけです。登録コードはリテール版でのみ機能します。試用版は登録コードを認識できません。独立した FLV プレイヤを作成する機能は、リテール版でのみ使用できます。

2. このソフトウェアの購入方法は?

弊社のソフトウェアをご購入いただくには、いくつかの方法があります。オンラインでクレジット カードを使って支払うか、FAX または電話でクレジット カードを使って支払うことができます。見積送り状による自動決済、電信送金、銀行小切手/小切手またはペイパル (US ドル) による支払いも可能です。

3. このソフトウェアの CD 版を手に入れることはできますか?

はい、できます。ただし、SWREG は現在 CD の配布に対応していません。このため、REGNOW (http://www.regnow.com/softsell/nph-softsell.cgi?item=13973-3) からソフトウェアをご購入いただくことになります。CD 版はできるだけ早く提供するために郵便局からの配送となるため、値段が高くなります。

4. 注文を送った後、いつリテール版を入手できますか?

ご注文をお送りいただいた後、24 時間以内に弊社の E コマース支払い処理サービス プロバイダの SWREG から登録の詳細を記載した電子メールをお送りいたします。
登録の詳細を記載した電子メールには、正式版のセットアップ ファイルのダウンロード URL と登録コードが記載されています。記載された URL からこのファイルをダウンロードし、実行してインストールしてください。以前に試用版の製品をインストールしてある場合は、まずそれを削除してください。.このプログラムを起動するのが初めての場合は、登録コードを入力するように求められます。有効な登録コードが確認されると、プログラムは制限なしに実行されます。
24 時間以内に登録の詳細を記載した電子メールが送られなかった場合は、弊社のサポートまでお問い合わせいただくか、注文番号と購入時に登録した電子メールアドレスを記載して、support@flash-video-mx.com まで電子メールをお送りください。

5. 登録コードを入力した後、コードが無効であると言われました。何が間違っているのでしょうか?

  • 弊社からお送りした電子メールから登録コードを直接コピーして、コードの先頭や最後にスペースが入らないように注意してボックスに貼り付けてください。そうしないと、コードは無効なコードとして認識されます。
  • 現在お手元にあるバージョンがリテール版であることを確認してください。試用版の場合、デスクトップのアイコンまたはクイック起動アイコンをクリックした後、[試用] ボタンが表示されます。リテール版には [登録] ボタンしかありません。

現在お手元にあるバージョンが試用版である場合は、ご購入後にお知らせしたダウンロード リンクからリテール版をダウンロードしてください。リテール版をインストールする前に、試用版を削除してください。現在のバージョンがリテール版である場合は、弊社のサポートにお問い合わせいただくか、注文 ID または購入時に登録した電子メール アドレスを記載して、support@flash-video-mx.comまで電子メールをお送りください。

6. シリアル番号をなくしました。

弊社のサポートにお問い合わせいただくか、注文番号および購入時の登録電子メール アドレスを記載して、support@flash-video-mx.com まで電子メールをお送りください。お客様には、弊社のサポートが情報を確認した後、シリアル番号をお受け取りいただきます。登録電子メール アドレスをご使用でない場合は、注文番号と登録電子メール アドレスに加えて、郵便住所や電話番号またはその他の購入時の情報をお送りください。

7. 登録情報の電子メール アドレスを新しい電子メール アドレスに変更したいのですが。

登録情報の配布先アドレスを変更されたい場合は、弊社のサポートにお問い合わせいただくか、電子メール アドレスを変更する理由、注文番号と登録電子メール アドレスに加えて、郵便住所や電話番号またはその他の購入時の情報を記載して、support@flash-video-mx.com まで電子メールをお送りください。

8. ソフトウェアを購入した場合、アップデートは無料ですか?

同じバージョン サフィックスのアップデートは無料です。たとえば、v1.1 から v1.6 へのアップグレードは無料ですが、v1.12 から v2.1 へのアップグレードには追加料金が必要です。v1.10 から v2.0 へのアップグレードの価格は保留されています。大きなアップグレードの場合、支払いが不要な場合もあります。通常、バージョン サフィックスが変更される場合が大きなアップグレードで、この場合、アップグレードによって、大幅に楽しみが増えます。

9. 自分の PC にこのソフトウェアをインストールしますが、もうすぐ新しいラップトップ PC を購入する予定です。ライセンスを 2 つ購入する必要がありますか?

古いコンピュータからプログラムを削除して、古いコンピュータのインストール フォルダも削除する必要があります。それから、購入後に弊社からお知らせしたリンクからリテール版を新しいラップトップ PC にダウンロードして、インストールしてください。
古いコンピュータと新しいラップトップ PC の両方でソフトウェアを使用する場合は、2 つのライセンスをご購入いただく必要があります。

その他のご質問がある場合は、弊社のサポートにご連絡いただくか、support@flash-video-mx.comまで電子メールをお送りください。


プログラミング インタフェースの使い方

On2 VP6、 Sorenson H.263 コーデック、および On2 VP6 with Alpha の比較

注意: On2 VP6 with Alphaは、Flash Video MXではサポートされません。Flash Video MX Proでのみサポートされます。

On2 VP6 コーデックやOn2 VP6 コーデック with alpha を使用すると、Sorenson H.263 コーデックに比べて、次の利点があります。

  • 同じデータ転送速度でより高品質のビデオをエンコードする
  • 合成ビデオを作成するためにアルファ チャンネルの使用をサポートする
  • On2 VP6 コーデック with alpha の場合、ソース ビデオ ファイルのアルファ効果を維持する

同じデータ転送速度でより高品質のビデオをサポートするためには、On2 VP6 コーデックのエンコードは非常に速度が遅くなり、クライアント コンピュータ上でビデオ データをデコードして再生するために、より多くのプロセッサ パワーが必要になります。このため、ビデオを見る人が作成した Flash ビデオ コンテンツにアクセスするときに使用するコンピュータに共通する最も低い基準に配慮してください。

On2 VP6 コーデック with alpha はファイルが大きくなることで変換速度の低下を引き起こすため、通常の場合は選択する必要はありません。ビデオを専門的に扱う方にはお勧めです。

多数のユーザーが比較的古いコンピュータを使用すると予測される場合は、FLV ファイルを Sorenson H.263 コーデックを使用してエンコードする方がよいかもしれません。


On2 VP6 VFW コーデックのインストール方法について

On2 VP6 コーデックを使用するには、まず On2 VP6 VFW コーデックをインストールする必要があります。もしくは、適切なコーデックをダウンロードして、入力ファイルを問題なくロードできるようにすることを求めるポップアップ ウィンドウが表示されるので、インターネットで検索してダウンロードしてください。

google.com を利用して、VP6 vfw codec 6.2 などで検索してみてください。
バージョン 6.2.x.x、6.4.2.x ともに問題なく動作します。

エンコーダをダウンロードすることを忘れないようにしてください。
たとえば、以下のコーデックはエンコーダが含まれていないため使用できません。
http://www.free-codecs.com/download/VP6.htm

ダウンロード元:

http://www.ogg.cn/software/view-software-309.html(version 6.4.2.0)
http://www.ogg.cn/software/view-software-56.html(version 6.2.6.0)
このウェブサイトは中国語表記です。ダウンロード リンクは以下の通りです。

Cole2 Media Codec Pack
http://www.cole2k.net/?display=Codec-Pack-Advanced(version 6.4.2.0)
すべてのコーデックをインストールする必要はありません。 On2 VP6 VFW コーデックのみのインストール方法については以下の通りです。

- Expert Installation を選択します

- Cole2k Media Toolbar (必須ではありません) の選択を解除します

- DVD/SVCD & DVD Filters の [Select None] を選択し、HDTV/DVD TV Card Filters のチェックボックスをオフにします。

- Video Codec's & Filters のチェックボックスをオフにし、On2 VP6 のみを選択します。

- その他すべてのチェックボックスをオフにして MP3 Playback Filters の [Select None] を選択します。

コーデックのインストール後はプログラムの再起動が必要です。

注: On2 VP6 コーデックのインストールに関して当社は一切の責任を負いません。
上記のコーデックの使用においては、コーデック付属の諸条件の対象です。ライセンス使用許諾契約に順守しなければなりません。


コーデックについて

注意: On2 VP6 with Alphaは、Flash Video MXではサポートされません。Flash Video MX Proでのみサポートされます。

On2 VP6 VFW コーデックのインストール方法について、およびOn2 VP6およびSorenson H.263 コーデックの比較を含むこの章は、Flash Video MXに適用します。

Flash Video MX で利用できるビデオ コーデックは Sorenson H.263、およびOn2 VP6の2種類です。必要に応じて選択してください。