新規プロジェクトの作成

ローカリゼーション プロセスを開始するには、まず、新規プロジェクトを作成して、翻訳対象の Windows バイナリ ファイル、Java properties ファイル、.NET resources ファイル、XML ファイルなど、Lingobit Localizer でサポートされているソース ファイルを追加する必要があります。Lingobit Localizer プロジェクトには、ローカリゼーションが必要なファイル、元の言語と対象言語、およびテキスト リソースの翻訳に関する情報が含まれます。対象言語のすべての翻訳は、現在のプロジェクトに保存されます。

Lingobit Localizer プロジェクト ファイルの拡張子は .loc で、保存先は自由に指定することができます。プロジェクト フォルダが、ローカライズ ファイルとサポート ファイルのホーム ディレクトリになります。

ソース ファイルとその元の言語と対象言語は、プロジェクトの作成時に指定することができます。なお、ファイルと対象言語は、後で追加または削除することもできます。Lingobit Localizer の詳細については、「新規プロジェクト ウィザードについて」を参照してください。

ローカライザビリティ テスト

リソースの翻訳


ローカライザビリティ テスト

ローカリゼーション プロセスを開始する前に、ローカライザビリティ テストを実施することをお勧めします。ローカライザビリティ テストを実施することで、グローバライズされたアプリケーションのローカリゼーションを開始しても問題ないかどうか、つまり、アプリケーションの実行コードがローカライズ可能なリソースと正しく分離されているかどうか、またプログラムのインターフェイスを翻訳する上でリエンジニアリングやコードの修正が必要ないかどうかを検証することができます。ローカライザビリティ テストを実施する際は、ダミー翻訳機能を使用すると便利です。詳細については、「ダミー翻訳エキスパート」を参照してください。

ローカリゼーション プロセスの早期の段階でローカリゼーション バグを見つけ、ローカライズ アプリケーションのクラッシュの原因となっているリソースを分離するには、問題検出機能を使用すると便利です。問題検出機能を使用すると、ローカライズ アプリケーション ファイルが複数回実行され、クラッシュの原因となっている要素が正確に検出されます。「問題検出機能について」を参照してください。


リソースの翻訳

Lingobit Localizer のメイン ウィンドウには、プロジェクト内のすべてのリソース、選択しているリソースの原文と訳文、およびプロジェクトに関する各種情報パネルが表示されます。選択した要素の翻訳を入力または変更して、翻訳ステータスを設定するには、[テキスト エディタ] パネルを使用します。翻訳エディタで要素を直接編集することもできます。

ローカライズ可能な要素を簡単に見分けられるように、Lingobit Localizer プロジェクト内のすべてのリソース要素に翻訳ステータスが割り当てられています。各ステータスは翻訳エディタでそれぞれ別の色で表示されます。ステータス フィルタを適用すると、特定のステータスの要素だけを表示することができます。詳細については、「翻訳ステータスの種類」を参照してください。

Lingobit Localizer では、翻訳メモリを使用して、既存の翻訳を新しい要素に再利用することができます。アプリケーションを更新した場合など、翻訳メモリを使用すると作業効率が大幅にアップします。詳細については、「[翻訳メモリ] パネル」を参照してください。

また、翻訳済みの既存のアプリケーション ファイルから翻訳をインポートすることもできます (「ローカライズ ファイルからの翻訳のインポート」を参照)。対象言語が複数ある場合、すべての言語の翻訳を抽出することも、特定の言語の翻訳だけを抽出することもできます。これらの翻訳は、既存のプロジェクトで再利用することができます。

アプリケーションに新しい機能を追加した場合、またはバグを修正した場合、[変更のスキャン] コマンドを使用すれば、新しいリソース要素と更新されたリソース要素のみを翻訳するだけですみます。未変更の要素については、元の翻訳がそのまま反映されます。プロジェクト内の新しい要素と更新された要素には、それぞれ "新規" と "更新" ステータスが割り当てられます (「翻訳ステータスの種類」を参照)。

アプリケーションのローカライズ バージョンを生成するには、[ローカライズ ファイルの作成] コマンドを使用します。


翻訳者とのやり取り

ローカリゼーション チームにとって、プロジェクトにかかわるチーム メンバとのやり取りに伴う負荷を低減することが重要になります。Lingobit Localizer には、こういったプロジェクト管理業務の改善を支援する機能が備わっています。Lingobit Localizer 交換ウィザードを使用すると、翻訳者または QA チームに送る交換パッケージを簡単に作成することができます。交換パッケージは、プロジェクト ファイルだけの形式で作成することも、Lingobit Localizer Translator Lite をインストールするための自己解凍型 EXE ファイルにプロジェクト ファイルを含める形で作成することもできます。詳細については、「交換ウィザードの利用」を参照してください。

Lingobit Localizer には、翻訳の自動 QA 機能も備わっています。詳細については、「検証機能について」および「問題検出機能について」を参照してください。


ローカライズ バージョンの作成

Lingobit Localizer で文字列リソースおよびその他のリソースの翻訳が完了したら、[プロジェクト] メニューの [ローカライズ ファイルの作成] をクリックして、アプリケーションのローカライズ (翻訳) バージョンを作成することができます。ローカライズ ファイルは、対象言語のロケールに応じて、プロジェクト フォルダのサブフォルダに保存されます (<プロジェクト フォルダ>\Output\<ロケール名>)。たとえば、プロジェクト フォルダが "c:\localize" でロケールが "German-Germany" の場合、ローカライズ ファイルは "c:\localize\De-de" に保存されます。

プラットフォーム固有のオプションを変更するには、[プロジェクト オプション] ダイアログを使用してください。

「Unicode 未対応のアプリケーションの実行」、「バージョン管理」、および「対象言語」も併せて参照してください。


翻訳のチェック

テキスト リソースに矛盾がないかどうかチェックするには、検証機能を使用します (「検証機能について」を参照)。書式指定子の位置が間違っていたり、空白文字の数が正しくないと、ローカライズ アプリケーションが正常に動作しない可能性があります。検証時に見つかったエラーは、[検証結果] パネルに表示されます。

ローカリゼーション プロセスの早期の段階でローカリゼーション バグを見つけ、ローカライズ アプリケーションのクラッシュの原因となっているリソースを分離するには、問題検出機能を使用すると便利です。問題検出機能を使用すると、ローカライズ アプリケーション ファイルが複数回実行され、クラッシュの原因となっている要素が正確に検出されます。

「翻訳者とのやり取り」も併せて参照してください。


バージョン管理

Lingobit Localizer には、同じプロジェクト ファイルの複数のバージョンを保存するための機能が備わっています。プロジェクトの各バージョンは別々の Lingobit Localizer ウィンドウで開き、バージョンにかかわらず通常どおり確認したり、編集したりすることができます。詳細については、「バージョン管理機能について」を参照してください。


変更のスキャン

アプリケーションに新しい機能を追加した場合、またはバグを修正した場合でも、新しいリソース要素と更新されたリソース要素のみを翻訳するだけですみます。未変更の要素については、元の翻訳がそのまま反映されます。

アプリケーション フォルダの新しいファイルを元のファイルの保存先フォルダにコピーします。各ファイルのフルパスはナビゲーション パネルで確認することができます。プロジェクト内のすべてのファイルの変更をスキャンするには、[プロジェクト] メニューの [変更のスキャン] をクリックします。1 ファイルだけ更新したい場合は、ナビゲーション パネルでファイルを右クリックして、[変更のスキャン] をクリックします。Lingobit Localizer では、リソース要素に変更がなければ、古いバージョンの翻訳が新しいバージョンでも維持されます。新しい要素と更新された要素は、わかりやすいように、それぞれ "新規"、"更新" ステータスで示されます。

「翻訳ステータスの種類」、「ステータス フィルタの利用」、および「統計の利用」も併せて参照してください。


参考資料

Lingobit Localizer はローカリゼーションの各種プロセスに対応した幅広い機能を備えており、このヘルプではその機能や用途について詳しく解説しています。製品の更新および新機能に関する最新情報については、Lingobit Technologies の Web サイト (http://www.lingobit.com) から入手することができます。Lingobit Technologies のリサーチ チームは、お客様の満足を第一に考え、サービスの拡充を行っています。また、お客様のご質問を迅速に解決できるよう Web サイトに最新の FAQ も掲載しています。


製品紹介

Lingobit Software Localization スイートをご利用いただきありがとうございます。

Lingobit Localizer は、ソフトウェアの多言語化を支援する強力なソリューションです。Lingobit Localizer はソフトウェア ローカリゼーションで必要となるあらゆる機能を兼ね備えているため、ソフトウェア リソースの適切なローカリゼーションが可能になります。これらの機能を使用すると、プロジェクト管理、チーム メンバ間でのファイルのハンドリング、翻訳不可の要素の分離、ローカライズ可能な要素の翻訳、ローカライズ ファイルの作成、QA テストなど、ローカリゼーション プロセス全体にわたって高レベルの品質を維持することができます。

Lingobit Localizer のユーザ インターフェイスは直感的にわかりやすく設計されているため、ソフトウェア ローカリゼーションの各種プロセスを比較的簡単に進めることができます。

Lingobit Localizer は、Windows バイナリ ファイル、Java properties ファイル、.NET resources ファイル、XML ファイルなど、ほとんどすべてのリソース ファイルに対応しています。


Edition 間の比較

Lingobit Technologies では、お客様のニーズに合わせて、Lingobit Localizer の複数の Edition を提供しています。ローカリゼーション プロジェクトの規模や必要な機能に応じて、以下のうちご希望の Edition を選択してください。

● Translator Edition - 翻訳者や QA チームへの配布用の Edition です。この Edition では新規プロジェクトは作成できないため、Professional Edition または Enterprise Edition と組み合わせて使用する必要があります。

● Professional Edition - 小規模～中規模のローカリゼーション プロジェクトを対象にした Edition です。Lingobit Localizer の標準的な機能はすべて備わっていますが、TMX のインポート/エクスポート機能と交換ウィザードは利用できません。この Edition には、Lingobit Localizer Translator Edtion の無料ライセンスが付属しています。

● Enterprise Edition - 多くの翻訳者がかかわる大規模のプロジェクトを対象にした Edition です。Lingobit Localizer のすべての機能を利用することができます。交換ウィザードも利用できるため、プロジェクト チーム間でローカライズ データのやり取りが容易になります。


新機能

Lingobit Localizer 4.7

  1. 利用できるユーザ インターフェイスが、英語、フランス語、ドイツ語、日本語、ロシア語、スペイン語、イタリア語、中国語の 8 言語に増えました。

  2. 交換ウィザードを改善しました。

  3. 言語選択用のダイアログを改善しました。

  4. リソースのみの DLL の Delphi サポートを改善しました。

  5. コマンドライン インターフェイスを改善しました。

  6. MFC アプリケーションのコンボ ボックスの問題を修正しました。

Lingobit Localizer 4.5

  1. .NET Framework 2.0 に対応しました。

  2. Borland Delphi および Borland C++Builder に対応しました。

  3. テキストベースのファイル (PHP ファイル、ASP ファイル、C/C++ ソース ファイル、INI ファイルなど) に対応しました。

Lingobit Localizer 4.2

  1. ユーザビリティを改善しました。

    • グリッド行の自動サイズ調整機能を追加しました。

    • 元に戻すためのコマンドを追加しました。

    • テキスト/CSV のインポート ウィザードとエクスポート ウィザードを追加しました。

    • ステータス管理機能を追加しました。

  2. 新しい検証オプションを追加しました。

  3. 新しいコマンドライン ディレクティブを追加しました。

Lingobit Localizer 4.0

  1. スペル チェック機能 (インタラクティブ + 検証) を追加しました。

  2. 比較エキスパート (プロジェクトのバージョン間を比較して差異を表示) を追加しました。

  3. オートコレクト メカニズムを実装しました。

  4. .NET フォームのビジュアル エディタを追加しました。

  5. テキストの文字切れをチェックする検証オプションを追加しました。

  6. 要素の重なりをチェックする検証オプションを追加しました。

  7. ダイアログ/フォーム用のビジュアル エディタのレイアウト管理機能を追加しました。

    • 配置管理機能を追加しました。

    • サイズ管理機能 (同じサイズに調整、グリッドに合わせる、コンテンツに合わせる) を追加しました。

    • 反転機能を追加しました。

    • グリッド表示機能を追加しました。

  8. ダイアログ/フォームの選択枠をコンテンツに合わせるための機能を追加しました。

  9. レポート機能 (プロジェクト、統計、出力、検証) を追加しました。

  10. Lingobit Localizer からローカライズ アプリケーションを実行するための機能を追加しました。

Lingobit Localizer 3.5

  1. 問題検出機能 - ローカライズ アプリケーションのクラッシュの原因となっているリソースの分離が容易になりました。

  2. テキスト エディタ - テキスト翻訳の編集が容易になりました。

  3. 翻訳メモリのテキスト/CSV 形式でのインポートとエクスポートが可能になりました。

    • Trados ファイルに対応しました。

    • Microsoft グロッサリに対応しました。

  4. プロジェクトのテキスト/CSV 形式でのエクスポートが可能になりました。

  5. コマンドライン インターフェイス - Localizer を自動ビルド プロセスに統合できるようになりました。


システム要件

最低システム要件

Pentium 300 MHz 以上、32 MB RAM、Microsoft Windows XP/2000/2003

推奨

Pentium 1000 MHz 以上、128 MB RAM、Microsoft Windows 2000/XP


サポートされているプラットフォーム

Lingobit Localizer では、各種プラットフォーム用のファイルのローカリゼーションが可能です。

  • Microsoft MFC/Win32 アプリケーション (*.exe、*.dll、*.ocx)

  • Microsoft .NET resources ファイル

  • Java properties ファイル

  • XML データ ファイル


試用版の制限事項

Lingobit Localizer は試してから購入できるシェアウェアです。お客様に適切な判断をしてもらえるよう、試用版でも正規版とまったく同じ機能を使用できるようになっています。

制限事項

Lingobit Localizer の試用版には以下の制限事項があります。

  • 90 日間の使用期限

  • 最初の 50 件の翻訳単位しか保存できない


用語集

アクセラレータ リソース

アクセラレータ リソースには、アプリケーションでショートカットとして使用されるキーの組み合わせが含まれます。

ビットマップ リソース

ビットマップ リソースにはイメージが含まれます。Lingobit Localizer では、実行可能ファイルからビットマップ リソースを抽出して、必要に応じてローカライズすることができます。

アイコン リソース

アイコン リソースにはアプリケーション固有のアイコンが含まれます。Lingobit Localizer では、実行可能ファイルからアイコン リソースを抽出して、必要に応じてローカライズすることができます。

ローカライザビリティ

ローカリゼーションの容易性の度合いです。アプリケーションには、テキスト、イメージ、音声など、ローカリゼーションが必要な各種リソースが多数含まれています。ただし、100% ローカライズ可能なアプリケーションはほとんど存在しません。たとえば、一部の単語や語句がアプリケーションのコード内にハードコードされていて翻訳できないことは珍しいことではありません。これらの問題はすべてローカライザビリティ バグといえます。

ローカリゼーション

アプリケーションを特定の地域の言語や文化に適応させるプロセスです。ローカリゼーションを正しく行うには、対象地域の言語、文化、習慣、および特性を考慮する必要があります。ローカリゼーションは、アプリケーションの書記体系はもちろん、キーボードの入力形式、フォント、日付/時刻、通貨の形式にも関係してきます。また、グラフィックス、色、音響効果も文化に合わせて調整する必要があります。ローカリゼーションの基礎となるのは、通常、ユーザ インターフェイス (ダイアログ、文字列、メニュー、ビットマップ、アイコン) の翻訳です。

ナビゲーション パネル

ドッキング式のパネルで、デフォルトではウィンドウの左側に配置されています。ナビゲーション パネルには、プロジェクト内のすべてのファイルとリソースがツリー構造で表示されます。ナビゲーション パネルで選択したリソースの翻訳が翻訳エディタに表示されます。

リソース

プログラムのコードから分離されたデータで、プロジェクトを構成する一部 (サイズはさまざま) です。プロジェクト内のファイルをリソースと呼ぶこともあれば、メニューやダイアログなどの基本単位をリソースと呼ぶこともあります。プロジェクト内のすべてのリソースがナビゲーション パネルにツリー構造で表示されます。Lingobit Localizer では、Windows の実行可能ファイル内からローカライズ可能なリソースの種類を検出して、Lingobit Localizer プロジェクトに追加することができます。リソースの中には WYSIWYG 形式で表示できるものもあります。

ソース ファイル

ローカリゼーションが必要なファイルです。

元の言語

ローカリゼーションが必要なアプリケーションの言語です。

[出力] パネル

ドッキング式のパネルで、デフォルトではウィンドウの下部に配置されています。[出力] パネルには、プログラムで実行した機能のログが表示されます。

プロジェクト

ローカリゼーションが必要な 1 つまたは複数のファイルで構成されます。プロジェクトにはファイル内のリソースの翻訳も含まれます。

ダミー翻訳

製品のローカライズ可能なリソースを自動的に翻訳して、製品を実際にローカライズしたものとしてビルドおよびテストするプロセスです。ダミー翻訳で見つかった問題は実際の翻訳が完了した際にも見つかると仮定できるため、問題の原因となっているリソースを早期の段階で修正することができます。

統計

プロジェクト内の要素 (アイテム) の数とそのパーセンテージ、および文字数とそのパーセンテージをステータス別に表示する機能です。

ステータス

リソースの各要素に割り当てられる進捗状況です。ステータスは翻訳エディタに表示されます。

ターゲット ファイル

ソース ファイル内のリソースの翻訳後、Lingobit Localizer で生成されたローカライズ ファイルです。

対象言語

プロジェクトの出力言語です。ローカリゼーションが必要なアプリケーションに複数の対象言語を選択することもできます。

TMX (Translation Memory Exchange)

翻訳メモリの形式を変換するプロセスを簡略化および自動化するために策定された XML ベースのオープン スタンダードです。

翻訳

テキスト要素を元の言語から対象言語に変換するプロセスです。元の言語のメッセージの意味を正確に理解して対象言語で伝えることが重要になります。

翻訳エディタ

メイン ウィンドウの右側に配置されているパネルです。翻訳エディタには、選択したリソース内の文字列の原文と訳文、およびその翻訳ステータスが表示されます。

翻訳メモリ

既存の翻訳データ (原文と訳文のペア) を格納した特別なデータベースです。翻訳メモリ内の翻訳は、文節単位でその一部またはすべてを再利用することができます。

検証

翻訳に矛盾がないかチェックするための機能です。この機能は、プロジェクト全体を対象に実行することも、プロジェクト内の特定のリソースを対象に実行することもできます。各種検証オプションが用意されています。

WYSIWYG (What You See Is What You Get)

ダイアログ リソース、フォーム リソースのサイズや位置を調整したり、ビットマップ リソース、メニュー リソースを視覚的に編集したりすることができる UI エディタです。

XML (eXtensible Markup Language)

電子情報 (特に、Web ドキュメント) の公開や送受信の国際標準となっているプログラミング言語/規格です。


重複箇所の翻訳

アプリケーションのローカリゼーションでは、矛盾のない高レベルの品質を維持することが重要になります。特に、同一要素が複数存在する場合はなおさらです。同一要素を矛盾なく翻訳し、さらに翻訳速度を上げるには、重複箇所翻訳機能を使用すると便利です。この機能を使用すると、該当する要素に既存の翻訳が自動的に挿入されます。

たとえば、テキスト リソースに "cancel" という要素が複数存在する場合、いずれか 1 つの要素を "キャンセル" と翻訳した後で重複箇所の翻訳機能を使用すると、残りのすべての要素に "キャンセル" という訳語が自動的に挿入されるため、手作業で入力する手間が省け、翻訳の生産性が向上します。

この機能を使用するには、ナビゲーション パネルで目的のリソースを右クリックして、[ツール]、[重複箇所の翻訳] の順にクリックします。または、メイン ウィンドウの [ツール] メニューで [重複箇所の翻訳] をクリックします。

「翻訳メモリについて」も併せて参照してください。


元に戻す

Lingobit Localizer には、翻訳単位の以下の要素を元に戻すための機能が備わっています。

  • テキスト

  • 境界

  • その他 (バイナリ データ、イメージなど)

プロジェクト ファイルまたは Lingobit Localizer 以外のツールでローカライズしたファイルから翻訳をインポートした場合、または [変更のスキャン] コマンドを実行した場合、テキスト要素は維持されますが、テキスト以外の要素が置換されたり変更されてしまう可能性があります。

Lingobit Localizer では、テキスト以外の要素 (たとえば、Windows バイナリ ファイル、アイコンなど) を元の状態に戻すことができます。また、ダイアログ/フォーム内の要素の位置やサイズをテキストを維持したまま元の状態に戻すこともできます。

この機能は、プロジェクト内のすべての要素に適用することも、単一のリソースに適用することもできます。この機能を使用するには、ナビゲーション パネルで該当するリソース (すべてのリソース ファイルを対象にする場合は [All]) を右クリックして、[元に戻す] から目的のコマンドを選択します。確認メッセージが表示されたら、[はい] をクリックします。

翻訳単位を完全に元に戻す場合は、[原文に戻す] コマンドを使用してください。

「ローカライズ ファイルからの翻訳のインポート」、「プロジェクトからの翻訳のインポート」、「翻訳ステータスの種類」も併せて参照してください。


ローカライズ アプリケーションの実行

[ローカライズ アプリケーションの実行] コマンドを使用すると、ローカライズ後のアプリケーションを起動することができます。[ローカライズ アプリケーションの実行] コマンドのパラメータは、必要に応じて、[プロジェクト オプション] ダイアログで変更することができます。

「実行パラメータ」および「Unicode 未対応のアプリケーションの実行」も併せて参照してください。


翻訳ステータスの種類

Lingobit Localizer プロジェクト内の各リソース要素には翻訳ステータスが割り当てられます。翻訳ステータスを見ると、ローカライズ可能な要素を簡単に見分けることができます。

リソース要素の翻訳ステータスは手動で設定することもできますが、ステータスの中には一部のローカリゼーション機能を実行すると自動的に設定されるものもあります。

未翻訳

デフォルトでは、プロジェクト内のすべてのリソース要素に "未翻訳" ステータスが割り当てられています。また、翻訳済みの要素を原文に戻すと、ステータスは自動的に "未翻訳" に変更されます。

ローカリゼーション プロセスの進捗に応じてユーザが手動で設定できるステータスには以下のものがあります。

完了

翻訳に問題のない要素には、[完了] ステータスを設定してください。

要レビュー

後でレビューが必要な要素には、[要レビュー] ステータスを設定してください。

翻訳中

下翻訳段階の要素には [翻訳中] ステータスを設定してください。[未翻訳] ステータスの要素を翻訳すると、[翻訳中] ステータスが自動的に割り当てられます。

ロック

(翻訳済みの) 要素を変更できないようにするには、[ロック] ステータスを設定してください。[ロック] ステータスの要素を変更するには、ロックを解除する必要があります。

リソース要素に自動的に設定されるステータスには以下のものがあります。

自動

[重複箇所の翻訳] コマンドまたは [翻訳メモリから翻訳] コマンドを使用して要素を自動的に翻訳した場合、[自動] ステータスが割り当てられます。

更新

[変更のスキャン] コマンドを使用したときに要素が変更された場合、[更新] ステータスが割り当てられます。

新規

[変更のスキャン] コマンドを使用したときに要素がプロジェクトに追加された場合、[新規] ステータスが割り当てられます。

インポート

[翻訳ファイルのインポート] コマンドを使用したときに要素が変更された場合、[インポート] ステータスが割り当てられます。

翻訳ステータスを変更するには、リソース要素を右クリックして、[ステータス] から目的のステータスを選択します。または、リソース要素を選択して、[翻訳] ツールバーの目的のボタンをクリックします。

「統計の利用」および「ステータス フィルタの利用」も併せて参照してください。


ステータス フィルタの利用

特定の条件のローカライズ データだけを確認したい場合、ステータス フィルタを利用すると便利です。フィルタを適用すると、翻訳進捗を分析したり、Lingobit Localizer の各種機能によって追加または変更されたデータを簡単に確認することができます。デフォルトでは、[<フィルタなし>] が適用されています。

フィルタを適用するには、ナビゲーション パネル または [表示] メニューの [ステータスでフィルタ] から目的のフィルタを選択します。

「翻訳ステータスの種類」および「統計について」も併せて参照してください。


新規プロジェクト ウィザードについて

新規プロジェクト ウィザードを使用すると、新しい Lingobit Localizer プロジェクトを作成することができます。プロジェクトには、アプリケーションのローカリゼーションに必要な情報がすべて含まれます。ローカリゼーション プロセスを開始するには、まず、プロジェクトを作成する必要があります。

Lingobit Localizer の起動時に新規プロジェクト ウィザードを開始するには、[Lingobit Localizer] ダイアログで [新規プロジェクトを作成する] を選択します。

Lingobit Localizer の起動後に新規プロジェクト ウィザードを開始するには、[ファイル] メニューの [新規] をクリックするか、Ctrl+N キーを押します。

新規プロジェクトを作成するには、以下の手順に従います。

  1. プロジェクト名と保存先を指定します。

  2. アプリケーションの元の言語と対象言語を指定します。

  3. ローカライズするファイルを追加します。

  4. ウィザードを終了します。


プロジェクト名と保存先

新規プロジェクト ウィザードの最初の手順では、プロジェクト名と保存先を指定します。保存先を指定する際は、[参照] ボタンをクリックして、[フォルダの参照] ダイアログで目的のフォルダを選択することができます。

Lingobit Localizer プロジェクト ファイル (拡張子 .loc) は、ユーザが指定した保存先フォルダの <プロジェクト名> サブフォルダに作成されます (<保存先>\<プロジェクト名>\<プロジェクト名>.loc)。

メモ:プロジェクト フォルダが、ローカライズ ファイルとサポート ファイル (特定の種類のプロジェクトで使用される一時ファイル) のホーム ディレクトリになります。ローカライズ ファイルとサポート ファイルは、対象言語のロケールに応じて、プロジェクト フォルダのサブフォルダに保存されます。

プロジェクト名と保存先をそれぞれ該当するフィールドに入力してください。[参照] ボタンを使用して、コンピュータ内のフォルダを選択することもできます。

名前

作成するプロジェクトの名前を入力してください。[保存先] フィールドで指定したフォルダにプロジェクトと同名のサブフォルダが作成されます。プロジェクトの種類によっては、ソース ファイルとその他のサポート ファイルが自動的に作成され、新しいプロジェクト フォルダに追加される場合があります。

メモ: プロジェクト名には以下の文字は使用できません。
シャープ (#)、パーセント (%)、アンパサンド (&)、アスタリスク (*)、縦棒 (|)、円記号 (\)、コロン (:)、二重引用符 (")、小なり記号 (<)、大なり記号 (>)、疑問符 (?)、スラッシュ (/)、先頭または末尾のスペース (' ')、Windows または DOS で予約されている名前 ("nul"、"aux"、"con"、"com1"、"lpt1" など)

保存先

作成するプロジェクトの保存先を入力するか、フォルダ ツリーから選択してください。

参照

[フォルダの参照] ダイアログを開いて、フォルダ ツリーからプロジェクトの保存先を選択することができます。

「新規プロジェクト ウィザードについて」も併せて参照してください。


プロジェクトの言語

Lingobit Localizer では、プロジェクトを特定のロケールでローカライズすることができます。新規プロジェクトを作成する際、アプリケーションの対象言語と、その言語が使用されている地域 (必要に応じて) を指定します。

たとえば、アラビア語は 16 種類 (アラビア語-イラク、アラビア語-モロッコ、アラビア語-レバノン、アラビア語-サウジアラビアなど) の地域に分類されています。ただし、必ずしも地域を指定する必要はありません。

アプリケーションの対象言語はプロジェクトの作成後に追加することもできますが、プロジェクトの作成時に最低 1 言語は指定する必要があります。

アプリケーションの元の言語をドロップダウン リストから選択します。

対象言語パネルで [追加] ボタンをクリックして、[言語] ダイアログを開きます。アプリケーションの対象言語を選択して、[追加] ボタンをクリックします。複数の言語を追加するには、同じ操作を繰り返します。目的の言語をすべて追加したら、[OK] をクリックします。

選択した言語をリストから削除するには、[削除] ボタンをクリックします。

「新規プロジェクト ウィザードについて」も併せて参照してください。


プロジェクトのファイル

新規プロジェクト ウィザードの最後の手順では、ローカライズするアプリケーションのファイルをプロジェクトに追加します。追加できるファイルの数に制限はありません。

[追加] ボタンをクリックして、[ファイルの追加] ダイアログを開きます。選択したファイルをプロジェクトから削除するには、[削除] ボタンをクリックします。

[ファイルの追加] ダイアログ

複数のファイルを追加するには、Ctrl キーまたは Shift キーを使用します。

ファイル パス

ファイル パスに一貫性がないと、Lingobit Localizer の操作で問題が生じる場合があります。デフォルトでは、ファイルは相対パスで Lingobit Localizer プロジェクトに追加されます。Lingobit Localizer プロジェクトを他のコンピュータに送信する場合など、ファイルを相対パスで追加しておいたほうが何かと便利です。ただし、このデフォルトの動作は必要に応じて変更することができます (「ツール オプション」を参照)。

「新規プロジェクト ウィザードについて」も併せて参照してください。


[検索と置換] ダイアログ

[検索と置換] ダイアログでは、原文の文字列、翻訳文字列、またはリソース ID を対象に検索することができます。

検索する文字列

検索する文字列を入力します。正規表現 (ワイルドカード) を使用することもできます。

置換後の文字列

[検索する文字列] テキスト ボックスに入力した文字列が見つかった場合に置換する文字列を入力します。正規表現を使用することもできます。

検索場所

以下の中から検索範囲を指定します。

  • 原文の文字列

  • 翻訳文字列

  • リソース ID

正規表現を使用する

このチェック ボックスをオンにすると、[検索する文字列]/[置換後の文字列] テキスト ボックスで実際の文字列の代わりに正規表現を使用できるようになります。

大文字/小文字を区別する

このチェック ボックスをオンにすると、大文字/小文字が一致する文字列のみが検索されるようになります。

アンパサンド (&) を無視する

このチェック ボックスをオンにすると、原文の文字列または翻訳文字列に含まれるホットキーを無視して検索されるようになります。

完全一致のみを検索する

このチェック ボックスをオンにすると、[検索する文字列] テキスト ボックスに入力した文字列と完全に一致する文字列のみが検索されるようになります。

「[検索結果] パネル」も併せて参照してください。


[検索結果] パネル

[検索と置換] ダイアログで指定した条件に一致する要素は [検索結果] パネルに表示されます。

アイテムをダブルクリックすると (または、アイテムを右クリックして、[移動] をクリックすると)、該当する要素が翻訳エディタに表示されます。

[検索結果] パネルからすべてのアイテムを削除するには、パネルを右クリックして、[すべてクリア] をクリックします。

「[検索と置換] ダイアログ」も併せて参照してください。


スタートアップ ダイアログ

プログラムを起動すると、新規プロジェクトを作成するか、既存のプロジェクトを開くか、または空のワークスペースを開くかを選択するためのダイアログが表示されます。空のワークスペースを開いた場合は、プログラムの起動後に新規プロジェクトを作成したり、既存のプロジェクトを開くことになります。

既存のプロジェクトで作業するには、[Lingobit Localizer] ダイアログのファイル オプションで [既存のプロジェクトを開く] を選択します。次に、[...] ボタンをクリックして、目的のプロジェクトを選択します。最後に、[OK] をクリックします。

新規プロジェクトを作成するには、[新規プロジェクトを作成する] を選択して、[OK] をクリックします。新規プロジェクト ウィザードが自動的に開始します。

空のワークスペースを開くには、[空のワークスペース] を選択して、[OK] をクリックします。

このスタートアップ ダイアログを今後表示しないように設定するには、[起動時にこのダイアログを表示する] チェック ボックスをオフにします。または、プロジェクトを開いた後で、[ツール オプション] ダイアログ ([ツール] -> [オプション]) の [スタートアップ ダイアログを表示する] チェック ボックスをオフにします。

「Lingobit Localizer プロジェクト」も併せて参照してください。


ナビゲーション パネル

ナビゲーション パネルはドッキング式のパネルで、デフォルトではウィンドウの左側に配置されています。

ナビゲーション パネルには、プロジェクト内のすべてのファイルとリソースがツリー構造で表示されます。ナビゲーション パネルでアイテムを選択すると、選択したアイテムのリソース要素が翻訳エディタに表示されます。各リソース要素を別々に表示するには、ツリーを展開して目的のリソースを選択します。

ナビゲーション パネルでアイテムを右クリックすると、ショートカット メニューが表示されます。このショートカット メニューから各種コマンドを実行することができます。

たとえば、ファイル内のすべてのダイアログの要素に [ロック] ステータスを設定することができます。この場合、ナビゲーション パネルで目的のファイルの [Dialogs] リソースを右クリックして、[ステータス]、[ロック] の順にクリックします。なお、[ロック] ステータスは、ダイアログごとに別々に設定することもできます。

ナビゲーション パネルのすべてのツリーを折りたたむには、[表示] メニューの [すべて折りたたむ] をクリックするか、ファイルまたはリソースを右クリックして [すべて折りたたむ] をクリックします。

ナビゲーション パネルを完全に隠すには、パネル上の [閉じる] ボタンをクリックするか、[表示] メニューの [ナビゲーション パネル] のチェックをはずします。

ナビゲーション パネルを自動的に隠すには、パネル上の [自動非表示] ボタンをクリックします。

デフォルトでは、ナビゲーション パネルにはプロジェクト内のファイル名だけが表示されます。ファイルのフルパスが表示されるようにするには、[ツール] メニューの [オプション] をクリックして、[ツール オプション] ダイアログの [ナビゲーション パネルにファイルのフルパスを表示する] チェック ボックスをオンにします。


ツールバー

Lingobit Localizer には、複数のツールバーが用意されています。各ツールバーのボタンは、メイン メニューのコマンドに対応しています。

ツールバーを隠すには、ツールバー領域を右クリックして、目的のツールバー名の左側のチェックをはずします。

[表示] メニューからツールバーの表示/非表示を切り替えることもできます。この場合、[表示] メニューの [ツールバー] をポイントして、目的のツールバー名の左側のチェックをはずします。


メイン ウィンドウ

Lingobit Localizer のメイン ウィンドウは、メイン メニュー、いくつかのツールバー、ステータス バー、翻訳エディタ、および一連のパネルで構成されます。

翻訳エディタと一連のパネルには、プロジェクト内のファイルとリソースに関する情報、翻訳リスト (原文と訳文)、およびプログラムで現在使用している機能の関連情報が表示されます。

翻訳エディタはメイン ウィンドウの右側に配置されています。翻訳エディタをメイン ウィンドウから隠したり、位置を変更したりすることはできません。ただし、メイン ウィンドウのその他のパネルを移動した場合、翻訳エディタの位置とサイズが変わります。

ナビゲーション パネルは、デフォルトではメイン ウィンドウの左側に配置されています。その他のパネルはメイン ウィンドウの下部に配置されています。

メイン ウィンドウのパネルは、デフォルトではドッキング式になってますが、必要に応じて可動式に変更することができます。

メイン ウィンドウの任意のパネルを完全に隠すには、[表示] メニューで目的のパネル名の左側のチェックをはずします。パネルをもう一度表示するには、チェックを付けます。デフォルトでは、すべてのパネルが表示されています。

メイン ウィンドウのすべてのパネルを自動的に隠すには、[ウィンドウ] メニューの [すべて隠す] をクリックします。


[出力] パネル

[出力] パネルには、プログラムで実行した機能のログが表示されます。

たとえば、[重複箇所の翻訳] コマンドを実行した場合、自動的に翻訳された要素に関する情報が [出力] パネルに表示されます。アイテムをダブルクリックすると (または、アイテムを右クリックして、[移動] をクリックすると)、該当する要素が翻訳エディタに表示されます。[重複箇所の翻訳] コマンドの詳細については、「重複箇所の翻訳」を参照してください。

[出力] パネルからすべてのアイテムを削除するには、パネルを右クリックして、[すべてクリア] をクリックします。


[テキスト エディタ] パネル

[テキスト エディタ] パネルは、デフォルトではメイン ウィンドウの下部に配置されています。このパネルでは、選択したリソース要素の翻訳を入力することができます。編集フィールドの上には対応する原文が表示されます。

[テキスト エディタ] パネルのツールバーを使用すると、作業中の要素に翻訳ステータスを割り当てたり、原文に戻したり、翻訳をコピーしたりすることができます。

また、[前へ (Alt+Up)]/[次へ (Alt+Down)] ボタンを使用して、前の要素に戻ったり、次の要素に進んだりすることができます。


翻訳エディタ

翻訳エディタには、翻訳可能なリソース要素が表示されます。翻訳エディタは以下の 5 つの列で構成されます。

ID

要素の ID です。ID は、数字、または要素のテクニカル コンテンツを表す単語 (たとえば、ProductVersion、ProductName、CompanyName) で表示されます。

ステータス

要素の翻訳ステータスです。デフォルトでは、すべての要素に "未翻訳" ステータスが割り当てられています。詳細については、「翻訳ステータスの種類」を参照してください。

元の言語

要素の原文 (テキスト要素) とデータ サイズ (テキスト以外の要素) です。列のヘッダには元の言語名が表示されます。

対象言語

要素の訳文です。列のヘッダには対象言語名が表示されます。複数の言語の訳文を同時に表示することはできません。別の言語の訳文を表示するには、[標準] ツールバーのドロップダウン リストから目的の言語を選択するか、[対象言語] ダイアログを使用して切り替えます。

コメント

ユーザのコメントです。コメントは翻訳エディタから直接追加することができます。追加したコメントは選択した対象言語に関係なく表示されます。なお、コメントを追加しても、ローカライズ ファイルにそのコメントが残ることはありません。

翻訳エディタでは、要素の訳文をすばやく追加、編集、またはレビューしたり、原文と比較したりすることができます。また、要素を右クリックして、ショートカット メニューから各種コマンドを実行することもできます。テキスト以外の要素を扱うには、要素をダブルクリックするか、ショートカット メニューの [バイナリ データ] から目的のコマンドを選択します。

選択した要素を翻訳または編集する際、[テキスト エディタ] パネルを使用することもできます。詳細については、「[テキスト エディタ] パネル」を参照してください。

翻訳エディタのフォントの種類、サイズ、色は、必要に応じて変更することができます。この場合、[ツール] メニューの [オプション] をクリックして、[ツール オプション] ダイアログの [翻訳エディタのフォントを変更] ボタンをクリックします。なお、フォントの変更を適用するには、Lingobit Localizer を再起動する必要があります。


Lingobit Localizer プロジェクト

Lingobit Localizer プロジェクトは、ローカリゼーションが必要な 1 つまたは複数のファイルで構成されます。プロジェクトにはファイル内のリソースの翻訳も含まれます。

保存先

Lingobit Localizer プロジェクト ファイル (拡張子 .loc) は、ユーザが指定した保存先フォルダの <プロジェクト名> サブフォルダに作成されます。プロジェクト フォルダが、ローカライズ ファイルとサポート ファイル (特定の種類のプロジェクトで使用される一時ファイル) のホーム ディレクトリになります。ローカライズ ファイルとサポート ファイルは、対象言語のロケールに応じて、プロジェクト フォルダのサブフォルダに保存されます。

言語

Lingobit Localizer では、プロジェクトを特定のロケールでローカライズすることができます。新規プロジェクトを作成する際、アプリケーションの対象言語と、その言語が使用されている地域 (必要に応じて) を指定します。

たとえば、アラビア語は 16 種類 (アラビア語-イラク、アラビア語-モロッコ、アラビア語-レバノン、アラビア語-サウジアラビアなど) の地域に分類されています。ただし、必ずしも地域を指定する必要はありません。

アプリケーションの対象言語はプロジェクトの作成後に追加することもできますが、プロジェクトの作成時に最低 1 言語は指定する必要があります。

「対象言語」、「新規プロジェクトの作成」、「プロジェクトへのファイルの追加」、および「プロジェクトからのファイルの削除」も併せて参照してください。


プロジェクトへのファイルの追加

ローカリゼーションが必要なファイルは、プロジェクトの作成時に新規プロジェクト ウィザードで追加することも、[プロジェクト] メニューの [ファイルの追加] コマンドを使用して既存のプロジェクトに追加することもできます。追加できるファイルの数に制限はありません。

ローカリゼーション プロセスでソース ファイルが必要になることが多々ありますので、ファイル パスの一貫性を維持することが重要になります。パスを変更する場合は、ナビゲーション パネルでファイルを右クリックして、[ファイル パス] コマンドを使用してください。

プロジェクト内のすべてのファイルがナビゲーション パネルにツリー構造で表示されます。必要に応じて、[ツール オプション] ダイアログ ([ツール] -> [オプション]) でファイル パスの表示形式を変更することができます。

デフォルトでは、ファイルの追加時に相対パスが使用されます。絶対パスを使用したい場合は、[ツール オプション] ダイアログ ([ツール] -> [オプション]) の該当するチェック ボックスをオフにしてください。

既存のプロジェクトにファイルを追加するには、[プロジェクト] メニューの [ファイルの追加] をクリックするか、Ctrl+I キーを押します。次に、[ファイルの追加] ダイアログの [ファイルの種類] から目的のファイルの種類を選択します。該当する種類のファイルだけが表示されるようになります。目的のファイルが見つかったら、そのファイルを選択して、[開く] をクリックします。複数のファイルを追加する場合は、Ctrl キーまたは Shift キーを押しながらファイルを選択してください。

「Lingobit Localizer プロジェクト」および「プロジェクトからのファイルの削除」も併せて参照してください。


プロジェクトからのファイルの削除

プロジェクト内のファイルは、必要に応じて削除することができます。ただし、削除したファイルの翻訳は回復できませんので注意してください。

プロジェクトからファイルを削除するには、ナビゲーション パネルでファイルを選択して、[プロジェクト] メニューの [ファイルの削除] をクリックします。または、ナビゲーション パネルでファイルを右クリックして、[プロジェクトから削除] をクリックします。


対象言語

対象言語とは、アプリケーション リソースの翻訳言語です。Lingobit Localizer プロジェクトには、1 つまたは複数の対象言語を追加することができます。プロジェクトが複数の対象言語で構成されている場合、翻訳エディタで作業する言語を選択する必要があります。複数の言語の翻訳を同時に追加または変更することはできません。

翻訳メモリに複数の対象言語の翻訳単位を追加した場合、[翻訳メモリ] パネルにはすべての言語の翻訳単位が同時に表示されます (詳細については、「翻訳メモリについて」を参照)。

Lingobit Localizer では、さまざまな国の言語がサポートされています。利用可能な言語のリストは、各国のプライマリ言語と、特定のロケールに対応するサブ言語で構成されています。プライマリ言語はそのロケール (たとえば、German) に関係なく共通で、サブ言語は特定のロケール (German-Germany または German-Switzerland) によって異なります。Lingobit Localizer プロジェクトには、必要に応じて、同じプライマリ言語の複数のサブ言語を追加することができます。

同じプライマリ言語のサブ言語間では、スペル、日付/時刻、通貨の形式などが異なる場合があります。たとえば、フランスで使用されているフランス語とカナダで使用されているフランス語にはかなりの違いがあります。また、サブ言語の中には別々の文字セット (中国の簡体字中国語と台湾の繁体字中国語など) を使用しているものもあります。

翻訳エディタには、原文と選択した対象言語の訳文がペアで表示されます。複数の対象言語の訳文を同時に表示することはできません。翻訳エディタの列ヘッダ、および [標準] ツールバーを見ると、現在選択している対象言語がわかります。

翻訳エディタに表示する言語を切り替えるには、[標準] ツールバーまたは [対象言語] ダイアログ ([プロジェクト] -> [言語]) のドロップダウン リストから目的の言語を選択します。

通常、対象言語はプロジェクトの作成時に指定します (詳細については、「新規プロジェクトの作成」を参照)。

また、プロジェクトでの作業中に言語を追加または削除することもできます。

プロジェクトに言語を追加したり、プロジェクトから言語を削除するには、[言語] ダイアログを使用します。[言語] ダイアログを開くには、[標準] ツールバーのドロップダウン リストから [追加] を選択するか、[プロジェクト] メニューの [言語] をクリックして [対象言語] ダイアログで [言語の追加/削除] ボタンをクリックします。

[言語] ダイアログは、[利用可能な言語]、[対象言語]、および [言語パラメータ] の 3 つのパネルで構成されています。[利用可能な言語] パネルまたは [対象言語] パネルで言語を選択すると、その言語に関する情報が [言語パラメータ] パネルに表示されます。

左側の [利用可能な言語] パネルから対象言語を追加するには、目的の言語をダブルクリックするか、選択して [追加] ボタンをクリックします。

言語を削除するには、[対象言語] パネルで目的の言語をダブルクリックするか、選択して [削除] ボタンをクリックします。

プロジェクトから以前に削除した言語をもう一度追加した場合、翻訳済みの要素はそのまま維持されています。

「Lingobit Localizer プロジェクト」も併せて参照してください。


レポート

Lingobit Localizer では、各種レポートを生成することができます。レポートを生成するには、[ツール] メニューの [レポート] コマンドを使用します。

プロジェクト レポート

プロジェクト レポートには、プロジェクト内のすべての要素の原文と訳文、およびその翻訳ステータスが表示されます。


実行パラメータ

[プロジェクト オプション] ダイアログの [実行パラメータ] タブでは、[ローカライズ アプリケーションの実行] コマンドと [問題検出] コマンドのパラメータを設定することができます。

実行するコマンド

プログラムを起動するコマンドを指定します。ドロップダウン リストからプロジェクト内のファイルを選択することも、独自の値を入力することもできます。

コマンド引数

[実行するコマンド] セクションで指定したコマンドの引数を指定します。

作業ディレクトリ

起動するプログラムの作業ディレクトリを指定します (出力ファイルが保存されているプロジェクト ディレクトリが基準になります)。何も指定しなかった場合、出力ファイル ディレクトリが作業ディレクトリになります。


出力ファイル

Windows バイナリ ファイルに対して Lingobit Localizer で作成する出力ファイルの形式を指定します。以下の 3 種類の出力ファイル オプションが用意されています。

ローカライズ ファイル

ファイルは言語別に分離されます。最も容易なローカリゼーション方法ですが、言語ごとに別々のファイルを配置する必要があります。デフォルトでは、このオプションが使用されます。

多言語ファイル

複数の言語が単一のファイルにエクスポートされます。言語選択のメカニズムはオペレーティング システムのバージョンによって異なるため、Microsoft 社はこの形式を推奨していません。

リソースのみの DLL

ローカライズ リソースが自動的にリソースのみの DLL に抽出されます。各 DLL は言語別に分離されます。多言語アプリケーションでは最も適した形式といえますが、アプリケーションのソース コードを若干変更する必要があります。


Borland リソース

フォームの Unicode サポート

Borland フォームでの Unicode 文字列のサポートは VCL バージョン 6 でのみ有効です。アプリケーションで古いバージョンの VCL を使用している場合は、このオプションを無効にする必要があります。


プロジェクトのエクスポート

Lingobit Localizer では、プロジェクト内の翻訳データを TMX ファイル形式またはテキスト/CSV ファイル形式でエクスポートすることができます。エクスポート後の翻訳データ (通常、原文と対応する訳文) は、将来のプロジェクトで再利用したり、チーム メンバ間で共有することができます。

「Lingobit Localizer プロジェクト」および「プロジェクトからの翻訳のインポート」も併せて参照してください。


プロジェクトのエクスポート: TMX

Lingobit Localizer では、プロジェクト内の翻訳データを TMX ファイルにエクスポートすることができます。TMX (Translation Memory eXchange) は、異なるソフトウェア ローカリゼーション ツール間での翻訳メモリの転送に使用されている XML ベースのデータ交換ファイル形式です。TMX ファイル形式の翻訳データは各種 CAT ツールにインポートすることができます。

TMX ファイルには、プロジェクト内のすべての要素の翻訳データが保存されます。

すべての要素の翻訳データを TMX ファイルにエクスポートするには、[ファイル] メニューから [エクスポート]、[TMX のエクスポート] の順にクリックします。

「プロジェクトのエクスポート」も併せて参照してください。


プロジェクトのエクスポート: テキスト/CSV

Lingobit Localizer では、プロジェクト内の翻訳データをプレーン テキスト ファイルまたは CSV (カンマ区切り) ファイルにエクスポートすることができます。テキスト ファイルは、翻訳データの交換に使用されている最も一般的な形式です。テキスト ファイルには、選択した単一言語のみの翻訳データが保存されます。テキスト/CSV ファイルの書式は、その用途や目的に応じてエクスポート時にカスタマイズすることができます。

選択した言語の翻訳データをエクスポートするには、[ファイル] メニューから [エクスポート]、[テキスト/CSV のエクスポート] の順にクリックします。

詳細については、「テキスト エクスポート ウィザード」を参照してください。

「プロジェクトのエクスポート」も併せて参照してください。


ローカライズ ファイルからの翻訳のインポート

Lingobit Localizer では、ローカライズ済みのファイル内の翻訳データを現在のプロジェクトにインポートすることができます。インポート可能なファイル形式は、Windows バイナリ ファイル、Java properties ファイル、.NET ファイル、および XML ファイルです。

この機能を実行すると、選択したファイル内のデータがプロジェクト内のデータと比較され、既存の要素の翻訳データが抽出されます。ファイルから抽出可能な言語の翻訳データは自動的に認識されます。選択したファイルに複数の言語の翻訳データが含まれている場合は、すべての言語の翻訳データを抽出するか、特定の言語の翻訳データのみを抽出するかを指定することができます。

プロジェクトに翻訳データがインポートされた要素には、自動的に "インポート" ステータスが割り当てられます (詳細については、「翻訳ステータスの種類」を参照)。

翻訳データをインポートするには、[ファイル] メニューから [インポート]、[翻訳ファイルのインポート] の順にクリックします。[翻訳ファイルのインポート] ダイアログで、目的のファイルを選択します。[インポート パラメータ] ダイアログで、インポート オプションを設定します。なお、選択したサブツリーの翻訳データのみをインポートする場合は、ナビゲーション パネルを右クリックして、[翻訳ファイルのインポート] をクリックします。

[翻訳ファイルのインポート] ダイアログで、ファイルから抽出する言語をドロップダウン リストから選択します。ファイルに複数の言語の翻訳データが含まれている場合、[すべての言語] がデフォルトで選択されています。このダイアログでは、対象言語も選択することができます。この際、抽出する言語の翻訳データに別の対象言語を選択することもできます。たとえば、選択したファイルの翻訳データが "German-Germany" に設定されている場合、翻訳データに影響を及ぼすことなく、データの言語を "German-Luxembourg" に変更することができます。デフォルトでは、抽出する言語と対象言語は同じに設定されています。

翻訳データのインポート処理を開始するには、[OK] をクリックします。

「プロジェクトのエクスポート」も併せて参照してください。


プロジェクトからの翻訳のインポート

Lingobit Localizer では、既存のプロジェクト ファイル内の翻訳データを現在のプロジェクトにインポートすることができます。翻訳データを再利用する場合など、この機能を使用すると便利です。

対象言語の異なるプロジェクトをインポートすることはできません。プロジェクトに複数の対象言語が含まれている場合、一致する言語の翻訳データのみがインポートされます。

プロジェクト ファイルをインポートするには、[ファイル] メニューから [インポート]、[プロジェクトのインポート] の順にクリックします。[ファイルを開く] ダイアログで、目的のプロジェクト ファイル (拡張子 .loc) を選択します。[インポート パラメータ] ダイアログで、インポート オプションを設定します。

プロジェクトのインポート処理を開始するには、[OK] をクリックします。

「プロジェクトのエクスポート」も併せて参照してください。


インポート パラメータ

[インポート パラメータ] ダイアログでは、翻訳データのインポート オプションを設定することができます。

デフォルトでは、既存のすべての要素が、インポートするファイルまたはプロジェクト内の翻訳データで上書きされ、それに応じて翻訳ステータスも変更されます。プロジェクトから翻訳データをインポートする場合は、[現在の値の上書き] パネルで [ステータスに応じて] オプションを選択できるようになります。この場合、インポートする要素のステータスが現在のプロジェクトの要素のステータスと同じか上位の場合に翻訳データが上書きされます (ステータスの詳細については、「翻訳ステータスの種類」) を参照してください。翻訳済みの要素を上書きしない場合は、[上書きしない] オプションを選択します。この場合、"未翻訳" ステータスの要素の翻訳データのみがインポートされます。

要素のステータスに応じて、インポートする翻訳データを決定することもできます。この場合、[ステータスが同じか上位の場合にインポートする] チェック ボックスをオンにして、ドロップダウン リストから目的のステータスを選択します。

現在の値の上書き

このオプションでは、既存の翻訳データの上書き条件を指定することができます。未翻訳の要素だけでなく、翻訳済みの要素に対しても翻訳データをインポートして上書きする場合は、[常に] オプションを選択します。翻訳済みの要素は変更せず、"未翻訳" ステータスの要素の翻訳データのみをインポートする場合は、[上書きしない] オプションを選択します。

また、プロジェクトから翻訳データをインポートする場合は、[ステータスに応じて] オプションを選択することもできます。このオプションを選択した場合、インポートする要素のステータスが現在のプロジェクトの要素のステータスと同じか上位の場合に翻訳データが上書きされます。

文字列のみをインポートする

このチェック ボックスをオンにすると、境界、ビットマップなどのデータは変更せず、翻訳文字列のみをインポートすることができます。


概要

多言語対応アプリケーションを開発する際は、アプリケーションの設計/開発過程で各種問題に取り組む必要があります。重要となるのは、大きく分けて、グローバリゼーション、ローカライザビリティ、およびローカリゼーションです。


グローバリゼーション

複数のロケールで動作するアプリケーションを設計/開発するプロセス

グローバリゼーションとは、サポート対象ロケールの決定、該当ロケールに対応した機能の設計、該当ロケールすべてで問題なく動作するコードの記述など、多言語対応アプリケーションの設計/開発過程の最初のプロセスです。グローバライズされたアプリケーションでは、ユーザ インターフェイスをローカライズすることができ、各ロケールの地域データにも対応している必要があります。文化や言語の影響を受けないアプリケーションが本当のグローバル アプリケーションといえます。


ローカリゼーション

特定の地域/言語用にアプリケーションをカスタマイズまたは翻訳するプロセス

ローカリゼーションとは、アプリケーションを特定の地域の言語や文化に適応させるプロセスです。ローカリゼーションを正しく行うには、対象地域の言語、文化、習慣、および特性を考慮する必要があります。ローカリゼーションは、アプリケーションの書記体系はもちろん、キーボードの入力形式、フォント、日付/時刻、通貨の形式にも関係してきます。また、グラフィックス、色、音響効果も文化に合わせて調整する必要があります。ローカリゼーションの基礎となるのは、通常、ユーザ インターフェイス (ダイアログ、文字列、メニュー、ビットマップ、アイコン) の翻訳です。

「リソースの翻訳」および「新規プロジェクトの作成」も併せて参照してください。


ローカライザビリティ

グローバライズされたアプリケーションのローカリゼーションを開始しても問題ないかどうか (アプリケーションの実行コードがローカライズ可能なリソースと正しく分離されているかどうか) を検証するプロセス

実際のローカリゼーション プロセスを開始する前に、アプリケーションのローカライザビリティをテストする中間プロセスです。このプロセスでは、翻訳が必要なリソースがアプリケーションのコードから正しく分離されているかどうか確認します。ローカライザビリティ テストを正しく実施しておけば、実際のローカリゼーション プロセスでアプリケーションのコードを修正する必要はなくなります。ローカリゼーション プロセスは、多言語対応アプリケーションの開発過程の最後のプロセスになります。スムーズにローカリゼーション プロセスを進められるよう、事前にローカライザビリティ テストを実施しておくことをお勧めします。

ローカライザビリティ テストを実施することで、アプリケーションのユーザ インターフェイスを翻訳する上でリエンジニアリングやコードの修正が必要ないかどうか検証することができます。ローカライザビリティ テストで見つかったバグは実際のローカリゼーション プロセスでも見つかると仮定できるため、早期の段階でバグを修正することができます。ローカライザビリティ テストは、実質、グローバリゼーション テストとローカリゼーション テストの複合テストといえます。ローカライザビリティ テストで見つかったバグをすべて解決したら、ローカリゼーションの準備ができたことになります。ローカライザビリティ バグを見つける最も効果的な方法はダミー翻訳です。ダミー翻訳機能を使用してローカライザビリティ バグをつぶしこんでおけば、実際のローカリゼーションに要する時間と費用を大幅に削減することができます。

「ダミー翻訳エキスパート」も併せて参照してください。


Windows バイナリのローカリゼーション

Windows バイナリ ローカリゼーション

概要

Lingobit Localizer は、Borland Delphi、Borland C++Builder などで開発した Windows アプリケーション、または Microsoft Visual C++、Intel C++ などのコンパイラでビルドした標準的な Win32/MFC アプリケーションをローカライズする上で最適なソリューションを提供します。

バイナリ ローカリゼーション

Lingobit Localizer では、Windows アプリケーションのバイナリ ファイル (実行可能ファイル) を直接ローカライズすることができます。通常、バイナリ アプリケーション、バイナリ ライブラリ、またはバイナリ コンポーネントには、アプリケーション ファイル (たとえば、.exe)、ライブラリ ファイル (たとえば、.dll)、またはコンポーネント ファイル (たとえば、.ocx) のすべてのリソース データが含まれています。Lingobit Localizer では、Lingobit Localizer プロジェクトに保存されている翻訳データを使用して、元のファイルからローカライズ版のアプリケーション ファイルを作成することができます。バイナリ ローカリゼーションは、ローカリゼーションの効率面を考えると、標準的な RC アプローチと比較して優れています。

サポートされている統合開発環境 (IDE)

Lingobit Localizer でサポートされている統合開発環境は、Win32、MFC、Delphi、および C++Builder です。


Win32/MFC/C++

Lingobit Localizer は、Microsoft Visual C++、Intel C++ などのコンパイラでビルドした標準的な Win32/MFC アプリケーションをローカライズする上で最適なソリューションを提供します。Lingobit Localizer では、バイナリ ローカリゼーション モデルを採用しています。

ビジュアル エディタ

Lingobit Localizer には、Microsoft Visual Studio のリソース エディタと同じようなビジュアル エディタが備わっているため、ダイアログを視覚的に編集することができます。また、反転機能やサイズ調整機能などのローカリゼーション固有の機能、および文字切れやホットキーの位置を検証するための機能も用意されています。

MFC DLGINIT テキスト データ

MFC DLGINIT テキスト リソース データは使用しないようにしてください。このリソース要素にはテキストが非 Unicode 形式で保存されるため、正しく表示されない可能性があります。初期化リストを指定した場合、DLGINIT リソースはコンボ ボックス コントロール用に自動的に作成されます。

出力ファイル

ローカライズ ファイルは複数の形式で出力することができます。各自のローカリゼーション モデルに応じて、適切な形式を選択してください。Lingobit Localizer でサポートされているローカリゼーション モデルについては、「出力ファイル」を参照してください。


Borland Delphi

Lingobit Localizer は、Borland Delphi で開発したアプリケーションをローカライズする上で最適なソリューションを提供します。Lingobit Localizer では、バイナリ ローカリゼーション モデルを採用しています。

ビジュアル エディタ

Lingobit Localizer には、Borland Delphi IDE のリソース エディタと同じようなビジュアル エディタが備わっているため、ダイアログやフォームを視覚的に編集することができます。また、反転機能やサイズ調整機能などのローカリゼーション固有の機能、および文字切れやホットキーの位置を検証するための機能も用意されています。

出力ファイル

ローカライズ ファイルは複数の形式で出力することができます。各自のローカリゼーション モデルに応じて、適切な形式を選択してください。Lingobit Localizer でサポートされているローカリゼーション モデルについては、「出力ファイル」を参照してください。

「Borland リソース」も併せて参照してください。


Borland C++Builder

Lingobit Localizer は、Borland C++Builder で開発したアプリケーションをローカライズする上で最適なソリューションを提供します。Lingobit Localizer では、バイナリ ローカリゼーション モデルを採用しています。

ビジュアル エディタ

Lingobit Localizer には、Borland C++Builder のリソース エディタと同じようなビジュアル エディタが備わっているため、ダイアログやフォームを視覚的に編集することができます。また、反転機能やサイズ調整機能などのローカリゼーション固有の機能、および文字切れやホットキーの位置を検証するための機能も用意されています。

出力ファイル

ローカライズ ファイルは複数の形式で出力することができます。各自のローカリゼーション モデルに応じて、適切な形式を選択してください。Lingobit Localizer でサポートされているローカリゼーション モデルについては、「出力ファイル」を参照してください。

「Borland リソース」も併せて参照してください。


概要

Lingobit Localizer は、以下の .NET ファイルのローカリゼーションにも完全に対応しています。

  • resources ファイル

  • ResX ファイル

  • .NET バイナリ ファイル

要件

.NET アプリケーションをローカライズする場合は、コンピュータに .NET Framework がインストールされている必要があります。

Windows アプリケーション プロジェクトを作成する

Windows フォームを含む大半のソリューションの基礎となるのは、Windows アプリケーション プロジェクトです。Windows アプリケーション プロジェクトは、統合開発環境 (IDE: Integrated Development Environment) で簡単に作成することができます。

Windows アプリケーション プロジェクトを作成するには、以下の手順に従います。

[ファイル] メニューから [新規作成]、[プロジェクト] の順にクリックします。

[プロジェクトの種類] パネルで、目的の言語を選択します。

[テンプレート] パネルで、[Windows アプリケーション] (Visual Basic または Visual C# プロジェクトの場合) または [Windows フォーム アプリケーション (.NET)] (Visual C++ プロジェクトの場合) をクリックします。

メモ:[プロジェクト名] ボックスには、アプリケーションの用途を表す一意のプロジェクト名を入力します。[場所] ボックスには、プロジェクトの保存先ディレクトリを入力するか、[参照] ボタンをクリックして目的のディレクトリを選択します。

ローカリゼーション サポートを有効にする

Windows フォーム デザイナが開き、作成したプロジェクトの Form1 が表示されます。

Visual Studio でリソース ファイルを生成するには、以下の手順に従います。

  1. "WindowsApplication1" という新しい Windows アプリケーションを作成します。詳細については、「Windows アプリケーション プロジェクトを作成する」を参照してください。

  2. [プロパティ] ウィンドウで、フォームの Localizable プロパティを "true" に設定します。

  3. Language プロパティは既に "(Default)" に設定されています。

特定のリソースを表示するように UI カルチャを設定する

コード エディタで、モジュールの先頭にある Form1 の宣言の前に、次のコードを追加します。

' Visual Basic

Imports System.Globalization

Imports System.Threading

// C#

using System.Globalization;

using System.Threading;

次のコードを追加します。Visual Basic では、New 関数内の、InitializeComponent 関数を呼び出す前の位置に追加します。Visual C# では、Form1 内の、やはり InitializeComponent 関数を呼び出す前の位置に追加します。

' Visual Basic

' Sets the UI culture to French (France)

Thread.CurrentThread.CurrentUICulture = New CultureInfo("fr-FR")

// C#

// Sets the UI culture to French (France)

Thread.CurrentThread.CurrentUICulture = new CultureInfo("fr-FR");

ソリューションを保存してビルドします。

Lingobit Localizer でのローカリゼーション

Lingobit Localizer で新規プロジェクトを作成して、ローカライズ対象の .NET resources ファイルまたは .NET バイナリ ファイルを追加します。

Lingobit Localizer でリソースを翻訳するには、以下の手順に従います。

[プロジェクト] メニューの [ローカライズ ファイルの作成] をクリックします。

ローカライズ版のサテライト アセンブリ ファイルまたはリソース ファイルが出力ディレクトリに作成されます。

これらのサテライト アセンブリ ファイルは、アプリケーションの実行可能ファイルが保存されているディレクトリの下に配置する必要があります。この際、ディレクトリ構造は変更しないでください。たとえば、アプリケーションの実行可能ファイルが c:\myprog\ ディレクトリにある場合、"German-German" のサテライト アセンブリ ファイルは c:\myprog\de-DE に配置する必要があります。

関連トピック

.NET サテライト アセンブリ

サテライト アセンブリに含まれるリソースの取得


.NET サテライト アセンブリ

.NET Framework は、ハブ アンド スポーク モデルを使用してリソースのパッケージ化と配置を行います。ハブは、ローカライズできない実行可能コードと、ニュートラル カルチャまたはデフォルト カルチャと呼ばれる単一のカルチャのリソースを含むメイン アセンブリです。デフォルト カルチャとは、アプリケーションで使用されるフォールバック カルチャです。各スポークは、単一のカルチャ用のリソースを含むが、コードはまったく含まないサテライト アセンブリにつながります。

  • このモデルにはいくつかのメリットがあります。

  • アプリケーションを配置した後で、新しいカルチャ用のリソースを徐々に追加していくことができます。アプリケーションの開発が完了しても、カルチャ固有のリソースを開発するために長時間を要する場合があります。このモデルを使用すると、まずメイン アプリケーションをリリースしておいて、カルチャ固有のリソースは後日リリースすることができます。

  • アプリケーションのサテライト アセンブリを更新または変更するときに、アプリケーションを再コンパイルしなくてもすみます。

  • アプリケーションには、特定のカルチャに必要なリソースを含むサテライト アセンブリだけが読み込まれます。そのため、システム リソースの使用率を大幅に低減することができます。

ただし、このモデルにはデメリットもあります。

  • 複数のリソース セットを管理する必要があります。

  • 複数の構成をテストする必要があるので、アプリケーションのテストにかかる初期費用が増大します。しかし、長い期間で考えると、複数の国際バージョンを平行してテストおよび保守するよりも、複数のサテライトを持つ 1 つのコア アプリケーションをテストするほうが簡単で負荷もかかりません。

リソースの名前付け規則

アプリケーションのリソースをパッケージ化する際には、共通言語ランタイムが要求するリソースの名前付け規則を使用して、各リソースに名前を付ける必要があります。ランタイムはカルチャの署名、つまり名前によってリソースを識別します。各カルチャには一意の名前が与えられます。この名前は、言語と関連付けられた 2 桁の小文字のカルチャ名と、必要に応じて、国または地域と関連付けられた 2 桁の大文字のサブカルチャ名の組み合わせで構成されます。サブカルチャ名がある場合は、カルチャ名の後ろにダッシュ (-) で区切って続けます。たとえば、日本の日本語を表す ja-JP、米国の英語を表す en-US、ドイツのドイツ語を表す de-DE (オーストリアのドイツ語を表す de-AT などのフォールバック カルチャとは異なります) などがあります。カルチャ名の一覧については、Microsoft MSDN ライブラリの「CultureInfo クラス」を参照してください。

リソース フォールバック プロセス

リソースをパッケージ化および配置するためのハブ アンド スポーク モデルは、フォールバック プロセスを使用して適切なリソースを検索します。アプリケーションのユーザが、利用不可能な ResourceSet を要求した場合、共通言語ランタイムはカルチャの階層を検索して、ユーザの要求に最も近いフォールバック リソースを探し、リソースが何も見つからなかった場合に最後の手段として例外を発生させます。階層の各レベルにおいて、適切なリソースが見つかった場合、ランタイムはそのリソースを使用します。リソースが見つからなかった場合、次のレベルへ移って検索を続行します。リソース フォールバック プロセスは、以下のように段階的に実行されます。

ランタイムは、まず、グローバル アセンブリ キャッシュの中に、アプリケーション用に要求されたカルチャと一致するアセンブリがあるかどうかをチェックします。

グローバル アセンブリ キャッシュには、多数のアプリケーションによって共有されるリソース アセンブリを格納することができます。そのため、作成するすべてのアプリケーションのディレクトリ構造内に特定のリソース セットを含める必要がなくなります。アセンブリへの参照が見つかった場合、そのアセンブリの中で、要求されたリソースを検索します。要求されたリソースがアセンブリ内に見つかった場合、ランタイムはそのリソースを使用します。リソースが見つからなかった場合、ランタイムは検索を続行します。

次に、ランタイムは現在実行されているアセンブリのディレクトリの中に、要求されたカルチャと一致するディレクトリがあるかどうかをチェックします。ディレクトリが見つかった場合、そのディレクトリの中に要求されたカルチャ用の有効なサテライト アセンブリがあるかどうかを検索します。次に、見つかったサテライト アセンブリの中で、要求されたリソースを検索します。アセンブリ内でリソースが見つかった場合、ランタイムはそのリソースを使用します。リソースが見つからなかった場合、ランタイムは検索を続行します。

次に、ランタイムはもう一度グローバル アセンブリ キャッシュを検索しますが、今度は要求されたリソースの親アセンブリを見つけようとします。グローバル アセンブリ キャッシュ内に親アセンブリが存在する場合、そのアセンブリの中で、要求されたリソースを検索します。

親は、適切なフォールバック カルチャとして定義されています。どのようなリソースでも例外が発生しなければよいという前提のもとで、親アセンブリが最適な代替リソース候補と見なされます。このプロセスを使用して、リソースを再利用することもできます。要求されたリソースを子のカルチャがローカライズする必要がない場合、特定のリソースを親のレベルだけに含めればすみます。たとえば、en (ニュートラルの英語)、en-GB (英国で話される英語)、および en-US (米国で話される英語) 用のサテライト アセンブリを作成する場合、サテライト en に共通の用語を組み込み、サテライト en-GB および en-US には、共通用語と異なる用語に関するオーバーライドだけを含めることができます。

次に、ランタイムは現在実行されているアセンブリのディレクトリの中に親ディレクトリが含まれるかどうかをチェックします。親ディレクトリが存在する場合、そのディレクトリの中で、親カルチャ用の有効なサテライト アセンブリを検索します。アセンブリが見つかった場合、そのアセンブリの中で、要求されたリソースを検索します。リソースが見つかった場合、ランタイムはそのリソースを使用します。リソースが見つからなかった場合、ランタイムは検索を続行します。

次に、ランタイムは上記の手順に従って、可能性のある各レベルにおいて親アセンブリを検索します。各カルチャの親は 1 つだけですが、親がさらにその上に親を持っている場合もあります。

もともと指定されたカルチャとそのすべての親を検索してもリソースが見つからなかった場合は、デフォルト (フォールバック) カルチャ用のリソースが使用されます。

メモ: デフォルト リソースは、メイン アセンブリと共にコンパイルされる唯一のリソースです。NeutralResourcesLanguageAttribute を使用してサテライト アセンブリを指定しない限り、メイン アセンブリが最終フォールバック (最終の親) になります。したがって、メイン アセンブリ内に必ずデフォルトのリソース セットを含めておくことを強くお勧めします。これにより、例外がスローされることがなくなります。デフォルトのリソース ファイルを含めておくことにより、すべてのリソース用のフォールバック リソースを用意して、カルチャに固有のリソースではなくても、少なくとも 1 つは利用できるリソースが確実に存在するようにしておくことができます。

最後に、デフォルト (フォールバック) カルチャ用のリソースが見つからなかった場合、ランタイムはリソースが見つからなかったことを示す例外を発生させます。

要求されたリソースの検索がどのように実行されるのかを示す例として、ユーザがメキシコのスペイン語用にローカライズされたリソースを要求した場合を考えてみます。上記のリソース名前付け規則に従い、まずランタイムはグローバル アセンブリ キャッシュの中で、要求されたカルチャ "es-MX" と一致するアセンブリを検索します。見つからなかった場合、次にランタイムは現在実行されているアセンブリのディレクトリの中で、"es-MX" ディレクトリを検索します。それにも失敗すると、ランタイムはもう一度グローバル アセンブリ キャッシュの中で、適切なフォールバック カルチャ、この場合は "es" (スペイン語) を示す親アセンブリを検索します。親アセンブリが見つからなかった場合、ランタイムは親アセンブリを含む可能性のあるすべてのレベルで、一致するリソースが見つかるまで "es-MX" カルチャを検索します。リソースが見つからなかった場合、デフォルト カルチャ用のリソースが使用されます。

パッケージ化に関して提案される代替手段

期間または予算の制約によっては、アプリケーションでサポートするすべてのサブカルチャについてリソース セットを作成できない場合があります。そのような場合には、親カルチャ用に単一のサテライト アセンブリを作成しておけば、関連するすべてのサブカルチャがそのアセンブリを使用することができます。たとえば、サテライト アセンブリ English (en) を用意しておくと、地域固有の English リソースを要求するユーザがそのアセンブリを取得することができます。地域固有の German リソースを要求するユーザにはサテライト アセンブリ German (de) を用意します。たとえば、ドイツのドイツ語 (de-DE)、オーストリアのドイツ語 (de-AT)、およびスイスのドイツ語 (de-CH) に対する要求には、サテライト アセンブリ German (de) をフォールバック アセンブリとして用意できます。メイン アセンブリと共にコンパイルするデフォルト リソースは慎重に選択してください。デフォルト リソースは最終的なフォールバック リソースになるので、ほとんどのアプリケーション ユーザから要求されるリソースをデフォルト リソースとしておく必要があります。そうしておくことで、配置されるリソースはカルチャに固有ではなくなりますが、アプリケーションのローカライズ費用を大幅に削減することができます。


サテライト アセンブリに含まれるリソースの取得

理想としては、デフォルト (ニュートラル) アセンブリのリソースをメイン アセンブリと共にパッケージ化し、アプリケーションでサポートする各言語についてサテライト アセンブリを個別に作成する必要があります。ResourceManager クラスを使用すると、実行時にカルチャ固有のリソースにアクセスしたり、アプリケーションがリソース フォールバック プロセスによってリソースを取得する方法を制御することができます。ResourceManager クラスのコンストラクタのいずれかを通じてリソースにアクセスすることを推奨します。そのためには、リソースをコンパイルしてサテライト アセンブリにするか、またはリソースをアプリケーションのメイン アセンブリの一部とする必要があります。

ResourceManager は、現在のスレッドの CultureInfo.CurrentUICulture プロパティに基づいて、どのリソースを取得するかを判断します。たとえば、アプリケーションのコンパイル時に、デフォルトの英語リソースと、フランス語とドイツ語のリソース用のリソースを含む 2 つのサテライト アセンブリを使用し、さらに CurrentUICulture プロパティを "de" と設定した場合、ResourceManager はドイツ語リソースを取得します。CurrentUICulture プロパティの設定方法の詳細ついては、Microsoft MSDN ライブラリの「CurrentUICulture プロパティの使用」を参照してください。

ResourceManager.GetString メソッドを使用して文字列リソースの取得と表示を行う例を以下に示します。

[Visual Basic]

...

Dim private rm As ResourceManager

rm = New ResourceManager("MyStrings", Me.GetType().Assembly)

Console.Writeline(rm.GetString("string1"))

...

[C#]

...

private ResourceManager rm;

rm = new ResourceManager("MyStrings", this.GetType().Assembly);

Console.Writeline(rm.GetString("string1"));

...

このコードにより、ファイル MyStrings から string1 が取得され、表示されます。 実際にどの文字列が読み込まれるかは、現在のスレッドの CurrentUICulture プロパティによって異なります。

ResourceManager.GetObject メソッドを使用してバイナリ リソース (グラフィック イメージなど) の取得と表示を行う例を以下に示します。

[Visual Basic]

...

Dim private rm As ResourceManager

rm = New ResourceManager("MyImages", Me.GetType().Assembly)

PictureBox.Image = Ctype(rm.GetObject("MyObject"), System.Drawing.Image)

...

[C#]

...

private ResourceManager rm;

rm = new ResourceManager("MyImages", this.GetType().Assembly);

PictureBox.Image = (System.Drawing.Image)rm.GetObject("MyObject");

...

このコードにより、リソース ファイル MyImages から MyObject という名前のオブジェクトが読み込まれます。MyObject は Image 型にキャストされ、PictureBox というイメージ プロパティに割り当てられます。実際にどのオブジェクトが読み込まれるかは、現在のスレッドの CurrentUICulture プロパティによって異なります。

ResourceSet クラスには、単一のカルチャ用にローカライズされたリソースがすべて格納されます。ResourceSet はリソース フォールバック プロセスを使用しません。したがって、ResourceSet はローカライズされたアプリケーションではそれほど便利ではありません。

サテライト アセンブリに関するバージョン管理サポート

デフォルトでは、要求されたリソースを取得するときに、ResourceManager はメイン アセンブリのバージョン番号と一致するバージョン番号を持ったサテライト アセンブリを探します。アプリケーションを配置した後で、メイン アセンブリまたは特定のリソース サテライト アセンブリを更新する場合が考えられます。.NET Framework は、メイン アセンブリとサテライト アセンブリのバージョン管理をサポートします。

SatelliteContractVersionAttribute クラスは、メイン アセンブリのバージョン管理をサポートします。アプリケーションのメイン アセンブリに対して SatelliteContractVersionAttribute を指定すると、サテライト アセンブリを更新しなくても、メイン アセンブリの更新と再配置を実行することができます。メイン アセンブリを更新した後で、メイン アセンブリのバージョン番号をインクリメントしてください。ただし、サテライト コントラクト バージョン番号は変更しません。要求されたリソースを取得するときに、ResourceManager はこの属性によって指定されたバージョンのサテライト アセンブリを読み込みます。

発行者ポリシー アセンブリは、サテライト アセンブリのバージョン管理をサポートします。メイン アセンブリを更新しなくても、サテライト アセンブリの更新と再配置を実行することができます。サテライト アセンブリを更新した後で、バージョン番号をインクリメントし、発行者ポリシー アセンブリと共に出荷してください。発行者ポリシー アセンブリの中で、新しいサテライト アセンブリが以前のバージョンとの下位互換性を持つことを指定してください。ResourceManager は、要求されたリソースを取得するためにメイン アセンブリの既存のサテライト コントラクト バージョン番号を使用しますが、アセンブリ ローダによって、発行者ポリシー アセンブリ内の指定されたバージョンのサテライト アセンブリにバインドされるため、正しい更新バージョンのアセンブリが取得されます。発行者ポリシー アセンブリの詳細については、Microsoft MSDNライブラリの「発行者ポリシーを作成する」を参照してください。

アセンブリ バージョン管理の完全なサポートを有効にするには、厳密な名前付きアセンブリをグローバル アセンブリ キャッシュに配置し、厳密な名前を持たないアセンブリをアプリケーション ディレクトリに配置することをお勧めします。厳密な名前付きアセンブリをアプリケーション ディレクトリに配置する場合は、アセンブリを更新しても、サテライト アセンブリのバージョン番号をインクリメントできません。代わりに、既存のコードを新しいコードに置き換える場所でインプレース更新を行い、バージョン番号は同じままにする必要があります。たとえば、完全限定名が "myApp.resources, Version=1.0.0.0, Culture=de, PublicKeyToken=b03f5f11d50a3a" であるサテライト アセンブリのバージョン 1.0.0.0 を更新する場合は、同じ完全限定名 "myApp.resources, Version=1.0.0.0, Culture=de, PublicKeyToken=b03f5f11d50a3a" でコンパイルした更新版の myApp.resources.dll で元のアセンブリを置き換えます。バージョン番号をインクリメントできないため、サテライト アセンブリ ファイルでインプレース更新を行うと、アプリケーション側でサテライト アセンブリのバージョンを正確に判断することが難しくなります。


概要

Lingobit Localizer は、XML ファイルのローカリゼーションにも対応しています。

XML (eXtensible Markup Language) は、Web 上で情報をより柔軟にやり取りできるように設計された構造化言語です。

"eXtensible Markup Languaeg (拡張可能なマークアップ言語)" と呼ばれる理由は、HTML (あらかじめ定義された単一のマークアップ言語) のような固定の形式ではないことにあります。XML は、ドキュメントの多様なクラスに対して、作成者が独自にマークアップ言語を定義できるメタ言語 (他の言語を記述するための言語) です。独自定義が可能なのは、XML がテキスト マークアップ体系の国際標準メタ言語 (ISO 8879) である SGML で記述されているからです。

XML の登場によって、Web 開発の発展を抑制していた以下の 2 つの制約がなくなりました。

  • 柔軟性/拡張性に欠ける HTML への依存

  • SGML の複雑さ (強力なオプションは多数ありますが、プログラミングが困難)

XML を使用すると、ユーザ定義のドキュメントをフレキシブルに開発することができます。また、Web 上でも Web 以外の場所でも、安全で検証可能なファイル形式で、テキストやデータの格納や転送が可能になります。

Lingobit Localizer では、XML ファイル内の言語固有のデータを簡単かつ迅速に翻訳することができます。


概要

Lingobit Localizer は、Java properties ファイル (リソース バンドル) のローカリゼーションにも対応しています。

Java プログラミング言語の利点として、国際化を支援する豊富な API メカニズムを利用することができ、各種言語の扱いが容易になることです。たとえば、Unicode 文字 (16 ビット) はほとんどの文字セットに対応しているため、他のプログラミング言語で使用されている従来の 8 ビット文字セットに比べ、多言語処理に優れています。最も重要なメカニズムの 1 つとして "リソース バンドル" があります。

リソース バンドルには、ロケール固有のオブジェクトが含まれます。プログラムで String などのロケール固有のリソースが必要なときは、ユーザのロケールに合ったリソース バンドルから読み込まれます。このように、リソース バンドルから、ロケール固有の情報のすべてでなくてもその大部分を切り離すことで、ユーザのロケールにはほとんど依存しないプログラム コードを記述することができます。

これにより、以下の特徴を持つプログラムを記述することが可能になります。

  • 異なる言語へのローカライズまたは翻訳が容易

  • 複数のロケールを同時に処理可能

  • 将来サポート予定のロケールを追加する際の修正が容易

リソース バンドルはファミリに属しています。このファミリでは、メンバは共通の基底名を共有していますが、ファミリ名にはロケールを識別する追加コンポーネントも含まれています。たとえば、リソース バンドルのファミリの基底名は "MyResources" です。ファミリは、ファミリと同じ名前 (MyResources) のデフォルト リソース バントルを持つ必要があります。このデフォルト リソース バンドルは、特定のロケールがサポートされていない場合に最後の手段して使用されます。これにより、ファミリはロケール固有のメンバを必要な数だけ提供できます。たとえば、"MyResources_de" という名前のドイツのメンバなどです。

ファミリの各リソース バンドルには同じ項目が含まれていますが、これらの項目は当該リソース バンドルのロケールに合わせて翻訳されています。たとえば、"MyResources" と "MyResources_de" の両方に操作キャンセル用のボタンに使用される文字列が含まれている場合は、"MyResources" では「Cancel」、"MyResources_de" では「Abbrechen」となっています。

同じ言語を使用するロケールでも国によってリソースが異なる場合は、区別が可能です。たとえば、"MyResources_de_CH" には、スイス (CH) 系のドイツ語 (de) のオブジェクトが含まれています。 必要に応じて、リソースの一部だけを修正することもできます。

#MyResources.properties file

OkKey=Ok

CancelKey=Cancel

#MyResources_de.properties file

#don't need okKey, since parent level handles it.

CancelKey=Abbrechen

プログラムでロケール固有のオブジェクトが必要なときは、getBundle メソッドを使用して、ResourceBundle クラスを読み込みます (以下の例を参照)。

ResourceBundlemyResources =

ResourceBundle.getBundle("MyResources", currentLocale);

ドイツ語の ResourceBundle を読み込む場合

ResourceBundlemyResources =

ResourceBundle.getBundle("MyResources", Locale.GERMAN);

リソース バンドルは、キー/値のペアになっています。キーは、バンドルのロケール固有のオブジェクトを一意に識別します。

リソース バンドルからオブジェクトを取得する際は、適切な getter メソッドを使用します。"OkKey" と "CancelKey" はどちらも文字列なので、getString を使用して取得します (以下の例を参照)。

button1 = new Button(myResources.getString("OkKey"));

button2 = new Button(myResources.getString("CancelKey"));

getter メソッドはすべて、引数としてキーを要求し、見つかったオブジェクトを返します。オブジェクトが見つからなかった場合、getter メソッドは MissingResourceException をスローします。

Java 2 プラットフォームでは、ResourceBundle の 2 つのサブクラス ListResourceBundle と PropertyResourceBundle が用意されています。これらのサブクラスを使用すると、リソースの作成がかなり容易になります。ListResourceBundle は、リソースをキー/値のペアのリストとして管理します。PropertyResourceBundle は、properties ファイルを使用してリソースを管理します。


ダミー翻訳エキスパートについて

ローカライザビリティ テストを実施する際は、ダミー翻訳エキスパートを使用すると便利です。

変換文字

英語のテキストを英語以外の文字を含むテキストに置換します。この際、テキストは意味が読み取れる形で維持されます。たとえば、英語の文字は、似たような形の英語以外の記号に置換されます (以下の例を参照)。

a の場合 - à または å を使用

c の場合 - ĉ または ç を使用

n の場合 - ń または ñ を使用

変更

独自のテキストに置換したり、テキストの前後に文字を追加します (たとえば、"some string" -> "+++some string+++")。

翻訳後のテキストが元のテキストより長くなることを想定して、ローカライザビリティ テストを実施することができます。

テキストの前後には任意の文字または記号を追加することができます。これにより、アプリケーションの実行時にテキストがどのように表示されるか (たとえば、文字化けや文字切れがないかどうか) を確認できるようになります。

拡張

テキストを指定のパーセンテージで拡張します (たとえば、"Sample text" -> "Sample textSample")。

アプリケーションのダミー翻訳が完了したら、その機能をテストしてみてください。ダミー翻訳後のアプリケーションは、実際に翻訳したアプリケーションと同じものと想定することができます。

「検証機能について」および「問題検出機能について」も併せて参照してください。


翻訳メモリについて

Lingobit Localizer では、既存の翻訳を再利用して、用語の統一を図れるように翻訳メモリ システムがサポートされています。

翻訳メモリは、各種言語の既存の翻訳データを格納した特別なデータベースです。翻訳メモリを使用して、プロジェクト内のリソースを自動的に翻訳することができます。

翻訳メモリには、プロジェクト リソースの既存の翻訳単位を適宜追加していくことができます。プロジェクトの翻訳メモリは、Lingobit Localizer 標準の .loc_tm ファイルのほかにも、特別な .tmx (Translation Memory Exchange) ファイルまたはテキスト/CSV ファイルにエクスポートすることができます。

また、[インポート (標準)]、[TMX のインポート]、または [テキスト/CSV のインポート] コマンドを使用して、翻訳メモリをプロジェクトにインポートすることができます。

翻訳メモリの利用


翻訳メモリの利用

翻訳メモリには、プロジェクト リソースの既存の翻訳単位を適宜追加していくことができます。プロジェクトの翻訳メモリは、Lingobit Localizer 標準の .loc_tm ファイルのほかにも、特別な .tmx (Translation Memory Exchange) ファイルまたはテキスト/CSV ファイルにエクスポートすることができます。

また、[インポート (標準)]、[TMX のインポート]、または [テキスト/CSV のインポート] コマンドを使用して、翻訳メモリをプロジェクトにインポートすることができます。

[翻訳メモリ] パネルでは、既存の翻訳単位を編集または削除したり、新しい翻訳単位を翻訳メモリに追加することができます。

プロジェクト全体を翻訳メモリを使用して翻訳するには、[ツール] メニューから [翻訳メモリ]、[翻訳メモリから翻訳] の順にクリックします。単一のリソースまたはその要素を翻訳メモリを使用して翻訳するには、ナビゲーション パネルでリソースを右クリックするか、翻訳エディタでリソース要素を右クリックして、[ツール]、[翻訳メモリ]、[翻訳] の順にクリックします。[翻訳オプション] ダイアログが表示されます。

プロジェクトの既存の翻訳単位を翻訳メモリに追加するには、[ツール] メニューから [翻訳メモリ]、[翻訳単位を翻訳メモリに追加] の順にクリックします。単一のリソースまたはその要素の翻訳単位を翻訳メモリに追加するには、ナビゲーション パネルでリソースを右クリックするか、翻訳エディタでリソース要素を右クリックして、[ツール]、[翻訳メモリ]、[追加] の順にクリックします。[翻訳単位の追加オプション] ダイアログが表示されます。

デフォルトでは、プロジェクトまたはリソース内のすべての要素の翻訳単位が翻訳メモリに追加されます。ただし、要素のステータスが指定したステータス (たとえば、"完了" または "要レビュー") と同じか上位の場合にのみその翻訳単位が翻訳メモリに追加されるように設定することができます。この場合、[翻訳単位の追加オプション] ダイアログで、該当するチェック ボックスをオンにして、ドロップダウン リストから目的のステータスを選択します。

翻訳メモリに新しい翻訳単位を手動で追加することもできます。この場合、[翻訳メモリ] パネルの [追加] をクリックするか、パネルを右クリックして [追加] をクリックします。[新しい翻訳単位] ダイアログが表示されたら、原文と訳文を入力して、[OK] をクリックします。

選択した翻訳単位を翻訳メモリから削除するには、[翻訳メモリ] パネルの [削除] をクリックするか、パネルを右クリックして [選択した翻訳単位を削除] をクリックします。

すべての翻訳単位を翻訳メモリから削除するには、[翻訳メモリ] パネルの [すべて削除] をクリックするか、パネルを右クリックして [すべて削除] をクリックします。

翻訳メモリについて


[翻訳オプション] ダイアログ

[翻訳オプション] ダイアログでは、既存の翻訳データの上書き条件 (常に上書き、ステータスに応じて上書き、または上書きしない) を指定することができます。

また、大文字/小文字を区別したり、アンパサンドを無視して、翻訳処理を実行することもできます。

翻訳処理を開始するには、[OK] をクリックします。

翻訳メモリについて

翻訳メモリの利用


[翻訳単位の追加オプション] ダイアログ

デフォルトでは、プロジェクトまたはリソース内のすべての要素の翻訳単位が翻訳メモリに追加されます。ただし、要素のステータスが指定したステータス (たとえば、"完了" または "要レビュー") と同じか上位の場合にのみその翻訳単位が翻訳メモリに追加されるように設定することができます。この場合、[翻訳単位の追加オプション] ダイアログで、該当するチェック ボックスをオンにして、ドロップダウン リストから目的のステータスを選択します。

翻訳メモリについて

翻訳メモリの利用


[翻訳メモリ] パネル

[翻訳メモリ] パネルには、翻訳メモリ内の翻訳単位が表示されます。列の数は、対象言語の数によって変わります。

[翻訳メモリ] パネルでは、翻訳メモリに新しい翻訳単位を手動で追加することができます。この場合、[翻訳メモリ] パネルの [追加] をクリックするか、パネルを右クリックして [追加] をクリックします。[新しい翻訳単位] ダイアログが表示されたら、原文と訳文を入力して、[OK] をクリックします。

選択した翻訳単位を翻訳メモリから削除するには、[翻訳メモリ] パネルの [削除] をクリックするか、パネルを右クリックして [選択した翻訳単位を削除] をクリックします。

すべての翻訳単位を翻訳メモリから削除するには、[翻訳メモリ] パネルの [すべて削除] をクリックするか、パネルを右クリックして [すべて削除] をクリックします。

翻訳メモリについて

翻訳メモリの利用


翻訳メモリのエクスポート

翻訳メモリは、翻訳の生産性を向上させ、用語の統一を図る上で欠かせない存在です。

Lingobit Localizer では、現在のプロジェクトの翻訳メモリ (原文と訳文) を外部ファイルにエクスポートすることができます。エクスポート可能なファイル形式は、Lingobit Localizer 標準の .loc_tm ファイル、TMX ファイル、テキスト/CSV ファイルです。エクスポート後の翻訳メモリは、将来のプロジェクトで再利用したり、チーム メンバ間で共有することができます。


翻訳メモリ: エクスポート (標準)

Lingobit Localizer では、プロジェクトの現在の翻訳メモリを Lingobit Localizer 翻訳メモリ ファイルにエクスポートすることができます。このファイルの拡張子は .loc_tm です。

翻訳メモリを .loc_tm ファイルにエクスポートするには、[ツール] メニューから [翻訳メモリ]、[エクスポート]、[エクスポート (標準)] の順にクリックします。

翻訳メモリのエクスポート


翻訳メモリ: テキスト/CSV のエクスポート

Lingobit Localizer では、翻訳メモリをプレーン テキスト ファイルまたは CSV (カンマ区切り) ファイルにエクスポートすることができます。テキスト ファイルは、翻訳データの交換に使用されている最も一般的な形式です。テキスト ファイルには、選択した単一言語のみの翻訳データが保存されます。テキスト/CSV ファイルの書式は、その用途や目的に応じてエクスポート時にカスタマイズすることができます。

翻訳メモリをテキスト/CSV ファイルにエクスポートするには、[ツール] メニューから [翻訳メモリ]、[エクスポート]、[テキスト/CSV のエクスポート] の順にクリックします。テキスト エクスポート ウィザードが開始します。

翻訳メモリのエクスポート


翻訳メモリ: TMX のエクスポート

Lingobit Localizer では、翻訳メモリを TMX ファイルにエクスポートすることができます。TMX (Translation Memory eXchange) は、異なるソフトウェア ローカリゼーション ツール間での翻訳メモリの転送に使用されている XML ベースのデータ交換ファイル形式です。

TMX ファイルには、プロジェクトのすべての対象言語の翻訳データが保存されます。

翻訳メモリを TMX ファイルにエクスポートするには、[ツール] メニューから [翻訳メモリ]、[エクスポート]、[TMX のエクスポート] の順にクリックします。

翻訳メモリのエクスポート


翻訳メモリのインポート

Lingobit Localizer では、作成済みの翻訳メモリ ファイルを現在のプロジェクトにインポートすることができます。インポートした翻訳メモリは、プロジェクトの翻訳作業で活用することができます。翻訳メモリ内の翻訳単位は、[翻訳メモリ] パネルに表示されます。複数の対象言語を扱っている場合、[翻訳メモリ] パネルの列が増えます。

インポート可能な翻訳メモリのファイル形式は以下の 3 種類です。

TMX (Translation Memory eXchange) ファイル - 異なるソフトウェア ローカリゼーション ツール間での翻訳メモリの転送に使用されているデータ交換ファイル形式です。

テキスト/CSV ファイル - 翻訳データの交換に使用されている最も一般的な形式です。テキスト ファイルには、選択した単一言語のみの翻訳データが保存されています。

.loc_tm ファイル - Lingobit Localizer 標準の翻訳メモリ形式です。


翻訳メモリ: インポート (標準)

Lingobit Localizer では、.loc_tm (Lingobit Localizer 翻訳メモリ) ファイルから翻訳メモリをインポートすることができます。

.loc_tm ファイルから翻訳メモリをインポートするには、[ツール] メニューから [翻訳メモリ]、[インポート]、[インポート (標準)] の順にクリックします。

翻訳メモリのインポート


翻訳メモリ: テキスト/CSV のインポート

Lingobit Localizer では、テキスト ファイルまたは CSV (カンマ区切り) ファイルから翻訳メモリをインポートすることができます。翻訳データを正しくインポートするには、ファイルのインポート オプションを指定する必要があります。

テキスト/CSV ファイルから翻訳メモリをインポートするには、[ツール] メニューから [翻訳メモリ]、[インポート]、[テキスト/CSV のインポート] の順にクリックします。インポートするファイルを選択すると、テキスト インポート ウィザードが開始します。

翻訳メモリのインポート


翻訳メモリ: TMX のインポート

Lingobit Localizer では、TMX ファイルから翻訳メモリをインポートすることができます。

TMX ファイルから翻訳メモリをインポートするには、[ツール] メニューから [翻訳メモリ]、[インポート]、[TMX のインポート] の順にクリックします。

翻訳メモリのインポート


Microsoft グロッサリのインポート

Microsoft グロッサリには、Microsoft 製品 (MS Windows、MS Office など) の各国語版で使用されている翻訳用語/文節が収録されています。アプリケーションの GUI の訳語を Microsoft 製品の訳語に合わせたい場合など、これらのグロッサリを参考にすると効果的です。なお、これらのグロッサリは Microsoft の Web サイトからダウンロード可能です。

Microsoft グロッサリは CSV 形式で保存されています。そのため、Microsoft グロッサリを Lingobit Localizer にインポートする際は、[テキスト/CSV のインポート] コマンドを使用してください。ただし、区切り文字や原文と訳文の順序はファイルによって異なる場合があります。


Trados 翻訳メモリのインポート

Lingobit Localizer は Trados にも対応しています。Trados 翻訳メモリをインポートするには、[TMX のインポート] コマンドを使用します。ただし、あらかじめ Trados 翻訳メモリを TMX ファイル形式でエクスポートしておく必要があります。


交換ウィザードについて

Lingobit Localizer でローカリゼーションを開始する際は、プロジェクトを作成して、その中にローカリゼーションが必要な多数のファイルを追加することになります。このプロジェクトをローカライズするには、ローカライズ可能なすべてのリソースを目的の言語に翻訳する必要があります。プロジェクトのボリュームが大きい場合やプロジェクトを複数の言語にローカライズする必要がある場合、翻訳作業を複数の翻訳者で分担しなければならなくなります。

Lingobit Localizer には、翻訳者とのファイルのやり取りに伴う負荷を低減する機能が備わっています。Lingobit Localizer 交換ウィザードを使用すると、翻訳者に送る交換パッケージを簡単に作成することができます。交換パッケージは、プロジェクト ファイルだけの形式で作成することも、Lingobit Localizer Translator Lite をインストールするための自己解凍型 EXE ファイルにプロジェクト ファイルを含める形で作成することもできます。この交換パッケージに含めるファイル、リソース、および対象言語は自由に指定することができます。また、必要に応じて、Lingobit Localizer プロジェクトには含まれていない独自のファイルを追加することもできます。

「交換ウィザードの利用」も併せて参照してください。


交換ウィザードの利用

交換ウィザードを使用すると、Lingobit Localizer プロジェクトの一部またはすべてを翻訳者用にエクスポートしたり、翻訳者からの翻訳済みプロジェクトをインポートしたりすることができます。翻訳者用のプロジェクトを作成する方法については、「交換パッケージの作成」を参照してください。翻訳者からのプロジェクトの取り込み方法については、「翻訳者から受け取ったプロジェクトの取り込み」を参照してください。

交換ウィザードを開始するには、[ファイル] メニューの [交換ウィザード] をクリックするか、[ツール] ツールバーの該当するボタンをクリックします。


交換パッケージの作成

交換パッケージを作成するには、以下の手順に従います。

1. 作成する交換パッケージの種類を選択します。

交換パッケージは、プロジェクト ファイルだけの形式で作成することも、Lingobit Localizer Translator Lite をインストールするための自己解凍型 EXE ファイルにプロジェクト ファイルを含める形で作成することもできます。前者の場合は [プロジェクト ファイル] を選択し、後者の場合は [プロジェクト ファイルと Lingobit Localizer Translator] を選択します。

[次へ] をクリックします。

2. エクスポートする言語とファイルを選択します。

左側のパネルで、目的の言語を選択します。右側のパネルで、目的のファイルとリソースを選択します。デフォルトでは、すべてのリソースが選択されています。

[次へ] をクリックします。

3. エクスポートする文字列を選択します。

[次へ] をクリックします。

4. コメントと独自のファイルを追加します (手順 1 で [プロジェクト ファイルと Lingobit Localizer Translator] を選択した場合)。

[プロジェクト ファイルと Lingobit Localizer Translator] を選択した場合、パッケージの受取人へのコメントを入力することができます。該当するフィールドに必要な情報を入力してください。

パッケージに独自のファイルを追加するには、[追加] ボタンをクリックします。選択したファイルはリストに追加されます。リストからファイルを削除するには、ファイルを選択して、[削除] ボタンをクリックします。

[次へ] をクリックします。

5. ファイル名を入力して、必要に応じて、パッケージをパスワードで保護します (手順 1 で [プロジェクト ファイルと Lingobit Localizer Translator] を選択した場合)。

ファイル名を [ファイル名] フィールドに入力します。

パッケージをパスワード保護する場合は、[パスワード] フィールドにパスワードを入力し、[パスワードの確認] フィールドに同じパスワードをもう一度入力します。何も入力しなかった場合、パッケージはパスワード保護されません。

[次へ] をクリックします。

6. [完了] をクリックして、ウィザードを閉じます。

「交換ウィザードについて」および「翻訳者から受け取ったプロジェクトの取り込み」も併せて参照してください。


翻訳者から受け取ったプロジェクトの取り込み

Lingobit Localizer では、翻訳者が翻訳したプロジェクトを既存のプロジェクトに簡単に取り込むことができます。

翻訳者から受け取ったプロジェクトを取り込むには、[ファイル] メニューの [交換ウィザード] をクリックします。

[翻訳者からプロジェクトを受け取る] を選択して、[次へ] をクリックします。

翻訳者から受け取ったプロジェクトを指定して、[次へ] をクリックします。

デフォルトでは、既存のすべての要素が、インポートするプロジェクト内の翻訳データで上書きされ、それに応じて翻訳ステータスも変更されます。[現在の値の上書き] パネルで [ステータスに応じて] オプションを選択した場合、インポートする要素のステータスが現在のプロジェクトの要素のステータスと同じか上位の場合に翻訳データが上書きされます (ステータスの詳細については、「翻訳ステータスの種類」) を参照してください。翻訳済みの要素を上書きしない場合は、[上書きしない] オプションを選択します。この場合、"未翻訳" ステータスの要素の翻訳データのみがインポートされます。

要素のステータスに応じて、インポートする翻訳データを決定することもできます。この場合、[ステータスが同じか上位の場合にインポートする] チェック ボックスをオンにして、ドロップダウン リストから目的のステータスを選択します。

[次へ] をクリックします。これで、翻訳データをインポートする準備ができたことになります。インポート処理を開始するには、[完了] をクリックします。

「交換ウィザードについて」および「交換パッケージの作成」も併せて参照してください。


統計について

Lingobit Localizer には、プロジェクト内の要素 (アイテム) の数とそのパーセンテージ、および文字数とそのパーセンテージをステータス別に表示する機能が備わっています。プロジェクト全体の統計情報を表示することも、単一のリソースの統計情報を表示することもできます。

「統計の利用」および「[統計] パネル」も併せて参照してください。


統計の利用

プロジェクト全体の統計を表示するには、[ツール] メニューの [統計] をクリックします。単一のリソースの統計を表示するには、ナビゲーション パネルでリソースを右クリックして、[ツール]、[統計] の順にクリックします。


[統計] パネル

[統計] パネルには、プロジェクト全体、またはナビゲーション パネルで選択したリソースの統計情報 (要素の数とそのパーセンテージ、および文字数とそのパーセンテージ) がステータス別に表示されます。


検証機能について

検証機能を使用すると、テキスト リソースに矛盾がないかどうかチェックすることができます。書式指定子の位置が間違っていたり、空白文字の数が正しくないと、ローカライズ アプリケーションが正常に動作しない可能性があります。

「検証機能の利用」および「[検証結果] パネル」も併せて参照してください。


検証機能の利用

検証機能を使用すると、翻訳後のリソースに以下のような問題がないかチェックすることができます。

ホットキーが重複している

メニュー、ダイアログ、またはフォームの複数の要素に同じホットキーが割り当てられていないかどうかチェックします。

書式文字列が一致していない

原文の書式指定子が訳文でも維持されているかどうかチェックします。%d や %s は訳文で省略することはできません。

たとえば、原文 "You entered: %s." を日本語に翻訳した場合、"入力値: %s" のように %s を維持する必要があります。

改行文字の数が正しくない

改行文字 (/n) の数が原文と訳文で一致しているかどうかチェックします。改行文字の数が一致していないと、文字列が正しく表示されないか、アプリケーションが正常に動作しなくなる可能性があります。

タブ文字の数が正しくない

タブ文字の数が原文と訳文で一致しているかどうかチェックします。

空白文字の数が正しくない

行の先頭または末尾の空白文字の数が原文と訳文で一致しているかどうかチェックします。複数の要素を組み合わせて 1 つの文にしている場合など、空白文字の数が一致していないと、アプリケーションが正常に動作しなくなる可能性があります。

ホットキーが正しくない

ホットキーの文字が正しいかどうかチェックします。

ホットキーの位置が正しくない

ホットキーの位置が正しいかどうかチェックします。

コロンが抜けている

原文の末尾のコロンが訳文でも維持されているかどうかチェックします。日本語など、コロンの代わりに別の文字を使用する言語では無視してもかまいません。

ピリオドが抜けている

原文の末尾のピリオドが訳文でも維持されているかどうかチェックします。日本語など、ピリオドの代わりに別の文字を使用する言語では無視してもかまいません。

翻訳メモリと一致していない

翻訳エディタ内の翻訳が翻訳メモリと一致しているかどうかチェックします。故意に別の訳文を使用している場合は無視してもかまいません。

スペル チェック

翻訳後の文字列のスペルをチェックします。

文字列が空になっている

原文が空でない場合に訳文が空になっていないかどうか、またはその逆をチェックします。

検証機能の実行方法

検証機能を実行するには、[ツール] メニューの [検証] をクリックするか、ナビゲーション パネルで目的のリソースを右クリックして [ツール]、[検証] の順にクリックします。

[検証オプション] ダイアログで、実行する検証の種類を指定して、[OK] をクリックします。すべてのチェック ボックスをまとめてオンまたはオフにする場合は、[すべてオン]/[すべてオフ] ボタンを使用してください。

検証結果は、[検証結果] パネルに表示されます。[検証結果] パネルでエラー メッセージをダブルクリックすると (または、エラー メッセージを右クリックして、[移動] をクリックすると)、該当する要素が翻訳エディタに表示されます。問題を修正した後は、検証機能をもう一度実行して、同じエラーが発生しないことを確かめてください。

「検証機能について」および「[検証結果] パネル」も併せて参照してください。


[検証結果] パネル

[検証結果] パネルには、検証時に見つかった問題のエラー メッセージが表示されます。問題を含む要素を翻訳エディタで確認するには、[検証結果] パネルでエラー メッセージをダブルクリックするか、エラー メッセージを右クリックして [移動] をクリックします。

[検証結果] パネルからすべてのエラー メッセージを削除するには、パネルを右クリックして、[すべてクリア] をクリックします。

検証時に見つかった問題の中で特に注意すべき要素にはステータスやコメントでマーキングしておくとよいでしょう。

「検証機能について」および「検証機能の利用」も併せて参照してください。


バージョン管理機能について

Lingobit Localizer では、同じプロジェクト ファイルの複数のバージョンを保存することができます。古いバージョンのプロジェクトも現在のバージョンのプロジェクトと同じように扱え、通常どおり確認したり、編集したりすることができます。

「バージョン管理機能の利用」および「[バージョン] パネル」も併せて参照してください。


バージョン管理機能の利用

プロジェクトのバージョン リストは、[バージョン] パネルに表示されます。また、[バージョン] ダイアログ ([ファイル] -> [バージョン] -> [バージョン リスト]) にも同じ情報が表示されます。

古いバージョンを読み取り専用モードで表示するには、[バージョン] パネルまたは [バージョン] ダイアログで目的のバージョンを選択して、[表示] をクリックします。この場合、古いバージョンのプロジェクトが一時フォルダにコピーされ、別々の Lingobit Localizer ウィンドウで開きます。

プロジェクトの現在のバージョンを保存するには、[ファイル] メニューから [バージョン]、[新規バージョン] の順にクリックするか、[バージョン] パネルの [今すぐ保存] をクリックします。必要に応じて、バージョンに関するコメントを追加することもできます。

バージョン間を比較するには、[バージョン] パネルの [差異] をクリックします。詳細については、「比較エキスパートについて」を参照してください。

各バージョンのプロジェクト ファイルは、現在のプロジェクト フォルダの [Versions] サブフォルダに日付/時刻別に保存されます。各バージョンは、Lingobit Localizer プロジェクト ファイル、翻訳メモリ ファイル (.loc_tm)、およびコメント ファイル (.txt) で構成されます。

「バージョン管理機能について」および「[バージョン] パネル」も併せて参照してください。


[バージョン] パネル

[バージョン] パネルには、プロジェクトの各バージョンのリストが日付/時刻の古い順に表示されます。バージョンの保存時にコメントを入力した場合は、そのコメントの一部が表示されます。

プロジェクトの現在のバージョンを保存するには、[バージョン] パネルの [今すぐ保存] をクリックするか、パネルを右クリックして [バージョンを保存] をクリックします。

プロジェクトの古いバージョンを削除するには、[バージョン] パネルで目的のバージョンを選択して [削除] をクリックするか、バージョンを右クリックして [削除] をクリックします。

バージョン間を比較するには、[バージョン] パネルの [差異] をクリックします。

  • [バージョン] パネルで 1 つのバージョンを選択して [差異] をクリックした場合、選択したバージョンと現在のプロジェクトが比較されます。

  • [バージョン] パネルで 2 つのバージョンを選択して [差異] をクリックした場合、選択した 2 つのバージョンが比較されます。

差異の詳細については、「比較エキスパートについて」を参照してください。

バージョンに関する完全なコメントを確認するには、目的のバージョンをダブルクリックするか、バージョンを選択して [コメント] をクリックするか、バージョンを右クリックして [コメント] をクリックします。

バージョンを別々の Lingobit Localizer ウィンドウで表示するには、目的のバージョンを選択して [表示] をクリックするか、バージョンを右クリックして [表示] をクリックします。

「バージョン管理機能について」および「バージョン管理機能の利用」も併せて参照してください。


問題検出機能について

問題検出機能を使用すると、ローカリゼーション プロセスの早期の段階でローカリゼーション バグを見つけ、ローカライズ アプリケーションのクラッシュの原因となっているリソースを分離することができます。文字列の拡張によるメモリのオーバーレイ、翻訳不可のコード内の変更、および書式指定子の翻訳エラーは、アプリケーションがクラッシュする原因となります。ほとんどのソフトウェア ローカリゼーション ツールでは、これらの問題を含む要素を試行錯誤で特定するしかありません。しかし、Lingobit Localizer では、このプロセスを自動的に実行することができます。

問題検出機能は、アプリケーションの品質を保証する上で欠かせない機能の 1 つです。たとえば、ダミー翻訳後のアプリケーションが正常に動作しない場合、問題検出機能を使用して、クラッシュの原因となっているすべての要素を特定して分離することができます。同様に、ローカライズ可能な一部のデータを実際に翻訳した後で、アプリケーションが正常に動作するか逐次確かめることができます。

問題検出機能を使用すると、ローカライズ アプリケーション ファイルが複数回実行され、クラッシュの原因となっている要素が正確に検出されます。たとえば、1000 個の翻訳要素を含むアプリケーションをテストする場合、ファイルは 10 回程度実行されます。ファイルの実行中に見つかった問題はすべて 1 回のセッションで分離されます。

「問題検出機能の利用」も併せて参照してください。


問題検出機能の利用

問題検出機能を使用するには、[ツール] メニューの [問題検出] をクリックします。

[問題検出機能のプロパティ] ダイアログの [全般] タブで、アプリケーション ファイルの実行時に自動的に作成される一時ファイルの保存先ディレクトリを指定します。Lingobit Localizer によって自動的にアプリケーションが起動されるようにするには、[プログラムを自動的に起動する] チェック ボックスをオンにします。[実行パラメータ] タブで、[実行するコマンド] フィールドにアプリケーション ファイルのパスを入力します。また、必要に応じて、作業ディレクトリとコマンド引数を指定します。

問題検出処理を開始するには、[OK] をクリックします。

問題検出機能によってアプリケーションが複数回実行され、毎回クラッシュしたかどうかを確認するメッセージが表示されます。このメッセージの進捗バーは、問題検出処理の進捗を示しています。

テストが完了すると、問題検出結果が [出力] パネルに表示されます。

「問題検出機能について」も併せて参照してください。


比較エキスパートについて

Lingobit Localizer には、現在のプロジェクトと以前のプロジェクト間の翻訳要素を比較するための機能 (比較エキスパート) が備わっています。この機能を使用して以前のプロジェクトを取り込むと、以前のプロジェクトの翻訳要素が現在のプロジェクトの翻訳要素の横に表示されます。ただし、原文の言語が異なるプロジェクトを比較することはできません。

各翻訳要素には以下のいずれかの比較ステータスが割り当てられ、翻訳エディタの一番左側の列に表示されます。

  • 同一 (=) - 翻訳要素は変更されていません。

  • 変更 - 翻訳要素が現在のプロジェクトで変更されています。

  • 削除 - 翻訳要素がプロジェクトから削除されています。

  • 新規 - 翻訳要素がプロジェクトに追加されています。

比較エキスパートを開始するには、[ツール] メニューの [比較] をクリックして、比較するプロジェクトを選択します。

現在のプロジェクトと同じプロジェクトの古いバージョンを比較するには、[バージョン] パネルで目的のバージョンを選択して、[差異] をクリックします。


コマンドライン インターフェイス

Lingobit Localizer には、基本的な操作のコマンドライン インターフェイスが備わっています。これらのコマンドライン インターフェイスは自動ビルド プロセスで重要になります。

構文: localizer.com <プロジェクト ファイル名> -<スイッチ>: param1 "param 2"

スイッチ

  • ? または help - コマンドライン ヘルプを表示します。

  • version - バージョンを保存します。詳細については、「バージョン管理機能について」を参照してください。

  • scan - 変更をスキャンします。詳細については、「変更のスキャン」を参照してください。

  • tgt_lng:lng_id - 対象言語を lng_id に変更します。lng_id を調べるには、[プロジェクト] メニューの [言語] をクリックして、[言語の追加/削除] ボタンをクリックします。[言語] ダイアログに表示される言語 Id が lng_id に該当します。詳細については、「対象言語」を参照してください。

  • create - ローカライズ ファイルを作成します。詳細については、「ローカライズ バージョンの作成」を参照してください。

  • translate - 翻訳メモリを使用して翻訳します。

  • duplicate - 重複箇所を翻訳します。

scan、tgt_lng、translate、duplicate コマンドの実行後、プロジェクトは自動的に保存されます。

なお、localizer.com ファイルは Lingobit Localizer のインストール フォルダにあります。


ツール オプション

[ツール オプション] ダイアログでは、Lingobit Localizer の作業環境を設定することができます。

スタートアップ ダイアログを表示する

Lingobit Localizer の起動時にスタートアップ ダイアログを表示するには、このチェック ボックスをオンにします。

ナビゲーション パネルにファイルのフルパスを表示する

ナビゲーション パネルにファイルのフルパスを表示するには、このチェック ボックスをオンにします。

ファイルの追加時に相対パスを使用する

プロジェクトへのファイルの追加時に相対パスを使用するには、このチェック ボックスをオンにします。このチェック ボックスをオフにすると、絶対パスが使用されます。

メモ:このオプションでは、新たに追加するファイルのパスが変更されるだけで、プロジェクトに既に追加されているファイルのパスは変更されません。既存のファイルのパスを変更するには、[ファイル パス] ダイアログを使用してください。このダイアログを表示するには、ナビゲーション パネルでファイルを右クリックして、[ファイル パス] をクリックします。

ダイアログの要素を自動的にサイズ調整する

ダイアログの要素を自動的にサイズ調整するには、このチェック ボックスをオンにします (翻訳テキストが要素の境界に収まらない場合)。

翻訳エディタのフォントを変更

翻訳エディタのフォントを変更するには、このボタンをクリックします。


よくある質問

Q:翻訳後のアプリケーションは Lingobit Localizer では問題なく表示されますが、実際に起動すると記号が正しく表示されません。

A:アプリケーションが Unicode に対応していない可能性があります。「Unicode 未対応のアプリケーションの実行」を参照してください。

Q:Lingobit Localizer で中国語が読めません。

A:必要な中国語フォントをインストールしてください。

Q:ローカリゼーション プロセスを独自のビルド プロセスのスクリプトに組み込む方法を教えてください。

A:Lingobit Localizer コマンドライン インターフェイスを使用してください。

Q:テキスト ファイル形式の既存の翻訳データがあります。このファイルを Lingobit Localizer プロジェクトに取り込めますか?

A:[テキスト/CSV のインポート] コマンドを使用して、テキスト ファイルを翻訳メモリにインポートすることができます。

Q:Lingobit Localizer プロジェクトには何種類の言語を追加できますか?

A:追加できる言語の数に制限はありません。

Q:Lingobit Localizer で MFC アプリケーションを翻訳しましたが、一部の文字が英語のまま表示されます。何が問題ですか?

A:MFC への動的リンクを使用している場合、MFC 再頒布可能ファイルも翻訳する必要があります。言語によっては、その翻訳ファイルが Visual Studio に含まれている場合があります。また、Windows メッセージやダイアログを独自のアプリケーションで利用する場合、そのコンテンツの翻訳有無は MS Windows に完全に依存します。

Q:すべての翻訳データを RC ファイルに抽出できますか?

A:いいえ、Lingobit Localizer ではバイナリ ローカリゼーションを推奨していますので、RC ファイルには対応していません。ただし、外部のツール (PE Explorer など) を使用して、ローカライズ ファイルからリソースを抽出することは可能です。

Q:Lingobit Localizer で Microsoft グロッサリを使用する方法を教えてください。

A:[テキスト/CSV のインポート] コマンドを使用して、1 つまたは複数のグロッサリを翻訳メモリにインポートすることができます。

Q:他の CAT ツールで使用していた翻訳データを Lingobit Localizer に取り込む方法を教えてください。

A:[テキスト/CSV のインポート] または [TMX のインポート] コマンドを使用して、既存の翻訳データを翻訳メモリにインポートすることができます。

Q:アプリケーションのソース コードまたはバイナリ ファイルを翻訳者に送る必要はありますか?

A:いいえ、ソース コードを送る必要はありません。ただし、翻訳者の側で [変更のスキャン]、[ローカライズ ファイルの作成]、[問題検出]、および [ローカライズ アプリケーションの実行] コマンドを使用する場合、バイナリ ファイルが必要になります。

Q:古いバージョンのアプリケーションでは RC ファイルを翻訳しましたが、その翻訳データを再利用する方法を教えてください。

A:[翻訳ファイルのインポート] コマンドを使用してください。インポートされた翻訳データには "インポート" ステータスが割り当てられます。

Q:ダイアログ エディタでコントロールを移動できません。

A:Ctrl+Alt+Shift+(Up/Down/Left/Right) キーを押すか、[書式] メニューの [移動] コマンドを使用してください。


Unicode 未対応のアプリケーションの実行

アプリケーションが Unicode に対応していない場合、翻訳した記号が正しく表示されない可能性があります。この場合、Windows コントロール パネルの [地域と言語のオプション] で、Unicode 未対応のアプリケーションのデフォルトのエンコーディング設定を対象言語に合わせる必要があります。ただし、多言語アプリケーションを開発する場合は、Unicode サポートを追加することを強くお勧めします。

また、中国語など、東アジアの言語の中には、該当するフォントをインストールしないと正しく表示されないものもあります。


Lingobit

Lingobit Technologies

Lingobit Technologies は、ローカリゼーション関連の優れた製品を提供している独立系ソフトウェア会社です。その主要製品が Lingobit Localizer です。Lingobit Localizer は、ソフトウェア会社のグローバル市場への参入を支援するソフトウェア ローカリゼーション/翻訳ツールです。Lingobit Localizer を使用すると、ソフトウェアのローカリゼーションに要する時間と費用を大幅に削減することができます。

Lingobit Technologies は、よりよいローカリゼーション環境の実現を目指して業務を推進しています。Lingobit Localizer に関するご意見/ご要望については、以下の宛先までお気軽にお寄せください。なお、日本国内におけるサポートは、nextEDGE Technology によって提供されています。

サポート

電子メール

support@lingobit.com (英語)
contact@nextEDGEtech.com (日本国内)

Web

http://www.lingobit.com/support/ (英語)
https://www.shareEDGE.com/cs/ (日本国内)


テキスト エクスポート ウィザード

テキスト エクスポート ウィザードを使用すると、プロジェクトまたは翻訳メモリをプレーン テキスト ファイルまたは CSV (カンマ区切り) ファイルにエクスポートすることができます。テキスト ファイルは、翻訳データの交換に使用されている最も一般的な形式です。テキスト ファイルには、選択した単一言語のみの翻訳データが保存されます。テキスト/CSV ファイルの書式は、その用途や目的に応じてエクスポート時にカスタマイズすることができます。

テキスト エクスポート ウィザードが開始したら、テキスト ファイルの保存先を指定して、ドロップダウン リストから文字エンコーディングを選択します。[次へ] をクリックして、次のページに進みます。

[区切り文字] パネルで、データの区切り文字を指定します。[その他] を選択して、独自の記号を指定することもできます。ドロップダウン リストからテキスト修飾子を選択します。デフォルトでは、テキスト修飾子 (引用符) は使用されません。修飾子のエスケープ文字として [バックスラッシュ] または [ダブル] を選択します。サンプル テキストが一番下に表示されます。[次へ] をクリックして、次のページに進みます。

テキスト ファイルにエクスポートするデータを指定します。データをエクスポート対象に追加するには、ドロップダウン リストで目的のデータを選択して、[追加] をクリックします。データをエクスポート対象から除外するには、左側のリストでデータを選択して、[削除] をクリックします。最後に、[完了] をクリックして、エクスポート処理を開始します。


テキスト インポート ウィザード

テキスト インポート ウィザードを使用すると、テキスト ファイルまたは CSV (カンマ区切り) ファイルから翻訳メモリをインポートすることができます。

テキスト インポート ウィザードが開始したら、[ファイル規格] ドロップダウン リストからテキスト ファイルのエンコーディングを選択します。[インポート開始行] フィールドで、インポート開始行を指定します。インポート対象データは下の [データ プレビュー] パネルに表示されます。

[次へ] をクリックして、次のページに進みます。

区切り文字と修飾子のオプションを指定します。選択したオプションによって、[データ プレビュー] パネルが更新されます。[次へ] をクリックして、次のページに進みます。

インポートするデータに対応する列をドロップダウン リストから選択します。翻訳メモリを正しくインポートするには、インポート対象ファイルに原文 (Original) と訳文 (Translated) に該当する列が含まれている必要があります。インポート対象ファイル内の不要な列については、[無視] を選択してください。

原文と訳文を選択したら、[完了] をクリックして、翻訳メモリのインポート処理を開始します。