ExeScript とは?

ExeScript は様々なスクリプトを実行ファイル (.EXE) に変換することが出来る、便利で効率的なプログラムです。バッチ、VBScript、JavaScript、WSF、WSH 及び HTA ファイルなどのスクリプト タイプをサポートしています。

BAT、 .VBS、 .JS、 .WSF、 .WSH 及び .HTA ファイルの内容を、他のユーザが変更することを防止します。

ExeScript は、実行タイプの選択、最終 EXE ファイルに追加のリソースファイルを追加、作業ディレクトリ機能 (スクリプトを実行するフォルダの指定) 、スクリプト タイプ (ウィンドウ、コンソール) の指定、コマンド ライン、バージョン情報機能等の、様々な便利な機能が利用できます。最新の技術とファイル タイプをサポートする、内蔵の InteliSence エディタを装備しています。

ExeScript は、定期タスクの自動実行用に理想的なツールです。上級ユーザは、様々なタスクを定期的に自動で実行するためだけでなく、インストール ファイルや配布モジュールの作成にこのプログラムを利用することが出来ます。


What's New

ExeScript の新しい機能

ExeScript version 3.0 では、次のような新しい機能を利用できます。

  • 新しいスクリプト タイプに HTA (HTML アプリケーション)、WSF、WSH が追加されました。
  • 最終 EXE ファイルに追加のリソース ファイルを追加することが可能になりました。
  • 作業ディレクトリ - スクリプトとリソースの解凍用のフォルダを指定することが可能です。
  • スクリプト タイプ - ここでは、ウィンドウかコンソールかのスクリプト タイプを指定できます。
  • コマンド ライン - コマンド ライン上でスクリプトを実行できます。
  • 最終 EXE ファイルからアイコンを変更/削除することが可能です。ICO ファイル、のほか、EXE、DLL その他のアイコンを含むファイルから、アイコンを選択することが可能です。
  • バージョン情報 - 開発者や最終 EXE ファイルのバージョンについての情報を追加することが出来ます。
  • スクリプトの暗号化 - 新バージョンでは、強力な AES 256 ビット暗号化を採用しました。ユーザの登録キーから変更された情報が暗号化キーとなります。登録されていないプログラムの場合は、キーは "ExeScript" です。そのため、試用版プログラムでコンパイルされた EXE ファイルは、容易に解読されてしまいます。登録版では、その EXE ファイルが作成された ExeScript のプログラムの登録情報が必要です。
  • 実行タイプ (JS、VBS 用のみ) - ディスクに書き込まずに、コンピュータのメモリ上でスクリプトを実行します。これにより、内容を見る事が不可能になるので、スクリプトのセキュリティを強化することが出来ます。
  • コンパイルされたスクリプトのパスワード -保護された起動- EXE アプリケーションに変換されたスクリプトを実行するためのパスワードを設定することが出来ます。スクリプトの内容はパスワードで暗号化され、スクリプトの保護を強化します。
  • Unicodeのフルサポート
  • 実行ファイルの圧縮 - ExeScript は実行ファイルを圧縮して .EXE アプリケーションを可能な限り小さくします。
  • より操作性がよい最新のインタフェース、インタフェース スタイル間のダイナミックな切替、プロジェクト設定をツールバーで簡単に編集できます。
  • InteliSence (オブジェクト要素のヒント)、 OutLine - コードの論理的に関連する部分を折りたたむ機能 (例えば、機能やループ)、構文強調表示、前の操作の取り消しなど、最新の技術全てをサポートした新しいエディタです。


なぜ ExeScript なのか？

ExeScript には様々な便利な機能があります。

ビルトイン エディタ

ExeScript はプロフェッショナル用の内蔵エディタを搭載しています。エディタには下記のような最新の機能が装備されています。

  • InteliSence による オブジェクト要素の入力候補表示
  • OutLine によりコードの論理的に関連した部分 (機能やループ等) を折り畳み表示
  • キーワード強調表示と構文強調表示
  • 前操作の取り消し/やり直し機能
  • テキストをクリップボードからコピー/貼り付け
  • ファイル内テキスト検索機能

サイレント モード

スクリプトを他のユーザから見えない状態で実行します。スクリプトは誰にも気づかれずに実行され、ユーザにはウィンドウや確認ダイアログ ボックスが見えません。このモードでスクリプトを実行するには、最初に、スクリプトを実行ファイルに変換する必要があります。[プロパティ] パネルで [サイレント モード] を有効にします。[メイン] 画面で [サイレント モード] を選択し、値を [True] に設定します。

Note 注意　このオプションは HTA ファイルでは利用できません。

リソース ファイル

リソースは、アイコン、画像、ファイル、フォルダ、そのほかのオブジェクト等、Windows での作業を快適にするアプリケーションの重要な部分を構成します。ExeScript では、実行アプリケーションにリソース ファイルを追加することが出来るので、これらのリソースをプログラムが使用することが出来ます。リソースのリストを表示したい場合は、[リソース表示] パネルに切り替えてください。

実行タイプ

この機能を使うとメモリから直接、アプリケーションを実行することができます。これを使用すると、スクリプトの内容を見る事が全く出来なくなるため、安全性が高められます。更に、アプリケーションの実行速度をかなり速くすることもできます。このコンパイル タイプはスクリプトへの最高の保護が必要な場合 (例えばスクリプトにパスワードが使用されている場合等) での使用をお勧めします。

スクリプト タイプ

ここでは、ウィンドウ、コンソールなどのスクリプトの種類を指定します。

作業ディレクトリ

アプリケーションが実行される場所を指定します。指定されたパスは、アプリケーションに追加のリソース ファイルが含まれる場合は、それらを解凍するためにも使用されます。

バージョン情報

バージョン情報は、開発者とアプリケーションについての情報を記入するために利用できます。

コマンド ライン

アプリケーションと共に実行されるコマンド ラインを指定することが出来ます。

パスワードで保護された起動

ExeScript では、起動をパスワードで保護したアプリケーションを作成することが出来ます。この機能を使うと、承認なしでアプリケーションを実行することができません。

実行ファイルの圧縮

ExeScript は実行ファイルを圧縮して .EXE アプリケーションを可能な限り小さくします。逆アセンブリ回避に役立ちます。


ExeScript を購入するには

ExeScript のライセンスは、クレジット カード (オンライン、電話/FAX )、小切手、電子送金、PayPal、注文書の発行によりご購入いただけます。

複数ライセンスご購入の場合は、ボリューム ディスカウントを実施しております。詳細につきましては、お問い合わせ下さい。

ライセンス一覧

家庭用ライセンス 非営利的な家庭用の使用のためのライセンスです。それ以外の環境下では企業用ライセンスをご使用下さい。このライセンスでは、ExeScript を企業ネットワーク、ネットワーク サーバ、および他のユーザがネットワーク経由で本製品を使用できるコンピュータにインストールして使用することは出来ません。お客様は、本ソフトウェアがインストールされているシステム上でのみ EXE アプリケーションを実行および作成することが出来ます。また、作成された EXE アプリケーションを他のコンピュータに配布することは出来ません。

企業用ライセンス 本製品を企業、非営利団体、国有機関、行政、その他のいかなる形態においても、団体において使用する場合、または、個人が営利目的で本製品を購入する場合 (例えば、個人又は家族経営の場合) には企業用ライセンスを取得しなければなりません。このライセンスでは、1 つのネットワーク内でのみ、作成された EXE アプリケーションの実行および配布を行うことが出来ます。

開発者用ライセンス このライセンスは営業用のものです。開発者用ライセンスでは、作成された EXE アプリケーションの実行や配布を制限なしに行うことができます。お客様は、本ライセンスの製品内および外で自由に EXE アプリケーションを配布することが出来ます。

登録ユーザの特典

  • 評価版の制限事項 (機能制限および時間制限) がすべてなくなります。
  • 12 ヶ月間の保守、サポートを受けられます。
  • 1 年間無料でアップグレードできます。それ以降のアップグレードでも割引が適用されます。

Check ご注文はこちらから http://www.shareEDGE.com

本製品ご購入に関するご質問は、こちらからお問い合わせ下さい。


ExeScript のロック解除

Note 注意　ExeScript の購入手続きが完了すると、登録キーが電子メールで届きます。この登録キーは安全な場所に保管しておいてください。ソフトウェアを再インストールしたり、テクニカル サポートに問い合わせる際に必要になります。

ExeScript を初めてインストールすると、評価モードで起動されます。ExeScript には、15 日間の評価期間が設けられています。この期間を過ぎると、ソフトウェアを使用できなくなります。

評価期間後も継続してソフトウェアを使用するには、購入時に受け取った登録キーでソフトウェアを登録する必要があります。登録処理が完了すると、評価版であることを示すメッセージも表示されなくなります。

登録キーを所有していない場合は、「ExeScript を購入するには」の説明に従って、購入手続きを済ませてください。

ExeScript は、以下の方法で登録することができます。

  • 登録キーが記載された電子メールを開きます。
  • マウスで登録キーを選択し、ショートカット メニューの [コピー] をクリックします (または、キーボードの Ctrl+C キーを押します)。
  • [スタート] メニューから、[すべてのプログラム] > [ExeScript] を選択します
  • [ヘルプ] メニューの [登録] をクリックします。
  • [登録キー] ダイアログ ボックスに登録キーを貼り付けます。
  • ExeScript を再起動する必要がある旨を示すメッセージが表示されたら、[OK] をクリックして閉じます。
  • ExeScript を一度終了し、再起動します。
  • 'Registered to:' の欄にあなたの名前が表示されます。また、評価版での制限事項が全て解除されます。

次の説明も参照してください。

ExeScript を購入するには


インタフェース

プログラム メイン ウィンドウは、プロパティ パネル、リソース表示パネル、メニューとツールバーなどの、スクリプトの内容を編集することのできる、複数のエリアで構成されています。新しいプロジェクトを作成すると、スクリプト編集用の新しいウィンドウが作成されます。プロパティ パネル、リソース表示パネルを、表示/隠す、閉じる、最小化/格納、再配置することができます。 - 詳細は プログラム表示のカスタマイズ をご覧下さい。

ExeScript Main Window

アプリケーション メニュー全てのリストはメニュー をご覧下さい。アイコンのリストはツールバーをご覧下さい。


メニュー

ファイル メニュー

  • [新規] - 新しいスクリプト プロジェクトを作成します。
  • [開く] - 既存のスクリプト ファイルを開きます。
  • [閉じる] - 開いているファイルを閉じます。
  • [保存] - 現在のスクリプトを作成したファイルに保存します。
  • [名前を付けて保存] - 現在のファイルを別の名前、又は別の保存場所に保存します。
  • [印刷] - 選択した出力先に現在のファイルを印刷します。
  • [印刷プレビュー] - 印刷する前にファイルをプレビューします。
  • [印刷設定] - プリンタやプリンタ オプションを変更します。
  • [終了] - プログラムを終了します。注意　保存されていないファイルがある場合、これらのファイルを保存するかしないかをプログラムから質問されます。

編集メニュー

  • [戻す] - 直前のコマンドを元に戻します。
  • [やり直す] - 直前のコマンドや操作をやり直します。
  • [切り取り] - 選択した部分をクリップボードに切り取ります。
  • [コピー] - 選択した部分をクリップボードにコピーします。
  • [貼り付け] - クリップボードの内容をカーソルの現在の位置に、選択した部分を置き換えて貼り付けます。
  • [検索] - 指定した文字列をファイル内で検索します。
  • [置換] - このコマンドでは、ドキュメント内の特定の文字列を検索して別の文字列に置き換えるためのダイアログ ボックスを表示します。文字列が見つからない場合メッセージが表示されます。

表示メニュー

  • [ツールバー > 標準] - ツールバーを表示/非表示します。
  • [ツールバー > カスタマイズ..]. - ツールバーとメニュー コマンドをカスタマイズします。
  • [プロパティ バー] - プロジェクトのプロパティ バーを表示/非表示します。
  • [リソース表示] - プロジェクトのリソース パネルを表示/非表示します。
  • [ステータス バー] - ステータス バーを表示/非表示します。
  • [アプリケーション ルック] - プログラムの画面表示をカスタマイズし、配色を変更します。

プロジェクト メニュー

  • [ソースをコンパイルしないまま実行] - スクリプトを変換せずにプログラム ウィンドウで実行します。
  • [ビルド] - プロジェクトを作成します。
  • [コンパイル + 実行] - プログラムをコンパイルして実行します。
  • [確認メッセージを無効化] - 確認メッセージが出ないようにします。

ウィンドウ メニュー

  • [新規ウィンドウ] - 新しいウィンドウを作成します。

    Note 注意　1 つまたは複数のウィンドウが開いている場合、このコマンドの下に、それらのリストが表示されます。ウィンドウ メニューで選択したウィンドウがアクセスできる状態になります。

  • [ウィンドウ] - ウィンドウを管理するダイアログ ボックスを開きます。

ヘルプ

  • [コンテンツ] - ExeScript ヘルプを開きます。
  • [アクティベーション] - ご購入後、プログラムの登録をします。登録の際には、登録キーをご使用下さい。

    Note 　詳細については、 ExeScript を購入するには をご覧下さい。

  • [今すぐ購入] - www.hide-folder.com でライセンス購入画面を開いてください。
  • [ExeScript バージョン情報] - ExeScript のバージョン番号、登録情報、関連リンクなどの情報を表示します。

次の説明も参照してください。

ツールバー


ツールバー

ツールバーには次のようなアイコンがあります。

New - 新しいスクリプト プロジェクトを作成します。

Open - 既存のスクリプト ファイルを開きます。

Save - 現在のスクリプトを上書き保存します。

Cut - 選択した部分をクリップボードに切り取ります。

Copy - 選択した部分をクリップボードにコピーします。

Paste - クリップボードの内容をカーソルの現在の位置に、選択した部分を置き換えて貼り付けます。

Find - 指定した文字列をファイル内で検索します。

Undo - 直前のコマンドを元に戻します。

Redo - 直前のコマンドや操作をやり直します。

Build project - プロジェクトを作成します。

Print - 選択したエレメントの現在のファイルを印刷します。

About - ExeScript のバージョン番号、登録情報、関連リンクなどの情報を表示します。

次の説明も参照してください。

メニュー


プロパティ パネル

プロパティ画面には現在、動作中のプロジェクトのプロパティと設定が表示されます。これらのプロパティは変更することが出来ます。プロパティの変更は、コンパイル後に適用されます。

フィールドの順序を変更したり、パネル ツールバーのボタンを使って並べ替えたりすることが出来ます。

Sort by category - カテゴリ順にフィールドを並べ替え

Alphabetic sort - アルファベット順にフィールドを並べ替え

プロパティ画面には以下のフィールドがあります。

メイン

作業ディレクトリ - スクリプトを解凍する場所を定義したり、リソース表示画面で指定した追加のリソース ファイルが解凍されるフォルダを表示します。

現在のディレクトリ - コンパイルされた EXE ファイルの実行元となるディレクトリにスクリプトを解凍します。

その他ディレクトリ - ユーザが定義したフォルダにスクリプトを解凍します。

Note 注意　リストでディレクトリを選択して、[OK] をクリックすると、ディレクトリを指定できます。選択したディレクトリは、[ディレクトリ] フィールドに記載されます。

ディレクトリ - EXE ファイルが実行されるときにスクリプトが解凍される、ユーザ定義のフォルダへのパス

Note 注意　 [image] ボタンを使ってフィールドをクリックするとフォルダへのパスを手動で変更できます。

サイレント モード - 実行が隠しウィンドウで行われるか、可視ウィンドウで行われるかを定義します。2 種類の値が選択可能です。

True - スクリプトをサイレント モードで実行します。ユーザにはスクリプトのウィンドウが見えないので、スクリプトが実行されていることに気づきません。

False - 通常の、可視モードでスクリプトを実行します。

Note 注意　このオプションは HTA ファイルでは利用できません。

スクリプト タイプ - ウィンドウまたは、コンソールのスクリプトの種類を定義します。

ウィンドウ - ウィンドウ スクリプト

コンソール - コンソール スクリプト

Note 注意　このオプションは BAT ファイル、HTA ファイルでは利用できません。

コマンド ライン - スクリプト実行のためのコマンド ライン。コンパイルされた EXE ファイルがコマンド ラインで実行される場合は使用されません。

実行タイプ - メモリからか、作業ディレクトリからかのスクリプト実行の種類を指定できます。

展開 - スクリプトが実行されるとワーク ディレクトリに解凍されます。

コンパイル - スクリプトはコンピュータ メモリで実行されます。このオプションは、ExeScript Host Technology を使用しています。

Note 注意　このオプションは VBS スクリプト、JS スクリプトのみで利用できます。

出力 ファイル - コンパイルされたスクリプトが格納されたファイル

Note 注意　このフィールドは、スクリプトのコンパイルの後、フィールドをクリックするか、 [image] ボタンを使ってフィールド名を手動で編集出来るようになってから指定されます。

アイコン

アイコン タイプ - 作成された EXE アプリケーションのアイコンを設定します。

アイコンなし - アプリケーション アイコンは、作成された EXE ファイルから削除されます。

ExeScript アイコン - ExeScript アイコンがアプリケーションのアイコンになります。

カスタム アイコン - ユーザ定義のアイコンがアプリケーションのアイコンになります。.ICO、.EXE、.DLL その他のアイコンを含むファイルから、アイコンを選択することが可能です。

Note 注意　アプリケーションにカスタム アイコンを設定する場合は、アイコンの入ったファイルを [開く... ] ダイアログ ボックスから選択してください。

アイコン パス名 - 前回のオプションがカスタム アイコンに設定されている場合、アイコン ファイルへのパスを表示します。

バージョン情報

- EXE アプリケーションと開発者についての情報を設定することが出来ます。

[バージョン情報] チェックボックスを選択して、EXE ファイルにこれらの情報を記入します。

コメント - コメントを記入します。

会社名 - 会社名を記入します。

ファイルバージョン - EXE ファイルのバージョンを記入します。

著作権 - 著作権についての情報

製品名 - 製品名を記入します。

製品バージョン - 製品バージョンを記入します。

セキュリティ

パスワード - 作成された EXE ファイルの実行をパスワードで保護します。[パスワード] オプションの設定を有効にして EXE アプリケーション実行用のパスワードを入力してください。

Note 注意　パスワード オプションを有効にして、パスワードの入力をしないと、パスワードは空になります。

Note 注意　パスワード オプションが選択されると、指定されたパスワードは、スクリプトの暗号化用にも使用されます。


リソース表示パネル

リソース表示では、実行アプリケーションに含まれるリソース ファイルについての情報を表示します。[リソース表示] タブをクリックすると、このパネルが表示されます。このパネルには、リソースを管理するツールバーがあります。

Add folder to project - 実行アプリケーションにリソースとしてフォルダを追加します。

Add folder to project - 実行アプリケーションにリソース ファイルを追加します。

Note 注意　リソース表示パネルは、ドラッグ アンド ドロップ操作をサポートしています。リソースの入ったファイルやフォルダをパネル上にドラッグ アンド ドロップして、追加することが出来ます。

Exclude from project - 選択したリソースをプロジェクトから削除します。

Files display mode - ファイル名を表示するモードを切り替えます。

含まれている全てのリソースがリソース リストに表示されます。

Note 注意　プロパティ パネルの作業ディレクトリは、リソース表示パネルで指定した追加のリソース ファイルが解凍されるフォルダを表示します。


プログラム表示のカスタマイズ

ExeScript にはカスタマイズ可能なインタフェースが装備されています。これは、モニタリングの結果を表示するメイン パネルと数種類のカスタマイズ可能なパネルで構成されています。カスタマイズ可能パネルは、表示/非表示、固定/非固定、別の場所に配置することができます。

  • パネルの表示/ 非表示は、[表示] メニューを選択して、対応するチェック ボックスを選択/解除します。
  • パネルを画面上に固定/非固定するには、ピン ボタンを使用してください。 - ウィンドウがポップ アップします。 - ウィンドウが固定します。
  • パネルが固定している場合には、別の場所に移動することが出来ます。マウスでパネルを選択し、プログラム ウィンドウ上を移動してください。パネルを別のパネルと結合させる場合は、上下、左右の矢印を使用してください。

次の説明も参照してください。

インタフェース


新規スクリプトの作成

ExeScript はスクリプトを EXE ファイルに変換するだけでなく、スクリプトの記述や作成にも便利なツールです。[ファイル] メニューから [新規] を選択するか、ツールバーの New ボタンをクリックして、新しいスクリプトを作成してください。作成したいファイルの種類は、リストから選択してください。プログラムのメイン エリアに、新しいスクリプト ファイルのウィンドウが表示されます。デフォルトのファイル名は、無題 です。スクリプト名の次のアイコンは、作成されたスクリプトのタイプを表示します。

スクリプト ウィンドウが表示されたら、コマンド ラインの入力を開始することが出来ます。

各スクリプトに独自のプロパティを設定できます。プロパティについての説明は、プロパティ パネルを参照してください。

プロパティ パネルで設定を変更すると、ExeScript Options のラインがスクリプトの先頭に追加されます。このラインは、後でプロパティを保存するとき必要です。

次の説明も参照してください。

既存のスクリプトを開く
スクリプトの編集方法
スクリプトの保存方法


既存のスクリプトを開く

以前に作成したスクリプト ファイルを開く場合は、[ファイル] メニューから [開く]、またはツールバーの Open ボタンを使用してください。ダイアログ ボックスからスクリプト ファイルを選択して、[開く] をクリックしてください。[ファイル タイプ] フィールドを指定すると、必要なファイルをより早く探すことが出来ます。

Note 注意　既存のファイルの場合は、プログラムのメインウィンドウにファイルをドラッグ アンド ドロップしても開くことが出来ます。

ファイルの選択が終了すると、プログラム メイン エリアの新しいウィンドウで、このファイルが編集可能になります。ウィンドウのタイトルはファイル名と同一になります。

また、ファイルを開いてから、プロパティを指定することも出来ます。

次の説明も参照してください。

新規スクリプトの作成
スクリプトの編集方法
スクリプトの保存方法


スクリプトの編集方法

スクリプトを編集するにはまず、スクリプトの内容が、アプリケーション ウィンドウで編集可能でなくてはなりません。編集可能でない場合、[ファイル] -> [開く] メニュー、または、ツールバーの Open ボタンを使ってスクリプト ファイルを開いてください。ファイル名のタブを使って、必要なスクリプトを選択してください。

ファイルの内容もプロパティも編集することが出来ます。

内蔵のエディタには、便利なテキスト入力機能があります。これは、前操作の取り消し/やり直し、クリップボードからテキストをコピーおよび貼り付け、構文強調表示等です。

次の説明も参照してください。

新規スクリプトの作成
既存のスクリプトを開く
スクリプトの保存方法


スクリプトの保存方法

新しいスクリプトや編集したスクリプトを保存する場合は、メニューから [ファイル] -> [保存]、または、ツールバーの Save ボタンを使用します。ダイアログ ボックスで、保存するファイルの保存場所とファイル名を指定してください。

メニューの [ファイル] -> [名前を付けて保存] から、別の名前や、別の場所にファイルを保存することが出来ます。

スクリプトのプロパティは、ファイルの内容と一緒に保存されます。

次の説明も参照してください。

新規スクリプトの作成
既存のスクリプトを開く
スクリプトの編集方法


スクリプトの変換 / コンパイル方法

スクリプトのコンパイルと変換は様々な場合に必要です。他のユーザ等からスクリプトの内容を保護しなければならない、他のユーザが内容を変更しないように保護しなければならない、簡単に実行できるようにする、などといった状況は頻繁に起こります。

スクリプト変換の主な利点は、スクリプトによって実行されるオペレーションが他のユーザから見えたり気づかれたりしない点です。さらに、サイレント モード機能でスクリプトを変換するために ExeScript を使用することが出来ます。この場合も、スクリプトの実行は気づかれることはありません。

スクリプトを変換/コンパイルするためには、次の準備をしてください。新しいスクリプト ファイルを作成する、あるいは、既存のスクリプト ファイルを開いてください。

新しいスクリプトを作成する場合は、[ファイル] メニューから [新規] を選択、あるいはツールバーの New ボタンをクリックして、必要なファイル タイプを選択してください。前回作成したスクリプト ファイルを開く場合は、[ファイル] メニューから [開く]、またはツールバーの Open ボタンからスクリプト ファイルを選択して [開く] をクリックしてください。プログラムのメイン ウィンドウにスクリプトの内容が表示されます。

スクリプトを変換するには、[プロジェクト] メニューから [作成] を選択、あるいは、ツールバーの Build project ボタンをクリックします。F7 キーもこの機能のために使用できます。実行ファイル名と保存先を指定してください。

Note 注意　EXE ファイルを作成せずにスクリプトを実行することができます。この場合は、[プロジェクト] メニューから [ソースをコンパイルしないまま実行] を選択します。スクリプトはプログラムのウィンドウから実行されます。


EXE アプリケーションの作成

何がアプリケーション ファイルを他とは違う独自のものにするのでしょうか ?一つは、プログラムの主要な機能を担うコードです。

EXE アプリケーションの作成は、しばしば必要になります。プログラミング言語を知らないユーザは、この点が問題になります。また、EXE アプリケーションの作成は、日常のタスクを自動化したり、モジュールやソフトウェアを配布するためのインストレーション パッケージの作成のためにたびたび必要になります。

さらに、EXE アプリケーションにはいくつかの強みがあります。EXE アプリケーションの内容は、他のユーザには利用出来ません。EXE アプリケーションが実行した操作は、他のユーザには知られることがありません。

ExeScript を使うと、既存のスクリプトから EXE アプリケーションを作成することが出来ます。EXE アプリケーションの作成には、まず、新しいスクリプト ファイルを作成するか既存のスクリプト ファイルを開きます。

新しいスクリプトを作成する場合は、[ファイル] メニューから [新規] を選択、あるいはツールバーの New ボタンをクリックして、必要なファイル タイプを選択してください。

既に作成したスクリプト ファイルがある場合は、それを開いてください。[ファイル] メニューから [開く]、またはツールバーから、 Open ボタンを選び、スクリプト ファイルを選択して [開く] をクリックしてください。スクリプト ファイルの内容はプログラムのメイン ウィンドウに表示され、タブのタイトルとファイル名は一致しています。

スクリプトを作成するには、[プロジェクト] メニューから [ビルド] を選択、あるいは、ツールバーの Build project ボタンをクリックします。F7 キーもこの機能のために使用できます。作成した EXE アプリケーション名と保存先を指定してください。ファイル名を指定して、[保存] をクリックしてください。

Note 注意　EXE ファイルの作成後、[プロジェクト] > [コンパイル＋実行] メニュー コマンドで EXE ファイルが実行されます。


スクリプトから EXE ファイルへの変換

スクリプト ファイルとプログラムの相違点は、プログラムは実行される前に、バイナリ コードの実行ファイルに変換されるという点です。スクリプトは元の形式のままで、実行されます。

スクリプトはテキストの形式で保存され、呼び出される前に、その都度読み込まれます。実行中に読み込まれるスクリプトは、実行速度が遅く、メモリの消費量も大きくなります。

スクリプト ファイルを EXE ファイルに変換すると、この弱点を克服できる上に、スクリプトの内容を変更されないように保護したり、スクリプトで実行されるオペレーションの順序を隠すことも出来ます。また、スクリプトのソース コードを表示せずに配布出来る、スタンドアロンのプログラムの作成が可能です。

スクリプトから EXE ファイルへの変換のために、ExeScript メイン ウィンドウで 新しいスクリプトの作成、または、既存のスクリプト ファイルを開いてください。 必要があれば、スクリプト ファイルを編集してください。

スクリプトを EXE ファイルに変換する前に、コンパイルせずに、スクリプトがどのように実行されるのかを確認できます。この場合は、[プロジェクト] メニューから [ソースをコンパイルしないまま実行] を選択します。F6 キーもこの機能のために使用できます。

スクリプトの変換は、下記の手順に従ってください。

  1. スクリプトを EXE ファイルに変換するには、[プロジェクト] から [ビルド] コマンドを選択します。
  2. EXE ファイルの保存先を指定して、EXE ファイルに名前をつけます。
  3. [保存] ボタンをクリックしてください。
  4. プログラムがスクリプトを変換して、結果を表示します。

EXE ファイルを保存した場所を表示するには、Windows Explorer を使ってください。

Note 　[プロジェクト] -> [コンパイル + 実行] メニューはスクリプトを EXE ファイルに変換するだけでなく、 EXE ファイルの実行も行います。

次の説明も参照してください。

BAT ファイルから EXE ファイルへの変換
VBSファイル から EXE ファイルへの変換
WSH ファイルから EXE ファイルへの変換
HTA ファイルから EXE ファイルへの変換
JS ファイルから EXE ファイルへの変換


BAT ファイルから EXE ファイルへの変換

BAT ファイルには、ファイルが実行されると特別なプログラムによって読み取られるテキスト コマンドが収められています。インタプリタが BAT ファイルから 1 コマンドごとに読み込んで実行します。

BAT ファイルが行う代表的な動作は、ファイル操作、プログラムの実行、テキストの印刷/表示、などです。

バッチファイルの非常に不利な点は、各コマンドごとに新しいサブ プロセスを作成する必要があるために、実行速度が遅いという点です。

バッチファイルの内容は誰でも見る事が出来、メモ帳（NOTEPAD.EXE)、その他のテキスト エディタで編集することが可能です。

BAT ファイルを作成するには、ExeScript を起動し、[ファイル] メニューから [新規] -> [バッチ] を選択して、新しいプロジェクトを作成します。そして、スクリプト ファイル ウィンドウにコマンド ラインを入力します。既存の.BAT ファイルを開くことも出来ます。この場合は、[ファイル] メニューから [開く] を選択します。

スクリプトの準備が出来たら、バッチファイルを EXE ファイルに変換します。まず、[プロジェクト] メニューから [作成] を選択します。必要な場所に EXE アプリケーションを保存してください。

下記は、簡単なバッチ スクリプトの作成と EXE アプリケーションへの変換の例です。

  1. BAT プロジェクトの作成
  2. バッチ スクリプト ウィンドウに下記のコマンド ラインを入力してください。
    @echo How to convert batch to exe
@pause
  3. [ファイル] メニューから [名前を付けて保存] を選択し、ファイル形式をバッチファイルとします。ファイル名のフィールドには 1.BAT を入力して、ルート フォルダ (例えば、C: ディスクなど) に保存します。
  4. [プロジェクト] メニューから [未コンパイル ソースの実行] を選択し、スクリプトの実行をチェックしてください。バッチファイルを EXE ファイルに変換する場合は、[プロジェクト] メニューから [作成] を選択します。
  5. ファイル形式を実行ファイルに設定し、ファイル名フィールドには 1.EXE を入力して、ルート フォルダ (例えば、C: ディスクなど) に保存します。
  6. C: ディスクを開き、1.EXE ファイルを実行します。ディスプレイには下記の 2 つの文字列が表示されます。

    バッチファイルを EXE ファイルに変換する方法
    任意のキーを押して継続してください・・・

    EXE ファイルの実行は終了しているので、任意のキーを押すとウィンドウが閉じます。

Note メモ: BAT ファイルの各コマンドの前の @ は、画面にコマンドそのものは表示せず、実行の結果のみが表示されるという意味です。

次の説明も参照してください。

スクリプトから EXE ファイルへの変換
VBSファイル から EXE ファイルへの変換
WSH ファイルから EXE ファイルへの変換
HTA ファイルから EXE ファイルへの変換
JS ファイルから EXE ファイルへの変換


VBS ファイルから EXE ファイルへの変換

VBS スクリプトは、次のような場合に最も良く使用されます。

  • Windows システムの管理を自動化する。
  • ASP ページでのサーバ プログラム コード
  • Internet Explorer のクライアント スクリプト

VBS スクリプトは、Web 環境、Windows GUI 環境、 及び、コマンド ライン環境から呼び出される VBSCRIPT.DLL によって解釈されます。

VBS ファイルを EXE ファイルに変換すると、次のような点で役立ちます。

  • スクリプトの内容を表示したり、変更することが出来ない。。
  • コンピュータ メモリで直接スクリプトを実行できる。
  • 実行速度が速い。
  • 他のユーザにスクリプトを配布しても、VBS ファイルの内容を見られたり、変更されたりしない。

VBS ファイルから EXE ファイルへの変換は、下記の手順で行ってください。

  1. ExeScript を開始します。
  2. メニューの、[ファイル] -> [新規] -> [VBScript file] 、または、ツールバーの New ボタンで新しい VBScript プロジェクトを作成します。以前に保存した VBScript ファイルを開く場合は、メニューの [ファイル] -> [開く]、または、ツールバーの Open ボタンを使い、ファイルを選択して、[開く] をクリックしてください。
  3. 必要であれば、VBS ファイルを変更してください。
  4. ファイルを既存のファイルに保存する場合は、[ファイル] -> [保存] コマンド、または、ツールバーの Save ボタンを使用します。新しいファイルに保存する場合は、[ファイル] -> [名前を付けて保存] を使用します。
  5. プロパティ パネルを開いて、スクリプトのコンパイル パラメータを設定してください。コンソール スクリプトの場合は、スクリプト種類 = コンソールを設定します。実行タイプ = コンパイルを設定すると、ExeScript Host Technology を使って、ハードディスクに書き込まずにメモリでスクリプトを実行することが出来ます。
  6. VBS ファイルを EXE アプリケーションに変換する前に、コンパイルせずにスクリプトがどのように実行されるのかを確認できます。この場合は、[プロジェクト] メニューから [ソースをコンパイルしないまま実行] を選択します。
  7. VBS ファイルを EXE ファイルに変換するには、[プロジェクト] から [ビルド] コマンドをクリックします。EXE アプリケーションの名前を入力して、[保存] をクリックしてください。プログラムが変換結果を表示します。
  8. 作成された EXE ファイルは、指定されたフォルダに保存されます。

次の説明も参照してください。

スクリプトから EXE ファイルへの変換
BAT ファイルから EXE ファイルへの変換
WSH ファイルから EXE ファイルへの変換
HTA ファイルから EXE ファイルへの変換
JS ファイルから EXE ファイルへの変換


WSH ファイルから EXE ファイルへの変換

Windows Script ホストはバッチファイルよりも強力な機能があり、JScript や VBScript、その他の追加でインストールされた言語 (Perl 等) で記述されたスクリプトを実行するために使用されます。

WSH スクリプトの特徴は、 オブジェクト機能を持ったフル装備言語、文字列と必要な操作、オブジェクト スクリプティング インタフェース (Active Scripting や OLE Automation) を実行しているソフトウェア との対話、それらのオブジェクト、メソッド、プロパティへのアクセス、ファイルやフォルダの操作、テキスト ファイルの処理、レジストリ管理などです。.JS、.VBS、.WSF その他のファイル タイプのスクリプトは、WSCRIPT.EXE (GUI でウィンドウから実行)、または、SCRIPT.EXE (バッチでコンソールから実行) によって実行されています。

下記は、標準的な WSH ファイルの例です。

[ScriptFile]
Path=C:\SHORTCUT.VBS
[Options]
Timeout=10
DisplayLogo=1
BatchMode=0

このファイルは、対話モードかバッチモードかといったユーザの好みを記憶しておいて、システム管理者が同じスクリプトでも、ユーザ毎に違った設定で実行できるようにします。

WSH ファイルから EXE ファイルへの変換は、下記の手順で行ってください。

  1. WSH ファイルを EXE ファイルに変換するには、[プロジェクト] から [ビルド] コマンドを選択します。
  2. EXE ファイルの保存先を指定して、EXE ファイルに名前をつけます。
  3. [保存] ボタンをクリックしてください。
  4. プログラムがスクリプトを変換して、結果を表示します。

WSH ファイルを EXE ファイルに変換するには、PATH 変数で指定したスクリプト自体が存在しなければなりません。

WSH から EXE を作成して、どのコンピュータにも自由に配布したい場合は、次の手順に従ってください。

WSH に次の内容を記述します。

Path=shortcut.vbs

ExeScript のリソース表示パネルへ SHORTCUT.VBS ファイルを追加します。

次の説明も参照してください。

スクリプトから EXE ファイルへの変換
BAT ファイルから EXE ファイルへの変換
VBSファイル から EXE ファイルへの変換
HTA ファイルから EXE ファイルへの変換
JS ファイルから EXE ファイルへの変換


HTA ファイルから EXE ファイルへの変換

HTA (HTML アプリケーション) では、HTML と DHTML を使ってアプリケーションを作成することが出来ます。

ＨＴＡ アプリケーションは、拡張子を .HTA に変更するだけで、通常の HTMLファイルから作成することが出来ます。HTA ファイルは HTML ファイルより、多くの点ですぐれています。HTA アプリケーションは、メニュー、アイコン、ツールバーや Web 開発者が作成したタイトル情報を表示することが出来ます。

残念ながら、HTA ファイルには欠点があるので、HTA ファイルの内容は表示と変更が出来ます。HTA ファイルを EXE アプリケーションに変換して、この問題を解決することが出来ます。

HTA ファイルから EXE アプリケーションへの変換は、次の手順で行ってください。

  1. HTA ファイルを EXE ファイルに変換するために、[プロジェクト] から [ビルド] コマンドを選択します。
  2. EXE ファイルの保存先を指定して、EXE ファイルに名前をつけます。
  3. [保存] ボタンをクリックしてください。
  4. プログラムが HTA ファイルを EXE ファイルに変換して、結果を表示します。

ほとんどの HTA スクリプトは外部リソースを使用しています。例えば、次の簡単なスクリプトはアプリケーション アイコンとして SIMPLE.ICO ファイルを使用しています。

<HTML>
<HEAD>
<TITLE>HTA Demo</TITLE>
<HTA:APPLICATION ID="oHTA"
APPLICATIONNAME="myApp"
BORDER="thin"
BORDERSTYLE="normal"
CAPTION="yes"
ICON="simple.ico"
MAXIMIZEBUTTON="yes"
MINIMIZEBUTTON="yes"
SHOWINTASKBAR="no"
SINGLEINSTANCE="no"
SYSMENU="yes"
VERSION="1.0"
WINDOWSTATE="maximize"/>
SCRIPT>
/SCRIPT>
<HEAD>
<BODY SCROLL="no">
    <PRE ID=oPre> </PRE>
</BODY>
<HTML>

この HTA を EXE にコンパイルすることは出来ますが、SIMPLE.ICO ファイルが、ExeScript の作業ディレクトリのプロパティで指定したフォルダに保存されていることを確認しなければなりません。

この問題を解決するには、次の 2 通りの方法が考えられます。作業ディレクトリ = スクリプト ディレクトリを指定し、SIMPLE.ICO を EXE ファイルと共にフォルダに保存する、あるいは、ExeScript のリソース表示パネルで SIMPLE.ICO を追加します。これで、EXE ファイルに SIMPLE.ICO がふくまれ、常にメイン スクリプトのフォルダに保存されるので、作業ディレクトリのプロパティに影響されません。

次の説明も参照してください。

スクリプトから EXE ファイルへの変換
BAT ファイルから EXE ファイルへの変換
VBSファイル から EXE ファイルへの変換
WSH ファイルから EXE ファイルへの変換
JS ファイルから EXE ファイルへの変換


JS ファイルから EXE ファイルへの変換

Jscript は Internet Explorer、 Windows Script ホスト及び Active Server Pages 経由で入手可能です。JScript は、Web ページにクライアント スクリプトを追加するほかに、Windows システム管理の自動化やASP ページの作成などのためにも使用する事が出来ます。

JS ファイルを変換すると、スクリプト ファイルの内容を表示されないように保護できるだけでなく、コンピュータのメモリ上でスクリプトを実行することができます。他のユーザにファイルを配布しても、スクリプトの内容を変更されたり、見られることがありません。

JScript から EXE アプリケーションへの変換は、次の手順で行ってください。

  1. JS ファイルを EXE ファイルへ変換するために、[プロジェクト] から [ビルド] コマンドを選択します。
  2. EXE ファイルの保存先を指定して、EXE ファイルに名前をつけます。
  3. プロパティ パネルを開いて、スクリプトのコンパイル パラメータを設定してください。コンソール スクリプトの場合は、スクリプト種類 = コンソール を設定します。実行タイプ = コンパイル を設定すると、ExeScript Host Technology を使って、ハードディスクに書き込まずにメモリでスクリプトを実行することが出来ます。
  4. [保存] ボタンをクリックしてください。
  5. プログラムが JS ファイルを EXE ファイルに変換して、結果を表示します。

次の説明も参照してください。

スクリプトから EXE ファイルへの変換
BAT ファイルから EXE ファイルへの変換
VBSファイル から EXE ファイルへの変換
WSH ファイルから EXE ファイルへの変換
HTA ファイルから EXE ファイルへの変換


ExeScript ホストとは?

Everstrike ExeScript ホスト は VBS 及び JS スクリプト用の言語独立スクリプティング ホストです。Windows プラットフォームで簡単、強力、かつフレキシブルなスクリプティングを可能にし、メモリから直接、スクリプトを実行することができます。

ExeScript はスクリプトでのオブジェクトやサービスの利用を可能にし、スクリプトの実行にガイドラインを提示します。また、Windows Script ホストはスクリプトのセキュリティを管理します。ExeScript ホスト 3.0 は、Windows スクリプト ホストの機能性を継承し、さらに機能と特性が追加されました。将来のバージョンでは、更に機能が拡張される予定です。機能についてのご意見、ご感想はこちらへお問い合わせ下さい。

ExeScript ホストはスクリプトの表示を最大限に防止し、Windows スクリプト ホストの機能を損ないたくなというユーザには、完璧なソリューションです。スクリプトを EXE に変換すると、ExeScript ホストによって実行されます。

次の説明も参照してください。

ExeScript ホストの使用方法 - ExeScript コンパティブル スクリプトの作成
ExeScript ホスト オブジェクト モデル- アーキテクチャへのロードマップ
ExeScript ホスト言語 - ExeScript ホスト オブジェクトと機能についての説明


ExeScript ホストの使用方法

ExeScript の本バージョンでは、VBS および JS スクリプトにおいてのみ ExeScript Host technology を使用できます。新しい VBS または JS スクリプトを作成するか、既存のスクリプトを開き、プロパティ パネルでコンパイルのための [実行タイプ] オプションを設定してください。スクリプト オプションの設定については、プロパティ パネルを参照してください。

スクリプトを EXE へコンパイルすると、スクリプトは EXE に組み込まれ、ExeScript ホストにより、ランダム アクセス メモリで実行されます。

ExeScript ホストについての制限 - スクリプトの中で WScript.ConnectObject と WScript.DisconnectObject は使用できません。この制限は、ExeScript ホストの次のバージョンでは、解除される予定です。ExeScript ホストの全ての機能の一覧は、ExeScript ホスト言語をご覧下さい。

次の説明も参照してください。

ExeScript ホストとは?
ExeScript ホスト オブジェクト モデル - アーキテクチャへのロードマップ
ExeScript ホスト言語 - ExeScript ホスト オブジェクトと機能についての説明


ExeScript ホスト オブジェクト モデル

下記は、ExeScript ホスト オブジェクト モデル階層を図にしたものです。

The ExeScript Host Object Model hierarchy

下記の表示は ExeScript ホスト オブジェクトと関連する主要なタスクの説明です。

オブジェクト | このオブジェクトで出来ること。
Wscript
  • コマンド ライン引数の設定と取得
  • スクリプト ファイル名の決定
  • EXE ファイル名の決定
  • ホスト ファイル名 (WSCRIPT.EXE または CSCRIPT.EXE) の決定
  • ホストのバージョン情報の決定
  • COM オブジェクトの作成と取得
  • プログラム的にスクリプトの実行を停止
  • 初期設定の出力装置 (ダイアログ ボックス、コマンド ライン等) への情報出力
WshArguments | コマンド ライン引数全体にアクセス
WshNamed | 名前をつけられたコマンド ライン引数の集合にアクセス
WshUnnamed | 名前をつけられていないコマンド ライン引数の集合にアクセス

次の説明も参照してください。

ExeScript ホストとは?
ExeScript ホストの使用方法 - ExeScript コンパティブル スクリプトの作成
ExeScript ホスト言語 - ExeScript ホスト オブジェクトと機能についての説明


ExeScript ホスト言語

実行タイプ = コンパイル を設定すると、ExeScript で実行される WScript オブジェクトの、下記のプロパティとメソッドを使用することが出来ます。

WScript.FullName - 実行ファイルへのフル パス + EXE 名(例) c:\test\1.exe
WScript.Name = "ExeScript Host"
WScript.ScriptFullName - 作業ディレクトリ + スクリプト名(例) "C:\Documents and Settings\Login\Local Settings\Temp\untitled1.vbs"
WScript.ScriptName - スクリプト ファイル名(例） untitled1.vbs
WScript.Sleep(time) - スクリプト遅延 (ミリ秒)
WScript.Version = 5.6
WScript.BuildVersion = 8820
WScript.Interactive = (true or false).ExeScript プロパティを表示 - サイレント モード

Note 注意　ここでは、相関は逆になります。 - Interactive = True のとき、サイレント モード = False

WScript.Echo [arg1] [,arg2] [,arg3] :- サイレント モードとスクリプト タイプ プロパティにより画面に表示
WScript.Arguments - ExeScript プロパティで指定、又は、EXE ファイル パラメータとして送られたコマンド ライン引数
WScript.Quit(result) - 特定のエラー コードの発生でスクリプトを終了

WScript.StdErr - 現在のスクリプトに、書込み専用エラー出力ストリームを表示
WScript.StdIn - 現在のスクリプトに、読み取り専用入力ストリームを表示
WScript.StdOut - 現在のスクリプトに書込み専用出力ストリームを表示

WScript.GetObject(strPathname [,strProgID], [strPrefix]) - 指定された ProgID またはファイルから新しい物を作成して既存のオブジェクトに返します。

strPathname - ディスク上のオブジェクトの入ったファイルの完全なパス名

strProgID
任意,オブジェクトのプログラム識別子 (ProgID)

strPrefix
任意,オブジェクトのイベントを同期させたいときに使用します。strPrefix 引数を入力すると、ExeScript は、オブジェクト作成後、オブジェクトの送出インタフェースをスクリプト ファイルへ接続します。

WScript.CreateObject(strProgID[,strPrefix]) - COM オブジェクトを作成

strProgID
作成したいオブジェクトのプログラム識別子を示す文字列の値

strPrefix
任意,ファンクション プレフィックスを示す文字列の値

Note 注意　スクリプトでは、WScript.ConnectObject と WScript.DisconnectObject 機能は使用できません。この制限は、ExeScript ホストの次のバージョンでは、解除される予定です。

次の説明も参照してください。

ExeScript ホストとは?
ExeScript ホストの使用方法 - ExeScript コンパティブル スクリプトの作成
ExeScript ホスト オブジェクト モデル - アーキテクチャへのロードマップ


バッチ コマンド

使用可能なバッチ コマンド
@ @ 記号の後のテキストをエコー バックしません。通常、@ECHO OFF として使用し、バッチファイル内のコマンドが表示されないようにします (つまり、必要な情報のみを表示します)。
%1 変数はコマンドライン アーギュメントの形でバッチ ストラクチャに挿入することが出来ます。%1, %2 等として使用します。変数にデータを入れるには、バッチファイルの実行時に、バッチファイル名の後に目的の値を入力します。以下にバッチファイルの例を示します。
echo Hello %1
上記のバッチファイルが作成されたら、バッチファイルの後にあなたの名前を加えます。例えば myname (BAT ファイル名です) を入力し、それからあなたの名前を入力すると、

myname bob

出力は、下記のようになります。

Hello bob
:LABEL | LABEL など、特定のテキストの前にコロン (:) を追加することで、ラベルとして一般に知られているカテゴリを作成します。ラベルを指定しておけば、バッチファイル内の特定のセクション (末尾のセクションなど) にスキップすることができます。「GOTO」の説明も参照してください。
CALL 別のバッチファイルを呼び出し、終了時に最初のものにコントロールを返します。
CALL C:\WINDOWS\NEW_BAT.BAT
別のプログラムを呼び出します。
CALL C:\WINDOWS\System32\calc.exe
CHOICE ユーザに選択を求めます。デフォルト値は Y または N ですが、/C: スイッチで独自の選択肢を作成することもできます。以下にバッチファイルの例を示します。
@echo off
CHOICE /C:123
IF errorlevel 3 goto THREE
IF errorlevel 2 goto TWO
IF errorlevel 1 goto ONE>

:ONE
ECHO One
PAUSE
EXIT
:TWO
ECHO Two
PAUSE
EXIT
:THREE
ECHO Three
PAUSE
EXIT
CLS | DOS コマンドと同様で、画面をクリアします。
ECHO ECHO を "オン" に設定するとバッチ プロセスが画面に表示され、"オフ" に設定するとバッチ プロセスが隠されます。ECHO は画面に出力を表示するためにバッチファイルでも使用できます。
@echo off
ECHO Hello
PAUSE
ECHO が空白行を出力します。
EXIT | バッチファイルが Windows で実行されたら、DOS ウィンドウを閉じます。
GOTO | 特定のラベル (LABEL など) にスキップします。たとえば、GOTO SUBSECTION のように指定します。
IF 条件がある場合、条件を確認するために使用します。その条件がある場合、その機能を実行します。以下にバッチファイルの例を示します。
@echo off
:START
COPY file.txt file2.txt
IF errorlevel 1 GOTO MKFILE
GOTO :END
:MKFILE
ECHO file text>file.txt
GOTO START
:END
ECHO Quitting
PAUSE
PAUSE | バッチファイルの処理を一時停止し、続行するには任意のキーを押すように求めるメッセージを表示します。
REM | バッチファイル内にコメントを挿入することができるようになります。バッチファイルの実行時にコメント行が表示されたり、実行されたりすることはありません。
SHIFT | バッチファイル内の置き換え可能なパラメータの位置を変更します。
START | Windows のアプリケーションを起動します。たとえば、START C:\WINDOWS\system32\calc とすると、Windows の電卓を起動します。なお、このコマンドは、Windows 95、Windows 98、Windows NT 4.0、またはそれ以降のバージョンでのみ使用できます。

Note DOS のバージョンによっては、「HELP <コマンド名>」、または 「<コマンド名> /?」と入力すると、該当するコマンドのヘルプを表示することができます。


バッチファイル作成時のヒント

  • 画面にテキストを出力するには ECHO コマンドを使用します。
  • "START" コマンドを使用して、コマンド ラインから Windows プログラムを実行します。
  • コマンド インプリタを新たに起動するには、"COMMAND" コマンドを使用します。
  • バッチファイル内で「if %1 == OK :」のように指定すると、バッチファイルがクラッシュする可能性があります (%1 が空であるため、構文エラーとなります)。代わりに、「if %1. == OK. :」を使用する必要があります。
  • REM の代わりに、:: も使用できます。
  • 画面に空白行を出力するには、ECHO: も使用できます。
  • 個々のファイル、またはファイル グループの断片化をチェックするには、DEFRAG の代わりに、CHKDSK filenames を使用できます。"filenames" には、断片化をチェックするファイル名またはファイル グループ名を指定します。たとえば、GAMES ディレクトリの *.DAT ファイルの断片化をチェックするには、CHKDSK C:\GAMES\*.DAT と指定します。CHKDSK を使用すると、各ファイルの非連続ブロックのレポートが表示されます。非連続ブロックの数が多いほど、ファイルの断片化の程度が大きいことを示します。

次の説明も参照してください。

バッチファイルの例


バッチファイルの例

パスワードの設定

以下のバッチファイルを使用すれば、プログラムを起動するためのパスワードを設定できます。バッチファイルの名前は START.BAT とし、CALC.EXE というプログラムを起動するものとします。

@echo off
IF %1==ExeScript GOTO OK
ECHO WRONG PASSWORD
GOTO END
:OK
ECHO PASSWORD IS ACCEPTED...STARTING
CALC.EXE
:END

間違ったパスワードと正しいパスワードを入力した場合の応答を以下に示します。

まず間違ったパスワードの場合です。コマンド プロンプトで START 123 と入力します。
C:/>
C:/>START 123
C:/>パスワードが間違っています

正しいパスワードを入力した場合です。
C:/>
C:/>START ExeScript
C:/>パスワードが承認されました - プログラムを起動します

正しいパスワードを入力した場合、CALC.EXE プログラムが起動します。

*.DOC ファイルのバックアップ (Windows NT/2000/XP バージョン)

使い方:backbat backupdir
バックアップ先:backupdir が .doc ファイルをコピーするディレクトリです。

@echo off
if not "%1"=="" goto argsok
echo の使い方:%0 backupdir
echo where:backupdir が .doc ファイルをコピーするディレクトリです。
goto end

:argsok
setlocal
set backupdir=%1
if not exist %backupdir% goto notfile
echo %backupdir% is a file
goto end
:notfile
rem  If the directory does not exist, create it.
if exist %backupdir%\nul goto skipdir
md %backupdir%
if "%errorlevel%"=="0" goto skipdir
echo Error creating backup directory
goto end
:skipdir
rem  Copy each .doc file one at a time.
rem  Note:the for loop variable (%%b) must be contain only one letter.
for %%b in ( *.doc ) do copy %%b %backupdir% > nul
rem  Use the for loop again to check if each file was copied (since it is  rem  difficult to run multiple commands in a for loop).

for %%b in ( *.doc ) do if not exist %backupdir%\%%b echo %%b was not copied:end

rem  Clean up
endlocal

タイム ログの作成

以下のコードを使用すれば、バッチファイルが読み込まれたときにタイム ログを記録することができるようになります。たとえば、AUTOEXEC.BAT で指定しておけば、他のユーザがコンピュータにログインしたときにログが記録されます。

ECHO.|TIME > TIME
COPY LOG +TIME

別の方法 1 (この方法は若干複雑で、Windows NT、Windows 2000、Windows Me では使用できません)

echo @prompt set date=$d$_set time=$t$h$h$h > {a}.bat
%comspec% /e:2048 /c {a}.bat > {b}.bat
for %%v in ({b}.bat del) do call %%v {?}.bat
echo %date% %time% >> log

別の方法 2

echo.|time |find "current" >> log

このバッチファイルを適切に動作させるためには、「EDIT LOG」と入力して、"LOG" というファイルを作成し、0 バイトのファイルが生成されるごとに、退避しておく必要があります。そうしておかないと、"Content of destination lost before copy" というエラー メッセージが表示され、上書きされてしまいます。

次の説明も参照してください。

バッチファイル作成時のヒント


VBScript ファイル作成時のヒント

  1. Chr(13) + Chr(10) の命令文を定数 vbCrLf で置き換えることが出来ます。
  2. MsgBox に、それぞれ違う行でいくつかの文字列を表示させたい場合は、次の例のように、文字列の間に定数 vbCrLf を挿入します。
    MsgBox "123" + vbCrLf + "123" + vbCrLf + "123" + vbCrLf + "123"
  3. コードが 1 行に収まらない場合、次のように、行継続記号を使用します。
    if a=1 and b=2 or c=3 then alert a
    は、次のように記述することが出来ます。
    if a=1 _
and b=2 _
or c=3 _
then alert a
  4. 2 個の数値変数を "つなぎ合わせる" 場合は、"+" を使用するより "&" を使用した方が良いでしょう。
    a="Hel" b="lo"
    は、次のようになります。
    a&b="Hello"

次の説明も参照してください。

VBS ファイルの例


VBS ファイルの例

メッセージ ボックス

Dim strMessage
strMessage = "Compile scripts into stand-alone applications"
MsgBox strMessage

再起動

以下のコードを使用すれば、VBScript スクリプトからローカル マシンを再起動できます。コードを正常に動作させるためには、再起動するマシンに Windows Management Instrumentation (WMI) がインストールされている必要があります。

Set OpSysSet = GetObject("winmgmts:{(Shutdown)}//./root/cimv2").ExecQuery("select * from Win32_OperatingSystem where Primary=true")

for each OpSys in OpSysSet
    OpSys.Reboot()
next

マシンをシャットダウンするには、OpSys.Reboot() 行を OpSys.Shutdown() に変更します。

Windows シャットダウン選択ポップアップ

set WshShell = wscript.CreateObject("Shell.Application")WshShell.ShutdownWindows

次の説明も参照してください。

VBScript ファイル作成時のヒント


FAQ

Q. VBS や JS のスクリプトが一時フォルダに解凍されました。一体どこが悪いのでしょうか？

A.スクリプトのオプションで、実行タイプ = コンパイルを設定してください。この場合、スクリプトは解凍されず、オリジナルのExeScript Host technology が実行に使われます。これは、誰にも変数の情報を引き出すことは出来ず、全てが暗号化されるなど、スクリプトを実行する際には最も安全な方法です。ExeScript はこの種のプログラムの中では唯一、スクリプトをフォルダに解凍しないようにすることの出来るプログラムです。しかし WScript 要素の使用についてはいくつかの制限があります。詳細については、ExeScript ホスト言語 をご覧下さい。

Q. 実行ファイルが大きすぎます。もっと小さくすることは出来ますか？

A.バージョン情報チェックボックスを消去して、アイコン タイプ = アイコンなし を設定してください。ExeScript には強力な暗号化が使用されており、 EXE ファイルは暗号化スクリプトを実行するために必要なデータやプロシージャを含んでいるため、ファイルをより小さくすることは出来ません。

Q.作業ディレクトリが何のためのものか分りました。作業ディレクトリ = その他ディレクトリで、スクリプトが実行されるコンピュータ上にディレクトリが存在しない場合はどうなるのですか？

A. 作業ディレクトリは、リソース表示パネルで指定した追加のリソース ファイルが解凍されるフォルダを表示します。実行タイプ = 展開 の場合、スクリプトは作業ディレクトリにも解凍されます。実行タイプ = コンパイルの場合、スクリプトは解凍されませんが、現在のフォルダが作業ディレクトリとして設定されます。作業ディレクトリ = その他ディレクトリ で、ディレクトリがスクリプトを実行するコンピュータ上に存在しない場合は、 EXE ファイルが置かれているフォルダがデフォルトで使用されます。

Q. ライセンスされた ExeScript で作成した EXE ファイルを配布することは出来ますか？

A. それはライセンスの種類によります。詳細については、ライセンス をご覧下さい。

Q. 色々問題があります。EXE ファイルが動かなかったり、正しく実行されなくて、スクリプトらしくありません。オプションを追加してしまいます。

A. Contact the support service へお問い合わせ下さい。


ライセンスの概観

ExeScript には 3 種類のライセンスがあります。

ExeScript の 1 ライセンスに付き一人の開発者に、スクリプトの作成、編集、変換、および保護された exe アプリケーションの作成が許諾されます。この条件は ExeScript を遠隔で使用する場合にも該当します。本製品を複数の開発者でご使用になる場合は、使用人数分のライセンスをご購入いただく必要があります。複数ライセンスご購入の場合は、割引の対象となります。

ExeScript には 3 種類のライセンスがあります。家庭用、企業用、開発者用です。

  • 家庭用ライセンス 非営利的な家庭用の使用のためのライセンスです。それ以外の環境下では企業用ライセンスをご使用下さい。このライセンスでは、ExeScript を企業ネットワーク、ネットワーク サーバ、および他のユーザがネットワーク経由で本製品を使用できるコンピュータにインストールして使用することは出来ません。お客様は、本ソフトウェアがインストールされているシステム上でのみ EXE アプリケーションを実行および作成することが出来ます。また、作成された EXE アプリケーションを他のコンピュータに配布することは出来ません。
  • 企業用ライセンス 本製品を企業、非営利団体、国有機関、行政、その他のいかなる形態においても、団体において使用する場合、または、個人が営利目的で本製品を購入する場合 (例えば、個人又は家族経営の場合) には企業用ライセンスを取得しなければなりません。このライセンスでは、1 つのネットワーク内でのみ、作成された EXE アプリケーションの実行および配布を行うことが出来ます。
  • 開発者用ライセンス このライセンスは営業用のものです。開発者用ライセンスでは、作成された EXE アプリケーションの実行や配布を制限なしに行うことができます。お客様は、本ライセンスの製品内外で自由に EXE アプリケーションを配布することが出来ます。

各ライセンス　タイプで、本製品の全ての機能が使用可能です。しかし、家庭用と企業用のライセンスには、ExeScript のインストール、スクリプトの作成と変換、作成された EXE アプリケーションの配布に関しての制限があります。お客様に最も適したライセンスをお選びいただくために、下記の比較表をご覧下さい。

ライセンス一覧
インストール | 家庭用ライセンス | 企業用ライセンス | 開発者用ライセンス
1 ライセンスで ExeScript をインストール出来るコンピュータの数 | 1 人のユーザによる使用で 1 台のコンピュータにインストールできます。
企業、団体内での商業的な利用 | × | ○ | ○
企業、団体内のコンピュータへのインストール | × | ○ | ○
企業ネットワーク内のコンピュータへのインストール | × | ○ | ○
ネットワーク サーバへのインストール | × | ○ | ○
ネットワークを介して、他のユーザが本製品を使用できるコンピュータへのインストール | × | × | ×
スクリプトの作成、編集、変換
ExeScript がインストールされているコンピュータでのスクリプトの作成、編集、変換 | ○ | ○ | ○
遠隔操作により、ExeScript がインストールされているコンピュータでのスクリプトの作成、編集、変換 | × | ExeScript 使用のライセンスがあるユーザ/開発者には許可 | ExeScript 使用のライセンスがあるユーザ/開発者には許可
配布
作成した EXE アプリケーションを他のコンピュータで実行 | × | 1つのコンピュータ ネットワーク内でのみ | ○
作成された EXE アプリケーションを、1つのコンピュータ ネットワーク内で実行、配布 | × | ○ | ○
作成された EXE アプリケーションを、別のコンピュータで実行、配布 | × | × | ○

次の説明も参照してください。

ExeScript を購入するには


システム要件とインストール

システム要件

ExeScript のご使用には次の環境が必要です。

  • Windows 2000/XP/2003/Vista/x64 Edition
  • およそ 3MB のハードディスク空き容量

インストール

インストール ウィザードの指示に従ってインストールを実行してください。再起動の必要はありませんので、システムへのインストール直後からプログラムは使用可能です。

アンインストール

ExeScript はシステムからプログラムを削除するための自動アンインストーラを備えています。

ExeScript のアンインストールは次のように行ってください。

  • Windows の [スタート] ボタンをクリックします。
  • [設定] メニューを開きます。
  • [コントロール パネル] を開きます。
  • [プログラムの追加と削除] を開きます。
  • 'ExeScript' までスクロールします。
  • 'ExeScript' を選択して、[削除] ボタンをクリックします。
  • アンインストーラから出される指示に従ってください。

Note 注意　ExeScript で作成した実行ファイルのパッケージは、Windows システム上でのみ実行されます。


ExeScript のアンインストール

ExeScript はシステムからプログラムを削除するための自動アンインストーラを備えています。

ExeScript をアンインストール方法

  1. ExeScript を閉じます。
  2. Windows の [スタート] ボタンをクリックします。
  3. [設定] メニューを開きます。
  4. [コントロール パネル] を開きます。
  5. ExeScript を完全にアンインストールするためには、コントロール パネルの Windows プログラムの追加と削除ツールをご使用下さい。
  6. 'ExeScript' を選択して、[削除] ボタンをクリックします。


ExeScript 使用許諾契約書

ExeScript をご利用になる前に、本使用許諾契約書をよくお読みください。

  1. 本使用許諾契約書 (以下、「本契約」) は、エンドユーザ (以下、「お客様」) とソフトウェアの開発元 (以下、「作者」) との間で交わされる法的契約です。本ソフトウェア (ExeScript) をご使用になるか、お客様のコンピュータ (またはその他メディア) に保存することで、本契約のすべての条項に同意したものと見なされます。
  2. ExeScript は "現状のまま" で配布されています。明示的にも黙示的にもいかなる種類の保証も行っておりません。お客様ご自身の責任下において本ソフトウェアをご使用ください。Everstrike Software は、本ソフトウェアの使用または使用結果に関して、正確性および信用性に対するいかなる保証も放棄するものとします。Everstrike Software は、本ソフトウェアの使用方法が正しいか否かに関わらず、また Everstrike Software によって損害の可能性が示唆されていた場合であっても、利益の損失、ビジネスの中断、および情報の喪失に限らず、いかなる偶発的、必然的、直接的、間接的損害に対する責任も負いません。本ソフトウェアをインストールすることで、お客様は本免責事項をお読みになり、理解し、すべての条項に同意したものと見なされます。また、本免責事項は当事者間における完全に排他的な了解事項であり、免責事項に関する過去の書面・口頭 (またはその他連絡方法) による提案または同意書に優先します。
  3. 本ソフトウェアに関するすべての著作権は作者である Everstrike Software が有します。
  4. お客様は 15 日間に限り本ソフトウェアの試用版を試用することが出来ます。この期間中、お客様はご自分のシステム上で本ソフトウェアを試用することが出来ます。15 日間の評価期間が過ぎると、評価版のサービスは停止になり、継続して使用する場合はライセンスを購入する必要があります。オンライン サービス、掲示板、またはその他の方法で本ソフトウェアを自由に配布できるのは評価版に限られます。
  5. Everstrike Software は、本ソフトウェアを購入されたお客様に対して、本ソフトウェアを 1 台のコンピュータで使用するための権利と、保管用として 1 部のコピーを作成するための権利を許諾します。ここでいう使用とは、ソフトウェアを RAM にロードしたり、ハード ディスクなどの記憶装置にインストールすることを意味します。お客様が本契約に同意している限りは、本ソフトウェアを継続して使用することができます。ただし、ネットワーク サーバにインストールする場合、または 1 度に複数のユーザで使用する場合は、事前にマルチユーザ ライセンスの手配が必要になります。すなわち、保管用としてバックアップ コピーを 1 部作成することが認められている以外、複製、販売、譲渡、贈呈など商用目的でのソフトウェアの利用や、サブライセンス、貸与などは一切認められていません。Everstrike Software に対して書面による文書を提出した場合にのみ、他者への譲渡が認められる場合があります。
  6. 本ソフトウェアおよび付属資料は、本契約において許諾されていない限り、いかなる手段においても、模倣、複製、貸与、リース、販売、譲渡、仕様変更、逆コンパイル、逆アセンブリ、リバース エンジニアリング、メッセージやウィンドウの変更や削除を行うことは禁止されています。不正使用を発見した場合は、ライセンスが自動的に即時終了するものとし、厳しい刑事上、民事上の訴追に帰着することがあります。
  7. Everstrike Software の事前の承諾なしに、いかなる形態においても ExeScript を、支払またはライセンス使用料を受取るために使用される、商業的に配布される製品の一部に含めることは出来ません。ExeScript の 1 ライセンスに付き一人の開発者に、スクリプトの作成、編集、変換、および保護された EXE アプリケーションの作成が許諾されます。この条件は ExeScript を遠隔で使用する場合にも該当します。ExeScript には 3 種類のライセンスがあります。
    • 家庭用ライセンス 非営利的な家庭用の使用のためのライセンスです。それ以外の環境下では企業用ライセンスをご使用下さい。このライセンスでは、ExeScript を企業ネットワーク、ネットワーク サーバ、および他のユーザがネットワーク経由で本製品を使用できるコンピュータにインストールして使用することは出来ません。お客様は、本ソフトウェアがインストールされているシステム上でのみ EXE アプリケーションを実行および作成することが出来ます。また、作成された EXE アプリケーションを他のコンピュータに配布することは出来ません。
    • 企業用ライセンス 本製品を企業、非営利団体、国有機関、行政、その他のいかなる形態においても、団体において使用する場合、または、個人が営利目的で本製品を購入する場合 (例えば、個人又は家族経営の場合) には企業用ライセンスを取得しなければなりません。このライセンスでは、1 つのネットワーク内でのみ、作成された EXE アプリケーションの実行および配布を行うことが出来ます。
    • 開発者用ライセンス このライセンスは営業用のものです。開発者用ライセンスでは、作成された EXE アプリケーションの実行や配布を制限なしに行うことができます。お客様は、本ライセンスの製品内外で自由に EXE アプリケーションを配布することが出来ます。
  8. アップグレードにより前のバージョンは置き換えられます。この場合追加のライセンスは提供されません。その際は、前のバージョンの使用を取り止め、他の誰も使用していないことを確認してください。
  9. 本契約に明示されていないすべての権利は作者に留保されます。
  10. 本契約の内容、および本ソフトウェアのインターフェイス デザイン、ドキュメント、コーディングは、将来のリリースにおいて予告なしに変更される場合があります。
  11. 本ソフトウェアをインストールし、使用するには、本契約のすべての条項に同意する必要があります。同意されない場合は、本ソフトウェアをただちに破棄し、使用を中止してください。

次の説明も参照してください。

評価版と登録版の違い


評価版と登録版の違い

ExeScript は、試してから購入 (Try Before You Buy) することができるシェアウェアです。特定の評価期間内であれば無料で利用することができますが、その期間を過ぎると、購入するか、利用を停止する必要があります。なお、ExeScript には、15 日間の評価期間が設けられています。

ExeScript では、評価版でも登録版とまったく同じ機能を使用できます。これは、お客様にソフトウェアの必要性を適切に判断してもらうことを目的としているためです。

しかしながら、試用版では次のような制限があります。評価版の場合、起動時に評価版であることを示す通知ウィンドウが表示される、メイン ウィンドウのタイトル バーに評価モードで実行していることを示すメッセージが表示される、終了時にフィードバックの送信を求めるウィンドウが表示される、などです。

ご購入後は、上記の制限事項が解除され、完全なテクニカル サポートと無料のアップグレードを受けることが出来ます。詳細については、ご購入ページを参照してください。

また、 "ソフトウェア ライセンス" の項で、ExeScript の使用許諾契約書をお読み下さい。


お問合せ先

Check | 一般的なご質問、販売について ご質問、ご意見、ご感想、バグのご報告は弊社 Web サイト http://www.hide-folder.com/support/ のお問い合わせフォームをご利用くださいますようお願いいたします。
Check | サポートとコンサルティング http://www.shareEDGE.com/cs より、テクニカル サポート チームへご相談下さい。(週末を含め) 1 - 2 日以内にご連絡を差し上げます。
Check | 米国オフィス所在地 Pacific Business Centre Att: Everstrike Software P.O. Box 34069 #381 Seattle, WA 98124-1069 USA FAX: 206-984-3919 TEL: +1-866-70-80-900
Check | カナダ オフィス所在地 Pacific Business Centre Att: Everstrike Software #101 - 1001 W. Broadway Suite 381 Vancouver, BC V6H 4E4 Canada


著作権

Copyright © 2007 Everstrike Software.All rights reserved.

本ドキュメントは、ExeScript ソフトウェアと併せて使用することだけを目的として、Everstrike Software によって発行されています。本ドキュメントの印刷版および電子版は、すべてのライセンス所有者が利用できます。Everstrike Software の書面による事前の許可なしに、本ドキュメントの一部またはすべてを複写、複製、再製造、または翻訳すること、電子的または機械的に読み取り可能な形式に変換すること、および Web サイトに掲載することは禁じられています。

商標

ExeScript 及び Everstrike Software は Everstrike Software の商標です。Microsoft、Windows、Windows NT、Word、および Excel は Microsoft Corporation の登録商標です。Adobe、Acrobat、および Acrobat Reader は Adobe Systems Incorporated の登録商標です。その他の会社名、製品名は、各社の商標または登録商標です。

日本語ローカリゼーション

株式会社ネクステッジテクノロジー


追加された機能

ビルトイン エディタ

ExeScript はプロフェッショナル用の内蔵エディタを搭載しています。エディタには下記のような最新の機能が装備されています。

  • InteliSence による オブジェクト 要素の入力候補表示
  • OutLine によりコードの論理的に関連した部分 (機能やループ等) を折り畳み表示
  • キーワード強調表示と構文強調表示
  • 前操作の取り消し/やり直し機能
  • テキストをクリップボードからコピー/貼り付け
  • ファイル内テキスト検索機能
サイレント モード

スクリプトを他のユーザから見えない状態で実行します。スクリプトは誰にも気づかれずに実行され、ユーザにはウィンドウや確認ダイアログ ボックスが見えません。このモードでスクリプトを実行するには、最初に、スクリプトを実行ファイルに変換する必要があります。 [プロパティ] ペインで [サイレント モード] を有効にします。[メイン] 画面で [サイレント モード] を選択し、値を [True] に設定します。

注意 このオプションは HTA ファイルでは利用できません。

リソース ファイル

リソースは、アイコン、画像、ファイル、フォルダ、そのほかのオブジェクト等、Windows での作業を快適にするアプリケーションの重要な部分を構成します。ExeScript では、実行アプリケーションにリソース ファイルを追加することが出来るので、これらのリソースをプログラムが使用することが出来ます。リソースのリストを表示したり、リソースを追加/削除したい場合は、[リソース表示] ペインに切り替えてください。

実行タイプ

この機能を使うとメモリから直接、アプリケーションを実行することができます。これを使用すると、スクリプトの内容を見る事が全く出来なくなるため、安全性が高められます。更に、アプリケーションの実行速度をかなり速くすることもできます。このコンパイル タイプはスクリプトへの最高の保護が必要な場合 (例えばスクリプトにパスワードが使用されている場合等) での使用をお勧めします。

スクリプト タイプ

ここでは、ウィンドウ、コンソールなどのスクリプトの種類を指定します。

作業ディレクトリ

アプリケーションが実行される場所を指定します。指定されたパスは、アプリケーションに追加のリソース ファイルが含まれる場合は、それらを解凍するためにも使用されます。

バージョン情報

バージョン情報は、開発者とアプリケーションについての情報を記入するために利用できます。

コマンド ライン

アプリケーションと共に実行されるコマンド ラインを指定することが出来ます。

パスワードで保護された起動

ExeScript では、起動をパスワードで保護したアプリケーションを作成することが出来ます。この機能を使うと、承認なしでアプリケーションを実行することができません。


ExeScript Online Help

ExeScript Main Window

オンライン ヘルプ


ExeScript Main Window