概要

  • Exe To Service とは?
  • なぜ Service なのか?
  • Exe To Service を使用して解決できる問題
  • Exe To Service の機能
  • Exe To Service の新しい機能
  • Exe To Service の購入方法
  • Exe To Service のアクティベーション方法


Exe To Service とは?

Exe To Service を使用すると、任意の Windows 実行可能ファイル (.EXE)、バッチ ファイル (.bat、 .cmd)、VBScript (.vbs) や JScript (.js) をサービスとしてインストールすることができます。 Windows サービスはバックグラウンド プロセスですのでユーザ環境に干渉しません。

Windows サービスは Service Control Manager により管理されます。ユーザがログオンする前のシステム スタートアップ時にサービスを開始したり、実行を遠隔操作で管理することができます。

Exe To Service は簡単なサービス スケジューラをインストールするので、設定した時間にサービスを開始することができます。

長期のミッション クリティカルなプログラムをサービスとしてインストールすることができます。それらをサービスに変換することにより、その実行を完全に管理することができます。ログオンしたユーザはこれらのプログラムを操作することはできません。また、現在ログオン中のユーザに付与された権限に関係なく、任意のセキュリティ コンテキストでそれらを実行することができます。

関連項目

なぜ Service なのか?
Exe To Service を使用して解決できる問題
Exe To Service の機能
Exe To Service の新しい機能

Exe To Service の購入方法
Exe To Service のアクティベーション方法


なぜ Service なのか?

サービスとは、特にロー (ハードウェアに近い) レベルの、他のソフトウェアのサポートを含む、特定のシステムの目的に使用されるプログラムまたはプロセスです。サービスがネットワーク経由でアクセスされた場合、Active Directory にパブリッシュされ、管理と使用がしやすくなります。サンプル サービスとして、Security Accounts Manager、File Replication Service、Routing および Remote Access Service があります。

下記はサービスの主要な特徴です。

  • サービスは非常に安定しています。障害が発生してサービスが停止した場合、自動的に再起動することができます。
  • サービス アプリケーションは Service Control Manager (SCM) と直接交信します。
  • システム スタートアップ時に自動的にサービスを起動します。
  • システムにユーザがログオンしていなくてもサービスを開始します。

サービスは Service Control Manager (SCM) インタフェースの規則に従ってコンパイルします。

Windows はコンピュータの基本機能を提供する多数のサービスを実行しています。これであなたもアプリケーションをサービスに変換することができます。

関連項目

Exe To Service とは?
Exe To Service を使用して解決できる問題
Exe To Service の機能
Exe To Service の新しい機能

Exe To Service の購入方法
Exe To Service のアクティベーション方法


Exe To Service を使用して解決できる問題

Exe To Service は管理者およびユーザに次のようなソリューションを提供します。

  1. (ドメイン管理者権限の場合) 全てのコンピュータ上のサービスを同時に管理できます。(サービスのインストール、停止、開始など)
  2. ユーザがシステムにログオンしているいないに係わりなく、サービスはシステム スタートアップ時に開始し、システムアカウントの元で実行されます。
  3. サービスはデスクトップでの操作を必要とせずに開始します。つまり、現在ログオン中のユーザはサービスの開始に気づきません。コンピュータのゲスト ユーザがサービスを停止することはできません。
  4. サービスは 1 箇所から管理することができます。
  5. 別のコンピュータにサービスをエクスポートして開始することができます。
  6. Exe To Service は、.EXE ファイルのほか.bat、.vbs (VBScript) および .js (JScript) をサービスに変換することができるので、自分でサービスを作成することが出来ない人にとって完璧なツールです。

関連項目

Exe To Service とは?
なぜ Service なのか?
Exe To Service の機能
Exe To Service の新しい機能

Exe To Service の購入方法
Exe To Service のアクティベーション方法


Exe To Service の機能

Exe To Service には次のような特徴があります。

  • 実行可能ファイル (exe フォーマット)、バッチ ファイル (.bat)、VBScript (.vbs) および JScript (.js) ファイルをサービスに変換します。
  • 作成、インストール、削除、起動、停止、再起動、サービスのエクスポートなどの制御をプログラム ウィンドウから行えます。
  • 新規、既存のサービスをエクスポートすることができます。例えば、.exe アプリケーションをサービスに変換してエクスポートすることができます。この機能により必要なところで (例えば別のPCなどで) どこでもサービスを起動することが可能になります。
  • デスクトップでの操作なしでサービスを起動します。このモードでは、ユーザにはサービスが見えません。
  • スケジューラによってサービスを起動できます。
  • サービス プロパティを編集できます。

関連項目

Exe To Service とは?
なせサービスなのか？
Exe To Service を使用して解決できる問題
Exe To Service の新しい機能

Exe To Service の購入方法
Exe To Service のアクティベーション方法


Exe To Service の新しい機能

バージョン 3.0

  • リモート コンピュータ上でのサービスの作成
  • サービスのネットワーク メンテナンスと管理
  • イベント ログとサービス アクティビティ ログ
  • 標準サービス管理
  • サービス プロパティの拡張
  • ドラッグ アンド ドロップのサポート
  • プログラム インタフェースの更新

バージョン 2.0

  • バッチ ファイル、VBScripts、JScripts をサービスに変換
  • 新規、既存サービスのエクスポート
  • イベント ログとサービス アクティビティ ログ
  • 標準サービス管理
  • サービス プロパティの拡張
  • ドラッグ アンド ドロップのサポート
  • プログラム インタフェースの更新

関連項目

Exe To Service とは?
なぜ Service なのか?
Exe To Service を使用して解決できる問題
Exe To Service の機能

Exe To Service の購入方法
Exe To Service のアクティベーション方法


Exe To Service の購入方法

Exe To Service のライセンスは、クレジットカードまたは銀行振り込みにてご購入いただけます。

本製品を複数の開発者でご使用になる場合は、使用人数分のライセンスをご購入いただく必要があります。複数ライセンスにはボリューム ディスカウントが適用されます。詳細についてはお問い合わせ下さい。

ライセンスには、Standalone License、Enterprise License、Developer Licenseの 3 種類があります。.

ライセンス一覧

ライセンス価格 (1 開発者あたり)
ライセンスタイプ 価格 (税込)

Exe To Service Standalone License (1 ユーザ)

  • 製品がインストールされているコンピュータ上でのみサービスの管理と作成を行うことができます。
  • サービスをエクスポートすることはできません。
  • インストールは 1 台のコンピュータに限られます。

5,243円

Exe To Service Enterprise License (1ユーザ)

  • 1 つのネットワーク内でサービスの管理と作成を行うことができます。
  • 1 つのネットワーク内でサービスのエクスポートと配布ができます。
  • インストールは 1 台のコンピュータに限られます。

26,243円

Exe To Service Developer License (1ユーザ)

  • 1 箇所内で制限なくサービスの作成ができます。
  • 1 つのネットワーク内で制限なくサービスの管理ができます。
  • エクスポートされたサービスを制限なく配布できます。
  • インストールは 1 台のコンピュータに限られます。

65,618円

登録ユーザの特典

  • 試用版の制限事項 (機能制限および時間制限) がすべてなくなります。
  • 12 ヶ月間の保守、サポートを受けられます。
  • 1 年間無料でアップグレードできます。それ以降のアップグレードでも割引が適用されます。

Check ご注文はこちらから
http://www.shareEDGE.com/

本製品ご購入に関するご質問は、こちらからお問い合わせ下さい。

関連項目

Exe To Service のアクティベーション方法


Exe To Service のアクティベーション方法

Note 注意 : Exe To Service の購入手続きが完了すると、アクティベーション キーが電子メールで送信されます。このアクティベーション キーは安全な場所に保管しておいてください。ソフトウェアを再インストールしたり、テクニカル サポートに問い合わせる際に必要になります。

Exe To Service を初めてインストールすると、試用モードで起動されます。Exe To Service には、15 日間の試用期間が設けられています。この期間を過ぎると、ソフトウェアを使用できなくなります。

試用期間後も継続してソフトウェアを使用するには、購入時に受け取ったアクティベーション キーでソフトウェアを登録する必要があります。登録処理が完了すると、試用版であることを示すメッセージも表示されなくなります。

アクティベーション キーを所有していない場合は、「Exe To Service の購入方法」の説明に従って、購入手続きを済ませてください。

Exe To Service のアクティベーションは、下記の手順をご覧下さい。

  • アクティベーション キーが記載された電子メールを開きます。
  • マウスでアクティベーション キーを選択し、ショートカット メニューの [コピー] をクリックします (または、キーボードの Ctrl+C キーを押します)。
  • [スタート] > [すべてのプログラム] > [Exe To Service] をクリックして Exe To Service を起動します。
  • [ヘルプ] メニューの [アクティベーション] をクリックします。
  • [アクティベーション キー] ダイアログ ボックスで [貼り付け] ボタンをクリックします。
  • Exe To Service を再起動してくださいというメッセージが表示されたら、[OK] をクリックして閉じます。
  • Exe To Service を一度終了し、再起動します。
  • [登録者] の欄にあなたの名前が表示されます。また、試用版での制限事項が全て解除されます。

関連項目

Exe To Service の購入方法


概観

  • インタフェース
  • メニュー
  • ツールバー
  • サービス リスト
  • サービス プロパティ
  • コンピュータ表示
  • ログ表示
  • プログラム表示のカスタマイズ


インタフェース

メイン ウィンドウにはネットワーク コンピュータのリスト、利用可能サービス、サービス プロパティ、サービス関連アクション ログの各エリア、およびメニューとツールバーがあります。[コンピュータ表示] パネルでコンピュータを選択すると、現在選択されているコンピュータ上のサービスのリストがメイン エリアに表示されます。

[コンピュータ表示] パネル、[サービス プロパティ] パネル、[ログ表示] パネルは、表示/非表示、自動的に隠す、フローティング/格納、再配置、タブ表示することができます。詳細についてはプログラム表示のカスタマイズを参照してください。

Exe To Service Main Window

アプリケーション メニューのリストはメニュー をご覧下さい。アイコンのリストはツールバーをご覧下さい。


メニュー

ファイル メニュー

  • [サービスの作成] - ローカル、リモート コンピュータ上に新しいサービスを作成します。ローカル、リモート コンピュータ上に .EXE ファイルまたはスクリプトから新規サービスを作成します。

    Note 注意 : ファイルがローカルの場合、元の場所から起動されます。リモートのファイルは、リモートシステムから WINDOWS\system32\ExeToService\servicename\ フォルダにコピーされます。

  • [サービスのエクスポート] - サービスを、 Window サービス フォーマットの別の自律ファイルとしてエクスポートします。
  • [サービス コントロール パネル] - サービス管理パネルが開きます。
  • [終了] - Exe To Service を終了します。

表示メニュー

  • [リフレッシュ] - サービス リストをリフレッシュします。
  • [ツールバー] > [標準] - ツールバーの表示/非表示を切り替えます。
  • [ツールバー] > [カスタマイズ..] - ツールバーとメニュー コマンドをカスタマイズします。
  • [コンピュータ表示バー] - コンピュータ表示バーの表示/非表示を切り替えます。
  • [サービス プロパティ バー] - サービス プロパティ バーの表示/非表示を切り替えます。
  • [ログ表示バー] - ログ表示バーの表示/非表示を切り替えます。
  • [ステータス バー] - ステータス バーの表示/非表示を切り替えます。
  • [表示スタイル] - プログラムの画面表示をカスタマイズします。カラー スキームを変更します。
  • [検索]- サービス リストからテキストを検索します。

サービス メニュー

  • [開始] - 選択したサービスを開始します。
  • [停止] - 選択したサービスを停止します。
  • [再開] - サービスを再開します。
  • [削除] - サービスをアンインストールします。
  • [プロパティ...] - 選択したサービスのプロパティを表示します。

ヘルプ メニュー

  • [コンテンツ] - Exe To Service ヘルプを開きます。
  • [今すぐ購入] - http://www.shareEDGE.com/ でライセンス購入画面を開いてください。
  • [アクティベーション] - Exe To Service ご購入後、アクティベーション キーを使って登録します。

    Note 詳細については、 Exe To Service の購入方法をご覧下さい。

  • [バージョン情報] - バージョン番号、登録情報、関連リンクなどExe To Service についての情報を表示します。

関連項目

ツールバー


ツールバー

Exe To Service のツールバーには次のようなアイコンがあります。

New - ローカルまたはリモート コンピュータ上に .EXE ファイルまたはスクリプトから新規サービスを作成します。

Note 注意 : ファイルがローカルの場合、元の場所から起動されます。リモートのファイルは、リモートシステムから WINDOWS\system32\ExeToService\servicename\ フォルダにコピーされます。

Export - サービスを、 Window Service フォーマットの独立で自律的なファイルとしてエクスポートします。

CP - [サービス コントロール] パネルを開きます。

Find - サービス リストからテキストを検索します。

Remove - サービスを削除します。

Refresh - サービス リストをリフレッシュします。

Start - 選択したサービスを開始します。

Stop - 選択したサービスを停止します。

Restart - サービスを再開します。

関連項目

メニュー


サービス リスト

サービス リストには、現在 [コンピュータ表示] パネルで選択されているコンピュータにインストールされている全てのサービスが表示されます。下記の情報が表示されます。

  • [サービス名] - サービスのショート ネーム
  • [表示名] - サービスの表示名
  • [説明] - サービスの説明
  • [ステータス] - サービスのステータス情報
  • [開始種類] - システム スタートアップ時のサービスの実行モード
  • [ログオン ユーザ] - 実行時にサブプロセスを所有する Windows ユーザ名

リストの並べ替え

各プロパティは昇順/降順に並べ替えができます。特定のプロパティで並べ替える場合は、列名をクリックします。

サービスリストは追加の要素によってサービスをグループ化したりフィルタをかけることができます。

フィールド選択

フィールド選択は列の表示/非表示を切り替えるツールです。サービス リストからこのパネルへ列をドラッグしたり戻すことができます。サービス リストに表示されている列の管理を行えます。この設定は、各コンピュータごとに固有のものです。

グループ化 ボックス

グループ化 ボックスはグループ パネルの表示/非表示を切り替えます。この設定は、全てのコンピュータに共通です。サービスをグループ化するには、グループ パネルへ必要な列をドラッグしてください。

Exe To Service フィルタ

この機能をオンにすると、Exe To Service で作成されたサービスのみが表示されます。エクスポートされたサービスは表示しません。この設定は、全てのコンピュータに共通です。[Exe To Service フィルタ] ボタンをクリックするとオンになります。オフにする場合は、再度クリックします。

リスト上の各サービスでコンテキスト メニューによるサービス管理コマンドの操作が可能です。コンテキスト メニューを表示するには、リスト上でサービスを選択して右クリックしてください。コンテキスト メニューでは次のコマンドが使用できます。

  • [開始] - 選択したサービスを開始します。
  • [停止] - 選択したサービスを停止します。
  • [再開] - サービスを再開します。
  • [削除] - サービスをアンインストールします。
  • [プロパティ...] - 選択したサービスのプロパティを表示します。

Note 注意 : サービス リストでサービスをダブルクリックするとプロパティが表示されます。

Note 注意 : 別のコンピュータのサービス リストを同時に開いて管理することができます。別のリストを開くには、[コンピュータ表示] 画面で別のコンピュータを選択します。

関連項目

コンピュータ表示
サービス プロパティ
ログ表示


サービス プロパティ

[サービス プロパティ] パネルには選択したサービスのプロパティが表示されます。プロパティは表示のみ可能ですサービスのプロパティを変更するには、[サービス プロパティ] ダイアログボックスを開きます ([サービス] > [プロパティ...] をクリックします)。

[サービス プロパティ] パネルには [プロパティ] 列と [値] 列があります。

関連項目

サービス リスト
コンピュータ表示
ログ表示


コンピュータ表示

コンピュータ表示パネルはローカル コンピュータおよびネットワーク コンピュータをリスト表示します。メイン ウィンドウでコンピュータを選択すると、そのコンピュータにインストールされているサービスの一覧が表示されます。リストから任意のコンピュータを選択して、インストールされているサービスの管理、新しいサービスのインストールを行うことができます。コンピュータがリストに表示されない場合は追加することができます。

Add - コンピュータをリストに追加します。

Remove - コンピュータをリストから削除します。

関連項目

サービス リスト
サービス プロパティ
ログ表示


ログ表示

[ログ表示] パネルにはサービスとともに実行されたアクションのリストが表示されます。全てのアクションのログは [ログ表示] パネルに、時間、コンピュータ名、イベント、ステータスのフォーマットで保存されます。

関連項目

サービス リスト
コンピュータ表示
サービス プロパティ


プログラム表示のカスタマイズ

Exe To Service のインタフェースは、モニタリングの結果を表示するメイン パネルと数種類のカスタマイズ可能なパネルにより構成されており、これらは、表示/非表示、固定/非固定、別の場所に配置することができます。

  • パネルの表示/ 非表示は、[表示] メニューを選択して、対応するメニューを選択/解除します。
  • パネルを画面上に固定/非固定するには、ピン ボタンを使用してください。 - ウィンドウが固定されます。 - ウィンドウが隠れます。
  • 固定されているパネルは、別の場所に移動することが出来ます。シフト キーを押しながらマウスでパネルを新しい場所にドラッグします。パネルを別のパネルと結合させる場合は、 [image] (上下左右の矢印) を使用してください。

関連項目

インタフェース


操作方法

  • EXE ファイルからのサービスの作成方法
  • スクリプト ファイルからのサービスの作成方法
  • スクリプトから EXE ファイルへの変換
  • サービスの制御方法
  • スケジュールの設定方法
  • リモート コンピュータ上のサービスの管理方法
  • サービスのエクスポート方法
  • サービスのインストール方法


EXE ファイルからのサービスの作成方法

Exe To Service は実行可能ファイル (EXE フォーマット) から Windows サービスを作成することが出来ます。サービスは Service Control Manager (SCM) の規則に従って作成されます。

まず、メニューから [ファイル] > [サービスの作成] を選択、または、ツールバーの [image] (サービスの作成) をクリックします。

サービスを作成する場合は、[サービスの作成] ウィンドウの各タブのフィールドに記入してください。

  1. 最初に [メイン] タブのフィールドを記入します。実行可能ファイルを選択し、サービス名と表示名を指定します。[説明] フィールドへの記入もお勧めします。

    [ソース] - このフィールドで実行可能ファイルへのパスを指定します。
    [サービス名] - サービス名を指定します。
    [表示名] - サービス コントロール パネルに表示される名称を指定します。
    [説明] - 何をするサービスかなどのサービスの説明を記入します。

    全てのフィールドを入力したら、[次へ] ボタンをクリックします。

  2. [ログオン] タブで、サービスの実行タイプとサービスを実行するアカウントを指定します。

    [開始種類] - サービスの実行モードを指定します。

    • [手動] - サービスを手動で実行します。
    • [自動] - システムの起動時に自動的にサービスを実行します。
    • [無効] - サービスを実行しません。

    [エラー制御] - サービス実行時のエラーをモニタできます。

    [システム アカウント] - システム アカウントでサービスを実行したい場合に選択します。

    [デスクトップで操作] - サービスがデスクトップで操作できるようにしたい場合に選択します。

    [指定アカウント] - 他のアカウントを指定する場合に選択します。アカウント名を指定するか、[参照] ボタンをクリックしてアカウントを選択します。

    [パスワード] - 指定したアカウントのパスワード

    全てのフィールドを入力したら、[次へ] ボタンをクリックします。

  3. [スケジュール] タブで、サービスの実行時間と再開するまでの間隔を指定します。

    [開始時のみ] - サービスを再開する必要がない場合に選択します。

    [指定時間後に再開] - 指定された時間の後、サービスを再開する場合に選択します。また、サービスが再開されるまでの間隔を指定してください。

    [週間スケジュールを使用] - スケジュールに従ってサービスを開始したい場合に選択します。曜日か毎日かを選択し、開始時間を指定して [追加 →] をクリックします。サービスの開始には複数の値を設定できます。

    全てのフィールドを入力したら、[次へ] ボタンをクリックします。

  4. [リカバリ] タブでは、サービスに障害が発生した場合のリカバリ アクションを指定します。 最初の障害、2 回目の障害、その後の障害に対するアクションをクリックします。

    全てのフィールドを入力したら、[次へ] ボタンをクリックします。

  5. [依存関係] タブで他のサービスやグループからの依存関係を指定します。

  6. [OK] ボタンをクリックします。新しいサービスが作成されたメッセージが表示されます。

    Note Exe To Service のメイン ウィンドウのリストに新しいサービスが追加されたことを確認してください。リストからサービスを選択し、メニューの [サービス] > [プロパティ] を選択すると、いつでもサービス プロパティを変更できます。

関連項目

スクリプト ファイルからのサービスの作成方法
スクリプトから EXE ファイルへの変換
サービスの制御方法
スケジュールの設定方法
サービスのエクスポート方法
サービスのインストール方法


スクリプト ファイルからのサービスの作成方法

Exe To Service では、任意のバッチ ファイル (.bat)、Visual Basic のスクリプト (.vbs)、JScripts (.js) から Windows のサービスを作成できます。サービスは Service Control Manager (SCM) の規則に従って作成されます。

スクリプト ファイルからサービスを作成する方法は実行可能ファイルの場合と同様です。

サービス作成時には、下記の点にご注意下さい。

  • バッチ ファイルには全てのアプリケーション パラメータが必要です。
  • ロング パスは全てダブル コーテーション マーク ( "" ) で囲んでください。

注意: スクリプトをより機動的に (コンソール、ウィンドウ、不可視化、暗号化等） 実行するためには、スクリプトを最初に実行可能 (.EXE) ファイルに変換することをお勧めします。Everstrike の ExeScript を使用すると、スクリプトを暗号化して内容が表示されたり変更されることを防ぎます。

関連項目

EXE ファイルからのサービスの作成方法
EXE ファイルからサービスへの変換方法
サービスの制御方法
スケジュールの設定方法
サービスのエクスポート方法
サービスのインストール方法


EXE ファイルからサービスへの変換方法

Exe To Service を使用すると .EXE ファイルやスクリプトをサービスに変換することが出ます。作成されたサービスは自律的に動作します。作成されたサービスは他のコンピュータに転送してインストールすることが出来ます。

  1. 現在はサービスではない実行可能ファイル、バッチファイルやスクリプトを変換するには、[ファイル] > [サービスの作成] をクリックします。
  2. ソースを指定して、[サービス名] と [表示名] フィールドに入力します。([説明] フィールドへの入力をお勧めします。)
  3. [ログオン]、[スケジュール]、[リカバリ]、[依存関係] タブに入力します。
  4. [OK] ボタンをクリックします。

エクスポート結果が表示されます。作成されたサービスは、.EXE ファイルやスクリプトが置かれているフォルダに保存されます。

注意 作成されたサービスは、.EXE ファイルやスクリプトが置かれているフォルダに保存されます1 つのサービスの管理のために 4 つのバッチファイルが作成されます。

任意の　bat、cmd、vbs、js、wsh、wsf スクリプトをサービスに変換することができます。Vbs と js はデフォルトでコンソール スクリプトとして起動されます (cscript.exe を使用) 。スクリプトのウィンドウ バージョンを起動するには、サービス作成時にスクリプト名の反対側の [ソース] フィールドに "wscript" コマンドを追加してください。

関連項目

EXE ファイルからのサービスの作成方法
スクリプト ファイルからのサービスの作成方法
サービスの制御方法
スケジュールの設定方法
サービスのエクスポート方法
サービスのインストール方法


サービスの制御方法

下記はサービスの作成、開始、停止、再開、削除/アンインストール、およびエクスポートの方法です。

作成

サービスを作成するには、メニューから [ファイル] > [サービスの作成] を選択、または、ツールバーの [サービスの作成] ボタン [image] をクリックします。

開始

サービスを開始するには、リストからサービスを選択し、メニューの [サービス] > [開始] を選択、または、　ツールバーの [サービス開始] ボタンをクリックします。また、コンテキスト メニューでサービスを選択して開始することもできます。リストを右クリックして [開始] をクリックします。選択されたサービスが開始し、実行結果が表示されます。

停止

1 つまたは複数のサービスを停止するには、リストからサービスを選択し、メニューの [サービス] > [停止] を選択、または、　ツールバーの [サービス停止] ボタンをクリックします。このコマンドはサービス リストのコンテキスト メニューからも操作できます。

再開

選択したサービスを再開するには、メニューから [サービス] > [再開] を選択、または、ツールバーの [サービス再開] ボタンをクリックするか、コンテキスト メニューで [再開] を選択します。

削除/アンインストール

サービスを削除するには、リストからサービスを選択し、メニューの [サービス] > [削除] を選択、または、　ツールバーの [サービスの削除] ボタンをクリックします。選択されたサービスをシステムから削除しても良いかを確認するメッセージが表示されます。

エクスポート

エクスポート オプションは、Exe To Service で作成したサービスを Windows サービス フォーマットの別の自律ファイルに変換できます。1 つのサービスのインストール、削除、開始、停止のために 4 つのバッチファイルが作成されます。サービスをエクスポートするには、メニューから [ファイル] > [サービスのエクスポート...] を選択します。

関連項目

EXE ファイルからのサービスの作成方法
スクリプト ファイルからのサービスの作成方法
スクリプトから EXE ファイルへの変換
スケジュールの設定方法
サービスのエクスポート方法
サービスのインストール方法


スケジュールの設定方法

Exe To Service ではサービスの開始をスケジュール化することができます。サービスは指定された時間まで開始されません。サービスを再開するまでの間隔を設定することもできます。

開始時間はサービスの作成時、または既に作成したサービスのプロパティで設定することができます。

サービス作成時のスケジュール設定

[スケジュール] タブで、サービスの開始時間と再開するまでの間隔を指定します。

  • [開始時のみ] - サービスを再開する必要がない場合、このオプションを選択します。
  • [指定時間後に再開] - 指定された期間の後、サービスを再開する場合、このオプションを選択します。また、サービスが再開されるまでの間隔を指定してください。

    • 注意 時間は秒で指定してください。間隔は、その前の .EXE ファイルまたはスクリプトが停止した時間から計算されます。例えば、1 度目のプログラムが開始、終了した後、設定した時間が経過すると 2 度目が開始します。

  • [週間スケジュールを使用] - スケジュールに従ってサービスを開始したい場合に選択します。曜日か毎日かを選択し、開始時間を指定して [追加 →] をクリックします。サービスの開始には複数の値を設定できます。

以前に作成したサービスのスケジュール設定

  • リストからサービスを選択し、メニューの [サービス] > [プロパティ] をクリックします。
  • [スケジュール] タブをクリックします。
  • サービスが開始する時間を指定してください。

関連項目

EXE ファイルからのサービスの作成方法
スクリプト ファイルからのサービスの作成方法
EXE ファイルからサービスへの変換方法
サービスの制御方法
サービスのエクスポート方法
サービスのインストール方法


リモート コンピュータ上のサービスの管理方法

リモート コンピュータ上のサービスの管理を行う場合はシステムの管理者権限が必要です。ドメイン管理者権限では、ドメイン内の全てのコンピュータ上のサービスを管理することができます。

遠隔操作でサービスの管理をする場合は、[コンピュータ表示] パネルでコンピュータを選択します。インストールされているサービスがメイン ウィンドウのリストに表示されます。これらのサービスに対し、全ての可能な操作を実行できます。

リモート コンピュータの管理者パスワードを持っているにもかかわらず、このコンピュータ上のサービスを Exe To Service で管理できない場合、次の操作を試してください。

  • Windows Explorer で [ツール] > [ネットワーク ドライブの割り当て] をクリックし、必要なコンピュータ上のフォルダを選択します。
  • [異なるユーザ名で接続] リンクをクリックします。
  • リモート コンピュータの管理者ログイン名とパスワードを入力します。
  • Exe To Service を開き、リモート コンピュータを選択します。

関連項目

サービスのエクスポート方法


サービスのエクスポート方法

Exe To Service は既存、新規のサービスをエクスポートして別のコンピュータ上で起動したり、アプリケーションをサービスとして配布することを可能にします。

既存サービスのエクスポート

エクスポートしたいサービスがリスト上にある場合のエクスポート方法を説明します。リストからサービスを選択し、[ファイル] > [サービスのエクスポート...] をクリック、または、リストのコンテキスト メニュー(サービスを選択して右クリックします) から [エクスポート] コマンドをクリックします。サービスの保存場所を指定してください、というメッセージが表示されます。ハード ディスク上の保存場所を指定してください。エクスポート結果が表示されます。

1 つのサービスのインストール、削除、起動、停止のために 4 つのバッチファイルが作成されます。

サービスの作成に使用された、最初の .EXE ファイルやスクリプトはエクスポートされたサービスと統合されます。エクスポートされたサービスのインストール中、統合された .EXE ファイルやスクリプトは、フォルダ内に同名のファイルがなければ、エクスポートされたサービスが置かれているフォルダに抽出されます。そのため、.EXE やスクリプトが dll や画像など他のファイルを必要とする場合は、サービスのフォルダに入れてください。また、このフォルダに最新バージョンの .EXE ファイルやスクリプトを入れることもできます。

新しいサービスのエクスポート

現在はサービスではない実行可能ファイル、バッチファイルやスクリプトをエクスポートするには、メニューから [ファイル] > [サービスに変換...] をクリックします。新規サービス作成ダイアログ ボックスが開きます。アプリケーションの場所、サービス名、スタートアップ プロパティなどの必要な情報を記入してください。作成されたサービスは、.EXE ファイルやスクリプトが置かれているフォルダに保存されます。エクスポート結果が表示されます。

関連項目

EXE ファイルからのサービスの作成方法
スクリプト ファイルからのサービスの作成方法
EXE ファイルからサービスへの変換方法
サービスの制御方法
スケジュールの設定方法
サービスのインストール方法


サービスのインストール方法

インストール機能を使用すると既存の Windows サービスをローカル コンピュータやリモート コンピュータにインストールすることができます。

以前に作成したサービスをインストールする場合は、メニューの [ファイル] > [サービスのインストール] をクリックします。[サービスのインストール] ダイアログ ボックスが表示されます。サービスへのパスを指定して、[メイン]、[ログ オン]、[リカバリ] および [依存関係] タブの各フィールドに記入してください。

サービスをインストールするには、[サービスのインストール] ウィンドウのタブを記入してください。

メイン

[実行可能ファイルへのパス] - 既存のサービスへのパス

[サービス名] - サービス名これは、Windows がサービスを識別する固有の名前です。この名前には句読点は使用できません。

[表示名] - サービス コントロール パネルに表示される名前

[説明] - サービスの説明(記入を推奨しますが、必須ではありません。)

全てのフィールドを入力したら、[次へ] ボタンをクリックします。

ログ オン

[開始種類] - サービス作成時とコンピュータが起動されたときのサービスの起動方法を指定します。[手動]、[自動]、[無効] 起動モードが使用できます。

[エラー制御] - サービス実行時のエラーをモニタできます。

注意 エラーはイベント ログに記録され、[コントロール パネル] > [管理ツール] > [イベント ビューア] > [システム] で確認できます。

[システム アカウント] - システム アカウントでサービスを実行したい場合に選択します。

[デスクトップで操作] - サービスがデスクトップで操作できるようにしたい場合に選択します。

[指定アカウント] - 他のアカウントを指定する場合に選択します。アカウント名を指定するか、[参照] ボタンをクリックしてアカウントを選択します。

[パスワード] - 指定したアカウントのパスワード

全てのフィールドを入力したら、[次へ] ボタンをクリックします。

リカバリ

[リカバリ] タブでは、サービスに障害が発生した場合のリカバリ アクションを指定することができます。最初の障害、2 回目の障害、その後の障害に対するアクションを選択します。

全てのフィールドを入力したら、[次へ] ボタンをクリックします。

依存関係

他のサービスやグループからの依存関係を指定することができます。

[オーダ グループ読み込み] - システム内のグループのリスト。サービスが所属するグループを選択できます。サービスの起動時には、選択されたグループと共に起動されます。

[依存関係] - サービスの開始が依存するサービスまたはグループのリスト。サービスは、依存関係で指定したサービスまたはグループの後にロードされます。

[サービス] - インストールされたサービスのリスト

[サービス グループ] - サービス グループのリスト

全てのタブのフィールドを入力したら、[OK] をクリックしてサービスをインストールします。

関連項目

EXE ファイルからのサービスの作成方法
スクリプト ファイルからのサービスの作成方法
EXE ファイルからサービスへの変換方法
サービスの制御方法
スケジュールの設定方法
サービスのエクスポート方法


サービス プロパティ

  • メイン
  • ログオン
  • スケジュール
  • リカバリ
  • 依存関係


メイン

このタブで主要なサービス プロパティの設定を行います。

[ソース] - 実行可能ファイル、bat、cmd、vbs、js、wsh、または wsf スクリプトなどサービスのソースサービスとして実行されるファイルのフル パスとファイル名を指定します。[参照] をクリックしてサービスのソースを変更することができます。

[サービス名] - サービス名。これは、Windows がサービスを識別する固有の名前です。この名前には句読点は使用できません。

[表示名] - サービス コントロール パネルに表示される名前。

[説明] - サービスの説明。(記入を推奨しますが、必須ではありません。)

セキュリティ

各サービスにアクセス権限を設定することができます。アクセス権限はユーザまたはグループごとに付与/否認できます。

アクセス権限の管理を行うには、[セキュリティ] ボタンをクリックします。必要なユーザまたはグループをリストから選択し、アクセス権限の設定を行います。

[適用] をクリックすると変更が保存されます。[OK] をクリックすると変更を保存してウィンドウを閉じます。変更を保存したくない場合は [キャンセル] をクリックします。

関連項目

ログオン
スケジュール
リカバリ
依存関係


ログオン

[ログオン] タブではサービスの開始パラメータの設定を行います。ここでは、システム アカウントかその他のアカウントか、など、サービスがどのアカウントで開始されるのかを設定することができます。

[開始種類] - サービス作成時とコンピュータのスタートアップ時にどのようにサービスが開始するかを指定します。[手動]、[自動]、[無効] のモードが使用できます。

[エラー制御] - サービス開始時のエラーをモニタできます。下記の値を設定できます。

  • [クリティカル]
    可能であれば、サービスはイベント ログにエラーのログを保存します。前回正常起動時の構成が実行されると、開始オペレーションは失敗します。システムは前回正常起動時の構成を使用して再起動されます。
  • [無視]
    サービスはエラーを無視して開始オペレーションを続けます。
  • [通常]
    サービスはエラーのログをイベント ログに保存しますが、開始オペレーションは継続されます。
  • [深刻]
    サービスはイベント ログにエラーのログを保存します。前回正常起動時の構成が起動された場合、開始オペレーションは継続されます。システムは前回正常起動時の構成を使用して再起動されます。

エラーはイベント ログに記録され、[コントロール パネル] > [管理ツール] > [イベント ビューア] > [システム] で確認できます。

[システム アカウント] - システム アカウントでサービスを実行したい場合に選択します。

[デスクトップで操作] - サービスがデスクトップで操作できるようにしたい場合に選択します。

[指定アカウント] - 他のアカウントを指定する場合に選択します。アカウント名を指定するか、[参照] ボタンをクリックしてアカウントを選択します。

[パスワード] - 指定したアカウントのパスワード

関連項目

メイン
スケジュール
リカバリ
依存関係


スケジュール

プロパティでスケジュールを表示するためにはサービスが Exe to Service で作成されている必要があります。

[スケジュール] タブではサービスの開始時間のほか、そのサービスを再開するまでの間隔を設定することができます。

[開始時のみ] - サービスを再開する必要がない場合に選択します。

[指定時間後に再開] - 指定された時間の後、サービスを再開する場合に選択します。サービスが再開されるまでの間隔を指定してください。

注意 時間は秒で指定してください。間隔は、その前の .EXE ファイルまたはスクリプトが停止した時間から計算されます。例えば、1 度目のプログラムが開始、終了した後、設定した時間が経過すると 2 度目が開始します。

[週間スケジュールを使用] - スケジュールに従ってサービスを開始したい場合に選択します。曜日か毎日かを選択し、開始時間を指定して [追加] をクリックします。サービスの開始には複数の値を設定できます。

関連項目

メイン
ログオン
リカバリ
依存関係


リカバリ

[リカバリ] タブでは、サービスに障害が発生した場合のリカバリ アクションを指定することができます。

最初の障害、2 回目の障害、その後の障害に対するアクションを選択します。

[指定日数後に障害カウンタをリセット] - カウンタがリセットされるまでにサービスが実行される日数。カウンタがリセット後、次の障害が起こると、最初の回復措置に対して設定したリカバリ アクションが開始します。

[指定時間後にサービスを再開] - 再開するまでの期間 (分)このパラメータは、障害に対して [サービスの再開] が選択されている場合に利用可能です。

[プログラム] - 障害が検出された場合に実行されるプログラムまたはスクリプト。このパラメータは、障害に対して、[プログラムの実行] が選択されている場合に利用可能です。[参照] ボタンをクリックするとプログラムやスクリプトを参照することができます。

Note 注意 : [プログラムの実行] を選択する場合は、ユーザ インプットを必要とするプログラムやスクリプトを指定しないで下さい。

[コマンド ライン パラメータ] - 実行時にプログラムに渡されるコマンド ライン パラメータ

[コマンドラインの最後に障害カウンタを追加 (/fail=%1%) ] - 最新のパラメータとしてサービス エラー カウンタを使用していることを示します。

[コンピュータを再起動オプション] - リカバリ アクションとしてのコンピュータの再起動オプション

関連項目

メイン
ログオン
スケジュール
依存関係


依存関係

他のサービスやグループからの依存関係を指定することができます。

[オーダ グループ読込み] - システム内のグループのリスト。サービスが所属するグループを選択できます。サービスの開始時には、選択されたグループと共に開始されます。

[依存関係] - サービスの開始が依存するサービスまたはグループのリスト。サービスは、依存関係で指定したサービスまたはグループの後にロードされます。

[サービス] - インストールされたサービスのリスト

[サービス グループ] - サービス グループのリスト

依存関係の使用方法

2 個の .EXE ファイルがあり、片方のサービスが他方より先に起動される場合を想定します。

  1. 各 .EXE ファイルのサービスを作成します。
  2. 2 番目のサービスをリスト内で選択してプロパティを開きます。
  3. [依存関係] タブを開きます。
  4. このページで最初のサービスからの依存関係を設定します。[依存関係] リストに最初のサービス名を入力します。[サービス] リストで最初のサービスを選択して、[追加] をクリックします。

この設定により、最初のサービスを先に起動することが保証されます。

例えば、サービスをファイル システム グループと共にロードしたい場合、

  1. [メイン ウィンドウ] のリストでサービスを選択してプロパティを開きます。
  2. [依存関係] タブを開きます。
  3. [オーダ グループ] フィールドでファイル システム グループを選択します。
  4. [OK] をクリックすると新しいプロパティが設定されます。

関連項目

メイン
ログオン
スケジュール
リカバリ


評価版と製品版の違い

試用版と製品版の違い

Exe To Service は、試してから購入 (Try Before You Buy) することができるシェアウェアです。特定の試用期間内であれば無料で利用することができますが、その期間を過ぎると、購入するか、利用を停止する必要があります。そのため、あらかじめ設けられた試用期間内で、ソフトウェアが自分の用途に適しているかどうか見極めることが重要です。なお、Exe To Service には、15 日間の試用期間が設けられています。

Exe To Service では、試用版でも製品版とまったく同じ機能を使用できます。そのため、お客様はソフトウェアの必要性を適切に判断することができます。

ただし、試用版の場合、起動時に試用版であることを示す通知ウィンドウが表示される、メイン ウィンドウのタイトル バーに試用モードで実行していることを示すメッセージが表示される、終了時にフィードバックの送信を求めるウィンドウが表示される、などの制限事項があります。

ご購入後は、上記の制限事項が解除され、テクニカル サポートを受けることが出来ます。


Exe To Service 使用許諾契約書

Exe To Service をご利用になる前に、本使用許諾契約書をよくお読みください。

  1. 本使用許諾契約書 (以下、「本契約」) は、エンドユーザ (以下、「お客様」) とソフトウェアの開発元 (以下、「作者」) との間で交わされる法的契約です。本ソフトウェア (Exe To Service) をご使用になるか、お客様のコンピュータ (またはその他メディア) に保存することで、本契約のすべての条項に同意したものと見なされます。
  2. Exe To Service は "現状のまま" で配布されています。明示的にも黙示的にもいかなる種類の保証も行っておりません。お客様ご自身の責任下において本ソフトウェアをご使用ください。Everstrike Software は、本ソフトウェアの使用または使用結果に関して、正確性および信用性に対するいかなる保証も放棄するものとします。Everstrike Software は、本ソフトウェアの使用方法が正しいか否かに関わらず、また Everstrike Software によって損害の可能性が示唆されていた場合であっても、利益の損失、ビジネスの中断、および情報の喪失に限らず、いかなる偶発的、必然的、直接的、間接的損害に対する責任も負いません。本ソフトウェアをインストールすることで、お客様は本免責事項をお読みになり、理解し、すべての条項に同意したものと見なされます。また、本免責事項は当事者間における完全に排他的な了解事項であり、免責事項に関する過去の書面・口頭 (またはその他連絡方法) による提案または同意書に優先します。
  3. 本ソフトウェアに関するすべての著作権は作者である Everstrike Software が有します。
  4. お客様は 15 日間に限り本ソフトウェアの試用版を試用することが出来ます。この期間中、お客様はご自分のシステム上で本ソフトウェアを試用することが出来ます。15 日間の評価期間が過ぎると、試用版のサービスは停止になり、継続して使用する場合はライセンスを購入する必要があります。オンライン サービス、掲示板、またはその他の方法で本ソフトウェアを自由に配布できるのは試用版に限られます。
  5. Everstrike Software は、本ソフトウェアを購入されたお客様に対して、本ソフトウェアを 1 台のコンピュータで使用するための権利と、保管用として 1 部のコピーを作成するための権利を許諾します。ここでいう使用とは、ソフトウェアを RAM にロードしたり、ハード ディスクなどの記憶装置にインストールすることを意味します。お客様が本契約に同意している限りは、本ソフトウェアを継続して使用することができます。ただし、ネットワーク サーバにインストールする場合、または 1 度に複数のユーザで使用する場合は、事前にマルチユーザ ライセンスの手配が必要になります。すなわち、保管用としてバックアップ コピーを 1 部作成することが認められている以外、複製、販売、譲渡、贈呈など商用目的でのソフトウェアの利用や、サブライセンス、貸与などは一切認められていません。Everstrike Software に対して書面による文書を提出した場合にのみ、他者への譲渡が認められる場合があります。
  6. 本ソフトウェアおよび付属資料は、本契約において許諾されていない限り、いかなる手段においても、模倣、複製、貸与、リース、販売、譲渡、仕様変更、逆コンパイル、逆アセンブリ、リバース エンジニアリング、メッセージやウィンドウの変更や削除を行うことは禁止されています。不正使用を発見した場合は、ライセンスが自動的に即時終了するものとし、厳しい刑事上、民事上の訴追に帰着することがあります。
  7. Everstrike Software の事前の承諾なしに、いかなる形態においても Exe To Service を、支払またはライセンス使用料を受取るために使用される、商業的に配布される製品の一部に含めることは出来ません。Exe To Service の 1 ライセンスに付き一人の開発者に、スクリプトの作成、編集、変換、および保護された EXE アプリケーションの作成が許諾されます。この条件は Exe To Service を遠隔で使用する場合にも該当します。Exe To Service のライセンスには 3 種類あります。
    • Standalone License製品がインストールされているコンピュータ上でのみサービスの管理と作成を行うことができます。サービスをエクスポートすることはできません。インストールは 1 台のコンピュータに限られます。
    • Enterprise License 1 つのネットワーク内でサービスの管理と作成を行うことができます。1 つのネットワーク内でサービスのエクスポートと配布ができます。インストールは 1 台のコンピュータに限られます。
    • Developer License1 箇所内で制限なくサービスの作成ができます。1 つのネットワーク内で制限なくサービスの管理ができます。エクスポートされたサービスを制限なく配布できます。インストールは 1 台のコンピュータに限られます。
  8. アップグレードにより前のバージョンは置き換えられます。この場合追加のライセンスは提供されません。その際は、前のバージョンの使用を取り止め、他の誰も使用していないことを確認してください。
  9. 本契約に明示されていないすべての権利は作者に留保されます。
  10. 本契約の内容、および本ソフトウェアのインターフェイス デザイン、ドキュメント、コーディングは、将来のリリースにおいて予告なしに変更される場合があります。
  11. 本ソフトウェアをインストールし、使用するには、本契約のすべての条項に同意する必要があります。同意されない場合は、本ソフトウェアをただちに破棄し、使用を中止してください。

関連項目

評価版と製品版の違い


Exe To Service のインストール方法

インストール ウィザードの手順に従ってください。再起動の必要はありませんので、システムへのインストール直後からプログラムは使用可能です。

Note 注意　Exe To Service で作成した実行ファイルのパッケージは、Windows システム上でのみ実行されます。


Exe To Service のアンインストール方法

Exe To Service はシステムからプログラムを削除するための自動アンインストーラを備えています。

Exe To Service のアンインストールは下記の手順に従ってください。

  1. Exe To Service を閉じます。
  2. Windows の [スタート] ボタンをクリックします。
  3. [設定] メニューを開きます。
  4. [コントロール パネル] を開きます。
  5. Exe To Service を完全にアンインストールするためには、コントロール パネルの Windows プログラムの追加と削除ツールをご使用下さい。
  6. 'Exe To Service' を選択して、[削除] ボタンをクリックします。
  7. アンインストーラから出される指示に従ってください。


お問い合わせ

Check 一般的なご質問、販売について
ご質問、ご意見、ご感想、バグのご報告は弊社 Web サイト http://www.shareEDGE.com/cs/ のお問い合わせフォームをご利用くださいますようお願いいたします。


著作権

Copyright © 2007 Everstrike Software. All rights reserved.

本ドキュメントは、Exe To Service ソフトウェアと併せて使用することだけを目的として、Everstrike Software によって発行されています。本ドキュメントの印刷版および電子版は、すべてのライセンス所有者が利用できます。Everstrike Software の書面による事前の許可なしに、本ドキュメントの一部またはすべてを複写、複製、再製造、または翻訳すること、電子的または機械的に読み取り可能な形式に変換すること、および Web サイトに掲載することは禁じられています。

商標

Exe To Service 及び Everstrike Software は Everstrike Software の商標です。Microsoft、Windows、Windows NT、Word、および Excel は Microsoft Corporation の登録商標です。Adobe、Acrobat、および Acrobat Reader は Adobe Systems Incorporated の登録商標です。その他の会社名、製品名は、各社の商標または登録商標です。


.topic 0
Create a new service

.topic 0
Export service; exe embedded into service

.topic 0
Export is not available in Standalone License

.topic 0
Start service

.topic 0
Stop service

.topic 0
Restart service

.topic 0
Allows you to add or remove toolbar buttons.

.topic 0
Opens the selected object in a separate Explorer window.

.topic 0
Checks for the new versions of the program.

.topic 0
Quit the application

.topic 0
Delete the current item from the list

.topic 0
Search through the list

.topic 0
Edit the properties of the current item in the list

.topic 0
Select the language of the program interface

.topic 0
Help topics

.topic 0
Context help

.topic 0
Buy now

.topic 0
Register product

.topic 0
About the program

.topic 0
The status bar displays the current status of Exe To Service.

.topic 0
List of services.


Exe To Service メイン ウィンドウ

Exe To Service Main Window