Flash Video MX Proバッチ エンコーダの使用

Flash Video MX Proの中にある直接変換機能は Macromedia Flash Video (FLV) および SWF フォーマットのビデオをエンコードできるエンコード アプリケーションです。FLV フォーマットを使用すれば、ビデオをほとんど誰でも Flash プレイヤを使用して表示できる形式で簡単に Web ページや Flash ドキュメントに埋め込むことができます。Flash プレイヤの汎用性のおかげで、Web サイトを訪れるほとんどのユーザが追加のプラグインをダウンロードすることなく Flash ビデオを見ることができるため、安価な開発、検証およびサポート費用で非常に多くのインターネット ユーザに Flash ビデオを提供できます。

この章では、次の項目について説明しています。

Flash ビデオでサポートされるビデオ圧縮コーデック

コーデックについて

On2 VP6 VFW コーデックのインストール方法について

On2 VP6、Sorenson H.263 コーデック、および On2 VP6 with Alpha の比較

ビデオの規格と用語について

フレーム レート

キーフレーム

データ転送速度

アスペクト比

非正方画素のビデオのエンコーディングについて

Flash Video MX Proバッチ エンコーダによるビデオのエンコード

エンコード キューの編集

ファイルのスキップ

オーディオのみのファイルのエンコードについて

Flash ビデオ エンコード設定

ビデオ エンコードの詳細設定の選択

出力ファイル設定の指定

ビデオ エンコードの詳細設定の指定

オーディオ エンコードの詳細設定の指定

ビデオ ロゴおよびキャプションの指定

ビデオ エフェクトおよびコントロール バー設定の指定

キュー ポイント

FLV キュー ポイントの操作

SWF キュー ポイントについて

Moyea FLV API

thePlayer オブジェクトのメソッドの概要

thePlayer オブジェクトのイベントの概要

プログラミング インタフェースの使い方

Moyea FLV プレイヤの使い方

サポートに関してよくある質問

-----------------------------------------------------------------------------------------------------------------------------


Flash ビデオでサポートされるビデオ圧縮コーデック

デフォルトでは、Flash Video MX Proは、Flash Player 7 で使用するために Sorenson H.263 コーデックを使用してビデオをエンコードします。Flash が低帯域幅要件で高品質ビデオを実現する方法を理解するには、ビデオの圧縮について理解する必要があります。

デジタル メディアに適用できる圧縮には、空間圧縮と時間圧縮の 2 種類があります。空間圧縮は、周囲のフレームから独立したシングル フレームのデータに適用されます。空間圧縮は、ロスレス (画像からデータが破棄される) または不可逆 (データが選択して破棄される) にすることができます。空間圧縮されたフレームは、フレーム内圧縮と呼ばれることがよくあります。

時間圧縮は、フレームとストアの差異を識別するため、フレームは前のフレームからの差異に基づいて記述されます。変更されていないエリアは、前のフレームから単純にリピートされます。時間圧縮されたフレームは、フレーム間圧縮と呼ばれることがよくあります。

On2 VP6 と Sorenson H.263 はどちらもフレーム間圧縮のコーデックです。他の多くのコーデックはフレーム内圧縮を使用しますが (たとえば、JPEG はフレーム内コーデックです)、On2 VP6 および Sorenson H.263 コーデックの効率的なフレーム間圧縮は、他の機能の中でも特に、高品質ビデオを作成するために必要なデータ転送速度 (ビット レートとも呼ばれる) が遥かに低いため、他の圧縮技術から抜きん出ています。

フレーム間圧縮もフレーム内圧縮を使用します。フレーム内圧縮は、フレーム間圧縮の参照フレーム (キーフレーム) として使用されます。On2 VP6 コーデックと Sorenson H.263 コーデックはどちらも常にキーフレームで始まります。各キーフレームは、次のフレーム間圧縮のメイン参照フレームとなります。次のフレームが前のフレームと大きく変わらない限り、このコーデックは新しいキーフレームを圧縮します。

Flash Video MX Proでは、Sorenson H.263、On2 VP6 、On2 VP6 with Alpha 、および On2 VP6 with alpha をコーデックとしてサポートしています。

コーデック設定の詳細については、コーデックについて を参照してください。


コーデックについて

On2 VP6 VFW コーデックのインストール方法について、およびOn2 VP6、Sorenson H.263、および On2 VP6 with Alpha の比較を含むこの章は、Flash Video MX Pro、Flash Video MX、DVD to Flash Video Converter に適用します。

Flash Video MX Pro で利用できるビデオ コーデックは Sorenson H.263、On2 VP6、および On2 VP6 with Alpha の 3 種類です。必要に応じて選択してください。

Flash Video MX Pro のみが On2 VP6 with alpha をサポートしています。Flash Video MX と DVD to Flash Video Converterはサポートしていないので注意してください。


On2 VP6 VFW コーデックのインストール方法について

On2 VP6 コーデックを使用するには、まず On2 VP6 VFW コーデックをインストールする必要があります。もしくは、適切なコーデックをダウンロードして、入力ファイルを問題なくロードできるようにすることを求めるポップアップ ウィンドウが表示されるので、インターネットで検索してダウンロードしてください。

google.com を利用して、VP6 vfw codec 6.2 などで検索してみてください。
バージョン 6.2.x.x、6.4.2.x ともに問題なく動作します。

エンコーダをダウンロードすることを忘れないようにしてください。
たとえば、以下のコーデックはエンコーダが含まれていないため使用できません。
http://www.free-codecs.com/download/VP6.htm

ダウンロード元:

http://www.ogg.cn/software/view-software-309.html(version 6.4.2.0)
http://www.ogg.cn/software/view-software-56.html(version 6.2.6.0)
このウェブサイトは中国語表記です。ダウンロード リンクは以下の通りです。

Cole2 Media Codec Pack
http://www.cole2k.net/?display=Codec-Pack-Advanced(version 6.4.2.0)
すべてのコーデックをインストールする必要はありません。 On2 VP6 VFW コーデックのみのインストール方法については以下の通りです。

- Expert Installation を選択します

- Cole2k Media Toolbar (必須ではありません) の選択を解除します

- DVD/SVCD & DVD Filters の [Select None] を選択し、HDTV/DVD TV Card Filters のチェックボックスをオフにします。

- Video Codec's & Filters のチェックボックスをオフにし、On2 VP6 のみを選択します。

- その他すべてのチェックボックスをオフにして MP3 Playback Filters の [Select None] を選択します。

コーデックのインストール後はプログラムの再起動が必要です。

注: On2 VP6 コーデックのインストールに関して当社は一切の責任を負いません。
上記のコーデックの使用においては、コーデック付属の諸条件の対象です。ライセンス使用許諾契約に順守しなければなりません。


プログラミング インタフェースの使い方

On2 VP6、 Sorenson H.263 コーデック、および On2 VP6 with Alpha の比較

On2 VP6 コーデック、および On2 VP6 コーデック with Alpha を使用すると、Sorenson H.263 コーデックに比べて、次の利点があります。

  • 同じデータ転送速度でより高品質のビデオをエンコードする
  • 合成ビデオを作成するためにアルファ チャンネルの使用をサポートする
  • On2 VP6 コーデック with Alpha でソース ビデオ ファイルのアルファ エフェクトを維持する

同じデータ転送速度でより高品質のビデオをサポートするためには、On2 VP6 コーデックのエンコードは非常に速度が遅くなり、クライアント コンピュータ上でビデオ データをデコードして再生するために、より多くのプロセッサ パワーが必要になります。このため、ビデオを見る人が作成した Flash ビデオ コンテンツにアクセスするときに使用するコンピュータに共通する最も低い基準に配慮してください。

変換速度が遅くなり、生成ファイルも大きくなってしまうため、通常は一般ユーザが On2 VP6 コーデック with Alpha を選択する必要はありません。ビデオに特別な目的を持たせたい専門的な知識を持つユーザによる使用が好ましく、効果的なアルファ エフェクトが得られるでしょう。

多数のユーザーが比較的古いコンピュータを使用すると予測される場合は、FLV ファイルを Sorenson H.263 コーデックを使用してエンコードする方がよいかもしれません。


ビデオの規格と用語について

以下のセクションでは、ビデオ コンテンツを取り扱うときに知っておく必要があるデジタル ビデオの概念と用語を紹介しています。デジタル ビデオの初心者であったり、デジタル ビデオおよび高品質ビデオ コンテンツのエンコードについてさらに詳しく知りたい場合は、これらのセクションを参照すれば、さまざまなアプリケーションでのビデオのエンコードとインターネットの表示環境とのトレードオフについて理解することができます。

以下の用語については、この章で説明しています。

フレーム レート

キーフレーム

データ転送速度

アスペクト比


フレーム レート

ビデオは画面にすばやく連続して表示される画像の連続で、動いているように見せるものです。毎秒表示されるフレーム数はフレーム レートとして表され、フレーム/秒 (fps) で測定されます。フレーム レートが高くなるほど、連続する画像を表示するために 1 秒当たりより多くのフレームが使用され、その結果、動きが滑らかになります。ただし、高品質の代償として、フレーム レートが高くなると、ビデオを表示するのにより大きなデータ量が必要になり、使用する帯域幅が大きくなります。

Flash ビデオなどのデジタル圧縮されたフォーマットでビデオを操作する場合、フレーム レートが高くなると、ファイル サイズが大きくなります。ファイル サイズを小さくするには、フレーム レートまたはデータ転送速度を低くする必要があります (詳細については、データ転送速度を参照)。データ転送速度を下げて、フレーム レートをそのままにすると、画像の品質は低下します。フレーム レートを下げて、データ転送速度を変更しないままにすると、ビデオの動きに必要な滑らかさが得られない場合があります。

ビデオは、ネイティブのフレーム レート (ビデオがもともとフィルム撮影されたときのフレーム レート) でよりよく表示されるため、配信チャンネルと再生プラットフォームが許す限り、フレーム レートを高いままにしておくことをお勧めします。フルモーション NTSC (米国のNational Television System Committee (国家テレビ標準化委員会) によって定義された規格) の場合、29.97 fps を使用し、PAL (Phase Alternating Line、ヨーロッパの主要なテレビ規格) の場合、25 fps を使用します。フレーム レートを下げると (これにより、エンコードの必要なビデオ データが大幅に減少する場合があります)、Flash Video MX Pro バッチ エンコーダは新しい fps レートを達成するためにリニア レートでフレームを落とします。ただし、フレーム レートを下げる必要がある場合、均等に分割することにより最良の結果が得られます。たとえば、ソースのフレーム レートが 24 fps の場合、フレーム レートを 12 fps、8 fps、6 fps、4 fps、3 fps、または 2 fps に落とします。ソースのフレーム レートが 30 fps である場合、ほとんどの場合、フレーム レートを 15 fps、10 fps、6 fps などに調整できます。

ビデオ クリップを高いデータ転送速度でエンコードする場合、ローエンドのコンピュータではフレーム レートが低い方が再生画質が向上します。たとえば、動きの少ない、会話主体のクリップを圧縮する場合、フレーム レートを半分にしても、データ転送速度は 20 % しか節約できません。しかし、動きの多いビデオを圧縮する場合、フレーム レートを減らすと、データ転送速度に 非常に大きな効果があります。


キーフレーム

キーフレームとは、一定の間隔でビデオ クリップに挿入される完全なビデオ フレーム (または画像) のことです。キーフレーム間のフレームには、キーフレーム間で発生する動きやシーンに関する情報が含まれます。たとえば、ビデオが戸口を歩いて通り過ぎる人を描写する場合、キーフレームにはその人と背景にあるドアの全体の画像が含まれ、インターバル フレームにはドアの前を歩く人の動きを表す情報が含まれます。

デフォルトでは、Flash Video MX Proバッチ エンコーダはビデオ クリップのフレーム レートに基づいて使用するキーフレーム間隔を自動的に決めます。キーフレーム間隔の値がエンコーダにビデオ画像を再評価し、フル フレームまたはキーフレームを FLV ファイルに記録する頻度を伝えます。Flash Video MX Proでは、この設定はキーフレーム間隔の値で、この値はキーフレーム間のフレーム数を表します。Flash Video MX Proは、複数のフレームを比較し、重複する情報を省くことによって画面上のすべてのピクセルのフル値を推定することによって、キーフレーム間に存在するフレームを概算します。

キーフレーム間隔値は、100 までの任意の数になります。間隔設定で [自動] を選択すると、Flash Video MX Proは再生時間の 2 秒ごとにキーフレームを設定します。たとえば、エンコードしているビデオのフレーム レートが 30 fps の場合、キーフレームは 60 フレームごとに挿入されます。通常、ビデオ クリップ内をシークするときに、デフォルトのキーフレーム間隔値が適切なレベルのコントロールを提供します。カスタム キーフレーム設定値を選択する必要がある場合は、キーフレーム間隔を小さくすると、ファイル サイズが大きくなることに注意してください。

映像に多数のシーン変更やすばやく移動する動きがある場合、キーフレーム間隔を低い数値にすると画質が向上します。一般に、キーフレーム間隔を小さくすると、画質が向上します。

キーフレーム間隔の設定が重要なのは、キーフレーム間隔が Flash プレーヤーで FLV ファイルをシーク (高速早送りまたは巻戻し) する能力に影響するという点にあります。Flash プレーヤーにできることはキーフレームからキーフレームに進むことだけです。このため、別の場所にスキップしてフレームを止めたい場合は、キーフレーム間隔の値を低くする必要があります。FLV ファイル内のすべてのフレームに進みたい場合は、キーフレーム間隔の値を 1 にします。キーフレーム間隔の値を小さくした場合、Flash ビデオのデータ転送速度を上げて、比較可能な画像品質を維持する必要があります。


データ転送速度

データ転送速度は、ビデオ クリップの品質に影響を及ぼし、ファイルをダウンロードするユーザは帯域幅の制約を受けます。

インターネットを使用してビデオを配信する場合、低いデータ転送速度でファイルを作成してください。高速のインターネット接続を使用するユーザはほとんど遅滞なくファイルを表示できますが、ダイヤルアップ ユーザはファイルがダウンロードされるまで待たなければなりません。ダイヤルアップ ユーザが見ることを予測する場合、短いビデオ クリップを作成して、ダウンロード時間を許容範囲内に収めてください。

Flash Video MX Proを使用して、ビデオ エンコーディングのデータ転送速度の設定を低、中、高の各品質に指定できます。[品質] ポップアップ メニューで利用できる設定で特定のソースの映像で必要な結果が得られない場合は、[カスタム] を選択して、[最大データ転送速度] テキスト ボックスにより高いデータ転送速度を入力します。


アスペクト比 (フレーム サイズ)

高品質のビデオを制作するには、フレームレートと同様にドキュメントのアスペクト比 (またはフレーム サイズ) が重要になります。特定のデータ転送速度 (接続速度) で、フレームサイズを大きくすると、ビデオ品質が低下します。ドキュメントのフレーム サイズを選択する場合、ソース ビデオ クリップのフレーム レート、アスペクト比、さらに優れたビデオ プレゼンテーションを作成するための個人的な優先設定を考慮します。インターネットの標準ビデオ表示解像度には、640 x 480、512 x 384、320 x 240、および 160 x 120 画素があります。

最も一般的なアスペクト比は 4:3 です(標準テレビジョン)。16:9 や 2:1 (ワイド画面) のアスペクト比も徐々に一般的になってきています。通常、最初にキャプチャしたときと同じアスペクト比を使用して、ビデオをエンコードしてください。ビデオクリップのアスペクト比を変更すると、ビデオ画像にひずみが生じる場合があります。ただし、デジタル ビデオ (DV) をエンコードする場合は例外です。デジタル ビデオでは長方画素を使用するため、デジタル ビデオのアスペクト比は 4:3 のアスペクト比とは少し異なります。デジタル ビデオ カメラでキャプチャしたビデオ コンテンツをエンコードする場合、使用する DV フォーマットのフレーム サイズを手動で指定して、ビデオのアスペクト比を維持する必要があります。詳細については、非正方画素のビデオのエンコードについてを参照してください。

次の標準フレーム サイズのリストをガイドラインとして使用できます。プロジェクトに最適の設定を見つけるために実験することができます。

4:3 アスペクト比のビデオのフレーム サイズ:

  • モデム (56k): 160 x 120
  • DSL: 320 x 240
  • ケーブル: 512 x 384
  • ケーブル/企業 LAN: 640 x 480

16:9 アスペクト比のビデオのフレーム サイズ:

  • モデム (56k): 192 x 108
  • DSL: 384 x 216
  • ケーブル: 448 x 252
  • ケーブル/企業 LAN: 704 x 396


非正方画素のビデオのエンコーディングについて

ほとんどの静的なコンピュータ グラフィックスは、縦横比が 1:1 の正方画素を使用しています。デジタル ビデオを操作する場合、画素の縦横比が異なる場合がよくあり、これは長方画素と呼ばれています。この動作の理由は、アナログ ビデオ (放送テレビジョンなど) とデジタル ビデオ (DVD ビデオなど) の共存を可能にすることです。非正方画素ビデオ フォーマット (アナモルフィック ビデオとも呼ばれる) をエンコードする場合、ビデオ画像を再サンプリングして正しい表示アスペクト比 (Display Aspect Ratio = DAR) にする必要があります。

たとえば、標準の NTSC デジタル ビデオ (DV) はフレーム サイズが 720 x 480 画素で通常は 4:3 のアスペクト比で表示されます。これは、各画素が正方形で画素アスペクト比 (PAR) が 10:11 (トール、ナロー ピクセル) であることを示します。通常は 4:3 または 16:9 (ワイド画面) のアスペクト比で表示される MPEG 1 および 2 の両方のビデオがさまざまなサイズ (720 x 480 または 480 x 480 が一般的) で出力されます。

非正方画素を使用するビデオをエンコードするときに画像フレームサイズを計算するには、まずどの寸法 (横または縦) を優先されるマスター寸法にするかを決め、続いて次の手順でその他の寸法を計算します。

縦がマスター寸法の場合、次の式を使って、横を計算します。

たとえば、アスペクト比が 4:3 のビデオの場合、式は次のようになります。

横がマスター寸法の場合、次の式を使って、縦を計算します。

たとえば、アスペクト比が 4:3 のビデオの場合、式は次のようになります。

たとえば、フレーム サイズが 720 x 480 ピクセルのビデオをエンコードする場合、ビデオ フレームをエンコードする幅を画素数で決める必要があります。

結果は、縦が 640 画素のビデオ画像になります。

このように、720 x 480 の画像を 640 x 480 (標準の 4:3 アスペクト比) にエンコードする必要があります。

Flash ビデオ エンコーダを使用してエンコードするときに画像サイズを修正するには、[エンコードの詳細設定] ダイアログ ボックスの [アスペクト比を維持] チェック ボックスのチェックを外して、ビデオをエンコードする修正した寸法を入力します。詳細については、ビデオ エンコードの詳細設定の選択を参照してください。


Flash Video MX Proバッチ エンコーダによるビデオのエンコード

デフォルトでは、Flash Video MX Proバッチ エンコーダが Flash Player 7用にビデオをエンコードするために、 Sorenson H. 263 コーデックを使用してソース ビデオをエンコードします。Flash Player 8 と互換性のある On2 VP6 コーデックを使用することもできます。

エンコーディング設定を設定するときに、個別のファイルに選択し、各ファイルに必要なビデオ フォーマットの種類と品質に基づいて、さまざまな設定を指定したり、複数のファイルを選択して、それらのファイルすべてに同じ設定を指定することができます。

Flash Video MX Pro バッチ エンコーダのインタフェース:

Flash Video MX Pro バッチ エンコーダでビデオをエンコードするには:

  1. [スタート] > [すべてのプログラム] > [Flash Video MX Pro] > [Flash Video MX Proバッチ エンコーダ] の順に選択するか、Flash Video MX Pro バッチ エンコーダ アプリケーションを含むフォルダを開いて、アプリケーション アイコンをダブルクリックして、Flash Video MX Proバッチ エンコーダを開始します。
  2. 設定 ([編集] > [エンコード設定]) をクリックして、[Flash Video MX Proバッチ エンコーダ エンコード設定]ダイアログ ボックスを表示します。

    詳細なビデオ エンコード設定の指定については、詳細なビデオ エンコード設定の指定を参照してください。

  3. 選択したエンコード プロファイルが意図したアプリケーションに適しているか確認します。[Flash ビデオ エンコード プロファイル] ポップアップ メニューの下のテキスト ボックスに、選択したエンコード プロファイルの Flash プレイヤ バージョン、ビデオ コーデック、ビデオ ビット レート、およびオーディオ エンコード情報が表示されます。
  4. エンコードした FLV ファイルのファイル名を入力します。ファイル名を指定しない場合、Flash Video MX Proバッチ エンコーダはソース ビデオ クリップのファイル名を使用します。ファイルに名前を付ける場合、.flv 拡張子を入力しないでください。これは、Flash Video MX Proバッチ エンコーダが自動的に入力します。

    ソース ビデオ クリップを含むフォルダに対して、エンコードした FLV ファイルを保存する宛先フォルダを指定できます。宛先フォルダを指定する場合:

    • 指定する宛先フォルダは既に存在する必要があります。存在しないフォルダを指定すると、フォルダが見つからないため、ファイルをエンコードできないというエラー メッセージが表示されます。
    • または、出力フォルダをクリックして、エンコードしたファイルを保存するフォルダを作成できます。
  5. 次のいずれかの操作を実行します。
    • [詳細設定を表示] をクリックして、エンコード設定をさらに調整するか、切り取りおよびトリム コントロールを使用してビデオ クリップのサイズまたは再生の長さを変更します。
    • [OK] をクリックして、[Flash Video MX Proバッチエンコーダ エンコード設定] ダイアログ ボックスを閉じます。
  6. [キューを開始] をクリックして、ファイルのエンコードを開始します。

    Flash Video MX Proバッチ エンコーダは、ビデオ エンコード リストの最初のファイルのエンコードを開始します。ファイルのエンコード中、ビデオ エンコード リストの [ステータス] 列に各ビデオのステータスに関する情報が表示されます。

    [待機中] は、ファイルはエンコード キューにあるが、エンコードされていないことを示します。エンコード済みまたはエンコード中でないキューからファイルを削除できます。詳細については、エンコード キューの編集を参照してください。

    [スキップ] は、エンコードプロセス中にファイルがスキップされることを示します。ファイルのスキップまたは [待機中] ステータスへの変更を選択できます。詳細については、ファイルのスキップを参照してください。

    エンコード キューに待機中のタスクがない場合、[編集] > [ステータスのリセット] を選択して、タスク ステータスを変更する必要があります。


ファイルのスキップ

Flash Video MX Proバッチ エンコーダが現在のエンコード キューのファイルをエンコードしないように指定できます。

ファイルをスキップするには:

  1. エンコード キューでスキップする 1 つまたは複数のファイルを選択します。エンコード キューで複数のファイルを選択するには、Control キーを押しながら、ファイルを選択します。
  2. [編集] > [選択したファイルをスキップ] を選択します。

ファイルのエンコードを停止するには:

  • ステータス バーの下の [スキップ] ボタンをクリックします。

スキップしたファイルをエンコードするようにリセットするには:

  1. エンコード キューでエンコード待機状態にリセットする 1 つまたは複数のファイルを選択します。エンコード キューで複数のファイルを選択するには、Control キーを押しながら、ファイルを選択します。
  2. [編集] > [ステータスのリセット] を選択します。

    選択された 1 つまたは複数のファイルがエンコード待機状態にリセットされます。Flash Video MX Proバッチ エンコーダでエンコードしながら、ファイルのステータスをリセットできます。


オーディオのみのファイルのエンコードについて

オーディオ制作の場合もビデオ制作の場合と同じ注意事項があります。オーディオの良好な圧縮を実現するには、音源の録音時に音のひずみや耳に聞こえるアーキファクトが入っていないオーディオ ファイルで始める必要があります。CD から取り込んだ素材をエンコードする場合、サウンド カードのアナログ入力ではなく、ダイレクト デジタル転送を使用してファイルを記録してみてください。サウンド カードでは、不必要なデジタル/アナログ変換およびアナログ/デジタル変換が行われて、転送したオーディオにノイズが混入する場合があります。ダイレクト デジタル転送ツールは Windows と Macintosh の両方のプラットフォームで使用できます。アナログ音源から録音する必要がある場合は、利用可能な最高品質のサウンド カードを使用してください。


エンコード キューの編集

ビデオから読み込み: ソース ビデオ クリップをエンコードするファイルのリストに追加します。1 つまたは複数のファイルをリストにドラッグするか、[追加] ボタンをクリックして、コンピュータ上のファイルを選択します。

複製: キューで選択した同じファイルをコピーし、必要に応じて異なる設定を変更します。

削除:選択したファイルをエンコード キューから削除します。

上へ移動: エンコード キューで選択したファイルを上へ移動します。

下へ移動: エンコード キューで選択したファイルを下へ移動します。

設定:[Flash Video MX Pro バッチエンコーダ エンコード設定] ダイアログ ボックスを表示します。

出力フォルダ: ファイルを保存するフォルダを指定します。

キューの開始: 選択したファイルのエンコードを開始します。

待機ステータスには、ファイルがエンコード待機中でないことが示されます。ステータスの詳細については、ファイルのスキップを参照してください。


Flash ビデオ エンコード設定

動画プロパティに現在のファイルまたはエンコード キューの詳細位置のファイルが表示されます。表示される情報は、ファイルのサイズ、フレーム レートおよび経過時間です。座標は、マウスまたはカーソルが移動するピクセル数を示します。

始点:バーをドラッグして、変換するビデオの始点を設定します。[始点] フィールドに有効な値を入力し、 [適用] を押して、ビデオを開始する正確な時間を設定することもできます。

終点:バーをドラッグして、変換するビデオの終点を設定します。[終点] フィールドに有効な値を入力し、[適用] を押して、ビデオを終了する正確な時間を設定することもできます。

現在位置:現在のフレームの位置/時間を表示します。

注:

緑色の線は、変換を選択した部分を示します。始点と終点を設定すると、Flash Video MX Pro は、選択した部分だけを再生します。

再生: ビデオ ファイルを再生します。

一時停止: 現在のフレームでビデオの再生を停止します。

停止: ビデオの再生を停止します。

MS: 現在のフレームを変換するビデオの始点に設定します。

MF: 現在のフレームを変換するビデオの終点に設定します。

切取り:切り取りするサイズを指定します。ビデオを切り取るには、次の 2 つの方法があります。

    • フレームをドラッグして、切り取ったビデオ サイズを指定する
    • 左、右、上、下の 4 つの位置の値を調整する

ビデオの切り取り中、[切り取り画像サイズ] および [切り取りアスペクト比] を参照して、変換用に適切なビデオを切り取りできます。

すべて選択: フルサイズのビデオを選択します。

サムネイル設定:現在のフレームを Flash のサムネイルとして設定します。


ビデオ エンコードの詳細設定の選択

Flash Video MX Pro バッチ エンコーダの [設定] オプションを使用して、カスタム ビデオ エンコード設定を作成できます。

カスタム ビデオ エンコード設定の前に、必ずさまざまなビデオ エンコード オプションを理解してください。ビデオ エンコード オプションの詳細については、ビデオの規格および用語についてを参照してください。

ビデオ エンコードの詳細設定を指定するには:

  1. エンコード設定を変更する 1 つまたは複数のファイルを選択します。
    エンコード リストで複数のファイルを選択するには、Control キーを押しながらファイルを選択するか、または [編集] > [すべて選択] を選択して、エンコード キューのすべてのファイルを選択します。[設定] をクリックします ([編集] > [エンコード設定])。

    [Flash ビデオ エンコード設定] ダイアログ ボックスが表示されます。

  2. [詳細設定を表示] をクリックします。

    Flash ビデオ エンコードの詳細設定オプションが表示されます。このダイアログ ボックスで、次の操作を実行できます。

    • 必要なファイルを取得し、ファイルの管理を容易にするための出力ファイル形式の指定。
    • さまざまな帯域幅および用途のビデオを提供するための代替エンコード設定の指定。
    • 寸法および開始フレームと終了フレームを変更するためのビデオ クリップのトリミング。
    • さまざまなビデオ エフェクト (雪、照明、火など) の追加。
    • ビデオのロゴ、キャプションの指定。
    [デフォルトとして保存] ボタンをクリックして、現在の設定をデフォルトとして保存できます。デフォルト設定が保存された後、この設定はバッチ エンコーダに追加されたファイルに適用されます。

[詳細設定]ダイアログ ボックスで使用できるオプションの詳細については、以下のセクションを参照してください。
  • 出力ファイル設定の指定
  • ビデオ エンコードの詳細設定の指定
  • オーディオ エンコードの詳細設定の指定
  • ビデオ エフェクトおよびコントロール バー設定の指定
  • ビデオ ロゴおよびキャプションの指定
  • キュー ポイント


出力ファイル設定の指定

[出力] タブの下で、出力フォルダに作成するファイルをチェックできます。

出力名: 出力するファイル名を変更します。テキストフィールドにファイル名を入力し、出力ファイル名を変更することができます。ファイル名の記入欄には拡張子は表示されません。また、jpg、html などの拡張子は記入しても無効になり、反映されません。

次のオプションをチェックして、Flash Video MX Proで関連ファイルを作成できるようにします。

FLV ファイルの作成: 指定した設定で FLV ファイルを作成します。このオプションをオフにすると、[SWF ファイルの作成] が自動的にオンになります。

サムネイル ファイルの作成: 出力ファイルのサムネイル ファイルを作成します。[ファイル] メニューの下のユーザ選択設定でサムネイル ファイル形式を指定できます。

SWF ファイルの作成: 2 種類の SWF ファイルがあり、1 つはビデオを埋め込んだファイルで、もう 1 つは FLV ファイルを再生する FLV プレイヤです。ビデオを埋め込んだ SWF ファイルを作成するオプションをオンにすると、[その他] タブでビデオ エフェクトを追加できます。FLV プレイヤとして SWF を作成するオプションをオンにすると、ビデオ エフェクトが無効になります。オプションをオフにすると、[HTML ファイルの作成] がグレイ表示になり、[FLV ファイルの作成] オプションが自動的にオンになります。

SWF ファイルにビデオを組み込む: このオプションを選択すると、他のファイルを使用することなく SWF を再生でき、[外部 FLV ファイルを再生する] をオンにしていても、FLV ファイルが SWF ファイルと同じフォルダにあることを確認する必要はありません。

外部 FLV ファイルを再生する: このオプションで作成された SWF ファイルは FLV ファイル用のプレイヤです。FLV ファイルが SWF ファイルと同じフォルダにあることを確認する必要があります。そうしないと、SWF ファイルをダブルクリックしても、プレイヤしか取得できません。[FLV ファイルの作成] をオンにし、[外部 FLV ファイルを再生する] を選択すると、[その他] タブの下の [ビデオ エフェクト] が無効になっています。

HTML ファイルの作成: Web ページを作成し、そこからソース コードを見つけて、ユーザ独自の Web ページの関連コードを作成するために使用します。[SWF ファイルの作成] オプションがオフになっている場合、このオプションはグレイ表示になります。

独自の FLV プレイヤの使用方法について: テキストをクリックすると、SWF ファイルの FLV プレイヤとしての使用に関するページが表示されます。この FLV プレイヤとしての SWF ファイルは、Web サイトで複数の FLV ファイルを再生するために適用できます。このオプションはリテール版でしか使用できない点に注意してください。

最初のフレームの jpg ファイルを出力用に作成する ("出力ファイル名"+"_FirstFrame.jpg"): このオプションをオンにした場合、最終出力ファイル名で始まり、"_FirstFrame" で終わる jpg ファイルが作成されます。たとえば、最終出力ファイル名が "MagLev" の場合、作成されるファイルは MagLve_FirstFrame.jpg になります。出力ビデオと同じサイズのこのファイルは、作成された FLV ファイルまたはビデオを埋め込んだ SWF ファイルと同じフォルダに置くと自動的にビデオに統合できます。

最初のフレームのファイルとサムネイル ファイルの違い:
1. ファイル名:最初のフレーム ファイルのファイル名はﾌﾟレフィックスとして出力ファイル名、サフィックスとして "_FirstFrame" を含み、一方、サムネイル ファイル名は Flash 出力ファイルと同じです。
2. 画像サイズ:最初のフレーム ファイルの寸法 (幅と高さ) は、Flash ファイルの寸法と同じになります。サムネイル ファイルの幅と高さは、[ファイル] > [ユーザ設定] を選択するか、[サムネイル] ボタンをクリックした後、[サムネイル] パネルで画像をダブルクリックして指定できます。
3. 機能:最初のフレーム ファイルはビデオに自動的に統合して、ビデオの冒頭に黒い画面が表示されるのを防ぐことができます。サムネイル ファイルは、HTML コードを変更して、ビデオの最初のフレームとして使用できます。サムネイルの画像サイズを変更できるため、ビデオの内容を紹介する画像として使用できます。

Flash Video MX Proの[エンコード設定]ダイアログ ボックスで使用できるその他のオプションの詳細については、以下のセクションを参照してください。

  • ビデオ エンコードの詳細設定の指定
  • オーディオ エンコードの詳細設定の指定
  • ビデオ エフェクトおよびコントロール バー設定の指定
  • ビデオ ロゴおよびキャプションの指定
  • キュー ポイント


オーディオ エンコードの詳細設定の指定

Flash Video MX Proの [バッチ エンコード設定] ダイアログ ボックスの [音声のエンコード] エリアは、[設定] をクリックすると自動的に有効になります。

オーディオ設定のカスタム設定を指定するには:

  1. エンコード設定を変更する 1 つまたは複数のファイルを選択します。
    エンコード リストで複数のファイルを選択するには、Control キーを押しながらファイルを選択するか、または [ファイル] > [すべて選択] を選択して、エンコード キューのすべてのファイルを選択します。

  2. [設定] をクリックします ([編集] > [エンコード設定])。
    [Flash ビデオ エンコード設定] ダイアログ ボックスが表示されます。

  3. [詳細設定を表示] をクリックして、[エンコード] タブをクリックします。

  4. Flash ビデオ エンコードの詳細設定オプションが表示されます。

  5. デフォルトでは、[音声のエンコード] チェック ボックスが選択されています。デフォルトでは、オーディオ コーデックは MP3 です。

  6. [サンプル レート] コンボ ボックスからサンプル レートを選択し、[ビット レート] を選択します。

  7. フェードインおよびフェードアウトを設定し、さらにフェードインおよびフェードアウト継続時間を設定できます。

  8. [音声チャンネル] コンボ ボックスから [音声チャンネル タイプ] を選択します。

    9. Flash Video MX Proの[エンコード設定]ダイアログ ボックスで使用できるその他のオプションの詳細については、以下のセクションを参照してください。

    • 出力ファイル設定の指定
    • ビデオ エンコードの詳細設定の指定
    • ビデオ エフェクトおよびコントロール バー設定の指定
    • ビデオ ロゴおよびキャプションのエンコード設定の指定


ビデオ エンコードの詳細設定の指定

ビデオおよびオーディオの詳細設定により、FLV ファイルの品質を選択できます。[エンコード] タブは、ビデオ ファイルのエンコード オプションを指定できる [ビデオ設定] と MP3 オーディオ エンコードのビット レートを選択できる [音声のエンコード] の 2 つのカテゴリに分かれています。次のセクションでは、エンコード オプションを説明しています。

ビデオ エンコードのカスタム設定を指定するには:
  1. エンコード設定を変更する 1 つまたは複数のファイルを選択します。
    エンコード リストで複数のファイルを選択するには、Control キーを押しながらファイルを選択するか、または [ファイル] > [すべて選択] を選択して、エンコード キューのすべてのファイルを選択します。

  2. [設定] をクリックします ([編集] > [エンコード設定])。
    [Flash ビデオ エンコード設定] ダイアログ ボックスが表示されます。

  3. [詳細設定を表示] をクリックし、 [エンコード] タブをクリックします。

  4. Flash ビデオ エンコードの詳細設定オプションが表示されます。

  5. 出力ファイルに設定する品質となるビデオ エンコード プロファイルを選択します。エンコード プロファイルを選択すると、ビデオ設定とオーディオ設定が同時に変わります。[カスタム] を選択するか、直接入力して、ユーザー独自のエンコード プロファイルを指定することもできます。

  6. ビデオ コーデックを選択します。Flash Video MX Proでは、Sorenson H.263 、 On2 Vp6、および On2 VP6 with alpha コーデックが利用可能なオプションです。

  7. フレーム レートを選択します。デフォルトでは、Flash Video MX Pro バッチ エンコーダは、ソース ビデオと同じフレーム レートを使用します。フレーム レートを変更する必要がある場合は、フレーム レートの変更がビデオの品質に与える影響をよく理解してください。詳細については、ビデオの規格および用語についてを参照してください。

    注:

    SWF ファイルに埋め込まれるビデオ クリップのエンコード設定を変更している場合、ビデオ フレーム レートが SWF ファイルと一致する必要があります。

  8. ビデオのデータ転送速度設定を選択します。
    9. [品質] ドロップダウン リストからビデオの品質設定を指定します。この品質設定により、エンコードされたビデオのデータ転送速度が決まります。データ転送速度を高くすると、エンコードされたビデオ クリップの品質が向上します。
    • データ転送速度の値を自動的に選択するには、プリセットの [品質] 設定 ([低]、[中]、[高]) を選択します。このメニューから [低]、[中]、[高] を選択すると、[最大データ転送速度] テキスト ボックスの値が更新されて、指定した値になります。
    • [カスタム] を選択し、[最大データ転送速度] テキスト ボックスに値 (kbps=キロビット/秒) を入力します。

    注:

    プリセットの品質設定がソースの映像で機能しない場合は、カスタムの最大データ転送速度を指定してみてください。データ転送速度とデータ転送速度がビデオの品質に与える影響の詳細については、データ転送速度を参照してください。

  9. ビデオ クリップのサイズ変更:
      • [ビデオサイズ変更] チェック ボックスを選択します。
      • [幅] と [高さ] の値を指定します。フレーム サイズをピクセルで指定してください。

    注:

    ビデオ クリップのフレーム サイズを変更して、[アスペクト比を維持] チェックボックスを選択しないと、ビデオの画像がゆがむ場合があります。

  10. [ビデオ フェード] チェックボックスを選択して、フェードインおよびフェードアウト時間、およびフェード カラーを設定します。

  11. カスタム キーフレーム設定値を選択する必要がある場合は、キーフレーム間隔を小さくすると、ファイル サイズが大きくなることに注意してください。詳細については、ビデオの規格および用語についてを参照してください。

  12. [始点] で選択したビデオの開始前にビデオ ファイルを追加できます。このビデオは、動画のオープニングと選択したビデオの開始の間に表示されます。[終点] で選択したビデオの終了時にビデオ ファイルを追加できます。このビデオは、選択したビデオの終了と動画の終わりの間に表示されます。

    所有権を表示するために、広告、警告または特定のビデオを追加できます。コンテンツを好きなように充実させることができます。

      • エンコードの詳細設定の指定を終了すると、[ビデオその他] を選択して、ビデオにカスタム イメージ ロゴやテキストを追加したり、[その他] タブを選択してビデオ エフェクトや SWF の再生コントロール パネルを追加したり、[OK] をクリックして、Flash Video MX Proのメイン [エンコード] ダイアログ ボックスに戻ることができます。

    ビデオ クリップをエンコードする準備ができたり、エンコードするソース ビデオ クリップを追加する場合は、Flash Video MX Proバッチ エンコーダによるビデオのエンコードを参照してください。

  1. 出力ファイル設定の指定
  2. オーディオ エンコードの詳細設定の指定
  3. ビデオ エフェクトおよびコントロール バー設定の指定
  4. ビデオ ロゴおよびキャプションの指定


エンコード設定ロゴ、キャプションの指定

ビデオ ロゴおよびキャプションの指定

ビデオ ロゴおよびキャプションを指定するには:

  1. エンコード設定を変更する 1 つまたは複数のファイルを選択します。
    エンコード リストで複数のファイルを選択するには、Control キーを押しながらファイルを選択するか、または [ファイル] > [すべて選択] を選択して、エンコード キューのすべてのファイルを選択します。

  2. [設定] をクリックします ([編集] > [エンコード設定])。
    [Flash ビデオ エンコード設定] ダイアログ ボックスが表示されます。

  3. [詳細設定を表示] をクリックして、[ビデオ その他] タブをクリックします。

  4. Flash ビデオ エンコードの詳細設定オプションが表示されます。

  5. ビデオに表示するキャプションとロゴを追加し、それぞれの透過や [配置] と [補正] を設定します。

  6. ビデオの輝度とコントラストを調整します。

  7. 一部のビデオで必要な場合は、[インターレース解除] または [反転] を選択します。

Flash Video MX Proの[エンコード設定]ダイアログ ボックスで使用できるその他のオプションの詳細については、以下のセクションを参照してください。
  • ビデオ エンコードの詳細設定の指定
  • オーディオ エンコードの詳細設定の指定


ビデオ エフェクトおよびコントロール バー設定の指定

[Flash その他] タブにより、出力フラッシュ ファイルのビデオ コントロール バーと Flash エフェクトを選択できます。

ビデオ エフェクトおよびコントロール バー設定を指定するには:

  1. エンコード設定を変更する 1 つまたは複数のファイルを選択します。
    エンコード リストで複数のファイルを選択するには、Control キーを押しながらファイルを選択するか、または [ファイル] > [すべて選択] を選択して、エンコード キューのすべてのファイルを選択します。

  2. [設定] をクリックします ([編集] > [エンコード設定])。
    [Flash ビデオ エンコード設定] ダイアログ ボックスが表示されます。

  3. [詳細設定を表示] をクリックして、[Flash その他] タブをクリックします。

  4. Flash ビデオ エンコードの詳細設定オプションが表示されます。

  5. コントロール バーのスタイル リストから使用するビデオのコントロール バーのスタイルを選択します。

  6. プリセットの Flash プレイヤ プロファイルを選択します。コントロール バーのスタイル リストの横のコントロール バー プロパティ インスペクタでパラメータを変更することもできます。ビデオで共通に使用される場合、パラメータを任意の名前で新しいプロファイルに保存できます。コントロール バーのスタイル リストの下に対応するパラメータが表示されます。プロパティの詳細については、Moyea FLV プレイヤの使い方を参照してください。

  7. ビデオに設定するビデオ エフェクトを選択します。SWF ファイルが選択されていなくても、プレビュー パネルでビデオ エフェクトをプレビューできます。ただし、[出力] タブでいずれかの種類の SWF ファイルを選択すると、出力 SWF ファイルでビデオ エフェクトが有効になります。

  8. サムネイル表示でリアルタイム エフェクトをプレビューします。[フロート] ボタンをクリックすると、ビデオ設定で設定したフレーム サイズでプレイヤが表示されます。

Flash Video MX Proの[エンコード設定]ダイアログ ボックスで使用できるその他のオプションの詳細については、以下のセクションを参照してください。
  • 出力ファイル設定の指定
  • ビデオ エンコードの詳細設定の指定
  • オーディオ エンコードの詳細設定の指定
  • ビデオ ロゴおよびキャプションの指定


FLV キュー ポイントの操作

キュー ポイント

[+] ボタンをクリックして、キュー ポイントを追加し、[時間]　列へキューポイントをトリガーさせたい場所にタイムポイントを指定します。ビデオを再生しているときにキュー ポイントを追加することもできます。好みに応じて名前を変更し、特定の時間とキュー ポイントの種類を選択します。

選択したキュー ポイントを削除する場合は、[-] ボタンをクリックします。

flv へのキュー ポイントの追加の詳細については、FLV キュー ポイントの操作を参照し、swf へのキュー ポイントの追加の詳細については、SWF キュー ポイントについてを参照してください。


Handling FLV Cue Point

FLV キュー ポイントの操作

キュー ポイントを FLV ファイルに組み込むことができます。FLV ファイルがプリセットされた時間ポイントで再生されると、onCuePointイベントをトリガーします。Flash Video MX Proによるプレイヤを適用しない場合、以下のようなコーディングを行うことでご自身の Action Script を FLVの再生に適用することができます。

var nc = new NetConnection(); //NetConnection オブジェクトを構築

nc.connect(null); //接続を確立

var ns = new NetStream(nc); //nc 付きの NetStream オブジェクトを構築

videoScr.attachVideo(ns); //videoScr はシーンに置かれたビデオ インスタンス

ns.play("xxx.flv"); //ビデオを再生するために、xxx.flv は flv 名。これは絶対または相対 URL とすることが可能

ns.pause(true); //ビデオを一時停止

ns.pause(false); //ビデオの再生を再開

ns.seek(t); //t 秒にシーク

ns. onCuePoint = function(info)

{

trace(info.name); //キュー ポイント名を取得

trace(info.time); //キュー ポイントを秒で取得

trace(info.type); //キュー ポイント タイプ "イベント" または"ナビゲーション"

trace(info.parameters["param_name"]); //キュー ポイントの param_name 値を取得

}

Flash Video MX Proによって提供されるプレイヤを使用して FLV ファイルを再生する場合は、Cue Point イベントを次のように操作できます。詳細については、プレイヤ API のドキュメントを参照してください。

var listener:Object = new Object(); //イベント リスナー オブジェクトを構築

listener.onEvent = function(sender, type, name, info)

{

if (name == "onCuePoint") { //onCuePoint イベントを処理

trace(info.name); //キュー ポイント名を取得

trace(info.time); //キュー ポイントを秒で取得

trace(info.type); //キュー ポイント タイプ "イベント" または"ナビゲーション"

trace(info.parameters["param_name"]); //キュー ポイントの param_name 値を取得

}

}

thePlayer.AddListener(listener); //リスナーが"onCuePoint"イベントを取得できるようにイベント リスナーを追加


SWF キュー ポイントについて

通常、キュー ポイントは FLV ファイルにのみ存在します。しかし、Flash Video MX Proでは、独立した SWF ファイルでキュー ポイントをエンコードできます。MovieClipLoader を適用して、このキュー ポイントを持った SWF を MovieClip にロードし、次に onLoadInit イベントを処理するときに、thePlayer のリスナー リストにリスナーを追加してください。

var mc = this.createEmptyMovieClip ("mc", this.getNextHighestDepth()); //新しい MovieClip を作成

var loader:MovieClipLoader = new MovieClipLoader(); //MovieClipLoader を作成

var loader_cb:Object = new Object(); //onLoadInit を処理するローダー コールバック オブジェクトを作成

var thePlayer = null;

loader_cb.onLoadInit = function(mc) // onLoadInit が呼び出されるときに、mc から thePlayer 変数を取得して、保存

{

thePlayer = mc.thePlayer; //変数を保存

mc._width = 400; //必要に応じて幅と高さを調節

mc._height = 300;

var listener:Object = new Object(); //thePlayer のイベントを待機するリスナー オブジェクトを構築

listener.onEvent = function(sender, type, name, info) //イベント処理手続き

{

trace(name);

}

thePlayer.AddListener(listener); //thePlayer のリスナー リストにリスナーを追加

}

loader.addListener(loader_cb); //onLoadInit を処理

loader.loadClip("xxx.swf", "mc"); //ビデオの swf をロード


プレイヤ API

はじめに

Flash Video MX Proでは、独立した SWF または対応する FLV に依存してのみ再生可能な SWF を作成できます。どちらのタイプのファイルにも同じプログラミング インタフェースが含まれます。これらのインタフェース機能によってプレイヤを制御できます (再生、一時停止、停止、シーク、コントロール バーの色の変更等の操作など)。また、コントロール バーを使って、プログラムであらゆる種類のイベント (キュー ポイント イベントや [再生] ボタンまたは [停止] ボタンをクリックするときのイベントなど) を操作できます。

Flash Video MX Proは互いに独立して、影響を与えることのない 2 つのタイプのフォーマットを作成します。

a) 独立した SWF ファイル

特長:

    • ビデオが SWF ファイルに埋め込まれている
    • ファイル サイズが大きい
    • 他のファイルに依存することなく独立して再生
    • ダウンロードするときにプログレッシブ ダウンロードを利用して監視可能
    • 整数フレーム レート
    • フレーム数が 16000 フレームに制限される (Flash Video MX Proは 16000 フレームを超える SWF を作成できますが、Flash プレイヤは 16000 番目より後の残りのフレームを再生できません。Flash Video MX は、ビデオが 16000 フレームを超えるかどうかを伝えることができます。)
    • 16000 フレーム以内のフレームをシーク可能

b) 対応する FLV に依存する FLV ファイルおよび SWF プレイヤ ファイル

特長:

    • ビデオが FLV ファイルとして保存される
    • FLV ファイルは Flash プレイヤで直接再生できないため、SWF プレイヤが必要
    • ダウンロードするときにプログレッシブ ダウンロードを利用して監視可能
    • 浮動小数点フレーム レート
    • 再生時間に制限なし
    • キーフレームのみシーク

一般条件でタイプ b のみ推奨

  • プログラミング インタフェース
タイプ a とタイプ b の両方とも同じプログラミング インタフェースに対応しています。ビデオの主要シーンに thePlayer という名前の変数があります。これはプレイヤ オブジェクトのインスタンスです。このオブジェクトは次のメソッドおよびイベントに対応しています。

thePlayer オブジェクトのメソッドの概要

thePlayer オブジェクトのイベントの概要

プログラミング インタフェースの使い方に例があります。

関連項目:

Moyea FLV プレイヤの使い方


thePlayer オブジェクトのメソッドの概要

メソッド

説明

Play()

ビデオを再生します

Pause()

現在のフレームで停止します

Stop()

再生を停止します

Seek(t)

ビデオの特定の時間にシークします。t は、Double型です

SetMute(b)

ミュート機能を設定します。b はブール型です

GetMute()

現在のミュート設定を取得します。戻り値はブール型です

SetVolume(v)

音量を設定します。v は 0～100 の範囲の整数型です。0 は無音、100 は最も大きな音量です。

GetVolume()

音量設定を取得します。戻り値は整数です

GetState()

現在の再生ステータスを取得します。戻りステータス文字列は、「play」、「pause」および「stop」です

GetTime()

現在の再生プロセスを取得します。戻り値はDouble型 (秒) です

GetDuration()

ビデオ再生時間を取得します。戻り値はDouble型 (秒) です

SetDebloking(l)

ブロック解除機能を設定します。I の範囲は次のとおりです

0: 必要に応じてビデオ コンプレッサにブロック解除フィルタを適用します

1: ブロック解除を適用しません

2: 常にブロック解除を適用します

(ブロック解除機能は常にファイル入力で適用されるため、このメソッドはファイルの入力には使用できません)

SetSmoothing(b)

スムージング機能を設定します。b はブール型です (スムージング機能は常にファイル入力で適用されるため、このメソッドはファイルの入力には使用できません)

SetVisible(b)

プレイヤを表示するかどうかを設定します。b はブール型です。プレイヤを非表示に設定した場合、プレイヤがマウス カーソルの無効を検知すると、自動的にコントロール バーが表示されます。

GetVisible()

プレイヤが表示されるかどうかを確認します。コントロール バーが自動的に非表示になり、コントロール バーが非表示に設定されている場合、戻り値は false です。

SetEnabled(b)

コントロール バーの UI の有効/無効を設定します。コントロール バーの UI が無効の場合、上のボタンはすべて無効になります

GetEnabled()

コントロール バーの UI が有効か無効かを確認します。

SetColor(c)

コントロール バーの色を設定します (cは整数です。たとえば、0xFF0000 は赤)。c が未定義に設定されている場合、コントロール バーは半透明になります。

AddListener(l)

イベントの Listener オブジェクトを Listener リストに追加します。オブジェクト l はonEventメソッド (sender、type、name、info) を実装する必要があり、sender はイベントの dispatcher です。type はイベント型で Flash Video MX Proプレイヤのイベントは常に「MoyeaPlayer」の型を持ちます。name は、イベント名で、info はイベントのその他の情報です

RemoveListener(l)

Listener リストからオブジェクト I を削除します。これでオブジェクト I はイベントを受け取ることができません。

DispatchEvent(event_type, event_name, info)

イベントを送信します。Listener リスト内のすべてのオブジェクトがイベントを受け取ることができます。event_type は dispatcher により定義される型です。event_name は dispatcher により定義される名前です。info は dispatcher により定義されるデータです

関連項目:

thePlayer オブジェクトのイベントの概要

プログラミング インタフェースの使い方

Moyea FLV プレイヤの使い方


thePlayer オブジェクトのイベントの概要

イベント

概要

onPlayPausePress

[再生] ボタンまたは [一時停止] ボタンが押されています

onReplayPress

[リプレイ]ボタンが押されています

onStopPress

[停止]ボタンが押されています

onProcBarDragStart

ユーザがプロセス バーのドラッグを開始します

onProcBarDragging

ユーザがプロセス バーをドラッグしています

ドラッグ操作中、このようなイベントを何回もトリガーできます

onProcBarDragEnd

ユーザがプロセス バーのドラッグを停止します

onMuteSwitch

[ミュート]ボタンが押されています

onPlayStart

コントロール バーが初期化され、再生準備ができています

このようなイベントは最初にロードするときにだけトリガーされ、リプレイなどのその他の場合にはトリガーされません

onMetaData

ロード時にメタデータ付きの FLV がこのようなイベントをトリガーします。イベント オブジェクト データには次の情報が含まれる場合があります。

info.duration: ビデオの継続時間

info.width: ビデオの横サイズ

info.height: ビデオの縦サイズ

info.videocodecid: ビデオ コーデック ID

ビデオ コーデック ID の選択可能な値:

2: Sorenson H.263

3: Screen video

4: VP6

5: VP6 with alpha

6: Screen Video V2

info.audiocodecid: オーディオのコーデック ID

オーディオ コーデック ID の選択可能な値:

0 = 非圧縮

1 = ADPCM

2 = MP3

5 = Nellymoser 8kHz モノラル

6 = Nellymoser

info.canSeekToEnd: 最後のフレームがキーフレームかどうかを表示

info.lasttimestamp: 最後のフレームのタイム スタンプ

info.videodatarate: ビデオのデータ転送速度

info.videodatarate: オーディオのデータ転送速度

info.metadatacreator: メタデータの作成者

info.cuePoints: キュー ポイント リスト

onPlaying

再生時に何回もトリガーされました

onPlayEnd

再生終了時にトリガーされました

onBufferEmpty

バッファが空のときにトリガーされました

b ファイルの入力に有効

onBufferFull

バッファがいっぱいのときにトリガーされました

b ファイルの入力に有効

onCuePoint

キュー ポイント イベント

イベント オブジェクト datainfo には、次の情報が含まれます。

info.name: キュー ポイントの名前

info.type: キュー ポイント、イベントまたはナビゲーションの種類

info.time: キュー ポイントの時間

info.parameters["param_name"]: キュー ポイントのパラメータ

param_name: エンコード時のパラメータ設定の名前

関連項目:

thePlayer オブジェクトのメソッドの概要

プログラミング インタフェースの使い方

Moyea FLV プレイヤの使い方


プログラミング インタフェースの使い方

最初に SWF を MovieClip にロードして、thePlayer 変数にアクセスできるようにします。loadMovie または MovieClipLoader を使用します。

var mc = createEmptyMovieClip("mc", getNextHighestDepth());

mc.loadMovie("xxx.swf");

var thePlayer = mc.thePlayer;

次に、thePlayer 変数を使用して、メソッドにアクセスします。コントロール バー イベントを処理するために、次のようなコードを書くことができます。

var listener: Object = new Object();

listener.onEvent = function(sender, type, name, info)

{

//senderは thePlayer

if (name == "onCuePoint") { //必要に応じて他のイベントを処理

trace("onCuePoint Event: name=" + info.name + ", type=" + info.type + ", time=" + info.time);

}

}

thePlayer.AddListener(listener);

関連項目:

thePlayer オブジェクトのメソッドの概要

thePlayer オブジェクトのイベントの概要

Moyea FLV プレイヤの使い方


Moyea FLV プレイヤの使い方

Flash Video MX Proのインストール フォルダに "Control" という名前のフォルダがあり、このフォルダでは SWF ファイルのそれぞれが FLV プレイヤになっています。これらの SWF ファイルは、Flash Video MX Proによって適用できるだけでなく、独立した FLV プレイヤでもあります。Flash Video MX Proによって作成された SWF ファイルは、独立した FLV プレイヤとなることもできます。FLV プレイヤとして作成された SWF ファイルと "Control" フォルダ内の SWF ファイルの違いは、"Control" フォルダ内の SWF ファイルの動作が Flash Video MX Proの設定によって、新しい SWF ファイルを作成するように変更されていることにあります。

必要なことは、この SWF ファイルを HTML ページに埋め込み、SWF ファイル パスから playerOpts と名付けられた文字列を渡して、コントロール バーの動作を制御することです。このページを次のようなコードで書くことができます。

<!--url's used in the movie-->
<!--text used in the movie-->
<!-- saved from url=(0013)about:internet -->
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="400" height="300">
<param name=movie value="mflvplayer.swf?playerOpts=targetClip*demo.flv*s">
<param name=quality value=high>
<embed src="mflvplayer.swf?playerOpts=targetClip*demo.flv*s" quality=high pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="400" height="300">
</embed>
</object>

mflvplayer.swf が青字になっていることにお気づきでしょうか。これは、独立した FLV プレイヤの 1 つです。

赤字で示された width="400" height="300" は、ビデオの幅と高さを示しています。

赤字の playerOpts=targetClip*demo.flv*s は、demo.flv がユーザーのビデオである場合に再生される FLV ファイルの名前を示します。targetClip、アスタリスクのセパレータおよび最後の "s" は何だろうと思われるかもしれません。

実際、playerOpts はそれほど簡単ではありません。PlayerOpts は複数のセグメントで構成され、それぞれのセグメントは "||" で分けられ、各セグメントにはコントロール バーのプロパティが含まれます。1 つのセグメントは、アスタリスク (*) で 3 つの部分に分けられます。最初の部分はプロパティ名、2 番目の部分はプロパティ値、3 番目の部分はプロパティのデータ型です。たとえば、 targetClip*demo.flv*s はセグメント、targetClip はプロパティ名、demo.flv はプロパティ値で "s" はこのプロパティの文字列の種類です。このセグメントは、コントロール バーでビデオを再生できるパスを指定します。この他にもプロパティがあります。"||" を使用してさまざまなセグメントを分離することにより、同時に複数のプロパティを設定できます。コードは次のようになります。

playerOpts=targetClip*demo.flv*s||panelColor*255,0,0*c

このようにして、targetClip プロパティを設定するときに、panelColor プロパティも設定します。panelColor はコントロール バーのカラーで、データ型はカラー "c" です。255,0,0 は RGB カラーです。プロパティ名とデータ型は大文字と小文字が区別されることに注意してください。

下の表はプロパティとその機能を示しています。

プロパティ

データ型

説明

targetClip

文字列:"s"

再生する FLV ファイルのパス。

scaleMode

文字列:"s"

コントロール バーをストレッチしたときに、ビデオをストレッチするかどうかを指定します。次のいずれかになります。
notcare:Flash プレイヤがストレッチを処理するかどうかに依存

no:サイズを変更しない

stage:幅をステージまで引き伸ばし、コントロール バーの元の高さを維持 (デフォルト)

pauseAtFirstFrame

ブール型:"b"

ビデオの再生を開始するときに、最初のフレームでビデオを一時停止するかどうかを指定します。true (デフォルト) は、最初のフレームで一時停止することを示し、false は自動的に再生することを示します。

pauseAtLastFrame

ブール型:"b"

ビデオの再生を終了するときに、最後のフレームでビデオを一時停止するかどうかを指定します。true は一時停止することを示し、false (デフォルト) は最初のフレームに戻ることを示します。

playerAlign

文字列:"s"

コントロール バーの位置を設定します。top は一番上で、bottom (デフォルト) は一番下です。

playerOverMovie

ブール型:"b"

コントロール バーを動画の前に表示するかどうかを設定します。デフォルト値は false です。

playerAutoHide

ブール型:"b"

コントロール バーを自動的に非表示にするかどうかを設定します。デフォルト値は false です。

hideDelay

整数型:"i"

コントロール バーを非表示にするまでの遅延時間をミリ秒で表示します。たとえば、hideDelay*1000*i
はマウスを 1 秒間動かさなかった場合にコントロール バーを非表示にすることを示します。

autoHideMouse

ブール型:"b"

マウス カーソルを自動的に非表示にするかどうかを設定します。

panelColor

カラー タイプ:"c"

コントロール バーの色を設定します。たとえば、
panelColor*255,0,0*c
はコントロール バーの色を赤に設定することを意味します。
255,0,0 は、R、G、B のカラー コンポーネントを示します。

一部のコントロール バーには、このプロパティが含まれません。このため、このようなコントロールバーでは、このプロパティを設定しても、効果が現れません。

bufferTime

浮動小数点:"f"

コントロール バーのバッファ時間を設定します。1.5 に設定すると、再生する前にデータを 1.5 秒間バッファします。デフォルト値は 5.0 です。

sndMute

ブール型:"b"

コントロール バーをミュートにするかどうかを設定します。デフォルト値は false です。

sndVolume

整数型:"i"

ビデオの再生を開始するときに、コントロール バーのボリュームのパーセンテージを設定します。設定できる値の範囲は 0 ～ 100 でデフォルト値は 100 です。

videoLink

文字列:"s"

画面をクリックするとリンクされたコンテンツが開かれるビデオ リンクを設定します (例:
videoLink*http://www.flash-video-mx.com*s)。

videoLinkTarget

文字列:"s"

ユーザがリンク付きのビデオをクリックしたときに、リンクしたコンテンツを表示するターゲット ウィンドウを指定します。

_self:現在のウィンドウに表示
_blank:新しいウィンドウに表示
_top:一番上のウィンドウに表示
_parent:親ウィンドウに表示

デフォルト値は _blank です。
たとえば、
videoLinkTarget*_blank*s
は、ユーザーがビデオ リンク付きの画面をクリックすると、リンクしたコンテンツを特定のリンクで新しいウィンドウに表示することを示します。

showReplay

ブール型:"b"

[リプレイ] ボタンを表示するかどうかを設定します。デフォルト値は false です。

textReplay

文字列:"s"

[リプレイ] ボタンの文字列を設定します。デフォルト値は [リプレイ] です。

autoLoad

ブール型:"b"

動画を自動的にロードするかどうかを設定します。
autoLoad が true の場合、SWF ファイルはプレイヤとして自動的に FLV ファイルをロードします。
autoLoad が false の場合、FLV ファイルは再生ボタンをクリックした後にロードされます。
デフォルト値は false です。

注: ビデオが SWF ファイルに埋め込まれている場合、動画は値に関係なく自動的にロードされます。

unloadOnStop

ブール型:"b"

再生が停止したときにビデオをアンロードするかどうかを設定します。

unloadOnStop が true の場合、[停止] ボタンをクリックすると、ビデオがアンロードされます。ビデオ データが完全にダウンロードされていない場合、ダウンロードされたビデオのデータはプレイヤから削除され、サムネイルを選択した場合はサムネイルが表示されるか、または黒い画面が表示されます。

unloadOnStop が false の場合、ビデオの最初のフレームが表示され、[停止] ボタンをクリックしても、ダウンロードしたビデオはアンロードされません。ビデオが完全にダウンロードされていない場合、ビデオの残りのデータがダウンロードされます。

autoRewind

ブール型:"b"

ビデオを自動的に巻き戻すかどうかを設定します。デフォルト値は false です。

urlOnEnd

文字列:"s"

ビデオの再生が終了したときにアクセスする URL を設定します。

urlOnEndBrowser

文字列:"s"

urlOnEnd を呼び出す方法を設定します。設定できる値は次のとおりです。

browser:ブラウザを使用して、urlOnEnd を開く

swf:Flash MovieClip から urlOnEnd をロードする

flv:urlOnEnd で指定された FLV ファイルを再生する

urlOnEndTarget

文字列:"s"

urlOnEndBrowser がブラウザの場合、urlOnEndTarget は urlOnEnd を参照するウィンドウ名です。

この値が swf の場合、urlOnEndTarget は urlOnEnd をロードする MovieClip の名前です。

この値が flv の場合、このプロパティは無視されます。

thumbNail

文字列:"s"

ビデオが再生される前にロードされるサムネイルを指定します。

bigPlay

文字列:"s"

SWF ファイルの URL を再生が一時停止または停止されたときに大きな [再生] ボタンを表示するように設定します。

playerExt

文字列:"s"

プレイヤの拡張子となる SWF ファイルの URL を設定します。ビデオをロードしているときに、playerExt で指定された swf がプレイヤによってロードされ、swf ファイルが拡張機能を実装します。

preLoader

文字列:"s"

再生する前にプリローダーがビデオ全体をロードするための SWF ファイルの URL を指定します。

showPlayer

ブール型:"b"

コントロール バーを表示するかしないかを設定します。デフォルト値は true です。

keepAspect

ブール型:"b"

ビデオをストレッチするときに、ビデオのアスペクト比を維持するように設定します。デフォルト値は false です。

movieID

文字列:"s"

onPlayURL に渡されるビデオの ID を設定します。

onPlayURL

文字列:"s"

ビデオの再生が開始するときにアクセスする URL を設定します。

movieID という名前のパラメータがこの URL に渡されます。

注: この URL にアクセスするときに、ブラウザ ウィンドウは表示されません。

minWidth

整数型:"i"

許容される最小幅。プレイヤの幅が最小幅よりも小さい場合、プレイヤの幅に合わせてストレッチされる代わりに、ビデオの左右 2 個所のサイドがカットされます。

デフォルト値は 0 で、ビデオの幅がプレイヤの幅と同じになります。

minHeight

整数型:"i"

許容される最小高さ。プレイヤの高さが最小高さよりも小さい場合、プレイヤの幅に合わせてストレッチされる代わりに、ビデオの上下 2 個所のサイドがカットされます。

デフォルト値は 0 で、ビデオの高さがプレイヤの高さと同じになります。

fscEvent

ブール型:"b"

プレイヤ イベントを fscommand に転送するかしないかを設定します。

この値は true の場合、プレイヤ イベントは fscommand(t, n) に転送されます。t はイベントの種類です。Flash Video MX Proによって提供されるプレイヤを使用する場合、t は常に MoyeaPlayer で、n はイベント名です。

subColor

カラー タイプ:"c"

サブタイトルのフォントの色を設定します。

subSize

整数型:"i"

サブタイトルのフォントのサイズを設定します。

subHeight

整数型:"i"

サブタイトルのボックスの高さを設定します。

noMuteBtn

ブール型:"b"

[ミュート] ボタンを非表示にするかどうかを設定します。

noStopBtn

ブール型:"b"

[停止] ボタンを非表示にするかどうかを設定します。

noProcBar

ブール型:"b"

プロセス バーを非表示にするかどうかを設定します。

noVolumeBar

ブール型:"b"

[音量調節] を非表示にするかどうかを設定します。

noTimeText

ブール型:"b"

ビデオ時間に関するテキストを非表示にするかどうかを設定します。表示形式は、[再生時間 / 合計時間] です。

playBtnAlign

文字列:"s"

大きな再生ボタンの位置調整。設定できる値は次のとおりです。

左上、中央上、右上、左中央、中央、右中央、左下、中央下、右下。

playBtnAlignX

整数型:"i"

大きな [再生] ボタンの x 座標を設定します。playBtnAlign が原点です。

playBtnAlignY

整数型:"i"

大きな [再生] ボタンの y 座標を設定します。playBtnAlign が原点です。

playBtnW

整数型:"i"

大きな [再生] ボタンの幅を設定します。

playBtnH

整数型:"i"

大きな [再生] ボタンの高さを設定します。

Moyea FLV プレイヤのサブタイトルのキュー ポイント フォーマット:

名前:"my::title"; 時間:バーをドラッグして、サブタイトルを表示するタイム ポイントを設定します。

パラメータ:
名前:"t"; 値:表示するテキストを入力します。
名前:"d"; 値:テキストを表示する時間の長さをパラメータ "t" (ミリ秒) で入力します。

サブタイトルの色、サイズ、高さを HTML コードで変更できます。

上記の独立したプレイヤのプロパティを設定するほかに、Action Scriptを理解している場合は、FLV プレイヤ API を適用して、これらのコントロール バーにイベント (再生または停止するイベント、ユーザが [一時停止] ボタンをクリックするときのイベントなど) を待機するよう設定することもできます。FLV プレイヤ APIを参照してください。


サポートに関してよくある質問

  • 1. バッチ エンコーダを起動したときに、「'1.0' は有効な浮動小数点値ではありません。」というエラー メッセージが表示され、さらに「'BatchCVT.exe' モジュールのアドレス 00524EB8 でアクセス違反が発生しました。アドレス 00000000 の読み出し。」という新しいメッセージが表示されます。何が悪いのですか?

この問題は英語版以外のコンピュータで発生します。これは小数点の記号に関連しています。
[コントロール パネル] -> [日付、時刻、地域と言語のオプション] -> [地域と言語のオプション] -> [地域のオプションのカスタマイズ] -> [数値] -> [小数点の記号] でシステムの"小数点の記号"をドット '.' に変更してください。

プログラムの使用時に問題があった場合は、まず、よくある質問 (FAQ) を参照してください。FAQ では、プログラムで発生しやすい問題を挙げて、適切な対処方法を紹介しています。このプログラムを使用してデジタル ライフを満喫する前に、FAQ を一通りご覧いただくことを強くお勧めします。

FAQ を見るにはここをクリック>>

カスタマーサポート

本製品に関するご意見、ご質問は、株式会社ネクステッジテクノロジー カスタマーサポートまでご連絡ください。
技術的なご質問の場合には、下記の情報を予め準備してください。

-製品バージョン
-Windows OS バージョン
-ハードウェアタイプと仕様
-表示された警告メッセージ
-問題が発生したときの詳しい状況

[Webサポート] http://www.shareEDGE.com/cs/

ご利用ありがとうございます


On2 VP6 と Sorenson H.263 コーデックの比較

On2 VP6 コーデックを使用すると、Sorenson H.263 コーデックに比べて、次の利点があります。

  • 同じデータ転送速度でより高品質のビデオをエンコードする
  • 合成ビデオを作成するためにアルファ チャンネルの使用をサポートする

同じデータ転送速度でより高品質のビデオをサポートするためには、On2 VP6 コーデックのエンコードは非常に速度が遅くなり、クライアント コンピュータ上でビデオ データをデコードして再生するために、より多くのプロセッサ パワーが必要になります。このため、ビデオを見る人が作成した Flash ビデオ コンテンツにアクセスするときに使用するコンピュータに共通する最も低い基準に配慮してください。

多数のユーザが比較的古いコンピュータを使用すると予測される場合は、FLV ファイルを Sorenson H.263 コーデックを使用してエンコードする方がよいかもしれません。